Структура и примеры изменения стандартных правил выгрузки перехода с ЗиК на ЗУП (до 2.5.27)

Публикация № 71830 16.06.10

Бухгалтерский учет - Зарплата

Здесь - http://infostart.ru/public/79349/ - изменяем стандартные правила по вычетам НДФЛ на детей.

Все нижеследующее можно использовать только в качестве опыта по изменению стандартных правил.

Для рабочего переноса данных это уже не годится.

При переходе с Зарплата и Кадры 7.7 на Зарплата и Управление Персоналом 8.2 (8.1) на текущий момент есть очень хороший штатный помошник переноса данных. Два года назад нормально перенести данные не ковыряясь в обработках и схемах было практически невозможно.
Эта публикация дополняла стандартные правила конвертации, которые можно сохранить из конфигуратора ЗУП (в справочнике "КонвертацииИзИнформационныхБаз1СПредприятия77" есть макеты, их можно сохранить как файлы).  НО С ВЫХОДОМ РЕЛИЗА 2.5.27.5 ПОТЕРЯЛА АКТУАЛЬНОСТЬ, потому что некоторые ошибки 1С в моих дополнениях так же были не исправлены.
Изначально в правилах было: "Приемник ВерсияПлатформы="8.0" ВерсияКонфигурации="2.5.20.1" , судя по ошибкам текстов модулей, аналогичных глобальному модулю ЗиК, источником был 292 релиз версии 7.7. Пробовал, выгружается только начиная 294 релиза.

В архиве файлы выгрузки из 7.7 (PrB_Wiz.efd, PrB_Wiz.ert, V77Exp.ert , PrB.xml). Нужно распаковать архив куда-нибудь (лучше распаковать в каталог ExtForms информационной базы ЗиК 7.7, тогда можно запускать помошник выгрузки из меню Сервис - Дополнительные возможности - Помощник перехода на 1С:Зарплату и Управление персоналом 8), запустить обработку PrB_Wiz.ert. На скриншотах показаны шаги выгрузки. На 4 шаге нужно выбрать имя файла выгрузки данных и его будущее расположение, каталог правил - тот, куда распаковали мой архив. Если там файлов нет, то об этом будет свидетельствовать красная надпись на форме.

В ЗУПе меню Сервис - Перенос данных из информационных баз 1С Предприятия 7.7 - Загрузить данные из файла.

 

Отличия от типовой.

  1. Изменил дату начала периода выгрузки (в типовой только с января 2008, 2007, 2006 года)
  2. Переносится реквизит ДатаРегистрации (по месту жительства) справочника Сотрудники
  3. В регистр сведений ПаспортныеДанныеФизЛиц, ресурс ДокументКодПодразделения, переносится дополнительный реквизит паспортных данных (он у вас есть только если вы сами меняли обработку ВводДокумента, добавив дополнительное, шестое поле, если нет - ничего страшного)
  4. В документ ПриемНаРаботуВОрганизацию, в реквизит УсловияПриемаНаРаботу переносится реквизит документа ПриказОПриемеНаРаботу ВидЗанятости  (тип - Справочник.ОКИН) для формы Т2.

Версия 2.2

  1. В регистре сведений ЛицевыеСчетаРаботниковОрганизации заполняется поле Банк созданным элементом справочника Контрагенты "Карточные счета"

Версия 2.3

  1. В последних релизах ЗиК исправлены процедуры глобального модуля СобратьДанныеДляСтраховыхВзносов и ОбходСотрудниковДляСтраховыхВзносов, в правилах они старые с ошибками, в результате страховые взносы переносятся не правильно. Исправил основную ошибку по невключению некоторых видов расчетов (оплата больничного за счет работодателя например) в облагаемую базу (см.скриншот).

Версия 2.5

Добавил опцию, может кому пригодится.

В ЗиКе очень интересно определялись параметры системы налогообложения организации, дошло до смешного, пришлось поставить признак ЕНВД и в видах расчетов установить этот признак, хотя организация просто УСН, чтобы в отчетах налоги выводились без ЕСН. Но сейчас не об этом. Добавил параметр выгрузки, при установке его значения в "НеНадоЕНВД" страховые взносы переносятся как не ЕНВД-шные (В 8-ке переносимые данные загружаются в документ ПереносДанных, так вот там суммы страховых взносов будут не в колонке например ПФРСтраховаяЕНВД, а просто ПФРСтраховая). Если параметр пуст, то данные переносятся стандартным образом. Тем более, что параметр нужно устанавливать не прибегая к обработке "Помощник выгрузки": открываем сразу обработку V77Exp.ert, выбираем файл правил, нажимаем кнопку загрузить правила, на закладке Параметры устанавливаем параметру "ПараметрОрганизации" значение "НеНадоЕНВД".

Версия 2.6

Заполняется реквизит НаименованиеСокращенное в справочнике Организации.

Начисления по больничным переносятся в предопределенные виды расчетов плана Основные начисления, а не создаются новые с незаполненными реквизитами.

Если в ЗиК не заведены Подразделения, чтобы потом не присваивать каждому сотруднику одно подразделение в ЗУП, можно создать элемент с именем "Для переноса в Зарплата и Управление Персоналом 8.2" в семерке, и все сотрудники будут в восьмерке на нем числиться. Его потом в восьмерке нужно переименовать, типа "Основное подразделение".

Заполняется код ОКОПФ у организаций "Общество с ограниченной ответственностью" - "65".

Выгружаются правильные суммы взносов в ФСС на страхование от несчастных случаев за 2010 год. В стандартной выгрузке неправильно. База просто умножается на ставку. Нужно еще разделить на 100.

Версия 2.7

При загрузке страховых взносов в документе Перенос данных добавил третью закладку для страницы панели регистров накопления по регистру "Расчеты по страховым взносам". В стандартной версии почему-то эти движения скрыты и еще начинают удваиваться при повторной загрузке данных из-за ошибки в модуле набора записей регистра СтраховыеВзносыИсчисленные, где и создаются записи регистра РасчетыПоСтраховымВзносам, записываются они с режимом Ложь (без замещения, см. скриншот) , что приводит к их накоплению при многократных загрузках данных. В свою версию добавил замещение этих движений, т.е. можно загружать много раз. Но если не править конфигурацию, то нужно обратить внимание на то, что при ручных исправлениях документа Перенос данных (страховых взносов исчисленных) на закладке Расчеты по страховым взносам после записи документа (и обновлении формы) произойдет увеличение записей, см скриншот.

Версия 2.8 от 26.07.2010

При выгрузке отклонений (больничные, отпуска), анализируются виды расчетов,  в коде проверки есть условия, где все ВР больничных перечислены, кроме ОплатаБЛс2010, нету так же в другом условии ОтпускПоБеременностис2010. Пока не проверял, на что это влияет, но после добавления изменений, база для налога сумм взносов в ФСС на страхование от несчастных случаев "пришла в норму", записи по больничным стали "вытеснять" записи по доплате по больничным за счет работодателя, а то раньше приходилось последнему виду расчета ставить признак облагается НС, что видимо не правильно. Проверено на регл. отчете 4-ФСС.

 

Внимательно переносите отдельные периоды, если первый раз перенесли с 2006 года, а потом переносите с 2010, можно получить несуществующие начальные остатки на 2010 год. В правилах остатки считаются при помощи отчета в ЗиКе - Отчет.СтруктураЗадолженности, с января 2001 года по дату начала переноса. Можно предварительно сформировать его и узнать, что будет переноситься или уже после переноса в ЗУПе открыть список документов Перенос данных, найти с номером ВЗР, откорректировать. Переносятся только положительные значения, как в отчете (долг предприятия), долги сотрудников не перенеслись. Я сейчас выгрузил данные по 2009 год при помощи обработки "Помощник выгрузки". Дальше буду загружать 2010 год по мере закрытия каждого месяца уже не открывая "Помощник...", сразу обработкой V77Exp.ert, убирать галочку с правила ОстаткиВзаиморасчетов (чтобы не искать ненужный документ ВЗР) . При этом будут затираться все документы 2010 года, документ Кадровых данных, Отклонений, Фактических отпусков (общие, там выборка не по годам. По поводу выгрузки за каждый месяц я анализировал правила и понял, что смысла в общем-то в этом никакого нет, проще выгрузить с начала года. Если кто-то этого захочет, то привожу краткую характеристику каждого правила выгрузки данных (ПВД), из которых видно, где уже организована выгрузка по месяцам, а где ее необходимо добавить.

  1. Организация - выгружаются сведения об организации, множество ПКО вызывается из обработчика ПередОбработкой
  2. КадровыеДанные - выборка справочника Сотрудники, по каждому элементу создается объект Периодический, выбираются все значения с ограничением по ДатаОкончания (выгрузки) , создается один документ ПереносДанных, номер КД. В нем заполняются  регистр сведений РаботникиОрганизаций и накопления ЗанятыеШтатныеЕдиницыОрганизаций. В регистре сведений реквизит ПервичныйДокумент заполняется созданными документами, выгруженными по соответствующим ПКО.
  3. Отклонения - выборка справочника Сотрудники, работавшие в текущем периоде, далее цикл по годам периода выгрузки с 2001 года, в нем выборка записей журнала расчетов. Создается один документ за каждый год выгрузки с № = "ОТК-" + Прав(ТекущийГод, 2)), в нем заполняется регистр сведений СостояниеРаботниковОрганизаций. Реквизит ПервичныйДокумент заполняется созданными документами, выгруженными по соответствующим ПКО
  4. ФактическиеОтпуска. Цикл по годам периода выгрузки, запрос к журналу расчетов с отбором по "отпускным" видам расчетов с 2001 года. Создается один документ за каждый год выгрузки с № = "ОТ-" + Прав(ТекущийГод, 2)), в нем заполняется регистр накоплений ФактическиеОтпускаОрганизаций.
  5. ШтатноеРасписаниеОрганизаций. Выборка справочника ШтатноеРасписание. Загружается в регистр сведений ШтатноеРасписаниеОрганизаций, плюс если есть надбавки регистр сведений НадбавкиПоШтатномуРасписаниюОрганизаций.
  6. ПлановыеНачисленияИУдержания, выборка сотрудников, его виды расчетов за последний год. Создается один документ  , номер  ПНУ , в нем заполняется регистр сведений ПлановыеНачисленияРаботниковОрганизаций, ПлановыеУдержанияРаботниковОрганизаций, РеглУчетПлановыхНачисленийРаботниковОрганизаций. Реквизит ПервичныйДокумент заполняется созданными документами, выгруженными по соответствующим ПКО
  7. КомиссионнаяВыручка, выборка одноименных документов.
  8. ДоговорЗаймаСРаботником, выборка одноименных документов.
  9. КоэффициентИндексацииЗаработка, выборка сотрудников, анализируется пошался ли оклад. Создается один документ  , номер  КИЗ , в нем заполняется регистр сведений КоэффициентИндексацииЗаработка. 
  10. ФактическиеНачисленияИУдержания, цикл по годам периода, в нем цикл по месяцам периода, в нем выборка сотрудников, их начисления и удержания. Создается документ за каждый месяц, № НЗР- годмесяц, в нем 2 регистра накоплений - ЗарплатаЗаМесяцОрганизаций, ВзаиморасчетыСРаботникамиОрганизаций, 6 регистров расчета - ОсновныеНачисленияРаботниковОрганизаций, ДополнительныеНачисленияРаботниковОрганизаций, УдержанияРаботниковОрганизаций, БУОсновныеНачисления, БУДополнительныеНачисления, БУУдержания.
  11. НДФЛ, цикл по годам, создается один документ за каждый год, № "НДФЛ-" + Прав(ТекущийГод, 2)), где заполняются табличные части по всем сотрудникам для регистров НДФЛСведенияОДоходах, НДФЛПредоставленныеСтандартныеВычетыФизЛиц, НДФЛИмущественныеВычетыФизлиц, НДФЛРасчетыСБюджетом, НДФЛКЗачету.
  12. ОстаткиВзаиморасчетов, формируется отчет СтруктураЗадолженности с 2001 года  по ДатаПериодаПо    = НачМесяца(ДатаНачала)-1 , по всем сотрудникам, создается один документ №ВЗР.
  13. ПогашениеЗаймовРаботниками, запрос к журналу расчетов с фильтром по документам СсудаПредприятия, создается один документ с № ПЗР.
  14. ВыплатыВозвраты, цикл по году, запрос к журналу расчетов. Один документ за год, № ВЗР - год.
  15. ЕСН_ПФР_ЕНВД, цикл по году до 2009 года.  Один документ за год, № ЕСН - год, заполняются регистры сведений ЕСНИсчисленный и ЕСНСведенияОДоходах, дальше цикл по месяцам с созданием документов с № ЕНЧ - годмесяц, где заполняются регистры расчета ЕСНОсновныеНачисления, ЕСНДополнительныеНачисления.
  16. СтраховыеВзносы, цикл по годам, начиная с 2010 года, один документ № СВЗ-год, заполняются регистры накопления СтраховыеВзносыИсчисленные, СтраховыеВзносыСведенияОДоходах, РасчетыПоСтраховымВзносам. Потом в цикле по месяцам заполняются документы за каждый месяц №ЕНЧ-годмесяц, как в предыдущем правиле.
  17. ФСС, цикл по году, один документ в год №ФСС-год.
  18. ОтражениеЗарплатыВРеглУчете, цикл по годам, создается документ ОтражениеЗарплатыВРеглУчете.
  19. ДозаполнениеВидовРасчета.
  20. УчетОсновногоЗаработкаПодразделенияОрганизации, создается один документ ПереносДанных, № УОЗ. Выборка справочника Подразделения.
  21. ФизическиеЛица, выборка справочника Сотрудники.
  22. КонтрольныеДанные. Проверяются СводЗаМесяц, ЕСНЗаМесяц, ОтражениеВУчетеЗаМесяц

16.07. Не знаю, как вставлять картинки в середину текста, поэтому получилось только создать фотоальбом: Изменения стандартных правил на примере выгрузки своего реквизита, там скрины пошагового изменения стандартных правил на примере добавления выгрузки своего реквизита.

19.07. Удалось вставить картинки в блоге, закаченные в фотоальбом, так что теперь и здесь:

Изменения стандартных правил на примере добавления выгрузки своего реквизита

 

Все изменения, дополнения отслеживаем на моем блоге: Изменить 1С

Успехов.

Скачать файлы

Наименование Файл Версия Размер
Версия 2.8

.zip 482,04Kb
812
.zip 482,04Kb 812 Скачать
Версия 1

.zip 476,10Kb
21
.zip 476,10Kb 21 Скачать
Версия 2.2

.zip 477,18Kb
10
.zip 477,18Kb 10 Скачать
Версия 2.3

.zip 477,85Kb
14
.zip 477,85Kb 14 Скачать
Версия 2.4

.zip 478,41Kb
29
.zip 478,41Kb 29 Скачать
Версия 2.4

.zip 478,39Kb
10
.zip 478,39Kb 10 Скачать
Версия 2.5

.zip 544,86Kb
30
.zip 544,86Kb 30 Скачать
Версия 2.6

.zip 481,00Kb
21
.zip 481,00Kb 21 Скачать
Версия 2.7

.zip 481,62Kb
156
.zip 481,62Kb 156 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. lihomanov 83 16.06.10 16:55 Сейчас в теме
2. Alav 13 17.06.10 01:19 Сейчас в теме
Много букв и практически ничего не сказано об отличий от типовых правил. Или единственное отличия это "реквизит ДатаРегистрации справочника Сотрудники". А в остальном типовое правило?
3. samamoiloff 861 18.06.10 12:22 Сейчас в теме
4. Олег1С 2 28.06.10 10:44 Сейчас в теме
Чтобы корректно переносились ИП - у них необходимо ставить слэш после ИНН в настройках организации
5. rybusha 97 13.07.10 18:23 Сейчас в теме
ФСС НС удавалось исправить Док. начисление страховых взносов за все перенесенные месяцы . При пересчете создаются минусовые начисления по НС
6. artbear 1424 16.07.10 08:04 Сейчас в теме
Описание хорошее, только не хватает самой малости - номеров релизов ЗИК 77 и ЗУП 8, на которых эти правила проверены :(
Ждем
7. samamoiloff 861 16.07.10 11:14 Сейчас в теме
Изначально в правилах было: "Приемник ВерсияПлатформы="8.0" ВерсияКонфигурации="2.5.20.1" , судя по ошибкам текстов модулей, аналогичных глобальному модулю ЗиК, источником был 292 релиз версии 7.7. Эти и более свежие версии поддерживаются. Более ранние релизы не пробовал. В семерочной обработке даже есть страничка (шаг 2,см.скрин) с проверкой новых версий ЗиКа через интернет.
8. samamoiloff 861 19.07.10 21:55 Сейчас в теме
9. samamoiloff 861 26.07.10 12:48 Сейчас в теме
Подскажите, как свои картинки добавлять, куда их закачивать, кроме как в фотоальбом?..
10. samamoiloff 861 30.07.10 12:08 Сейчас в теме
11. renat_1st 09.08.10 14:00 Сейчас в теме
А не подскажете что делать, если выходит такая ошибка " msxml3.dll: Недостаточно памяти для завершения операции." Я выгружаю только одно правило - Кадровые данные.
12. samamoiloff 861 09.08.10 23:48 Сейчас в теме
(11) По вопросам xml, к сожалению, не специалист. Может установить какие-нето обновления, цифра 3 в msxml3 смущает, на памяти версии 4 или 6 вертятся, хотя это может и не о том, врать не буду.
13. samamoiloff 861 09.08.10 23:58 Сейчас в теме
(11) Если надо, можно Кадровые данные и разделить на периоды. См. блог, там инструкция по изменению правил. Находите ПВД КадровыеДанные, там обработчик вроде ПередВыгрузкой (сейчас нет под рукой...), там есть закомментированные мои добавления. Раскомментируйте их, я сначала хотел периодами выгружать, а потом не стал. Только надо либо после каждой загрузки номер КД документа переименовывать, либо в ПКО КадровыеДанные галочку добавить в колонке Поиск для свойства Период.
14. Re:аниматор 336 13.08.10 07:59 Сейчас в теме
Версия 2.8 от 26.07.2010

Ошибка исполнения обработчика: ПВД_ПередОбработкойПравила_СтраховыеВзносы
- Неверный идентификатор колонки!
kraspay; _LEV_; +2 Ответить
15. samamoiloff 861 13.08.10 21:56 Сейчас в теме
19. Re:аниматор 336 14.08.10 05:14 Сейчас в теме
(15) текст ошибки оригинал, без указания строки. в переходе с зик 7.7 на зуп последнем та же ошибка.

так для заметки скинул, что есть такая ошибка
59. fomix 31 26.06.12 13:12 Сейчас в теме
(19) Re:аниматор, Правила устарели! На данных старше 2011 года поменялся алгоритм "СобратьДанныеДляСтраховыхВзносов" и соответственно надо менять алгоритм "ОбходСотрудниковДляСтраховыхВзносов".
60. samamoiloff 861 27.06.12 22:31 Сейчас в теме
(59) Не понял. Ведь:
Все нижеследующее можно использовать только в качестве опыта по изменению стандартных правил.

Для рабочего переноса данных это уже не годится

, да и коммент от 10 года... Смысл?
61. fomix 31 28.06.12 09:29 Сейчас в теме
(60) Владимир, то, что ваши правила выложены здесь в качестве опыта - хорошо. Эти правила мне реально помогли, поэтому еще раз спасибо.Но жизнь не стоит на месте! Меняется все: и правила и алгоритмы. И приходится допиливать и то и другое...
16. samamoiloff 861 13.08.10 22:18 Сейчас в теме
(14) В этом обработчике моих изменений только и всего:

Для НомерПорции = 1 По СписокСотрудников.РазмерСписка() Цикл

ПорцияСотрудников = СписокСотрудников.ПолучитьЗначение(НомерПорции);

ТаблицаСтраховыеВзносыИсчисленные = СоздатьТЗСтраховыеВзносыИсчисленные();
ТаблицаСтраховыеВзносыСведенияОДоходах = СоздатьТЗСтраховыеВзносыСведенияОДоходах();
ТаблицаЕСННачисления = СоздатьТЗЕСННачисления();

// Собрать данные о начислениях и сведениях о доходах,
// а также доходы/вычеты/налоги для ЕСН исчисленного
ДоходыВычетыНалогиСотрудников = СобратьДанныеДляСтраховыхВзносов(ТаблицаСтраховыеВзносыСведенияОДоходах, ТаблицаЕСННачисления, ПорцияСотрудников, КонГода(Дата(ТекущийГод,12,15)));

// Страховые взносы Исчисленные
Состояние("Страховые взносы Исчисленные");
ЗаполнитьТаблицуСтраховыеВзносыИсчисленные(ТаблицаСтраховыеВзносыИсчисленные, ПорцияСотрудников, ДоходыВычетыНалогиСотрудников, КонГода(Дата(ТекущийГод,12,15)));
ДоходыВычетыНалогиСотрудников = 0;

Если ТаблицаСтраховыеВзносыИсчисленные.КоличествоСтрок() > 0 Тогда
ТаблицаСтраховыеВзносыИсчисленные.НоваяКолонка("Организация");
ТаблицаСтраховыеВзносыИсчисленные.НоваяКолонка("ОбособленноеПодразделение");

СтраховыеВзносы = СоздатьОбъект("СписокЗначений");
СтраховыеВзносы.Установить("Дата", ТекущаяДата());
СтраховыеВзносы.Установить("ПериодРегистрации", ПериодРегистрации);
СтраховыеВзносы.Установить("Номер", "СВЗ-" + Прав(ТекущийГод, 2));
СтраховыеВзносы.Установить("Организация", "Наша организация");
СтраховыеВзносы.Установить("Комментарий", "Страховые взносы за " + ТекущийГод + "г.");

СтраховыеВзносы.Установить("СтраховыеВзносыИсчисленные", ТаблицаСтраховыеВзносыИсчисленные);

ВыгрузитьПоПравилу(СтраховыеВзносы, , 1, , "СтраховыеВзносы");
СтраховыеВзносы = 0;
КонецЕсли;

ТаблицаСтраховыеВзносыИсчисленные = 0;


Если ТаблицаСтраховыеВзносыСведенияОДоходах.КоличествоСтрок() > 0 Тогда
ТаблицаСтраховыеВзносыСведенияОДоходах.НоваяКолонка("Организация");
ТаблицаСтраховыеВзносыСведенияОДоходах.НоваяКолонка("ОбособленноеПодразделение");

СтраховыеВзносы = СоздатьОбъект("СписокЗначений");
СтраховыеВзносы.Установить("Дата", ТекущаяДата());
СтраховыеВзносы.Установить("ПериодРегистрации", ПериодРегистрации);
СтраховыеВзносы.Установить("Номер", "СВЗ-" + Прав(ТекущийГод, 2));
СтраховыеВзносы.Установить("Организация", "Наша организация");
СтраховыеВзносы.Установить("Комментарий", "Страховые взносы за " + ТекущийГод + "г.");
//******************************************************Изменил Самойлов 07.07.10
Если СокрЛП(Параметры.ПараметрОрганизации) = "НеНадоЕНВД" Тогда
ТаблицаСтраховыеВзносыСведенияОДоходах.ВыбратьСтроки();
Пока ТаблицаСтраховыеВзносыСведенияОДоходах.ПолучитьСтроку()=1 Цикл
ТаблицаСтраховыеВзносыСведенияОДоходах.ОблагаетсяЕНВД = 0;
КонецЦикла;
КонецЕсли;
//*******************************************************************************
СтраховыеВзносы.Установить("СтраховыеВзносыСведенияОДоходах", ТаблицаСтраховыеВзносыСведенияОДоходах);

ВыгрузитьПоПравилу(СтраховыеВзносы, , 1, , "СтраховыеВзносы");
СтраховыеВзносы = 0;
КонецЕсли;

ТаблицаСтраховыеВзносыСведе

сама таблица инициализируется в алгоритме СоздатьТЗСтраховыеВзносыСведенияОДоходах();

его текст :

ТЗ = СоздатьОбъект("ТаблицаЗначений");
ТЗ.НоваяКолонка("Физлицо");
ТЗ.НоваяКолонка("Период");
ТЗ.НоваяКолонка("Результат");
ТЗ.НоваяКолонка("Скидка");
ТЗ.НоваяКолонка("ВидДохода");
ТЗ.НоваяКолонка("ОблагаетсяЕНВД");
ТЗ.НоваяКолонка("ВидРасчета");
ТЗ.НоваяКолонка("ОблагаетсяПоДополнительномуТарифу");
ТЗ.НоваяКолонка("ДокументОснование");

Возврат ТЗ;



как видим колонка, к которой обращаюсь присутствует в таблице.

Нужно больше фактических данных.
17. samamoiloff 861 13.08.10 22:38 Сейчас в теме
(14)Инициализация таблицы: (рисую при помощи Разукрашки)

ТЗ = СоздатьОбъект("ТаблицаЗначений");
ТЗ.НоваяКолонка("Физлицо");
ТЗ.НоваяКолонка("Период");
ТЗ.НоваяКолонка("Результат");
ТЗ.НоваяКолонка("Скидка");
ТЗ.НоваяКолонка("ВидДохода");
ТЗ.НоваяКолонка("ОблагаетсяЕНВД");
ТЗ.НоваяКолонка("ВидРасчета");
ТЗ.НоваяКолонка("ОблагаетсяПоДополнительномуТарифу");
ТЗ.НоваяКолонка("ДокументОснование");

Возврат
ТЗ;

18. samamoiloff 861 13.08.10 22:44 Сейчас в теме
Мои изменения в обработчике (пропускаю "лишний" текст - ...):
Для НомерПорции = 1 По СписокСотрудников.РазмерСписка() Цикл

...

ТаблицаСтраховыеВзносыСведенияОДоходах = СоздатьТЗСтраховыеВзносыСведенияОДоходах();

...

Если
ТаблицаСтраховыеВзносыСведенияОДоходах.КоличествоСтрок() > 0 Тогда

    ...

//******************************************************Изменил Самойлов 07.07.10
   
Если СокрЛП(Параметры.ПараметрОрганизации) = "НеНадоЕНВД" Тогда
       
ТаблицаСтраховыеВзносыСведенияОДоходах.ВыбратьСтроки();
        Пока
ТаблицаСтраховыеВзносыСведенияОДоходах.ПолучитьСтроку()=1 Цикл
           
ТаблицаСтраховыеВзносыСведенияОДоходах.ОблагаетсяЕНВД = 0;
        КонецЦикла;
    КонецЕсли;
//*******************************************************************************

...

КонецЕсли;

как видим колонка, к которой обращаюсь присутствует в таблице.

Нужно больше фактических данных.
20. lord_ru 18.08.10 07:15 Сейчас в теме
умные товарищи и просто гуру помогите ошибка таже что и ниже в нете нет ничего о решении данной проблемы
ЗУП (2.5.26.2) ЗИК 299 релиз последний на данный момент как я понимаю а ошибка все таже
Выгрузка данных: Страховые взносы за 2010г. Ошибка исполнения обработчика: ПВД_ПередОбработкойПравила_СтраховыеВзносы: Неверный идентификатор колонки!
Выгрузка данных: Физические лица, подразделения Обнаружен неизвестный код вычета по НДФЛ: 0000009. Обратитесь в техническую поддержку.
Выгрузка данных: Физические лица, подразделения Обнаружен неизвестный код вычета по НДФЛ: 0000001. Обратитесь в техническую поддержку.

Кто может помочь или еше какая доп инфа нужна стучитесь в аську 22з Ч89 5з9
ну или суда пишите
21. samamoiloff 861 18.08.10 09:00 Сейчас в теме
49. fomix 31 20.12.11 10:35 Сейчас в теме
(20) lord_ru, Вылезла аналогичная ошибка. Начал ковырять и нашел ошибку. Поправил правила в двух местах:

1. Алгоритм СобратьДанныеДляСтраховыхВзносов: добавить после строки - "ДоходыВычетыНалогиСотрудников.НоваяКолонка("ИсчисленоФСС_НС","Число",15,2);"

объявление 4 колонок:

ДоходыВычетыНалогиСотрудников.НоваяКолонка("ВзиматьВзносыПФРиФСС","Число",1,0);
ДоходыВычетыНалогиСотрудников.НоваяКолонка("ВзиматьВзносыФОМС","Число",1,0);
ДоходыВычетыНалогиСотрудников.НоваяКолонка("ТарифИнвалид","Число",1,0);
ДоходыВычетыНалогиСотрудников.НоваяКолонка("Летчик","Число",1,0);

2. Алгоритм ОбходСотрудниковДляСтраховыхВзносов:
перед строкой "ВремТаблицаСтраховыеВзносыСведенияОДоходах.Сортировать("Физлицо, Период");" вставить следующий код:

Для Сч = МесяцДохода По 12 Цикл
НомерТекущейСтрокиСотрудника = НомерСтрокиСотрудника+Сч;

КоэфВзносыПФРиФСС = Число(Сред(ВзиматьВзносыПФРиФСС,Сч,1));
КоэфВзносыФОМС = Число(Сред(ВзиматьВзносыФОМС,Сч,1));
ЭтоИнвалид = Число(Сред(Инвалид,Сч,1));
ДоходыВычетыНалогиСотрудников.УстановитьЗначение(НомерТекущейСтрокиСотрудника,"ВзиматьВзносыПФРиФСС",КоэфВзносыПФРиФСС);
ДоходыВычетыНалогиСотрудников.УстановитьЗначение(НомерТекущейСтрокиСотрудника,"ВзиматьВзносыФОМС",КоэфВзносыФОМС);
ДоходыВычетыНалогиСотрудников.УстановитьЗначение(НомерТекущейСтрокиСотрудника,"ТарифИнвалид",ЭтоИнвалид);
КонецЦикла;

Тогда страховые взносы сформируются и загрузятся корректно!

Кроме того, при загрузке в конфигурацию 8.х Зарплата и Управление Персоналом, редакция 2.5 (2.5.40.3) вылезала ошибка про гражданство физических лиц. В этой конфе, в регистре сведений "ГражданствоФизЛиц" изменен ресурс "НеЯвляетсяНалоговымРезидентомРФ" на "УдалитьНеЯвляетсяНалоговымРезидентомРФ" - тоже исправил.

В ответе прилагаю новые правила и обработку.
Прикрепленные файлы:
Обмен_Зик_ЗУП.rar
Nicholas; +1 Ответить
22. flord 48 20.08.10 08:43 Сейчас в теме
Ошибки конвертации в ЗУП 2.5.26.3 от самой 1С:

Код ошибки: 10061129
Дата публикации: 20.08.2010 15:49:10
Дата последнего изменения: 20.08.2010 0:00:00
Описание: При конвертации вычетов НДФЛ с кодами 111 и 113, появляется сообщение об ошибке и не переносятся данные физических лиц.
Планируется исправить в релизе: 2.5.27

Код ошибки: 10061113
Дата публикации: 17.08.2010 16:11:54
Дата последнего изменения: 17.08.2010 0:00:00
Описание: При конвертации плановых начислений может возникать сообщение об ошибке.
Планируется исправить в релизе: 2.5.27

Код ошибки: 10050825
Дата публикации: 17.08.2010 16:11:45
Дата последнего изменения: 17.08.2010 0:00:00
Описание: При конвертации плановых начислений, если физическое лицо несколько раз принималось на работу, некоторые плановые начисления привязывались к уволенным сотрудникам.
Планируется исправить в релизе: 2.5.27

Код ошибки: 10061570
Дата публикации: 13.08.2010 13:56:48
Дата последнего изменения: 13.08.2010 0:00:00
Описание: При конвертации неправильно переносится ИНН организации, если не указан КПП.
Планируется исправить в релизе: 2.5.27

Код ошибки: 10047272
Дата публикации: 13.08.2010 13:56:27
Дата последнего изменения: 13.08.2010 0:00:00
Описание: При конвертации основных начислений неправильно заполняются ресурсы "Отработано дней/часов по пятидневке", из-за чего может неправильно считаться средний заработок.
Планируется исправить в релизе: 2.5.27

Код ошибки: 10061235
Дата публикации: 11.08.2010 12:19:15
Дата последнего изменения: 11.08.2010 0:00:00
Описание: При конвертации не переносятся новые виды расчета для оплаты пособий.
Планируется исправить в релизе: 2.5.27

Код ошибки: 10055310
Дата публикации: 11.08.2010 12:18:44
Дата последнего изменения: 11.08.2010 0:00:00
Описание: При конвертации неправильно переносится списание имущественных вычетов по НДФЛ.
Планируется исправить в релизе: 2.5.27

Код ошибки: 10050904
Дата публикации: 11.08.2010 12:18:27
Дата последнего изменения: 11.08.2010 0:00:00
Описание: При конвертации лицевых счетов, не заполняется банк.
Планируется исправить в релизе: 2.5.27

Код ошибки: 10049604
Дата публикации: 11.08.2010 12:17:46
Дата последнего изменения: 11.08.2010 0:00:00
Описание: Неправильно конвертируется средний заработок 2010 года.
Планируется исправить в релизе: 2.5.27

Код ошибки: 10052363
Дата публикации: 11.08.2010 12:17:34
Дата последнего изменения: 11.08.2010 0:00:00
Описание: При конвертации НДФЛ, в регистрах заполняются поля "Код по ОКАТО" и "КПП" для случаев, когда указано подразделениею Из-за этого неправильно формируется 2-НДФЛ.
Планируется исправить в релизе: 2.5.27

Код ошибки: 10048414
Дата публикации: 11.08.2010 12:13:53
Дата последнего изменения: 11.08.2010 0:00:00
Описание: При конвертации ФСС НС за 2010 год, переносимые суммы больше в 100 раз.
Планируется исправить в релизе: 2.5.27
Re:аниматор; +1 Ответить
23. samamoiloff 861 16.09.10 18:51 Сейчас в теме
В тестовый релиз ЗУП 2.5.27.4 включены обновленные правила конвертации.
Без обновления базы Приемника до 27 релиза не работают, так что здесь не выкладываю.
Буду тестировать.
24. mart-sha 295 24.09.10 16:42 Сейчас в теме
То - что нужно ! Была бы возможность поставил бы 2 ПЛЮСА !
Только что проверил перенос штатный в новой ЗУП 2,5,27 из ЗИК 300
1) ФСС по прежнему расползаются (отличны ЗИК от ЗУП)
2) Больничные и Отпускные не перенеслись (видимо поэтому расхождения в сводах ЗИК-ЗУП)
3) нет 2010 года в пунктах выбора за какой период переносить.

**** ТАК ЧТО ЖДЕМ ВАШИ ПРАВИЛА !! *****
25. flord 48 27.09.10 10:30 Сейчас в теме
В конвертации данных из «1С:Зарплата и Кадры» в «1С:Зарплата и Управление Персоналом» последних релизов есть грубая ошибка не верно заполняется оклад в «Регистре плановых начислений» и документе «Кадровое перемещение» . Ошибка заключается в том, что программа заполняет оклад сотрудника не последним периодическим значением если у сотрудника в ЗиК в определенной дате было несколько изменений оклада. Возможно так же что и другие периодические значения из справочника Сотрудники подтягиваются не правильно при описанной выше ситуации. Исправляем ситуацию кодом:
Функция ЗначениеПериодическогоРеквизитаНаНачало(
			ИсходящиеДанные = "", ВходящиеДанные = "", Источник = "", Приемник = "", ТипПриемника = "", Значение = "", Выражение = "",
			Пусто = "", ВыборкаДанных = "", Объект = "", КоллекцияОбъектов = "", ОбъектКоллекции = "", ИмяПКО = "", ИмяПКОВидСубконто = "",
			НомерПКО = "", НомерПКС = "", Правило = "", КлючВыгружаемыхДанных = "", НеЗапоминатьВыгруженные = "", НеЗамещатьОбъектПриЗагрузке = "",
			ВсеОбъектыВыгружены = "", ТолькоПолучитьУзелСсылки = "", РежимЗаписи = "", РежимПроведения = "", СтандартнаяОбработка = "",
			НеЗамещать = "", НеОчищать = "", УзелСсылки = "", УзелКоллекцииОбъектов = "", УзелОбъектаКоллекции = "", УзелСвойства = "",
			ВидСубконто = "", Субконто = "", Отказ = "")


	Реквизит	= ИсходящиеДанные;
	Сотрудник	= ВходящиеДанные;
	Начало		= Источник;
	
	Если (Сотрудник.Выбран()=0) или (ПустоеЗначение(Начало)=1) Тогда //вернем пустое значение
		Возврат "";
	КонецЕсли;
	Периодический = СоздатьОбъект("Периодический"); 
	Периодический.ИспользоватьОбъект(Реквизит,Сотрудник);
	Если Периодический.ВыбратьЗначения(Начало,Начало)=1 Тогда 
		////в нужном дне значения вводились, возьмем самое первое и посмотрим не родное ли оно
		//Если Периодический.ПолучитьЗначение()=1 Тогда
		//	//Если Периодический.ТекущийДокумент() <> ТекущийДокумент() Тогда
		//		Возврат Периодический.Значение;	//значение не от нашего документа, значит его и возвращаем	
		//	//Иначе //первое же значение введено нашим документом, значит меняли мы значение от предыдущей даты
		//	//	Возврат Периодический.ЗначениеНаДату(Начало-1);
		//	//КонецЕсли;
		//Иначе
		//	//по какой-то причине не смогли получить это значение (интересно по какой?)
		//	Возврат "";
		//КонецЕсли;
//ВАВ - Исправление для выборки последнего периодического значения в пределах выбранной даты
//Начало
		ПоследнееЗначение = "";
		Пока Периодический.ПолучитьЗначение()=1 Цикл
			ПоследнееЗначение = Периодический.Значение;
		КонецЦикла;
		Возврат ПоследнееЗначение;
//Конец
	Иначе //в нужной дате движений не было, значит смело возвращаем последнее действующее   
		Возврат Периодический.ЗначениеНаДату(Начало);
	КонецЕсли;


КонецФункции // ЗначениеПериодическогоРеквизитаНаНачало()
Показать
26. Tolpinski 60 15.10.10 09:21 Сейчас в теме
Печально что покупая за несколько десятков тыщ 8ку, не имеем инструмента по миграции.
Перенос пробую делать через подключение к базе, работает 24 часа на ксеоне 2ггц, и на 98% выдает ошибку. Попробую перенос через файл, и заодно галочку поставлю "отладка" при загрузке, судя по модулю должно помочь. не понятно только почему она в визарде не ставится
27. flord 48 21.10.10 12:11 Сейчас в теме
У кого как переносятся остатки отпусков? У меня после переноса какие-то левые остатки по отпускам сотрудников.
28. samamoiloff 861 22.10.10 08:36 Сейчас в теме
По отпускам пришлось сделать следующие изменения:
		ФормаТрудаСотрудника = Сотрудник.ФормаТруда.Получить(ДатаОкончанияТекущегоГода);
				//******************************************************Изменил Самойлов 26.07.10
				//Если (ФормаТрудаСотрудника = Перечисление.ФормыТруда.ТабельПодневнОклад) или (ФормаТрудаСотрудника = Перечисление.ФормыТруда.ТабельПочасОклад) или (ФормаТрудаСотрудника = Перечисление.ФормыТруда.ТабельПочасТариф) тогда
				//	Если ПустоеЗначение(ДокументТабель) = 0 тогда
				//		ДокументТабель.ПолучитьСтрокуПоНомеру(НомерВТабеле);
				//		
               ...
			   
				Если ЕстьЗаписиПоЖР = 1 Тогда
				//*******************************************************************************
			// заполнение данных по графику работы
			ТаблицаРеквизитов 	= глПолучитьТаблицуИсторииРеквизитов(Сотрудник,ДатаНачалаТекущегоГода,ДатаОкончанияТекущегоГода,"СостояниеФизлица,Ставка,ГрафикРаботы");
			КоличествоСтрок		= ТаблицаРеквизитов.КоличествоСтрок();
			Для Номер = 1 по КоличествоСтрок Цикл
				ТаблицаРеквизитов.ПолучитьСтрокуПоНомеру(Номер);
				СледующаяДата = ?(Номер<КоличествоСтрок,ТаблицаРеквизитов.ПолучитьЗначение(Номер+1,"Дата")-1,ДатаОкончанияТекущегоГода);
				Если (Номер < КоличествоСтрок) и (ТаблицаРеквизитов.Дата >= ?(Номер<КоличествоСтрок,ТаблицаРеквизитов.ПолучитьЗначение(Номер + 1, "Дата"), ДатаОкончанияТекущегоГода)) Тогда
					Продолжить
				КонецЕсли;
				ГрафикРаботы = ПолучитьПустоеЗначение("Справочник.ГрафикиРаботы");
				Если ПустоеЗначение(ТаблицаРеквизитов.СостояниеФизлица)=0 Тогда
					ГрафикРаботы = ТаблицаРеквизитов.ГрафикРаботы;
					Если ПустоеЗначение(ГрафикРаботы)=1 Тогда
						ГрафикРаботы = Константа.ОсновнойГрафик;
					КонецЕсли;
				КонецЕсли;
				Если ПустоеЗначение(ГрафикРаботы)=0 Тогда
					ОбщееКоличествоЧасовВПериоде = ГрафикРаботы.ОсновныеЧасы.Часов(ДатаНачалаТекущегоГода, ДатаОкончанияТекущегоГода);
					КоличествоРабочихДнейВПериоде = ГрафикРаботы.ОсновныеЧасы.Дней(ДатаНачалаТекущегоГода, ДатаОкончанияТекущегоГода);
					Для ДатаКалендаря = ТаблицаРеквизитов.Дата по СледующаяДата Цикл
						Если КоличествоРабочихДнейВПериоде = 0 Тогда
							СреднеДневноеКоличествоЧасов = 0;
						Иначе
							СреднеДневноеКоличествоЧасов = Окр(ОбщееКоличествоЧасовВПериоде/КоличествоРабочихДнейВПериоде)*ТаблицаРеквизитов.Ставка;
						КонецЕсли;
						Часов = ГрафикРаботы.ОсновныеЧасы.Часов(ДатаКалендаря,ДатаКалендаря)*ТаблицаРеквизитов.Ставка;
						НочныхЧасов = ГрафикРаботы.НочныеЧасы.Часов(ДатаКалендаря,ДатаКалендаря);
						ПозицияМассива = НомерДняГода(ДатаКалендаря);
						Если Часов>0 Тогда
							Если ПустоеЗначение(КодЧасов.ПолучитьЗначение(ПозицияМассива)) = 1 Тогда
								КодЧасов.УстановитьЗначение(ПозицияМассива, "Я");
							КонецЕсли;
						ИначеЕсли КодЧасов.ПолучитьЗначение(ПозицияМассива) <> "РВ" Тогда
							Если ПустоеЗначение(КодЧасов.ПолучитьЗначение(ПозицияМассива)) = 1 Тогда
								КодЧасов.УстановитьЗначение(ПозицияМассива, "В");
							КонецЕсли;
						КонецЕсли;
					КонецЦикла;
				КонецЕсли;
			КонецЦикла;
		КонецЕсли;
Показать


К сожалению, сейчас аргументировать за или против не смогу, точно не помню почему только таким образом в моем случае работает и почему стандарт не работает.
29. flord 48 22.10.10 11:13 Сейчас в теме
Вчера разобрался в чем проблема с переносом отпусков. При переносе если в ЗиК было исправление начисления отпуска, то оно тоже переносится и они задваиваются в ЗУПе. Отсюда косяки с остатками отпусков.

Спасибо за код с отпусками потестирую.

Ждем новых правил!!!
30. mikeA 1 03.11.10 08:08 Сейчас в теме
> Морально (и не только) устарела.
C переходящими больничными косяк остался в 28 релизе.
31. 105raz 16.12.10 06:56 Сейчас в теме
Как исправить ошибку с переходяшими больничными и отпусками? К примеру, больничный за январь-февраль введен в феврале. При переносе теряется сумма больничного, приходящегося на январь.
32. AnRyb 6 21.12.10 17:10 Сейчас в теме
105raz пишет:
Как исправить ошибку с переходяшими больничными и отпусками? К примеру, больничный за январь-февраль введен в феврале. При переносе теряется сумма больничного, приходящегося на январь.

У меня такая же ошибка. При чем не у всех сотрудников. У некоторых выгрузилось верно, никак не могу отследить зависимость.
В документе "перенос данных" в "Основные начисления работников" нет записи с отпуском(больничным) прошлого месяца, а в "БУ Основные начисления работников" есть соответствующие записи. Это странно, т.к. в правилах табличные части формируются в одном цикле..
Может ошибки возникают при большом файле выгрузки (у меня больше 1ГБ только "Начисления и удержания (за период переноса)")?
Попробывал сделать выгрузку только по тем сотрудника, у которых возникли ошибки. Все записи загрузились верно, с прошлыми периодами.
Что делать? Руками перепроверить около 800 сотрудников за 12 месяцев не представляется возможным..
Платформа 8.2.13.199
33. 105raz 21.12.10 17:28 Сейчас в теме
Мы выгружали две базы, но размер файлов я не отследила. Могу только сказать, что в первой 2000 сотрудников и ошибок очень много. Во второй сотрудников 50, ошибок мало. Закономерность возникновения ошибки тоже не поняла: во второй базе был сотрудник, у которого один больничный перенёсся с ошибкой, а второй больничный - правильно (оба больничные переходящие). А за идею выгрузить отдельно по "кривым" сотрудникам спасибо. Я их довольно быстро могу отфильтровать.
34. 105raz 21.12.10 17:39 Сейчас в теме
Забыла самое главное спросить: а как вы по отдельным сотрудникам выгрузку делали?
35. AnRyb 6 22.12.10 05:46 Сейчас в теме
105raz пишет:
Забыла самое главное спросить: а как вы по отдельным сотрудникам выгрузку делали?

В справочник сотрудников в ЗиК добавил реквизит "ВыгружатьВЗУП" 0/1. Заполнил реквизит тем или иным способом.
В правилах изменил функцию "РазделитьСотрудниковНаПорции" на следующую:

СписокСотрудников = СоздатьОбъект("СписокЗначений");

ПорцияСотрудников = СоздатьОбъект("СписокЗначений");
КоличествоСотрудников = 0;

СпрСотрудники = СоздатьОбъект("Справочник.Сотрудники");
СпрСотрудники.ВыбратьЭлементы();
Пока СпрСотрудники.ПолучитьЭлемент() = 1 Цикл
	Если СпрСотрудники.ЭтоГруппа() = 1 Тогда
		Продолжить;
	КонецЕсли;
	Если СпрСотрудники.ОсновнойЭлемент <> СпрСотрудники.ТекущийЭлемент() Тогда
		Продолжить;
	КонецЕсли;
	
	//***** Начало изменений
	Если СпрСотрудники.ВыгружатьВЗУП <> 1 тогда
		Продолжить;
	КонецЕсли;	
	//***** Конец изменений
	
	Если КоличествоСотрудников = 100 Тогда
		ПорцияСотрудников.Сортировать();
		СписокСотрудников.ДобавитьЗначение(ПорцияСотрудников);
		ПорцияСотрудников = СоздатьОбъект("СписокЗначений");
		КоличествоСотрудников = 0;
	КонецЕсли;
	
	ПорцияСотрудников.ДобавитьЗначение(СпрСотрудники.ТекущийЭлемент());
	КоличествоСотрудников = КоличествоСотрудников + 1;
КонецЦикла;
Если ПорцияСотрудников.РазмерСписка() > 0 Тогда
	СписокСотрудников.ДобавитьЗначение(ПорцияСотрудников);
КонецЕсли;

Возврат СписокСотрудников;
Показать
36. AnRyb 6 22.12.10 05:55 Сейчас в теме
105raz, вы писали, что можете быстро отфильтровать "кривых" сотрудников.
Поделитесь запросом или идеей.
37. 105raz 22.12.10 09:31 Сейчас в теме
Спасибо за ответ.
Запроса нет, я не программист,к сожалению, обхожусь штатными средствами. В восьмерке в меню Файл есть пункт "Сравнить файлы". Я сравниваю в формате тхт по каждому месяцу. Формирую два файла одинаковой структуры из восьмерки и семерки: ФИО и начисленно за месяц. В восьмерке для этого использую свод начисленной зарплаты, сохраняю в ексель, убираю ненужные строки (и (или) столбцы), сохраняю в формате тхт. В семерке беру отчет Расчетная ведомость, сохраняю в ехсель, убираю лишние строки, столбцы, оставляю только столбец Начислено Всего. Тут ещё надо заменить точку на запятую. Сохраняю в формате тхт. Из восмерки сравниваю эти два файла. Может, не очень автоматизировано, но по-другому пока не умею. Надеюсь, внятно написала.
38. AnRyb 6 22.12.10 10:34 Сейчас в теме
105raz, спасибо за ответ.
Продолжаю разбираться с данной проблемой.
Оказалось, что верно выгружает данные если делать не за весь период в целом, а за каждый месяц в отдельности.
39. 105raz 22.12.10 13:24 Сейчас в теме
Это подтверждает вашу версию о зависимости от объема данных. У нас пока временный перерыв в работе. Если не трудно, держите меня в курсе своих изысканий, буду вам очень благодарна.
40. 105raz 29.12.10 05:53 Сейчас в теме
Взяла с сайта новый вариант внешней обработки переноса (от 27 декабря) и перенесла данные в релиз 2.5.30.4. Ошибки нет, обработку исправили.
41. RuzAleks 108 20.01.11 21:56 Сейчас в теме
42. 4lf 20.01.11 21:59 Сейчас в теме
Здравствуйте, если есть возможность помогите. Переношу Зик в ЗБУ Релизы 305 и 1.0.19.4 соответственно. В конфе что-то накосячено с 2009 годом, так как двесаналогичные конфы перенеслись. а в двух вылетает ошибка: на 2009 году "" ПВД_ПередОбработкойПравила_ФактическиеНачисленияИУдержания: Поле агрегатного объекта не обнаружено (ПериодДействияБазовый)"".
А когда выгружаю данные начиная с 2010 года, меня бы и это на худой конец устроиловылетает при загрузке в ЗБУ (при выгрузке все красиво): Ошибка при загрузке данных: {Обработка.УниверсальныйОбменДаннымиXML(7065)}: Поле объекта не обнаружено (ПрограммаБухгалтерскогоУчета)

Если есть возможность посоветуйте где рыть.
ЗЫ я не кодер (((
43. samamoiloff 861 05.02.11 23:28 Сейчас в теме
(42) Извините? сам оказался не подписан на сообщения своей публикации. По вашим данным только в отладчике и смотреть, что именно вызывает ошибку, в какой-то видимо таблице с данными не хватает колонки, скорее всего, а почему колонка не добавлена никак заочно не поймешь. Открывать в Зик Обработку выгрузки, искать процедуру ПВД_трам-пам-пам, открывать в отладчике и прогонять до ошибки, пытаться анализировать, что к чему.







Изменить 1С
44. 4lf 06.02.11 08:35 Сейчас в теме
Спасибо за ответ, хоть и поздний. Все решил. Установил обработкой все виды расчетов фиксированной суммой и сделал разовыми. Выгрузилось без проблем.
45. okroshina 26.09.11 17:48 Сейчас в теме
Спасибо большое!Данные регистров перенеслись. А есть ли возможность переносить документы? вернее создавать их при переносе? Я понимаю что это большая работа, но вот если бы хотя бы часть по ФСС (больничный), было бы очень хорошо!
46. opolyakova 16 12.10.11 11:06 Сейчас в теме
47. JackIVC 12.10.11 20:43 Сейчас в теме
Хотя много недороботок, вцелом весьма полезная штука. Если каждый с должными познаниями возьмется за обработку, прок выйдет у большениства.
48. пользователь 13.12.11 07:46
Сообщение было скрыто модератором.
...
50. fomix 31 22.12.11 12:32 Сейчас в теме
Попробовал обработку и правила на маленькой базе (сотрудников 50 чел) все выгрузилось хорошо. На базе с кол-вом сотров больше 3700 обвал!!! Не хватило оперативной памяти + файл выгрузки просто офигенный по размеру... А все потому, что в ПКО "ГрафикРаботы" после выгрузки в файл прописан код выгрузки "ГрафикаРаботы" за период по каждому сотру + виду его графика!
Сейчас поправил правила выгрузки: 1. сделал отбор табельных номеров (с: ... по: ...) и выгрузку Графика работы отдельно по справочнику, а не для каждого сотра. Как протестю выложу здесь.
51. post279 04.01.12 12:51 Сейчас в теме
Для бюджетки такое есть?
52. post279 04.01.12 12:51 Сейчас в теме
Где можно взять стандартную обработку выгрузки в файл из ЗИК 7.7?
53. samamoiloff 861 10.01.12 20:43 Сейчас в теме
(52)В ЗУП есть справочник КонвертацииИзИнформационныхБаз..., там есть набор обработок для ЗиК-выгрузки
54. post279 11.01.12 05:56 Сейчас в теме
55. ifedosov 25.01.12 14:27 Сейчас в теме
56. пользователь 22.02.12 07:41
Сообщение было скрыто модератором.
...
57. Vdddslep 27.02.12 14:24 Сейчас в теме
Спасибо за файлы .. очень кстати
58. samamoiloff 861 01.03.12 22:05 Сейчас в теме
(57) Позвольте, какие файлы? Это только схема - структура. А файлы... в заголовке же написано "Для рабочего переноса данных это уже не годится."
Файлы же есть в самой ЗУП! Вы же переносите в ЗУП, значит зуп у вас есть, значит и файлы есть, они в ЗУП ведь свеженькие! Как их извлечь, смотрите мой видеоурок.
Оставьте свое сообщение

См. также

Перенос объектов 1С Промо

Обмен между базами 1C Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Простой и наглядный перенос объектов между любыми базами 1С 8 с предварительным анализом на возможные различия в данных (через файл, через интернет, через буфер обмена, через Com). Интерактивная настройка правил обмена на стороне источника и получателя. В обработке есть удобный обзор по подсистемам, поиск и обработка данных по заданному фильтру. Сравнение объектов, поиск ссылок, регистрация в плане обмена. Конструктор кода по созданию объектов, написание скриптов и отладка мини-функций в УФ. Отключение/включение регламентных заданий. Отчеты по наполнению базы и разные проверки. Всевозможные инструменты администратора или программиста в одной обработке.

1 стартмани

16.03.2015    117430    2324    moolex    282    

Защита объектов от изменения обменом

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Расширение позволяет пользователю заблокировать объект 1С (документ, справочник) от изменения последующими загрузками данных или обменами.

5 стартмани

05.01.2022    12832    49    sapervodichka    52    

Создание стартовой базы

Обмен между базами 1C Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Часто требуется создать «Новую базу» почти пустую, но совпадающую с «Исходной базой» по необходимым обязательным настройкам: константам, регистрам сведений, справочникам, видам субконто и планами счетов и т.п., при этом уникальные идентификаторы объектов должны совпадать.

1 стартмани

11.10.2021    12511    23    sapervodichka    48    

Аванс с проверкой невыходов (Расширение для ЗУП 3.1 и ЗКГУ 3.1) Промо

Обработка документов Зарплата Платформа 1С v8.3 Платформа 1С v8.3 Сложные периодические расчеты Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 1С:Зарплата и кадры государственного учреждения 3 1С:Зарплата и Управление Персоналом 3.x 1С:Зарплата и Управление Персоналом 3.x Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Проверка перед выплатой аванса в документе "Ведомость в банк" и "Ведомость в кассу" по отсутствующим сотрудникам. Тестировал на платформе 1С:Предприятие 8.3 (8.3.15.1489), конфигурации Зарплата и управление персоналом, редакция 3.1 (3.1.10.78) и Зарплата и кадры государственного учреждения, редакция 3.1 (3.1.10.78)

2 стартмани

26.07.2019    14009    55    APTEM_SLV    43    

ЗУП 2.5 - УПП 1.3. Обработка “Выгрузка данных в бухгалтерскую программу”, адаптированная к выгрузке в УПП Промо

Обмен между базами 1C Зарплата Платформа 1С v8.3 Платформа 1С v8.3 1С:Зарплата и Управление Персоналом 2.5 1С:Зарплата и Управление Персоналом 2.5 1С:Управление производственным предприятием 1С:Управление производственным предприятием Россия Россия Абонемент ($m) Абонемент ($m)

ЗУП 2.5 - УПП 1.3 Обработка “Выгрузка данных в бухгалтерскую программу” адаптированная к выгрузке в УПП. (Зарплата и Управление Персоналом, редакция 2.5 (2.5.48.1)-->Управление производственным предприятием, редакция 1.3 (1.3.22.1)) В некоторых случаях перенос данных зарлатного учета в УПП затруднен, и зарплатный учет по прежнему приходится вести в ЗУП, имея бухгалтерский учет уже в УПП. В этом случае поможет данное решение. Это стандартная обработка из ЗУП, с адаптированными правилами переноса под УПП.

2 стартмани

05.04.2012    31486    0    milkers    22    

АРМ "Касса-Лом". Обмен между 1С и учетной системой по оплате с физическими лицами за сдачу металлолома

Оптовая торговля Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

АРМ "КАССА-ЛОМ" предназначено для проведения безналичных взаиморасчетов между физическими лицами-сборщиками металлолома и предприятиями, являющимися членами НП НСРО «РУСЛОМ.КОМ» и осуществляющими деятельность в области обращения с ломом и отходами металлов.

5 стартмани

23.09.2019    15017    24    vik070777    0    

Редактор объектов информационной базы 8.3

Универсальные обработки Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Универсальная внешняя обработка для редактирования реквизитов и табличных частей объектов информационной базы, редактирование движений документов. Доступ ко всем реквизитам объектов, есть возможность выгрузки и загрузки данных (объекты и движения документов) через XML. Платформа 8.3, управляемые формы. Версия 1.1.0.65 от 17.01.2023

2 стартмани

23.01.2019    54678    641    ROL32    83    

Мастер XML-обмена Промо

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Конфигурации 1cv7 Конфигурации 1cv7 Абонемент ($m) Абонемент ($m)

Функциональный аналог конвертации данных в кармане - комплекс обработок предназначенный для быстрой и удобной разработки обмена данными между информационными базами 1С.

5 стартмани

02.09.2015    43669    20    Lancelot-2M    23    

Выполнение запроса в другой базе 1С без com-соединения. HTTP-сервис

Обмен между базами 1C Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Выполнение любого запроса с параметрами из одной базы 1С в другую. Используя HTTP-сервис. Посредством POST-запроса и JSON.

1 стартмани

30.11.2018    44763    51    John_d    29    

Пример получения данных из другой базы 1С через Web-сервис

Обмен между базами 1C Платформа 1С v8.3 Платформа 1С v8.3 Россия Россия Абонемент ($m) Абонемент ($m)

В данной статье описан пример получения данных справочника из другой базы 1С через Web-сервис.

1 стартмани

11.11.2018    62368    50    flyDrag    30    

Выгрузка данных из УТ 11.3/11.4 в БП 3.0 (перенос документов и справочной информации из "Управление торговлей" ред. 11.3/11.4 в "Бухгалтерия предприятием" ред. 3.0). Обновлен до УТ 11.3.4.х/11.4.7х и БП 3.0.7х.х Промо

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Управление торговлей 11 Абонемент ($m) Абонемент ($m)

Данная обработка предназначена для выгрузки в формате XML данных из программы «Управление торговлей» ред. 11.3/11.4 по основным группам документов (документы покупки/продажи товаров и услуг, складские документы, счета-фактуры, ценообразование), а также набор основных справочников. Загрузка данных в БП ред. 3.0 через обработку «Универсальный обмен данными XML». Основная цель обработки – оптимизация работы бухгалтеров во время обмена данными между программами, а также выборочная корректировка загруженных ранее документов.

1 стартмани

04.03.2016    74356    214    SEOAngels    67    

SOAP для чайников

WEB-интеграция Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Немножко про SOAP сервис. И пример работы с подключением и получением данных по SOAP за 5 минут.

1 стартмани

05.09.2018    107391    72    dusha0020    25    

[Розница 8. Аптека] Загрузка приходных накладных из файлов DBF Промо

Файловый обмен (TXT, XML, DBF), FTP Розничная торговля Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница Фармацевтика, аптеки Фармацевтика, аптеки Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Внешняя обработка для загрузки документов «Поступление товаров» из файлов поставщиков в формате DBF для Розница 8. Аптека редакция 2.1. Для работы с дополнительными реквизитами и сведениями используется БДРС: http://infostart.ru/public/288722/ Для купивших БДРС предусмотрена скидка (второй файл - ...без БДРС - это для Вас). При написании использовался шаблон http://infostart.ru/public/303564/. Описание настройки интерфейса и регистрации обработки подробно можно посмотреть там. 20.03.2018 - Версия 3.2 для Розница - Аптека 2.2 (используется новая версия БДРС)

2 стартмани

11.05.2015    39373    0    Alex_E    12    

Создание в 1С 7.7 XML в формате EnterpriseData (универсальный формат обмена), версия 1.5. Инструкции и примеры переноса данных из устаревшей конфигурации 1С 7.7 в любую современную 1С 8.3, поддерживающую EnterpriseData, через Конвертацию данных 3

Файловый обмен (TXT, XML, DBF), FTP Обмен между базами 1C Платформа 1С v7.7 Платформа 1С v7.7 Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv7 Конфигурации 1cv7 Россия Россия Абонемент ($m) Абонемент ($m)

Воспользоваться современным средством переноса данных "Конвертация данных 3.0.5.3" можно только выгрузив из системы - источника данных XML в формате обмена данными EnterpriseData. В этой публикации можно скачать приемы выгрузки из 1С 7.7 универсального формата обмена для Конвертации данных 3. Выполняем перенос данных из «1С:Предприятие 7.7» в «1С:Предприятие 8.3». Используем Конвертацию данных КД 3.0 из 1c 7.7 --> 1С 8.3. На первой стадии еще не опубликовано иного способа подложить файл для Конвертации данных 3 кроме как сформировать его вручную, постараемся решить данную проблему.

1 стартмани

26.02.2018    58282    65    ksnik    3    

Синхронизация данных по правилам КД2.0

Обмен между базами 1C Анализ учета Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Новый инструмент для сравнения и загрузки данных, сочетающий в себе: гибкость запросов (используются для сопоставления объектов); наглядный вывод отличий; удобный отбор загружаемых данных; возможность пообъектной синхронизации двух баз по правилам КД2 с помощью вызова обработки "Универсальный обмен XML" в базе-источнике через COM-соединение.

1 стартмани

27.08.2017    37721    129    vikad    40    

Загрузка выписки из клиент-банка в 1С:Предприятие 8.2 / 8.3 для 1С: Бухгалтерии Предприятия ред.2.0 Промо

Обмен с интернет-банком Банковские операции Зарплата Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Бухгалтерия 2.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Эффективное решение для загрузки банковской выписки из Клиент-Банка в бухгалтерскую программу 1С:Бухгалтерия 2.0 (ПРОФ/КОРП) Требования к файлу экспорта выписки: поддержка формата 1С:Предприятие обмена с клиент-банками Автоматическая установка ключевых реквизитов документов: вид операции, корр.счет, субконто (Контрагенты, сотрудники, прочие доходы и расходы), контрагент Подстройка к любым особенностям учета движения денежных средств

10 стартмани

25.02.2013    120695    298    Designer1C    48    

Перенос справочников и документов из УТ 10.3 в БП 3.0

Обмен между базами 1C Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Налоговый учет Налоговый учет Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Синхронизация справочников и документов из Управление торговлей 10.3 в Бухгалтерию предприятия 3.0. Обработка не затрагивает штатный механизм. Подключение и перенос документов происходит посредством OLE. Без ввода начальных остатков.

10 стартмани

25.07.2017    34329    23    fullstack1c    6    

Обмен данными онлайн через Веб-сервис с использованием обработки "Универсальный обмен данными XML"

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Доработка позволяет организовать двухсторонний обмен данными в режиме реального времени между любыми конфигурациями (типовые, самописные, обычные формы, управляемые формы). Также предлагается вариант в виде расширения конфигурации (.cfe) для конфигураций стоящих на поддержке без возможности изменения. В обмене может участвовать любое количество баз. Правила обмена подготавливаются с использованием конфигурации "Конвертация данных".

2 стартмани

28.10.2016    61245    356    linkov    58    

Поиск и исправление ошибок при заполнении 6-НДФЛ в ЗУП 2.5, Бухгалтерии 2.0, УПП 1.3 версия от 28.08.2018

Регламентированный учет и отчетность Анализ учета Зарплата Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет Сложные периодические расчеты Сложные периодические расчеты 1С:Бухгалтерия 2.0 1С:Бухгалтерия 2.0 1С:Зарплата и Управление Персоналом 2.5 1С:Зарплата и Управление Персоналом 2.5 1С:Управление производственным предприятием 1С:Управление производственным предприятием Россия Россия Бухгалтерский учет Бухгалтерский учет НДФЛ НДФЛ Абонемент ($m) Абонемент ($m)

Помощь в поиске и исправлении ошибок при заполнении отчёта 6-НДФЛ в ЗУП 2.5, Бухгалтерии 2.0 Просмотр всех записей регистров, имеющих отношение к учёту НДФЛ с детализаций до сотрудника и документа. Ручная корректировка основных регистров. Обновлённая версия от 02.07.2018г

3 стартмани

25.10.2016    50669    236    serge_msk    21    

Загрузка файлов на сервер с прогрессом и докачкой

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Пример использования новых возможностей платформы 8.3.9 по низкоуровневой работе с двоичными данными для инкрементальной передачи файлов на сервер.

1 стартмани

04.10.2016    22413    61    mrstomak    22    

Обмен данными между УТ 10.3 и Розницей 2.2 (правила обмена данными между "Управлением торговлей" ред. 10.3. и "Розницей" ред. 2.2)

Обмен между базами 1C Оптовая торговля Розничная торговля Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 1С:Розница 1С:Розница Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Данные правила предназначены для обмена в формате XML данных из программы «Управление торговлей» ред. 10.3. и "Розница" ред. 2.2 по основным группам документов и основных справочников. Загрузка данных осуществляется через встроенную обработку «Универсальный обмен данными XML». Основная цель обработки – корректировка типовых правил на выявленные ошибки и расширение выгрузки для корректной выгрузки данных по ЕГАИС и продажам в целом. Протестировано до УТ 10.3.47.х и Розница 2.2.11.х

3 стартмани

16.09.2016    68303    19    SEOAngels    65    

Редактор движений документа. Сохранение в XML, обмен между базами, замена регистратора.

Обработка документов Универсальные обработки Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

Редактор набора записей движений документа. Позволяет сохранить набор записей в XML, в настройки пользователя, прочитать сохраненный XML в другой идентичной базе, заменить регистратор. Можно изменять порядок записей, менять активность, как массово, так и по одной и др. Тонкий клиент, управляемые формы.

1 стартмани

07.09.2016    59751    180    Aphanas    5    

Соответствия объектов обмена

Обмен между базами 1C Платформа 1С v8.3 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Комплексная автоматизация 1.х Россия Россия Абонемент ($m) Абонемент ($m)

Обработка позволяет проверять, исправлять ошибки, добавлять и удалять соответствия объектов в обменах данными между конфигурациями на основе «Комплексной автоматизации 1.1» или похожими конфигурациям. Подходит для обменов с использованием регистра сведений «СоответствиеОбъектовДляОбмена».

1 стартмани

26.08.2016    33487    13    xxxelaaa    3    

Загрузка Счета покупателя из PDF

Обработка документов Файловый обмен (TXT, XML, DBF), FTP Оптовая торговля Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Абонемент ($m) Абонемент ($m)

Обработка позволяет загрузить счет покупателя из pdf-файла в документ Счет на оплату покупателю (Бухгалтерия 3.0)

2 стартмани

23.05.2016    34983    40    John_d    6    

Перечисление НДФЛ в бюджет РФ (13%, 30%)

Обработка документов Зарплата Платформа 1С v8.3 Платформа 1С v8.3 Сложные периодические расчеты Сложные периодические расчеты 1С:Зарплата и Управление Персоналом 2.5 1С:Зарплата и Управление Персоналом 2.5 Бухгалтерский учет Бухгалтерский учет Налоговый учет Налоговый учет НДФЛ НДФЛ Абонемент ($m) Абонемент ($m)

Внешняя обработка (табличных частей), предназначенная для корректного заполнения документа "Перечисление НДФЛ в бюджет РФ". Конфигурация: Зарплата и Управление Персоналом, редакция 2.5

1 стартмани

27.01.2016    49953    241    1kashak    23    

Выгрузка/загрузка данных в формате JSON v 1.1.2

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка предназначена для обмена данными между схожими конфигурациями в формате JSON. Этот формат обладает рядом существенных преимуществ по сравнению с xml и прочими популярными форматами. В отличие от существующих аналогов, обработка не использует никаких дополнительных библиотек. (де)Сериализация всех объектов происходит средствами встроенного языка и методов ЗаписатьJSON() и ПрочитатьJSON(). Работает на платформе версии не ниже 8.3.6.

4 стартмани

27.01.2016    59966    426    kser87    57