Расчеты онлайн с клиентами "поехали"? Как откорректировать? Управление торговлей 11.5

Публикация № 1738768 07.10.22

Пользовательские инструменты - Корректировка данных

управление торговлей 11.5 взаиморасчеты расчеты онлайн офлайн новая архитектура сбой некорректно поехали

В публикации рассмотрен механизм, позволяющий перезаполнить в 1С:Управление торговлей 11.5 расчеты с клиентами новой архитектуры "онлайн".

В 1С:Управление торговлей 11.5 есть возможность использовать 2 архитектуры расчетов: офлайн (старая) и онлайн (новая).

 

 

Если у вас этого переключателя не видно, значит у вас уже Онлайн.

В данной публикации рассматриваются только расчеты с клиентамиОфлайн (старая) архитектура использует регистр накопления РасчетыСКлиентами, онлайн (новая)регистр накопления РасчетыСКлиентамиПоСрокам.

Иногда после обновления ведомость взаиморасчетов или сверка взаиморасчетов показывает неправильные остатки или обороты. Радует, что "портится" только один регистр РасчетыСКлиентамиПоСрокам. Сверяться можно по-прежнему по регистру РасчетыСКлиентами. Но только с помощью консоли запросов т.к. все штатные отчеты будут брать данные из регистра РасчетыСКлиентамиПоСрокам.

Приложенная обработка делает следующее:
- очищает регистр РасчетыСКлиентамиПоСрокам по заданному Партнеру
- перезаполняет регистр РасчетыСКлиентамиПоСрокам по заданному Партнеру по данным регистра РасчетыСКлиентами.

 

 

Тестировалось на демо базе конфигурации 1С:Управление торговлей 11.5.9.119 на платформе 8.3.21.1302. Код обработки ниже.


&НаКлиенте
Процедура ПартнерПриИзменении(Элемент)
	ПартнерПриИзмененииНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПартнерПриИзмененииНаСервере()
	
	ДолгОфлайн = 0;
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	РасчетыСКлиентамиОстатки.СуммаОстаток КАК ДолгОфлайн
	|ИЗ
	|	РегистрНакопления.РасчетыСКлиентами.Остатки(, АналитикаУчетаПоПартнерам.Партнер = &Партнер) КАК РасчетыСКлиентамиОстатки";
	
	Запрос.УстановитьПараметр("Партнер", Партнер);
	РезультатЗапроса = Запрос.Выполнить();
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	Если ВыборкаДетальныеЗаписи.Следующий() Тогда
		ДолгОфлайн = ВыборкаДетальныеЗаписи.ДолгОфлайн;
	КонецЕсли;
	
	ДолгОнлайн = 0;
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	РасчетыСКлиентамиПоСрокамОстатки.ДолгОстаток - РасчетыСКлиентамиПоСрокамОстатки.ПредоплатаОстаток КАК ДолгОнлайн
	|ИЗ
	|	РегистрНакопления.РасчетыСКлиентамиПоСрокам.Остатки(, АналитикаУчетаПоПартнерам.Партнер = &Партнер) КАК РасчетыСКлиентамиПоСрокамОстатки";
	
	Запрос.УстановитьПараметр("Партнер", Партнер);
	РезультатЗапроса = Запрос.Выполнить();
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	Если ВыборкаДетальныеЗаписи.Следующий() Тогда
		ДолгОнлайн = ВыборкаДетальныеЗаписи.ДолгОнлайн;
	КонецЕсли;
	
	Разница = ДолгОфлайн - ДолгОнлайн;
	
КонецПроцедуры

&НаКлиенте
Процедура ОткорректироватьРасчеты(Команда)
	ОчиститьРасчетыПартнераНаСервере(); 
	ОбработатьДокументыНаСервере();
	ПартнерПриИзмененииНаСервере();
КонецПроцедуры 

&НаСервере
Процедура ОчиститьРасчетыПартнераНаСервере()
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ РАЗЛИЧНЫЕ
	|	РасчетыСКлиентамиПоСрокамОбороты.Регистратор КАК Регистратор
	|ПОМЕСТИТЬ РегистраторыРасчетов
	|ИЗ
	|	РегистрНакопления.РасчетыСКлиентамиПоСрокам.Обороты(, , Регистратор, АналитикаУчетаПоПартнерам.Партнер = &Партнер) КАК РасчетыСКлиентамиПоСрокамОбороты
	|
	|ОБЪЕДИНИТЬ ВСЕ
	|
	|ВЫБРАТЬ
	|	РегистраторРасчетов.Ссылка
	|ИЗ
	|	Документ.РегистраторРасчетов КАК РегистраторРасчетов
	|ГДЕ
	|	РегистраторРасчетов.АналитикаУчетаПоПартнерам.Партнер = &Партнер
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ РАЗЛИЧНЫЕ
	|	РегистраторыРасчетов.Регистратор КАК Регистратор
	|ИЗ
	|	РегистраторыРасчетов КАК РегистраторыРасчетов";
	
	Запрос.УстановитьПараметр("Партнер", Партнер);
	РезультатЗапроса = Запрос.Выполнить();
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		НаборЗаписей = РегистрыНакопления.РасчетыСКлиентамиПоСрокам.СоздатьНаборЗаписей();
		НаборЗаписей.Отбор.Регистратор.Установить(ВыборкаДетальныеЗаписи.Регистратор);
		НаборЗаписей.Записать();
		
		РегистраторРасчетовОбъект = ВыборкаДетальныеЗаписи.Регистратор.ПолучитьОбъект();
		РегистраторРасчетовОбъект.Удалить();
	КонецЦикла; 
	
КонецПроцедуры

&НаСервере
Процедура ОбработатьДокументыНаСервере() 
	СписокОбъектовВзаиморасчетов = СписокОбъектовВзаиморасчетов();
	Для каждого СтрокаОбъектыВзаиморасчетов из СписокОбъектовВзаиморасчетов Цикл
		
		ДокументСсылка = НайтиРегистраторРасчетов(СтрокаОбъектыВзаиморасчетов);
		Если ДокументСсылка.Пустая() Тогда
			
			ДокументОбъект = Документы.РегистраторРасчетов.СоздатьДокумент();
			ДокументОбъект.Комментарий = "кс";
			ДокументОбъект.Валюта = СтрокаОбъектыВзаиморасчетов.Ссылка.Валюта;
			ДокументОбъект.АналитикаУчетаПоПартнерам = СтрокаОбъектыВзаиморасчетов.АналитикаУчетаПоПартнерам;
			ДокументОбъект.Организация = СтрокаОбъектыВзаиморасчетов.Ссылка.Организация;
			ДокументОбъект.ОбъектРасчетов = СтрокаОбъектыВзаиморасчетов.Ссылка;
			ДокументОбъект.ТипРасчетов = Перечисления.ТипыРасчетовСПартнерами.РасчетыСКлиентом;
			ДокументОбъект.Дата = ТекущаяДатаСеанса();
			ДокументОбъект.Записать(РежимЗаписиДокумента.Проведение);
			
		Иначе 
			
			ДокументОбъект = ДокументСсылка.ПолучитьОбъект();	
			
		КонецЕсли;
		
		ТаблицаДвижений = ПолучитьТаблицуДвижений(СтрокаОбъектыВзаиморасчетов.Ссылка); 
		НаборЗаписей = РегистрыНакопления.РасчетыСКлиентамиПоСрокам.СоздатьНаборЗаписей();
		НаборЗаписей.Отбор.Регистратор.Установить(ДокументОбъект.Ссылка);
		НаборЗаписей.Загрузить(ТаблицаДвижений);   
		НаборЗаписей.Записать();
		
	КонецЦикла;
КонецПроцедуры   

&НаСервере
Функция СписокОбъектовВзаиморасчетов()
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	РасчетыСКлиентамиОбороты.ОбъектРасчетов КАК Ссылка,
	|	РасчетыСКлиентамиОбороты.СуммаПриход КАК Приход,
	|	РасчетыСКлиентамиОбороты.СуммаРасход КАК Расход,
	|	РасчетыСКлиентамиОбороты.АналитикаУчетаПоПартнерам КАК АналитикаУчетаПоПартнерам
	|ИЗ
	|	РегистрНакопления.РасчетыСКлиентами.Обороты(, , , АналитикаУчетаПоПартнерам.Партнер = &Партнер) КАК РасчетыСКлиентамиОбороты
	|
	|УПОРЯДОЧИТЬ ПО
	|	РасчетыСКлиентамиОбороты.ОбъектРасчетов.Дата";
	
	Запрос.УстановитьПараметр("Партнер", Партнер);
	РезультатЗапроса = Запрос.Выполнить();
	СписокОбъектовВзаиморасчетов = РезультатЗапроса.Выгрузить();
	
	Возврат СписокОбъектовВзаиморасчетов;
	
КонецФункции

&НаСервере
Функция НайтиРегистраторРасчетов(СтрокаОбъектыВзаиморасчетов)
	Результат = Документы.РегистраторРасчетов.ПустаяСсылка();
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	РегистраторРасчетов.Ссылка КАК Ссылка
	|ИЗ
	|	Документ.РегистраторРасчетов КАК РегистраторРасчетов
	|ГДЕ
	|	РегистраторРасчетов.Валюта = &Валюта
	|	И РегистраторРасчетов.АналитикаУчетаПоПартнерам = &АналитикаУчетаПоПартнерам
	|	И РегистраторРасчетов.Организация = &Организация
	|	И РегистраторРасчетов.ОбъектРасчетов = &ОбъектРасчетов
	|	И РегистраторРасчетов.ТипРасчетов = &ТипРасчетов";
	
	Запрос.УстановитьПараметр("АналитикаУчетаПоПартнерам", СтрокаОбъектыВзаиморасчетов.АналитикаУчетаПоПартнерам);
	Запрос.УстановитьПараметр("Валюта", СтрокаОбъектыВзаиморасчетов.Ссылка.Валюта);
	Запрос.УстановитьПараметр("ОбъектРасчетов", СтрокаОбъектыВзаиморасчетов.Ссылка);
	Запрос.УстановитьПараметр("Организация", СтрокаОбъектыВзаиморасчетов.Ссылка.Организация);
	Запрос.УстановитьПараметр("ТипРасчетов", Перечисления.ТипыРасчетовСПартнерами.РасчетыСКлиентом);
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Если ВыборкаДетальныеЗаписи.Следующий() Тогда
		Результат = ВыборкаДетальныеЗаписи.Ссылка;
	КонецЕсли;
	
	Возврат Результат;
КонецФункции

&НаСервере
Функция ПолучитьТаблицуДвижений(ОбъектРасчетов)
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	РасчетыСКлиентамиОбороты.АналитикаУчетаПоПартнерам КАК АналитикаУчетаПоПартнерам,
	|	РасчетыСКлиентамиОбороты.ОбъектРасчетов КАК ОбъектРасчетов,
	|	РасчетыСКлиентамиОбороты.Валюта КАК Валюта,
	|	РасчетыСКлиентамиОбороты.Регистратор КАК РасчетныйДокумент,
	|	РасчетыСКлиентамиОбороты.СуммаОборот КАК Долг,
	|	РасчетыСКлиентамиОбороты.СуммаОборот КАК ДолгРегл,
	|	РасчетыСКлиентамиОбороты.СуммаОборот КАК ДолгУпр,
	|	РасчетыСКлиентамиОбороты.Период КАК Период,
	|	РасчетыСКлиентамиОбороты.Регистратор КАК ДокументРегистратор
	|ИЗ
	|	РегистрНакопления.РасчетыСКлиентами.Обороты(, , Регистратор, ОбъектРасчетов = &ОбъектРасчетов) КАК РасчетыСКлиентамиОбороты";
	
	Запрос.УстановитьПараметр("ОбъектРасчетов", ОбъектРасчетов);
	
	РезультатЗапроса = Запрос.Выполнить();
	ТаблицаДвижений = РезультатЗапроса.Выгрузить();
	ТаблицаДвижений.Колонки.Добавить("ВидДвижения", Новый ОписаниеТипов("ВидДвиженияНакопления"));
	ТаблицаДвижений.Колонки.Добавить("ХозяйственнаяОперация", Новый ОписаниеТипов("ПеречислениеСсылка.ХозяйственныеОперации"));
	
	Для каждого СтрокаДвижения из ТаблицаДвижений Цикл
		СтрокаДвижения.ВидДвижения = ВидДвиженияНакопления.Приход;
		СтрокаДвижения.ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.РеализацияКлиенту;
		Если СтрокаДвижения.Долг < 0 Тогда  
			СтрокаДвижения.Долг = -СтрокаДвижения.Долг;	
			СтрокаДвижения.ДолгРегл = -СтрокаДвижения.ДолгРегл;	
			СтрокаДвижения.ДолгУпр = -СтрокаДвижения.ДолгУпр;
			СтрокаДвижения.ВидДвижения = ВидДвиженияНакопления.Расход;
			СтрокаДвижения.ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.ПогашениеЗадолженностиКлиента;
		КонецЕсли;
	КонецЦикла;
	
	Возврат ТаблицаДвижений;
КонецФункции

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	ПартнерПриИзмененииНаСервере();
КонецПроцедуры

 

Скачать файлы

Наименование Файл Версия Размер
Управление торговлей 11.5. Расчеты Онлайн с клиентами "поехали"? Как откорректировать?:

.epf 8,09Kb
3
.epf 8,09Kb 3 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Константин С. 731 21.11.22 22:37 Сейчас в теме
А работа штатной не подходит для формирования документов "РегистраторРасчетов"
e1cib/app/Обработка.ЗаполнениеРегистровВзаиморасчетов

и не приводит ваше действие "корректировки" системой остатков по регистру "по срокам", в момент закрытия месяца "Актуализацией движения документов..."
Оставьте свое сообщение

См. также

Восстановление предопределенных элементов справочника средствами платформы (переинициализацией) Промо

Обработка справочников Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка восстанавливает потерянные предопределенные элементы справочника с заполненным наименованием, кодом и иерархией, которые описаны в конфигурации. Исправление ошибки "Предопределенный элемент отсутствует в данных".

2 стартмани

28.03.2018    23446    119    Dipod    13    

Универсальная обработка корректировки справочников, документов и регистров (движений документов) 1С. УФ

Обработка документов Обработка справочников Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Послужит вспомогательным средством при работе с системами 1С на управляемых формах. При выборе объекта форма обработки перестраивается динамически, поэтому никаким заранее определенным перечнем объектов обработка не ограничена.

10 стартмани

18.03.2021    9160    34    perepetulichka    1    

Подсистема "Корректировка движений документов" Промо

Обработка документов Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Универсальная подсистема, позволяющая просматривать и корректировать движения документа по учетным регистрам конфигурации прямо из его формы. Подсистема актуальна для тех конфигураций, в которых подобный функционал не предусмотрен (например, типовая конфигурация "Управление торговлей 11").

3 стартмани

10.03.2016    29709    47    Bassgood    31    

Превращение доработанной конфигурации в типовую или исправление ошибки "Имеются записи с одинаковыми измерениями"

Чистка данных Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Помогает решить проблему связанную с дублями в регистрах сведений при возвращении к типовой конфигурации. Ошибка "Имеются записи с одинаковыми измерениями".

1 стартмани

12.02.2021    19930    212    pyrkin_vanya    43    

Восстановление базы 1С из бэкапа SQL при помощи Python

Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Скрипт для создания копии базы на сервере SQL и добавления базы в кластер 1С.

1 стартмани

16.12.2020    9326    4    user1287977    1    

Просмотр и восстановление любых таблиц БД для компоненты 1CDLib + Быстрая очистка регистра "Замеры времени"

Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Доработанная обработка для компоненты 1CDLib для просмотра и восстановления любых таблиц БД из БД донора. Тестировалось на версии платформы 8.3.17.1549.

1 стартмани

09.11.2020    12335    124    sxp    9    

Групповая корректировка записей регистров (Управляемое приложение) v 2.3 Промо

Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Система компоновки данных Система компоновки данных Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка предназначена для групповой корректировки записей регистров Накопления, Сведений и Бухгалтерии. Разработана специально для Управляемого приложения.

4 стартмани

06.09.2013    79584    447    kser87    76    

Тестирование любых конфигураций

Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Расширение для тестирования любых конфигураций на управляемых формах, в том числе тестируется запись, проведение и другие стандартные операции.

1 стартмани

29.10.2020    6005    22    ManyakRus    20    

Расширенное редактирование трудовой деятельности СЗВ-ТД

Зарплата Обработка документов Кадровый учет Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Сложные периодические расчеты Сложные периодические расчеты 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 1С:Зарплата и кадры государственного учреждения 3 1С:Зарплата и кадры государственного учреждения 3 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x 1С:Зарплата и Управление Персоналом 3.x Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Расширение, позволяющее отредактировать документ Сведения о трудовой деятельности работников, СЗВ-ТД. Добавление, отмена, изменение, редактирование, удаление мероприятий, замена идентификатора (UUID). Для конфигураций ЗУП, ЗГУ, БП, КА, ERP.

2 стартмани

21.04.2020    14251    141    ixijixi    21    

Исправление ошибки "Для одного ссылочного кода существует более одной таблицы в базе данных" в БД SQL

Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка позволяет исправить схему имен базы данных, схема которой была испорчена и из-за этого возникают ошибки при обновлении конфигурации или при сервисной процедуре тестирования и исправления. Ошибка SDBL: Ошибка обновления конфигурации базы данных. Для одного ссылочного кода существует более одной таблицы в базе данных. Имена таблиц с кодом .... Далее перечисляются пары таблиц, которые имеют одинаковый номер. Обработка таблице находит новый номер, заменяет на него все ссылки в схеме, переименовывает таблицу SQL

3 стартмани

23.01.2020    23951    238    rokhin    69    

Корректировка остатков регистров бухгалтерии (обычные и управляемые формы) Промо

Свертка базы Чистка данных Закрытие периода Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Платформа 1C v8.2 Платформа 1C v8.2 Бухгалтерский учет Бухгалтерский учет Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Бухгалтерский учет Бухгалтерский учет Налоговый учет Налоговый учет Абонемент ($m) Абонемент ($m)

Внешняя обработка, предназначенная для удобного исправления остатков по регистрам бухгалтерии (Хозрасчетный, Налоговый или любой другой) посредством автоматизации ввода корректировочного документа ("Операция", "Корректировка записей регистров"), приводящего регистр в нужное состояние остатков от текущего. Удобна для массовых правок остатков по бухгалтерскому и налоговому учету на какую-то дату (обычно перед реорганизацией учета, сверткой базы и т.п.)

2 стартмани

03.06.2017    47508    298    stvorl    36    

Проверка работы расширений после обновлений

Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Иногда бывает, что после обновления конфигурации некоторые расширения перестают работать и часто такие ошибки выявляются только в процессе тестирования или рабочем режиме. При правильной разработке и проектировании расширения можно свести к минимуму такие ошибки, но иногда их не избежать. Если в базе расширений не более 5-10, то проверить каждое после обновления не составляет труда, а вот если их больше 50 - проверка отнимает слишком много времени Поэтому была написана обработка, которая в автоматическом режиме проверяет расширения, подключенные в программе. Обработка универсальная и будет работать в любой программе, в которой есть расширения.

3 стартмани

19.07.2019    26204    36    77dream77    4    

Список заказов поставщикам (новая форма) + два ноу-хау для разработчиков Промо

Рабочее место Взаиморасчеты Оптовая торговля Платформа 1С v8.3 Платформа 1С v8.3 Оперативный учет Оперативный учет 1С:Комплексная автоматизация 1.х 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление торговлей 10 Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Представлена внешняя обработка - "Список заказов поставщикам (новая форма)". Удобство заключается в том, что в одном окне списка отображается структура всех связанных документов с указанием контрагента (заказ поставщику - поступление товаров - заказ покупателя - реализация товаров - оплата товара покупателем). В этом же окне отображается список товаров с заказанным количеством и ценами. Имеется возможность видеть статусы заказов по цветам (исполнен, выполняется, черновик). Форму легко встроить в типовую конфигурацию.

2 стартмани

31.08.2017    37005    21    RustIG    18    

Исправление ошибки "Записи регистра сведений стали не уникальными"

Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Обработка исправления ошибки "Записи регистра сведений стали не уникальными"

1 стартмани

02.06.2019    33184    448    Sholl    0    

Восстановление структуры DBSchema

Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Абонемент ($m) Абонемент ($m)

Обработка для анализа ошибок в структуре DBShema, восстановление структуры объектов, перенос данных из выгруженных в XML таблиц базы, при помощи "Tool 1CD".

10 стартмани

11.03.2019    22464    104    spawn_a    31    

Групповое создание актов сверки "Бухгалтерии предприятия" ред. 3.0

Обработка документов Взаиморасчеты Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Простая, но полезная обработка по массовому созданию документов актов сверок за период в "Бухгалтерии предприятия 3.0". Есть отборы по группе контрагентов, остаткам и оборотам на счетах, доп.опции. В базе создаются документы "Акт сверки расчетов".

1 стартмани

19.01.2019    19250    123    maxx    9    

Корректировка остатков ЕГАИС, возврат из регистра 2, загрузка ТТН из файлов, другое для УТ10.3 Промо

Розничная торговля Обработка документов Обмен с ГосИС Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Оперативный учет Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 10 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Набор обработок для автоматизации работы с ЕГАИС: Обработка корректировки остатков ЕГАИС для УТ 10.3, аналогичная имеющимся в УТ 11, Рознице 2.2. Автоматически формирует документы "Передача в торговый зал", "Акт постановки на баланс в торговом зале", "Акт списания в торговом зале". Обработка возврата из регистра 2 с подбором справок Б. Обработка формирования ТТН из файлов xml.

1 стартмани

24.01.2018    55337    20    biz-intel    6    

Замена конфигурации в правилах обмена

Обработка справочников Корректировка данных Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 1С:Конвертация данных 1С:Конвертация данных Абонемент ($m) Абонемент ($m)

С помощью этой внешней обработки для конфигурации 1С:Конвертация данных, ред. 2.1 вы легко замените конфигурацию приемника или источника в правилах конвертации объектов.

2 стартмани

08.01.2019    15866    102    tomvlad    14    

Сравнение pdf-файлов актов сверки

Универсальные обработки Взаиморасчеты Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 2.0 1С:Бухгалтерия 2.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Обработка сравнивает два pdf-файла, в которых находятся стандартные печатные формы актов сверки, и показывает на экране совпадающие и/или отличающиеся по суммам документы взаиморасчетов.

1 стартмани

19.12.2018    28965    21    Torin99    2    

Нестандартные подсистемы: Живая вода

Поиск данных Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

В БСП есть все, чтобы справиться с проблемой «Битых ссылок», но почему-то так и не реализовали возможность сохранять версию объекта перед удалением. Решил исправить эту досадную несправедливость и создать подсистему с кодовым названием «Живая вода».

1 стартмани

11.10.2018    19176    4    dsdred    14    

Восстановление битой ссылки на раз-два Промо

Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Простой способ восстановить битую ссылку типа " (20:94b81c6f65428d5911e2a8bebc48d793)".

1 стартмани

26.04.2013    42172    736    Vin_Tik    36    

Поиск и восстановление битых ссылок (Объект не найден)

Поиск данных Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Групповая обработка ссылок вида Объект не найден (502:37855254002e11eb11e73b8f36150d9e) заполняется максимально просто копированием и вставкой из буфера: 1) Выделяет уникальные идентификаторы (далее УИ); 2) Ищет ссылки на объекты базы по УИ; 3) Создаёт пустые объекты с указанным УИ; 4) Регистрирует найденные ссылки для обмена данными. Работает на любых продуктах 8.3. Проверялась на 1С:ERP Управление предприятием 2 (2.4.3.167)

1 стартмани

17.08.2018    25321    198    sapervodichka    4    

Корректировка остатков регистров накопления (обычные и управляемые формы) Промо

Свертка базы Чистка данных Универсальные обработки Закрытие периода Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Внешняя обработка, предназначенная для удобного и быстрого исправления остатков регистров накопления (посредством автоматического ввода документов "Корректировки записей регистров", "Операция", содержащих движения, приводящие существующие остатки к желаемым). Позволяет корректировать и обнулять по аналитике и суммам остатки регистров учета товаров, партий, взаиморасчетов, налогового учета по НДС, РАУЗ, и др.

2 стартмани

14.01.2012    98339    1880    stvorl    86    

Запуск и контроль выполнения автоматизированных тестов из 1С – Jenkins Skin

Корректировка данных DevOps и автоматизация разработки Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

Мы рассмотрим пример создания заданий выполнения автоматизированных тестов из 1С с использованием различных Фреймворков (xUnit1C, Тестирование 3.0): запуск, ожидание завершения, загрузка результатов и выполнение полного цикла тестирования продукта. Убедимся, что все действия можно выполнить в пару кликов в дружественном интерфейсе.

1 стартмани

09.07.2018    24323    16    ivanov660    5    

Корректировка остатков ЕГАИС для 1С:Розница/УТ 10.3 - альтернативный вариант

Обработка документов Розничная торговля Логистика, склад и ТМЦ Обмен с ГосИС Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница Розничная и сетевая торговля (FMCG) Розничная и сетевая торговля (FMCG) Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Обработка корректировки остатков ЕГАИС для 1С Розница версии 2.2.7/2.2.8/2.2.9/2.2.10/2.2.11/УТ 10.3.47.ХХХ-48.XXX-49.XXX-50.XXX раздельно по маркируемому/немаркируемому алкоголю + создание документов постановки/списания по пересортице.

1 стартмани

02.06.2018    52405    445    independ    300    

Загрузка данных в документ Перенос данных, Операция Бух, Корректировка регистров

Обработка документов Загрузка и выгрузка в Excel Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Загрузка данных из табличного документа в документ корректировки записей регистров и сведений, кроме регистров бух. учета (Хозрасчетный и т.д.) Например -"Операция Бух" -"Корректировка регистров" "Перенос данных" Предназначена для разработчиков в 1с. Не является конечным решением. Работы с обработкой проводились на : Управление торговлей, редакция 11 (11.4.3.126).

3 стартмани

24.05.2018    17671    131    aleksey.kubovtsov    19    

Сбой во взаиморасчетах в КА и ERP

Взаиморасчеты Обработка документов Платформа 1С v8.3 Платформа 1С v8.3 1С:Комплексная автоматизация 2.х 1С:Комплексная автоматизация 2.х Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Недавно столкнулся с проблемой во взаиморасчетах в комплексной автоматизации. Взаиморасчеты в КА полностью аналогичны ERP. Опишу свой опыт на примере 1С:Комплексная автоматизация 2.4.2.123, возможно, это кому-то поможет.

1 стартмани

03.04.2018    49488    281    human_new    21    

Ошибка: Попытка вставки неуникального значения в уникальный индекс: Microsoft SQL Server. При переходе с Бух ПРОФ на КОРП и не только

Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Пример текста ошибки: Попытка вставки неуникального значения в уникальный индекс: Microsoft SQL Server Native Client 11.0: Выполнение инструкции CREATE UNIQUE INDEX прервано, поскольку обнаружен повторяющийся ключ для объекта с именем "dbo._InfoRg22530" и индекса с именем "_InfoRg22530_ByPeriod". Повторяющееся значение ключа: (0, 3900-01-01 00:00:00, 0x9100fa815581b9604de110ca98afc344, 0x00000000000000000000000000000000). HRESULT=80040E2F, SQLSrvr: SQLSTATE=23000, state=1, Severity=10, native=1505, line=1

1 стартмани

16.06.2017    57965    203    N0D    41    

Упрощение работы с актами сверки в УТ/КА/УПП - вывод номеров счетов в документе и печатной форме

Обработка документов Печатные формы Взаиморасчеты Платформа 1С v8.3 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление торговлей 10 1С:Управление производственным предприятием 1С:Управление производственным предприятием Бухгалтерский учет Бухгалтерский учет Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Обычно акт сверки с клиентами содержат информацию о документах реализации товаров (накладных) и выполненных платежах. Но платежи делаются на основании счетов, номера которых отсутствуют в актах, что затрудняет собственно сверку. Данная обработка находит соответствующие расходным накладным счета/заказы, показывает их в форме документа и выводит в печатную форму акта.

2 стартмани

12.05.2017    46929    5    denmax    7    

Поиск и восстановление битых ссылок (обычная и управляемая форма) 8.2-8.3

Универсальные обработки Поиск данных Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка для поиска и восстановления битых ссылок (Объект не найден). Адаптирована для конфигураций на обычных и управляемых формах 8.2 - 8.3

1 стартмани

08.04.2017    52022    727    Xershi    66    

Автоматическое заполнение Акта списания ЕГАИС на основании остатков ЕГАИС. 1С Розница 2.2. Корректировка КлассификаторАлкогольнойПродукцииЕГАИС Импортер

Обработка документов Розничная торговля Обмен с ГосИС Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

На остатках регистра 2 ЕГАИС хранятся остатки, которые должны равняться остаткам в 1С Розница 2.2. Иногда случается, что остатки не равны по каким либо причинам - пересортица или недостача алкоголя(особенно с розливом). Существует стандартная система корректировки остатков, но там много телодвижений нужно сделать. Суть данной обработки: выровняли остатки на складе ( в т.ч. Торговый зал тоже), затем запросили Остатки ЕГАИС и данной обработкой сделали Акт Списания ЕГАИС. Но самое главное в табличную часть загружается строки с излишками. Их нужно было до 31.12.2016 оприходовать, в настоящий момент можно выпить. Адаптировано под релиз 2.2.9-2.2.11

3 стартмани

29.03.2017    24223    187    dj_tol    14    

Лекарство на случай, если перестала работать форма списка для сделок. (ERP).

Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 Абонемент ($m) Абонемент ($m)

Форма списка справочник сделки стала выпадать с ошибкой?  Или все еще в порядке, но хочется спокойно съездить в отпуск, без паники, что менеджеры устроят бунт.

1 стартмани

28.07.2016    29705    0    milkers    2    

Зачистка ссылок на документы после свертки. 1С:Бухгалтерия 3.0

Свертка базы Чистка данных Обработка документов Взаиморасчеты Логистика, склад и ТМЦ Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Бухгалтерия 2.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

После стандартной свертки не удаляются документы из базы? Вы уже заметили, что они абсолютно во всех операциях по вводу начальных остатков? Эта обработка поможет решить вопрос!!! Все документы расчетов в виде старых документов будут заменены на новый документ расчетов, и Вы сможете избавиться от ненужных старых документов!

2 стартмани

05.04.2016    28144    92    katerinaUniv    8