Удаление дублирующихся файлов в томах на диске

Публикация № 1738039 05.10.22

Пользовательские инструменты - Адаптация типовых решений

Хеширование присоединенных файлов

Типовой механизм хранения файлов позволяет один и тот же файл прикреплять несколько раз. Это бесит наших админов, и по их просьбе был реализован следующий алгоритм.

Мы провели анализ и выяснили, что в базе УТ один и тот же файл прикрепляют к разным документам.

Пример на скрине, один файл прикрепили 139 раз, и это не предел:

 

 

Решили избавиться от данной проблемы.

Суть решения.

1. Прокешировать всё файлы алгоритмом  МД5.

2. Выявить дубли.

3. Удалить лишние файлы, а в Справочнике присоединенных файлов сделать ссылки на уникальные файлы.

Вопрос, куда записывать информацию по файлам. Решил создать индексированный ресурс в регистре сведений Сведения о файлах.

К сожалению, в текущей версии платформы и конфигурации данный механизм нельзя полностью реализовать через расширение,  т.к. нельзя создать доп. ресурс. А перечислять в расширении все имена справочников, в которых есть "...ПрисоединенныеФайлы" проблематично. Это реализация для старой УТ. Для Бухгалтерии всё это вынесено в расширение, которое прикрепляю к данной публикации.

 

 

И в процедуре "перед записью"  в  модуле объекта регистра сведений "СведенияОФайлах" дописывать кеш файла.

//++Семенихин 05.10.2022 ++ Полати // 
//Дозаписываем Хеш по файлу
Процедура ПередЗаписью(Отказ, Замещение)
	Если ОбменДанными.Загрузка Тогда
		Возврат;
	КонецЕсли;
	
	Для Каждого строка из ЭтотОбъект Цикл
		//ПолучимИмяФалаФайл.Строка(Файл)
		//ОбщегоНазначенияКлиентСервер.ПолучитьПолноеИмяФайла(ИмяВременногоКаталога, ИмяФайла)
		Если строка.ТипХраненияФайла = 	Перечисления.ТипыХраненияФайлов.ВТомахНаДиске тогда
			Попытка
				ИмяФайла = ОбщегоНазначенияКлиентСервер.ПолучитьПолноеИмяФайла(строка.Файл.Том.ПолныйПутьWindows,строка.Файл.ПутьКФайлу);
				строка.Пл_КонтрольнаяСумма = MD5ХешФайл(ИмяФайла);
			Исключение
				
			КонецПопытки;	
			
		ИначеЕсли строка.ТипХраненияФайла = Перечисления.ТипыХраненияФайлов.ВИнформационнойБазе тогда
			//Двоичных данных ещё нет, они появятся позже..
			//Надо обрабатывать уже ОбщийМодуль.РаботаСФайламиСлужебный.Модуль.ЗаписатьФайлВИнформационнуюБазу и обновлять
			//сведения о файлах.
			//Пока данный вариант реализации не рассматриваем, Его можно на отдельное рег задание возложить	
			//ДвоичныеДанные = РаботаСФайлами.ДвоичныеДанныеФайла(строка.Файл);
			//строка.Пл_КонтрольнаяСумма = MD5ХешСтрока(ДвоичныеДанные);
			
		КонецЕсли;
	КонецЦикла;

КонецПроцедуры 

 //++Семенихин 05.10.2022 ++ Полати // 
Функция MD5ХешФайл(тСтрока)
 	Хеш = Новый ХешированиеДанных(ХешФункция.MD5);
 
 	Хеш.ДобавитьФайл(тСтрока);
	 
 	Возврат Хеш.ХешСумма; 
КонецФункции

//++Семенихин 05.10.2022 ++ Полати // 
Функция MD5ХешСтрока(тСтрока)
 	Хеш = Новый ХешированиеДанных(ХешФункция.MD5);
 
	 Хеш.Добавить(тСтрока);
 
 	Возврат Хеш.ХешСумма; 
КонецФункции

 

После добавления ресурса его можно заполнить обработкой:

Для этого перезаписываем регистр Сведения о файлах, а они уже сами допишутся, т.к. в модуле объекта уже есть соответствующая процедура 

 

Процедура ДописатьКЕШвСведенияОФайлах()Экспорт
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	СведенияОФайлах.Файл КАК Файл,
		|	СведенияОФайлах.Пл_КонтрольнаяСумма КАК Пл_КонтрольнаяСумма
		|ИЗ
		|	РегистрСведений.СведенияОФайлах КАК СведенияОФайлах
		|ГДЕ
		|	СведенияОФайлах.ТипХраненияФайла = &ТипХраненияФайла
		|	И СведенияОФайлах.Пл_КонтрольнаяСумма = """"";
	
	Запрос.УстановитьПараметр("ТипХраненияФайла", Перечисления.ТипыХраненияФайлов.ВТомахНаДиске);
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		
	  //  СвойстваФайлаВТоме = РаботаСФайламиВТомахСлужебный.СвойстваФайлаВТоме(ВыборкаДетальныеЗаписи.Файл);
	  //ИмяФайла = РаботаСФайламиВТомахСлужебный.ПолноеИмяФайлаВТоме(СвойстваФайлаВТоме);
	  //  Пл_КонтрольнаяСумма = MD5ХешФайл(ИмяФайла);
		ДописатьХешВСведенияОФайлах(ВыборкаДетальныеЗаписи.Файл);
	КонецЦикла;
	
	

КонецПроцедуры


Процедура ДописатьХешВСведенияОФайлах(Файл)
	
	Попытка
	Запись = РегистрыСведений.СведенияОФайлах.СоздатьМенеджерЗаписи();
	Запись.Файл = Файл;
	Запись.Прочитать();
	Если Запись.Выбран() Тогда
		//Запись.Пл_КонтрольнаяСумма = Пл_КонтрольнаяСумма;
		
		Запись.Записать();
	КонецЕсли;
	Исключение
	 Сообщить("Проблема в файле " + Файл);
	КонецПопытки;
	
	
КонецПроцедуры

После этого обработкой удаляем ненужные файлы и меняем ссылки в справочнике на эксклюзивные файлы. Обработку тоже прилагаю



Процедура УдалитьОдинаковыеФайлы() Экспорт

		
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	КОЛИЧЕСТВО(РАЗЛИЧНЫЕ СведенияОФайлах.Файл) КАК Файл,
		|	СведенияОФайлах.Пл_КонтрольнаяСумма КАК Пл_КонтрольнаяСумма
		|ПОМЕСТИТЬ ВТ_СведенияОФайлах
		|ИЗ
		|	РегистрСведений.СведенияОФайлах КАК СведенияОФайлах
		|ГДЕ
		|	СведенияОФайлах.Пл_КонтрольнаяСумма <> """"
		|
		|СГРУППИРОВАТЬ ПО
		|	СведенияОФайлах.Пл_КонтрольнаяСумма
		|;
		|
		|////////////////////////////////////////////////////////////////////////////////
		|ВЫБРАТЬ
		|	СведенияОФайлах.Файл КАК Файл,
		|	СведенияОФайлах.Размер КАК Размер,
		|	ВТ_СведенияОФайлах.Файл КАК КоличетвоОдинаковыхФайлов,
		|	ВТ_СведенияОФайлах.Пл_КонтрольнаяСумма КАК Пл_КонтрольнаяСумма,
		|	СведенияОФайлах.ВладелецФайла КАК ВладелецФайла,
		|	СведенияОФайлах.Файл.ПутьКФайлу КАК ФайлПутьКФайлу,
		|	СведенияОФайлах.Файл.Том.ПолныйПутьWindows КАК ФайлТомПолныйПутьWindows,
		|	СведенияОФайлах.Файл.Том КАК ФайлТом
		|ИЗ
		|	ВТ_СведенияОФайлах КАК ВТ_СведенияОФайлах
		|		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.СведенияОФайлах КАК СведенияОФайлах
		|		ПО ВТ_СведенияОФайлах.Пл_КонтрольнаяСумма = СведенияОФайлах.Пл_КонтрольнаяСумма
		|ГДЕ
		|	ВТ_СведенияОФайлах.Файл > 1
		|ИТОГИ ПО
		|	Пл_КонтрольнаяСумма";
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаПл_КонтрольнаяСумма = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
	
	Пока ВыборкаПл_КонтрольнаяСумма.Следующий() Цикл
		// Вставить обработку выборки ВыборкаПл_КонтрольнаяСумма
	
		ВыборкаДетальныеЗаписи = ВыборкаПл_КонтрольнаяСумма.Выбрать();
		
		ПервыйФайл = Истина;
		
		Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
			
			Если ПервыйФайл Тогда
				ГлавноеИмяФайла = ПолучитьИмяФайлаПоВыборке(ВыборкаДетальныеЗаписи);
				ГлавныйТом = ВыборкаДетальныеЗаписи.ФайлТом;
				ГлавныйПутьКФайлу = ВыборкаДетальныеЗаписи.ФайлПутьКФайлу;
			Иначе
				
                ИмяТекущегоФайла = ПолучитьИмяФайлаПоВыборке(ВыборкаДетальныеЗаписи);
				Если ГлавноеИмяФайла <> ИмяТекущегоФайла Тогда
					ВыбФайл = Новый Файл(ИмяТекущегоФайла);
					Если ВыбФайл.Существует() Тогда 
					    Если ВыбФайл.ПолучитьТолькоЧтение() Тогда
					        ВыбФайл.УстановитьТолькоЧтение(Ложь);
				    КонецЕсли;
				    УдалитьФайлы(ИмяТекущегоФайла);                       
				КонецЕсли;
				//	УдалитьФайлы(ИмяТекущегоФайла);
					ПереписатьСправочникПрисоединенныхФайлов(ВыборкаДетальныеЗаписи.Файл,ГлавныйТом,ГлавныйПутьКФайлу);
				КонецЕсли;	
			КонецЕсли;
			
			ПервыйФайл = Ложь;
        КонецЦикла;
	КонецЦикла;
	
КонецПроцедуры


Процедура ПереписатьСправочникПрисоединенныхФайлов(Файл,ГлавныйТом,ГлавныйПутьКФайлу)
	
	ОбъектФайл = Файл.ПолучитьОбъект();
	ОбъектФайл.Том = ГлавныйТом;
	ОбъектФайл.ПутьКФайлу = ГлавныйПутьКФайлу;
	ОбъектФайл.Записать();
	
КонецПроцедуры 

Функция ПолучитьИмяФайлаПоВыборке(ВыборкаДетальныеЗаписи)
	 Возврат ОбщегоНазначенияКлиентСервер.ПолучитьПолноеИмяФайла(ВыборкаДетальныеЗаписи.ФайлТомПолныйПутьWindows,ВыборкаДетальныеЗаписи.ФайлПутьКФайлу);
КонецФункции	

 

Тестировалось на Бухгалтерии 3.0.113.17 и Управление торговлей, редакция 11 (11.4.10.75).

Скачать файлы

Наименование Файл Версия Размер
Удаление дублирующихся файлов в томах на диске при типовом хранении файлов в 1с.:

.cfe 10,36Kb
1
.cfe 10,36Kb 1 Скачать
Удаление дублирующихся файлов в томах на диске при типовом хранении файлов в 1с.:

.epf 7,79Kb
2
.epf 7,79Kb 2 Скачать

Специальные предложения

Вознаграждение за ответ
Показать полностью
Лучшие комментарии
2. PLAstic 289 06.10.22 09:24 Сейчас в теме +1 $m
Я вот всё думаю, когда мне хоть какие бонусы начнут капать с плюсов на твоих разработках.
chigsrOck; +1 Ответить
Остальные комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. arsentevpva 06.10.22 09:00 Сейчас в теме
хм.. а ведь работает. Спасибо автору.
2. PLAstic 289 06.10.22 09:24 Сейчас в теме +1 $m
Я вот всё думаю, когда мне хоть какие бонусы начнут капать с плюсов на твоих разработках.
chigsrOck; +1 Ответить
3. human_new 504 06.10.22 09:38 Сейчас в теме
4. SerVer1C 509 06.10.22 09:39 Сейчас в теме
Лучше для хранения файлов использовать файловую систему с возможностью дедупликации.
И почему у вас под хэш тип строка(50) переменная? Думаете, что найдется MD5 длиннее 32 символов?
5. human_new 504 06.10.22 09:41 Сейчас в теме
(4) Хеш всегда 47 символов, не зависит от объема файла. А вот про файловую систему с возможностью дедупликации, пожалуйста, поподробнее, что бы админам переслать
6. MSK_Step 22 06.10.22 10:11 Сейчас в теме
Например, если в одной документы можно изменить файл по правам, а такой же файл в другом месте нельзя, то файлы надо дублировать. В вашем случае экономия пары ГБ, но получиться может хуже.
Может админам выделить 1 Тб? Цены сейчас не такие большие+дедупликация на нем
7. human_new 504 06.10.22 10:16 Сейчас в теме
(6) Справочник присоединенных файлов и так задублированным остается, у него всегда только один владелец, а ссылки на путь до файла подмениваются. Разделение по правам редактирования файлов я в 1с вообще не встречал. Согласен, что с версиями файлов надо ещё обдумывать, если изменяемые файлы хранить но у нас грузят в основном только PDF.
10. MSK_Step 22 06.10.22 11:13 Сейчас в теме
(7)Если в поступление А загрузили 1 скан, затем в поступление Б загрузили этот же скан. После обработки - они будет указывать на 1 файл, все верно? Что делать тогда, если в поступление Б пользователь поймет что совершил ошибку и заменит файл на правильный, в поступление А - тоже будет указывать на этот файл?
11. human_new 504 06.10.22 11:18 Сейчас в теме
(10) Да, Совсем забыл, у нас прикрепление файлов к документам тоже доработано на дату запрета изменения сразу после проведения... А так надо ещё над отборами подумать по срокам давности
13. human_new 504 06.10.22 11:22 Сейчас в теме
(10) Хотя всё тоже решается определенными отборами по сроку давности документов. механизм при этом никак не меняется. А отбор в обработке можете у себя поставить
14. human_new 504 06.10.22 12:01 Сейчас в теме
(10) Кстати, начал думать, А что значит заменит файл, у нас доступ к файлам только у службы 1с. Он может только удалить старый и прикрепить новый и тут всё отработает четко, никакой подмены не будет.
8. brolin 06.10.22 10:34 Сейчас в теме
Как только разработчики 1С сделают хоть один шаг в сторону S3 или любой другой сторонней хранилки - появится и дедупликация на уровне ФС.
9. brolin 06.10.22 10:41 Сейчас в теме
Ну это всё в рамках юмора.
Юрий с обработкой - просто монстр, спасибо большое.

Дедупликация файлов на уровне ФС с точки зрения админов - ну такое. Есть 1С которая по каким-то своим алгоритмам складывает файлы в хранилище. Да, видим, что файлы одинаковые, но мало ли как и по какой причине они были сохранены?
Если же ставится задача о том, что на хранилке с файлами не должно быть одинаковых файлов, то как решить который из 2 файлов верный, а который должен быть удален?
Для меня логически кажется верным, что удалением дублей занимается та же система, что их плодит.
12. MSK_Step 22 06.10.22 11:19 Сейчас в теме
(9)
Для меня логически кажется верным, что удалением дублей занимается та же система, что их плодит.

Система Windows или 1с ? Если привести аналогию, что файлы плодит сервер exchange, тогда дедупликация отлично справляется с файлами, при этом сам exchange не занимается, тем, что надо следить за дублями.
15. brolin 06.10.22 12:09 Сейчас в теме
Да, всё так. exchange использует файловое хранилище на сервере с ролью "файловый сервер" с включенной дедупликацией (типа того: https://learn.microsoft.com/ru-ru/windows-server/storage/data-deduplication/understand).
Поймет ли 1С (на уровне приложения) такое отношение у ней файловой системы - не готов ответить, ни разу не пробовал.
16. MSK_Step 22 06.10.22 13:59 Сейчас в теме
(15)
ни разу не пробовал.

мы используем, при частой перезаписи файлов это спасает от дублирования новых версий на самом диске
17. brolin 06.10.22 14:06 Сейчас в теме
(16)
Огромное спасибо за наводку :)
18. starik-2005 2771 06.10.22 20:09 Сейчас в теме
В детстве, помню, пилил на паскале софтинку, которая удаляла одинаковые файлы (размер + простой XOR CRC 32 бита на асме). Коллегам с универа это позволило сильно уменьшить количество мусора на дисках, которые были совсем не такими большими, аки щаз.
19. starik-2005 2771 06.10.22 23:14 Сейчас в теме
Кстати, аффтор, имей ввиду, что файлы с одной и той же контрольной суммой могут быть разными. Это называется коллизией хеша. Фактически на сообщение из Х бит с хешем в У бит количество коллизий для каждого хеша будет равно 2^(Х-У). Т.е. если сообщение длиннее хеша всего на байт, то на каждый вариант хеша будет 2^8 сообщений. Но это так, математика. Ее все вроде бы знают, так что не принимайте близко к сердцу, если очевидные вещи говорю. Просто в интернетах иногда шутки ходят о том, что самый крутой архиватор - это md5.
GorkyGorod; asupsam; +2 Ответить
Оставьте свое сообщение

См. также

Хранение файлов в томах на диске (для УПП 1.3) Промо

Адаптация типовых решений Платформа 1С v8.3 1С:Управление производственным предприятием Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    76928    20    wowik    33    

Важная ошибка в УТ 11.5.10.46. Многократное применение скидок в реализациях по заказам

Адаптация типовых решений Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 11 Управленческий учет Абонемент ($m)

Перевели одного клиента на эту версию и столкнулись с достаточно критической ошибкой, за которую где-то могут менеджеров и уволить, или будут крупные разбирательства. Если реализации создается по заказу, и в заказе есть скидки, то каждое выполнение расчета скидок уменьшает сумму документа. В списке исправлений ошибок релиза по данной ошибке пока нет информации. Будьте аккуратны.

1 стартмани

30.11.2022    382    0    qwinter    2    

Расчет переоценки валютных средств

Адаптация типовых решений Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Налоговый учет Налог на прибыль Абонемент ($m)

При проведении операции по закрытию месяца 1С пишет ошибку, не может записать РС РасчетПереоценкиВалютныхСредств. Причина оказалась в разных остатках - валютный остаток и рублевый по одному и тому же счету.

1 стартмани

27.10.2022    723    0    human_new    0    

Добавляем новый документ в обработку Диадок

Файловый обмен (TXT, XML, DBF), FTP Адаптация типовых решений Платформа 1С v8.3 1С:Комплексная автоматизация 2.х Абонемент ($m)

Добавляем новый документ для подписания и отправки в обработку Диадок (через подключаемый модуль). Отправлять его будем, как неформализованный (внешняя печатная форма в формате pdf).

2 стартмани

07.10.2022    3751    8    John_d    18    

Создание внешней печатной формы под Управляемое Приложение (Управление Торговлей 11.1.1.11) Промо

Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Создание внешней печатной формы под Управляемое Приложение (Управление Торговлей 11.1.1.11)

1 стартмани

28.03.2013    163799    548    Stradivari    31    

Управление сбором истории согласования в комплексных процессах

Документооборот и делопроизводство Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Абонемент ($m)

Интерфейс настройки сбора истории согласования в комплексных процессах.

1 стартмани

19.09.2022    957    3    Free_Danial    0    

Физлицо сотрудника и список сотрудников по физлицу

Адаптация типовых решений Кадровый учет Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Абонемент ($m)

О том как быстро сделать расширение, отображающее взаимосвязь физлиц и сотрудников. И мой вариант (протестирован на 8.3.22.1368, Зарплата и управление персоналом, редакция 3.1 (3.1.23.68) и (3.1.18.616)).

1 стартмани

17.09.2022    1126    0    niko11s    0    

Множественные дополнительные реквизиты для УТ 11

Адаптация типовых решений Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 11 Россия Управленческий учет Абонемент ($m)

Готовое расширение для множественного дополнительного реквизита в УТ 11.

3 стартмани

06.09.2022    989    4    nemec    0    

Отправка сообщений пользователям Промо

Адаптация типовых решений Платформа 1С v8.3 1С:Управление торговлей 10 Россия Абонемент ($m)

Предполагаю, что в организациях, где работает больше 10-15 человек, сложно звонить каждому и сообщать пользователям какую-либо информацию. Я обыскал на всех ресурсах, так того, что требуется, не нашел.

1 стартмани

13.01.2012    20069    374    kojinandrej    54    

Присоединенные файлы в 1С:Бухгалтерии в расширении

Адаптация типовых решений Платформа 1С v8.3 1С:Бухгалтерия 3.0 Россия Абонемент ($m)

Столкнулся с необходимостью добавить возможность прикреплять файлы в конфигурации 1С:Бухгалтерия предприятия, находящейся на поддержке. Разработал расширение, которое можно подключить к конфигурации не снимая ее с поддержки, и реализовать функционал присоединенных файлов к любому документу системы.

3 стартмани

05.09.2022    1226    7    NightBreez    8    

Управление созданием задач ознакомления в процессах согласования

Документооборот и делопроизводство Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Управленческий учет Абонемент ($m)

Используя регистр настроек, отключаем задачи ознакомления для различных точек маршрута согласования.

1 стартмани

18.08.2022    1540    3    Free_Danial    0    

Параметризация печатных форм под контрагентов (подключаемое расширение)

Печатные формы Адаптация типовых решений Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Расширение добавляет возможности параметризации печати для контрагентов. Подробнее описано здесь https://infostart.ru/1c/articles/1510459/

5 стартмани

05.08.2022    5062    6    sapervodichka    4    

Загрузка банка (дополнительный парсинг)

Обмен с интернет-банком Адаптация типовых решений Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Абонемент ($m)

Данное расширение позволяет производить дополнительное изменение при загрузке банковских документов. Изменение конфигурации - не требуется.

5 стартмани

02.08.2022    1494    2    sulig    6    

Просмотр объектов очереди сообщений в 1С:Документооборот

Адаптация типовых решений Документооборот и делопроизводство Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

В базах с бесшовной интеграцией с 1С:Документооборот есть Регистр сведений "Очередь сообщений в 1С:Документооборот". Для пользователя он мало информативен. Расширение позволяет просматривать сообщение в человеческом виде. И понимать проблему до объекта.

1 стартмани

02.08.2022    5016    16    sapervodichka    4    

Cчет на оплату выводит шапку "Банковские реквизиты / BANK INFORMATION"

Адаптация типовых решений Платформа 1С v8.3 1С:ERP Управление предприятием 2 Абонемент ($m)

При печати счета на оплату выводит шапку "ОбразецЗаполненияРеквизитыБанка", причины и пути решения.

1 стартмани

11.07.2022    1054    1    osa92    0    

Видимость переключателя Без закрывающих документов

Адаптация типовых решений Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

В 1С:Бухгалтерии в банковских выписках в документах поступление на расчетный счет есть переключатель - Учет без закрывающих документов. Его удобно использовать для УСН доходы или патента. Однако при определённых настройках он не виден на форме. Расширение включает видимость этого переключателя для любых СНО.

2 стартмани

07.07.2022    1751    6    de0nis    0    

Исправление ошибки РДИК_0333

Адаптация типовых решений Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Исправление ошибки РДИК_0333 при выгрузке документов в ЕИС.

1 стартмани

05.07.2022    2729    32    oleg-x    9    

Добавление строк в регистрации обязательств по договорам с разными ИФО. БГУ 2.0

Адаптация типовых решений Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия государственного учреждения Государственные, бюджетные структуры Бухгалтерский учет Бюджетный учет Абонемент ($m)

Иногда нужно и очень хочется добавить принимаемые обязательства по одному договору, но по нескольким ИФО, но БГУ 2.0 не дает это сделать, а жаль! В результате приходится заводить одинаковые договоры или создавать бухгалтерскую операцию, ну или корректировать проводки вручную - плохо! С помощью расширения решим это и сможем добавлять строки с разными ИФО.

3 стартмани

30.06.2022    1617    7    VID1234    0    

Выгрузка документов в формате XML для загрузки в ЭДО операторов СБИС, Диадок и т.п.

Адаптация типовых решений Файловый обмен (TXT, XML, DBF), FTP ЭДО и ОФД Платформа 1С v8.3 1С:ERP Управление предприятием 2 Россия Абонемент ($m)

Расширение для добавления дополнительного функционала в библиотеку БЭД , добавляет команду для выгрузки данных в формате XML для загрузки в ЭДО из 1С.

3 стартмани

30.06.2022    2206    33    osa92    14    

Гарантийные талоны УТ 11.4

Оптовая торговля Розничная торговля Адаптация типовых решений Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Расширение предназначено для автоматизации выдачи и учета гарантийных талонов в УТ 11.4 (возможно и в других конфигурациях УТ, не тестировалось)

3 стартмани

21.06.2022    1113    6    gonzaomsk    0    

Исправление обработки Подбор номенклатуры в Бухгалтерии для Беларуси, редакция 2.1.42.8

Адаптация типовых решений Платформа 1С v8.3 Конфигурации 1cv8 Беларусь Бухгалтерский учет Абонемент ($m)

В версии 1С 8.3 Бухгалтерия для Беларуси 2.1.42.8 обнаружена ошибка в подборе номенклатуры (из любого документа): независимо от выбранного количества номенклатуры в форму попадает единица.

1 стартмани

15.06.2022    1270    1    1v7    2    

Критерии отбора в расширении. 16+

Адаптация типовых решений Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Связываем критерии отбора расширения с типовой структурой подчиненности в универсальных решениях 1С.

3 стартмани

09.06.2022    3739    27    Ankare    11    

Штрихкодирование номенклатуры. УАТ

Логистика, склад и ТМЦ Адаптация типовых решений Платформа 1С v8.3 Конфигурации 1cv8 Автомобили, автосервисы Транспорт, автопарки, такси Управленческий учет Абонемент ($m)

Расширение для штрихкодирования номенклатуры в конфигурации "Управление Автотранспортом" 2.2.

2 стартмани

09.06.2022    1336    6    Kh_Romeroo    2    

Исправление ошибки - не печатается код вида дохода 2, 3, 4, 5 в списках в банк

Зарплата Адаптация типовых решений Платформа 1С v8.3 Сложные периодические расчеты 1С:ERP Управление предприятием 2 1С:Зарплата и кадры государственного учреждения 3 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Абонемент ($m)

С версии ЗУП минимум 3.1.22.48 в печатной форме "Список перечислений" для ведомостей в банк и ведомостей на счета не печатает код дохода исполнительного производства, если он отличается от единицы. Данное расширение исправляет эту ошибку.

1 стартмани

01.06.2022    1579    0    ixijixi    0    

Обезжиривание шрифта в печатной форме (экономим тонер)

Печатные формы Адаптация типовых решений Платформа 1С v8.3 1С:Бухгалтерия 3.0 Абонемент ($m)

Код, который убирает полужирное начертание у шрифтов в печатной форме. Тестировалось на конфигурации Бухгалтерия Предприятия 3.0.111.16. Но должно работать на любых конфигурациях с БСП.

1 стартмани

24.05.2022    1709    1    q_i    4    

Присоединение внешней печатной формы в виде файла к объекту-основанию

Печатные формы Адаптация типовых решений Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

В данной публикации речь пойдёт о том, как можно присоединить сформированную внешнюю печатную форму в виде файла к тому объекту (справочнику, документу и т.п.), на основании которого она была сформирована.

1 стартмани

20.05.2022    2457    1    delta    0    

Добавление состояния согласования из 1С: Документооборот

Документооборот и делопроизводство Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Абонемент ($m)

Добавляем статус согласования из подключенной базы 1С Документооборот в типовые и нетиповые конфигурации с использованием библиотеки интеграции с 1С: Документооборотом. Статусы добавляются в формы списка и формы объектов.

1 стартмани

11.05.2022    2947    1    Free_Danial    0    

Автозаполнение шаблонов файлов MXL в "1С:Документообороте"

Документооборот и делопроизводство Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Абонемент ($m)

Добавление возможности создавать автозаполняемые шаблоны файлов в формате MXL в 1С:Документооборот и сохранением заполненного файлы в формате PDF (таблицы, результаты запроса реквизиты...)

1 стартмани

05.05.2022    3332    17    JIEX@    0    

Шаблон этикетки для УНФ (1С:Фреш)

Адаптация типовых решений Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Описан механизм создания этикетки для термопринтера ТSC TDP-225 в подробностях. Приложен XML-файл с самим шаблоном.

1 стартмани

01.05.2022    3446    2    zemskov    3    

Электронный чек взамен бумажного

Кассовые операции Розничная торговля Адаптация типовых решений Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 Абонемент ($m)

Упрощаем выдачу электронного чека взамен бумажного в УНФ 1.6.

1 стартмани

19.04.2022    2605    9    ixijixi    0    

ЗУП: История изменения контактной информации для организации

Адаптация типовых решений Платформа 1С v8.3 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Абонемент ($m)

История изменения контактной информации для организации в конфигурации ЗУП.

1 стартмани

23.03.2022    2509    1    MaxxiMiliSan    2    

Внутренний оборот тары при перемещениях. УТ 11.4

Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Адаптация типовых решений Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 11 Россия Управленческий учет Абонемент ($m)

Внутренний оборот тары при перемещениях для Управления торговлей 11.4, которого почему-то нет в конфигурации из коробки.

2 стартмани

16.03.2022    2544    0    13D    0    

Отключение системных команд "Печать, Предварительный просмотр, Сохранить", которые по умолчанию отображаются с релиза 8.3.15

Универсальные функции Адаптация типовых решений Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

В УТ 11 возникла необходимо при печати чека отключить системные команды Печать, Предварительный просмотр, Сохранить. Задача: отключить возможность у пользователя (кассира) печатать документы реализации (Товарный чек или Реализацию) в количестве более 1 экземпляра.

1 стартмани

16.02.2022    3316    1    whitevolta    0    

Моментальный поиск документов при сканировании штрих-кода, замена штрих-кода на QR код, QR-кодирование печатных форм в 1С: Управление нашей фирмой (УНФ)

Адаптация типовых решений Обработка документов Поиск данных Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 Россия Абонемент ($m)

Моментальный поиск документов при сканировании штрих-кода, замена штрих-кода на QR код, QR-кодирование печатных форм в 1С: Управление нашей фирмой (УНФ) для мобильного приложения.

1 стартмани

11.02.2022    2610    2    1c-krund    2    

Исправление ошибки с аналитиками в бюджетировании ERP 2.4

Адаптация типовых решений Бюджетирование и планирование Платформа 1С v8.3 1С:ERP Управление предприятием 2 Абонемент ($m)

В случае когда у статьи бюджета больше одного правила получения фактических данных, происходит некорректное поведение программы при подстановке конкретных значений аналитик, данное расширение исправляет эту ситуацию.

1 стартмани

17.01.2022    3108    0    bob_    0    

Исправление ошибки: Изменение запрещено, объект расчетов используется в других объектах. УТ 11.5, КА и ERP 2.5

Взаиморасчеты Адаптация типовых решений Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Бухгалтерский учет Управленческий учет Абонемент ($m)

После обновления на 2.5 стала появляться ошибка при изменении объекта расчетов, например, в поступлении ДС. Изменение запрещено, объект расчетов Поступление безналичных ДС используется в других объектах: Сверка взаиморасчетов. При этом пометка на удаление сверки не помогает.

1 стартмани

14.01.2022    5040    56    77dream77    8    

Программное создание и расчет документов начисления зарплаты в конфигурации ЗУП 3.1 и ERP (по подразделениям)

Зарплата Адаптация типовых решений Платформа 1С v8.3 Сложные периодические расчеты 1С:ERP Управление предприятием 2 1С:Зарплата и Управление Персоналом 3.x Бухгалтерский учет Абонемент ($m)

Краткое описание типового механизма расчета зарплаты в конфигурации ЗУП 3.1 и ERP и описание разработанной обработки по программному расчету документов зарплаты в разрезе подразделений. Т.к. формирование документов происходит полностью программно, с минимумов параметров, его можно брать за основу для расчета документов по своим условиям, вплоть до создания по расписанию при необходимости.

10 стартмани

27.12.2021    6159    16    maraty    39    

БСП 3.1.5 Форма отчета. Быстрый вызов редактирования варианта

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Работа с интерфейсом Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

В последних релизах современных конфигураций, основанных на БСП версии 3.1.5, спрятали кнопку настройки варианта в дебри вложенных форм. Вернём всё как было, и даже лучше.

1 стартмани

20.12.2021    4561    1    ixijixi    0    

Доработка документа для формирования проводок в регламентированном учете ERP

Адаптация типовых решений Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Бухгалтерский учет Абонемент ($m)

Статья о том, как включить разработанный документ в подсистему формирования проводок в конфигурации ERP

1 стартмани

17.12.2021    7064    5    maraty    6    

Обновление МДЛП - проблемы с перемещением (431 сообщение)

Логистика, склад и ТМЦ Адаптация типовых решений Платформа 1С v8.3 Конфигурации 1cv8 Фармацевтика, аптеки Россия Управленческий учет Абонемент ($m)

Исправление ошибки с получением квитанции о перемещении МДЛП ("Мониторинг движения лекарственных препаратов для медицинского применения от производителя до конечного потребителя").

1 стартмани

24.11.2021    4744    2    Vladimir45    9    

Отображение ОГРН в карточке контрагента. УТ 11

Обработка справочников Адаптация типовых решений Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Возможность заполнения и отображения уже заполненного ОГРН из сервиса 1С:Контрагенты (расширение).

1 стартмани

11.11.2021    2822    6    pridecom    0