Добавляем новый документ в обработку Диадок

Публикация № 1737685 07.10.22

Интеграция и обмен данными - Файловый обмен (TXT, XML, DBF), FTP

Диадок

Добавляем новый документ для подписания и отправки в обработку Диадок (через подключаемый модуль). Отправлять его будем, как неформализованный (внешняя печатная форма в формате pdf).

Для начала сгенерируем нужные нам события

 

 

 

Выбираем обработать типовой результат. Можно и переопределить полностью, но тогда придется описывать все документы, с которыми мы работаем.

 

 

Получаем шаблон с событиями, которые нам нужно обработать

 

 

1. ПолучитьТаблицуИспользуемыхПакетов()

 

 

Функция ПолучитьТаблицуИспользуемыхПакетов(Параметры)

	Если ТипЗнч(Параметры) = Тип("Структура") И Параметры.Свойство("Результат_ИМ") Тогда 
		
		//ТЗ = ТаблицаЗначенийСКолонками("ID, Наименование, СоставПакета, КатегорияПакета, НаименованиеКатегории, Шаблон");

		ТЗ  = Параметры.Результат_ИМ;
		ОсновнойМодуль.ЭДО_Служебные_ДобавитьСтрокуВТаблицуЗначений(ТЗ, "ID_Приложение", "Приложение" , "ID_Приложение", "ЗаказКлиента", "ЗаказКлиента");  
					
		Возврат ТЗ;

	КонецЕсли;

КонецФункции 

 

2. ПолучитьТаблицуИспользуемыхВидовДокументов()

 

 

Функция ПолучитьТаблицуИспользуемыхВидовДокументов(Параметры)

	Если ТипЗнч(Параметры) = Тип("Структура") И Параметры.Свойство("Результат_ИМ") Тогда  
		
		ТЗ  = Параметры.Результат_ИМ;
		ОсновнойМодуль.ЭДО_Служебные_ДобавитьСтрокуВТаблицуЗначений(ТЗ, "ID_Приложение", "Приложение", "Nonformalized", "");   

		Возврат ТЗ;

	КонецЕсли;

КонецФункции 

 

3.ПолучитьТекстЗапросаДляСпискаПакетовНаОтправкуПоМассивуВидовПакетов()

 

 

Функция ПолучитьТекстЗапросаДляСпискаПакетовНаОтправкуПоМассивуВидовПакетов(Параметры)

	Если ТипЗнч(Параметры) = Тип("Структура") И Параметры.Свойство("Результат_ИМ") Тогда 
				
		Если Параметры.МассивВидовПакетов.Найти("ID_Приложение") <> Неопределено Тогда
		
			ОписаниеВидаПакета = ОсновнойМодуль.ЭДО_СправочникМенеджер_ПолучитьЭлемент("ВидыПакетов", "ID_Приложение");
			     
			Параметры.ПараметрыЗапроса.Вставить("ВидПакетаID_ID_Приложение","ID_Приложение");
			
			Если Параметры.МассивВидовПакетов.Количество() = 1 Тогда
				Результат = ТекстЗапроса_Приложение(ОписаниеВидаПакета);   
				Результат = "ВЫБРАТЬ РАЗРЕШЕННЫЕ" + Сред(Результат, СтрДлина("ВЫБРАТЬ") + 1);
				Результат = ТекстЗапроса_ВременныеТаблицыДляСпискаПакетовНаОтправку_1С() + "
							|;
							|
							|//////////////////////////
							|" + Результат + "
							|УПОРЯДОЧИТЬ ПО
							|	ДатаДокумента, НомерДокумента";    
				Параметры.Результат_ИМ = Результат;

			Иначе	
				Результат = ДобавитьОбъединениеВТекстЗапроса() + ТекстЗапроса_Приложение(ОписаниеВидаПакета);
				ТекстДляЗамены = "
							|" + Результат + " 
							|
							|УПОРЯДОЧИТЬ ПО 
							|";
				Параметры.Результат_ИМ = СтрЗаменить(Параметры.Результат_ИМ, "УПОРЯДОЧИТЬ ПО" , ТекстДляЗамены); 
			КонецЕсли;
						
			Возврат Параметры.Результат_ИМ;
    	КонецЕсли;
	КонецЕсли;

КонецФункции

 

В функции ПолучитьТекстЗапросаДляСпискаПакетовНаОтправкуПоМассивуВидовПакетов нужно определить, запрос идет ко всем документам, с которыми мы работаем, или только к новому документу. Если ко всем, то запрос просто дописываем в конец основного запроса, а если только к новому документу, то нужно написать весь запрос (со всеми временными таблицами).

 
 Запрос к новому документу

 Если у вас модуль Диадока встроен в конфигурацию, то у вас будут другие временные таблицы. Их можно будет взять из запроса, когда мы добавляем наш запрос к основному запросу.

 
 Временные таблицы

4. ПодготовитьПакет()

 

 

Функция ПодготовитьПакет(Параметры)

	Если ТипЗнч(Параметры) = Тип("Структура") И Параметры.Свойство("Результат_ИМ") Тогда
		
		Если Параметры.ВидПакетаРазвернутый.ID = "ID_Приложение" Тогда	
			ОсновнойМодуль.ЭДО_ДокументМенеджер_ПодготовитьИДобавитьДокументВПакет(Параметры.Пакет, Параметры.СтрокаСписка.Документ, "ID_Приложение");     
			Возврат Истина;
		КонецЕсли;	

	КонецЕсли;

КонецФункции

 

Далее подключаем модуль и жмем сохранить

 

 

Заходим в настройки организации.

Ставим галочку на новый документ

 

 

 

 

Там же выбираем нужную печатную форму (желательно, чтобы в печатной форме была одна команда), которую будем отправлять и подписывать

 

 

 

готово

 

 

 

Тестировал: 

  • 1С:Комплексная автоматизация 2 (2.4.13.209)
  • Платформа 1С:Предприятие 8.3 (8.3.19.1467)

Диадок:

  • Версия модуля: 4.21.2.2018
  • Версия плагина: 1.4.5.286
  • Расположение модуля: ВСправочнике
  • Модуль интеграции: ПМ_УТ_11

Скачать файлы

Наименование Файл Версия Размер
ДиадокПодключаемыйМодуль.epf

.epf 7,31Kb
9
.epf 7,31Kb 9 Скачать

Специальные предложения

Вознаграждение за ответ
Показать полностью
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. bavkyz 3 07.10.22 10:54 Сейчас в теме
Добрый, спасибо за труд +1, Маленько не понял, в вашем решении пользователь с ЭЦП или пользователь по логин/пароль, создает документ и передать на подписание руководителю?

И еще вопрос, где вы нашли описание по работе с универсальной обработкой диадока?
2. John_d 4362 07.10.22 11:23 Сейчас в теме
(1) -Только пользователи с ЭЦП могут подписать документ, но просматривать документы в обработке могут все.
-Документы после создания и проведения сами появляются в обработке. Пользователь их выбирает подписывает и отправляет.
https://developer.kontur.ru/Docs/Diadoc_UM/
sapervodichka; +1 Ответить
3. bavkyz 3 07.10.22 11:28 Сейчас в теме
(2)
пользователи с ЭЦП могут подписать документ
- это логично), в вашем решении обязательно ли пользователю иметь ЭЦП для создания документа?

P.S. мне надо чтоб пользователь мог создать документ, а руководитель "потом" подпишет
4. tricolor 21 07.10.22 11:34 Сейчас в теме
(3) у нас пользователи заходят по логину и паролю, и отправляют документ на согласование, далее руководитель подписывает и отправляет документы.
6. John_d 4362 07.10.22 11:40 Сейчас в теме
(3) не обязательно. Пользователь вообще может не заходить в обработку Диадок создать документ, как обычно создает в 1с.
5. stsasha87 135 07.10.22 11:40 Сейчас в теме
Зная, насколько сложно там всё реализовано, понимаешь сколько времени и трудов ушло на эту доработку.

Тоже сижу разбираюсь с подключаемым модулем. Пытаюсь решить задачу автоматического получения подписанных файлов и прикрепления их к документам 1с. Очень хитро всё сделано. Не попадалось случайно ничего подобного?
tricolor; mrChOP93; KRIHA; +3 Ответить
7. John_d 4362 07.10.22 11:42 Сейчас в теме
(5) решал, через диадок API. Чтобы подключаться к API Диадока нужно оплатить данную услугу отдельно.
8. bavkyz 3 07.10.22 11:48 Сейчас в теме
(6) Спасибо, понял.


(5) Полностью согласен, сложно все там на первый взгляд и нормальной инструкции нет ... то что есть мне мало.


Я маленько изменил алгоритм создание документа "поступление товара" (создание новой ном-ры, создание СФ и документ Измен. цены), но так и не решил вопрос с сопоставлением ном-ры... вроде все сопоставлено, т.е. сообщения о не сопоставленной ном-ры нет.... но документ не создается, пишет что не сопоставлено. Нужно обязательно нажать кнопку "Сопоставить", а потом кнопку "Ок".
12. Razyiller 10.10.22 04:49 Сейчас в теме +2 $m
(5)
м модулем. Пытаюсь решить задачу автоматического получения подписанных файлов и прикрепления их к документам 1с. Очень

попробуйте плагины использовать.
Настройки - Системные.

В Плагинах есть "Плагин для выгрузки архива документов".
14. stsasha87 135 19.10.22 16:15 Сейчас в теме
(12) Добрался, попробовал, спасибо! Честно говоря, не знал, что он там есть. Вроде всё указал, галки установил. Но в 1С присоединенных файлов у подписанных документов почему-то не вижу... Может не там смотрю или этот плагин надо как-то отдельно запускать?

Попробовал в подключаемом модуле запускать в событии ПослеОбновленияСпискаДокументов что-то типа
АрхивДокументооборота = ОсновнойМодуль.ЭДО_ПолучитьАрхивДокументооборота(boxId, letterId, documentId);

и получаю ошибку авторизации...

В прошлой версии обходился финтом ушами - в основном модуле на клиенте дёргал метод SaveAllContentZipAsync() при формировании списка документов, тут же всё иначе... Весь мозг уже сломал.
Если есть где подсмотреть, поделитесь, плиз ))
15. Razyiller 19.10.22 17:17 Сейчас в теме
(14)
Плагин это всего лишь конструктор с примерами, доработать все равно приходится.
Там помоему и пример авторизации есть.

Примера нет, просто изучал этот генератор ПМ и видел что там такое есть. для целей добавление в пакет своих печатных форм и отправку своих видов документов.
17. Razyiller 22.11.22 10:03 Сейчас в теме
(14)
Функция ОбработатьСобытие(ИмяСобытия, Параметры) Экспорт
............................
ИначеЕсли ИмяСобытия = "ВыполнитьРегламентныеДействия" Тогда

		Возврат ВыполнитьРегламентныеДействия(Параметры); 
................................
КонецФункции

Функция ВыполнитьРегламентныеДействия(Параметры)

	// Имя шаблона: Авторизация под логином (РЗ)
	АвторизоватьсяПодЛогином();

КонецФункции 

Функция УчетнаяЗапись()
    
    Результат = Новый Структура;

    Результат.Вставить("Логин"	, ОсновнойМодуль.ЭДО_Модуль_ОбщиеНастройки().СлужебнаяУчетнаяЗаписьЛогин);
    Результат.Вставить("Пароль"	, ОсновнойМодуль.ЭДО_Модуль_ОбщиеНастройки().СлужебнаяУчетнаяЗаписьПароль);
    
    Возврат Результат;
    
КонецФункции

Процедура АвторизоватьсяПодЛогином()
ДанныеУчетнойЗаписи = УчетнаяЗапись();

	ЗаписатьВЖурналРегистрацииИнформацию("Диадок.АвторизацияПодЛогином", ДанныеУчетнойЗаписи.Логин);

	ОсновнойМодуль.ЭДО_АвторизоватьсяПодЛогином(ДанныеУчетнойЗаписи.Логин, ДанныеУчетнойЗаписи.Пароль);		
	ОсновнойМодуль.ЭДО_ЗаполнитьКонтекстСеансаДляСлужебнойУчетнойЗаписи();
        МассивВидовДокументов = Новый Массив;
	МассивВидовДокументов.Добавить("ID_УПД_НаАванс");
	МассивВидовДокументов.Добавить("ID_СФ_НаАванс");
	МассивВидовДокументов.Добавить("ID_УПД_раздельно");
	МассивВидовДокументов.Добавить("ID_КСФ");
	МассивВидовДокументов.Добавить("ID_АктСверки");
	МассивВидовДокументов.Добавить("ID_УКД");
	МассивВидовДокументов.Добавить("ID_УКД_раздельно");
	МассивВидовДокументов.Добавить("ID_ИУПД_БезНДС");
	МассивВидовДокументов.Добавить("ID_УКД_БезНДС");
	МассивВидовДокументов.Добавить("ID_ТОРГ12_Акт_БезНДС");
	МассивВидовДокументов.Добавить("ID_Счет");
	МассивВидовДокументов.Добавить("ID_ИСФ_НаАванс");
	МассивВидовДокументов.Добавить("ID_ИУПД_НаАванс");
	МассивВидовДокументов.Добавить("ID_УПД_БезНДС");
	МассивВидовДокументов.Добавить("ID_ИКСФ");
	МассивВидовДокументов.Добавить("ID_ОсновнойПакет");
	МассивВидовДокументов.Добавить("ID_ИУКД");
	МассивВидовДокументов.Добавить("ID_ИУКД_раздельно");
	МассивВидовДокументов.Добавить("ID_ИСФ");
	МассивВидовДокументов.Добавить("ID_АктСверкиТара");
	МассивВидовДокументов.Добавить("ID_СчетФормализованный");
	МассивВидовДокументов.Добавить("ID_УПД" );
	МассивВидовДокументов.Добавить("ID_АктСверкиОборудование");
	МассивВидовДокументов.Добавить("ID_ИУПД_раздельно");
	МассивВидовДокументов.Добавить("ID_ИУПД");
	
	
	МассивСтатусов = Новый Массив;
	МассивСтатусов.Добавить("Подписан");
	//Результат.Добавить("Отказано в подписи контрагенту");
	МассивСтатусов.Добавить("Документооборот завершен");
	//Результат.Добавить("Аннулирован");
	//Результат.Добавить("Контрагент отказал в подписи");
	МассивСтатусов.Добавить("Подписан контрагентом");
	МассивСтатусов.Добавить("Подписан с разногласиями");

	
	
	
	ПараметрыОбновленияСписка = Новый Структура;
	ПараметрыОбновленияСписка.Вставить("Режим", "ОтправленныеДокументы");
	ПараметрыОбновленияСписка.Вставить("НачалоПериода", Дата('2019.04.01 00:00:00'));
	ПараметрыОбновленияСписка.Вставить("КонецПериода", Дата('2019.08.01 00:00:00'));
	ПараметрыОбновленияСписка.Вставить("МассивВыбранныхВидов", Неопределено);
	ПараметрыОбновленияСписка.Вставить("ОтборПоОрганизации ", Неопределено);
	ПараметрыОбновленияСписка.Вставить("ОтборПоКонтрагенту ", Неопределено);
	ПараметрыОбновленияСписка.Вставить("ОтборПоПакету ", Неопределено);
	//ПараметрыОбновленияСписка.Вставить("ОтборПоСтатусу ", МассивСтатусов);
	                                                        
	
	ПараметрыОбновленияСписка.Вставить("ВключитьОтборПоКонтрагенту ", ЛОЖЬ);
	ПараметрыОбновленияСписка.Вставить("ВключитьОтборПоОрганизации ", ЛОЖЬ);
	ПараметрыОбновленияСписка.Вставить("ВключитьОтборПоСтатусу ", ЛОЖЬ);
	ПараметрыОбновленияСписка.Вставить("ПоказыватьЗавершенные ", ИСТИНА);
	ПараметрыОбновленияСписка.Вставить("РежимОтбораПоПериоду ", "ПоДатеДокумента");
	
	
	ОсновнойМодуль.ЭДО_Модуль_ОбновитьСписокДокументов(ПараметрыОбновленияСписка);
               Для Каждого Стр Из ОсновнойМодуль.СписокДокументов Цикл
                                BoxId = ОсновнойМодуль.ЭДО_Модуль_ТаблицаОрганизацийПользователя()[0].BoxId;
				Архив = ОсновнойМодуль.ЭДО_ПолучитьАрхивДокументооборота(BoxId,Стр.LetterId,Стр.DocumentId);
                                Если Архив<>Неопределено Тогда
				
				   Каталог = "каталог куда сохранять будем" ;
				   Каталог = ЗаменитьНедопустимыеСимволыИмениФайла(Каталог);
				   ПроверитьСуществованиеКаталога(Каталог);
				   Архив.Записать(Каталог + Стр.ПредставлениеДокументаДиадок + ".zip");	
			        КонецЕсли;
			//сохранение архива ДО

		
		
	          КонецЦикла;
Показать


как то так сохраняю ДО. в настройках обработки Диадок необходимо указать логин пароль для авторизации
tricolor; John_d; +2 Ответить
9. ZOMI 438 07.10.22 12:21 Сейчас в теме
API для Диадока стоит 18 000 в год и я посмотрев на решение Контура для 1С взялся и написал свое решение. Дорабатывать обработку Контура - которую несколько десятков разработчиков видоизменяли - то еще удовольствие. Простейшие доработки вызывают боль.
10. bavkyz 3 07.10.22 12:36 Сейчас в теме
(9)
написал свое решение.


Поделитесь решением )
13. Razyiller 10.10.22 04:54 Сейчас в теме
Тоже реализовал такой функционал, только еще к каждому виду документов заказчик попросил отдельные пакеты печатных форм, причем пакет динамический. сделал через ПМ.

текущий релиз обработки Диадока намного удобнее в доработке нежели предыдущий))))
11. ZOMI 438 07.10.22 12:51 Сейчас в теме
(10)сейчас сложно назвать сроки... но видимо в течение месяца выложу
tambu; prestige; Evgenij1990; Dach; bavkyz; +5 Ответить
16. user954261 19.11.22 09:03 Сейчас в теме
Здравствуйте. Прошу помощи.
1С:УПП 1.3.190, настраиваю универсальный модуль КонтурДиадокИнтеграция 4.24.
Задача:
сопоставлять номенклатуру поставщика с нашей номенклатурой в соответствии с алгоритмом (на лету, без хранения таблицы соответствия, т.к. хранить не целесообразно). Это актуально, например, для услуг, когда каждый раз от поставщика прилетает уникальное наименование услуги. Это уникальное наименование нужно транслировать в нашу номенклатуру (примитивно, по вхождению подстроки).
При загрузке входящего док-та Накладная в док-т 1С:ПоступлениеТоваровУслуг сопоставление происходит дважды (как я понял). Первый этап удалось победить: в ПодключаемомМодуле добавил "Функция ПрочитатьСопоставлениеНоменклатуры(Параметры)". Сопоставление проходит успешно, далее нажимаю "Создать документы", после чего модуль второй раз пытается сопоставить номенклатуру (предположительно из РегистраСведений.НоменклатураКонтрагентов и из Справочник.ХранилищеДополнительнойИнформации).
Вопрос:
как победить второй этап сопоставления (при создании док-та ПоступлениеТоваров) ? Или есть решение, которое поможет пройти сразу два этапа сопоставления?
18. Vo-Va 427 26.11.22 13:36 Сейчас в теме
Кто бы написал еще статью как добавить выгрузку счет фактуры сделанной по отчету комиссионера. Только формализованную по стандарту фнс.
19. kai068 5 05.12.22 10:51 Сейчас в теме
Друзья, никто не сталкивался с добавлением документа Реализации(УПД) в Диадок со статусом "Отправлено на подпись"?
т.е чтобы не заходить в обработку Диадока, а программно отправить нужную накладную по "кнопке" сразу в обработку с нужным статусом.
Буду признателен, если направите куда копать.
20. kai068 5 05.12.22 10:53 Сейчас в теме
Оставьте свое сообщение

См. также

Удаление дублирующихся файлов в томах на диске

Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Типовой механизм хранения файлов позволяет один и тот же файл прикреплять несколько раз. Это бесит наших админов, и по их просьбе был реализован следующий алгоритм.

1 стартмани

05.10.2022    2481    3    human_new    19    

Параметризация печатных форм под контрагентов (подключаемое расширение)

Печатные формы Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Расширение добавляет возможности параметризации печати для контрагентов. Подробнее описано здесь https://infostart.ru/1c/articles/1510459/

10 стартмани

05.08.2022    6053    8    sapervodichka    4    

Просмотр объектов очереди сообщений в 1С:Документооборот

Адаптация типовых решений Документооборот и делопроизводство Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

В базах с бесшовной интеграцией с 1С:Документооборот есть Регистр сведений "Очередь сообщений в 1С:Документооборот". Для пользователя он мало информативен. Расширение позволяет просматривать сообщение в человеческом виде. И понимать проблему до объекта.

2 стартмани

02.08.2022    6083    17    sapervodichka    4    

Конвертация данных 2 и JSON

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Описание минимально необходимых изменений, которые нужно внести в обработку "УниверсальныйОбменДаннымиXML" для того, чтобы реализовать конвертацию объектов конфигурации в произвольный формат JSON.

1 стартмани

01.07.2022    5763    16    zhichkin    19    

Пульт управления телевизором LG Smart TV

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

Пульт LG телевизором smart TV (2014 года). Цель - управлять телевизором из 1С. Может быть полезна тем, кто потерял и не может найти пульт ДУ, кто смотрит телевизор и сидит за ноутбуком одновременно, для изучения обмена xml с внешними устройствами, в данном случае телевизором.

1 стартмани

11.01.2022    9376    6    confer2003@mail.ru    52    

Мастер XML-обмена Промо

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Конфигурации 1cv7 Конфигурации 1cv7 Абонемент ($m) Абонемент ($m)

Функциональный аналог конвертации данных в кармане - комплекс обработок предназначенный для быстрой и удобной разработки обмена данными между информационными базами 1С.

5 стартмани

02.09.2015    43714    20    Lancelot-2M    23    

Защита объектов от изменения обменом

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Расширение позволяет пользователю заблокировать объект 1С (документ, справочник) от изменения последующими загрузками данных или обменами.

5 стартмани

05.01.2022    12913    52    sapervodichka    52    

Декларации по формам 7 и 8 алкогольной продукции, перенос данных из Декларант-Алко, импорт данных из файлов XML форм 11,12,7,8

Розничная торговля Регламентированный учет и отчетность Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Розничная и сетевая торговля (FMCG) Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Рестораны, кафе и фаст-фуд Россия Россия Бухгалтерский учет Бухгалтерский учет Акцизы Акцизы Абонемент ($m) Абонемент ($m)

Конфигурация на управляемых формах, платформа 1С 8.3.10.2667 и выше, с помощью которой можно сформировать Декларации по формам 7 и 8 алкогольной продукции, выполнить перенос данных из ПО Декларант-Алко версии 4.31.05 и выше, импорт и загрузку из файлов XML форм 11,12,7,8. Есть возможность автоматического подписания и шифрации файла выгрузки.

1 стартмани

15.04.2021    15470    56    independ    41    

Выгрузка данных из УТ 11.3/11.4 в БП 3.0 (перенос документов и справочной информации из "Управление торговлей" ред. 11.3/11.4 в "Бухгалтерия предприятием" ред. 3.0). Обновлен до УТ 11.3.4.х/11.4.7х и БП 3.0.7х.х Промо

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Управление торговлей 11 Абонемент ($m) Абонемент ($m)

Данная обработка предназначена для выгрузки в формате XML данных из программы «Управление торговлей» ред. 11.3/11.4 по основным группам документов (документы покупки/продажи товаров и услуг, складские документы, счета-фактуры, ценообразование), а также набор основных справочников. Загрузка данных в БП ред. 3.0 через обработку «Универсальный обмен данными XML». Основная цель обработки – оптимизация работы бухгалтеров во время обмена данными между программами, а также выборочная корректировка загруженных ранее документов.

1 стартмани

04.03.2016    74392    215    SEOAngels    67    

Настройка обмена с любой устаревшей конфигурацией на базе 8.2 через обработку "Универсальный обмен данными в формате XML" и "Конвертацию данных 2.0"

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Платформа 1C v8.2 Платформа 1C v8.2 Конфигурации 1cv8 Конфигурации 1cv8 Бухгалтерский учет Бухгалтерский учет Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Разберем кейс, как настроить простенький обмен с любой устаревшей конфигурацией на базе 8.2 через обработку "Универсальный обмен данными в формате XML" и Конвертацию данных 2.0 с возможностью настройки гибких отборов по периоду, организации и списку документов.

1 стартмани

23.11.2020    25124    23    orfos    14    

Улучшенная обработка универсального обмена данными в формате XML (УФ)

Универсальные обработки Внешние источники данных Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Улучшенная обработка "Универсальный обмен данными" с полноценными возможностями СКД для выборки данных (не только для отборов).

1 стартмани

23.06.2020    21060    205    Lem0n    1    

Отключение создания задачи ознакомления для бизнес-процесса "Согласование" в 1С: Документооборот

Документооборот и делопроизводство Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 Бизнес-процессы Бизнес-процессы 1С:Документооборот 1С:Документооборот Абонемент ($m) Абонемент ($m)

В данной публикации я хочу поделиться расширением, с помощью которого можно отключить создание задачи ознакомления для бизнес-процесса "Согласование" в 1С: Документооборот.

1 стартмани

30.11.2019    27500    88    pavelpribytkin96    10    

Выгрузка и загрузка XML для управляемых форм 8.3 (с отбором)

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

В работе постоянно приходится разделять в различные базы или объединять несколько организаций в одну базу, долгое время пользовался стандартной обработкой выгрузка-загрузка из UNIREPS 8.2, в режиме обычного приложения, но, к сожалению, для управляемого приложения стандартная обработка из UNIREPS 8.3 (Диск ИТС) не позволяет нормально сделать выгрузку с отбором, поэтому ей никогда не воспользовался. Решил что напишу обработку, которая позволит делать отборы в различных вариациях, кроме того, в обработках из UNIREPS (8.2 и 8.3) существенно отличается процесс загрузки предопределенных, что не всегда удобно при больших объемах данных. Обработка написана на базе UNIREPS 8.3, но есть существенные изменения. Но интерфейс доработан так, чтобы обработка была похожа на старую добрую обработку из UNIREPS 8.2, к которой все так привыкли.

1 стартмани

05.11.2019    23853    397    o.kovalev    37    

[Розница 8. Аптека] Загрузка приходных накладных из файлов DBF Промо

Файловый обмен (TXT, XML, DBF), FTP Розничная торговля Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница Фармацевтика, аптеки Фармацевтика, аптеки Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Внешняя обработка для загрузки документов «Поступление товаров» из файлов поставщиков в формате DBF для Розница 8. Аптека редакция 2.1. Для работы с дополнительными реквизитами и сведениями используется БДРС: http://infostart.ru/public/288722/ Для купивших БДРС предусмотрена скидка (второй файл - ...без БДРС - это для Вас). При написании использовался шаблон http://infostart.ru/public/303564/. Описание настройки интерфейса и регистрации обработки подробно можно посмотреть там. 20.03.2018 - Версия 3.2 для Розница - Аптека 2.2 (используется новая версия БДРС)

2 стартмани

11.05.2015    39426    0    Alex_E    12    

Правила обмена УТ 11.4 БП 3.0 для обработки "Универсальный обмен данными в формате XML"

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Управление торговлей 11 Бухгалтерский учет Бухгалтерский учет Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Правила обмена УТ 11.4 БП 3.0 для обработки "Универсальный обмен данными в формате XML". Для быстрой или частичной выгрузки справочников и документов, без настройки синхронизации данных.

1 стартмани

23.10.2019    24907    419    RAV38574    75    

Преобразование XML файла в переменную структура, Загрузка в дерево значений

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка, демонстрирующая работу процедур и функций по преобразованию XML файла в дерево значений, а также в переменную типа структура.

1 стартмани

14.09.2019    23778    39    vik070777    19    

ЗУП 3.1.10 или когда пропадают элементы в отборах списком

Адаптация типовых решений Зарплата Платформа 1С v8.3 Платформа 1С v8.3 Сложные периодические расчеты Сложные периодические расчеты 1С:Зарплата и Управление Персоналом 3.x 1С:Зарплата и Управление Персоналом 3.x Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

ЗУП 3.1.10 значительно изменил функционал формы отчетов по сравнению с 3.1.9, 3.1.8 и т.д.. В отчетах в отборах с видом сравнения: В списке, В группе из списка - неприятно, но стали пропадать из списков не отмеченные флажком элементы. Данное расширение решает проблему, не изменяя типовой функционал.

1 стартмани

31.07.2019    18360    7    sapervodichka    6    

АРМ "Касса-Лом". Обмен между 1С и учетной системой по оплате с физическими лицами за сдачу металлолома Промо

Оптовая торговля Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

АРМ "КАССА-ЛОМ" предназначено для проведения безналичных взаиморасчетов между физическими лицами-сборщиками металлолома и предприятиями, являющимися членами НП НСРО «РУСЛОМ.КОМ» и осуществляющими деятельность в области обращения с ломом и отходами металлов.

5 стартмани

23.09.2019    15044    24    vik070777    0    

Документы и Справочники в JSON

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Пример выгрузки всех данных Документа или Справочника в JSON

1 стартмани

20.06.2019    33776    47    Teut_Vlad    22    

Универсальный обмен данными XML (с гибкими отборами и сохранением вариантов настроек)

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка предназначена для загрузки и выгрузки данных по правилам обмена в любых конфигурациях, реализованных на платформе 1С:Предприятие 8.3. Преимуществом перед типовой обработкой является добавленный функционал: #1. Установка произвольных фильтров на выгружаемые объекты при помощи механизма системы компоновки данных #2. Сохранение различных вариантов настроек (сохраняются правила обмена, фильтры выгрузки, параметры, настройки обработки) - что позволяет гибко настроить в базе-источнике фильтры для выгрузки объектов по различным правилам обмена для различных баз-приемников, сохранить выполненные настройки и в будущем уже пользоваться этими вариантами настроек. Проверялась на 1С:ERP Управление предприятием 2.4.7.141.

1 стартмани

29.04.2019    44292    677    sapervodichka    20    

Выгрузка и загрузка данных XML с гибкими отборами

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка выгрузки и загрузки данных через XML между идентичными конфигурациями с возможностью установки произвольных отборов на выгружаемые объекты.

1 стартмани

07.04.2019    48592    1255    sapervodichka    54    

Обмен данными между УТ 10.3 и Розницей 2.2 (правила обмена данными между "Управлением торговлей" ред. 10.3. и "Розницей" ред. 2.2) Промо

Обмен между базами 1C Оптовая торговля Розничная торговля Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 1С:Розница 1С:Розница Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Данные правила предназначены для обмена в формате XML данных из программы «Управление торговлей» ред. 10.3. и "Розница" ред. 2.2 по основным группам документов и основных справочников. Загрузка данных осуществляется через встроенную обработку «Универсальный обмен данными XML». Основная цель обработки – корректировка типовых правил на выявленные ошибки и расширение выгрузки для корректной выгрузки данных по ЕГАИС и продажам в целом. Протестировано до УТ 10.3.47.х и Розница 2.2.11.х

3 стартмани

16.09.2016    68345    19    SEOAngels    65    

Перенос данных КА 1.1 -> КА 2

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Комплексная автоматизация 1.х 1С:Комплексная автоматизация 2.х 1С:Комплексная автоматизация 2.х Россия Россия Абонемент ($m) Абонемент ($m)

Перенос данных КА 1.1 => КА 2 с помощью правил обмена данными в формате XML КД 2 (переносятся остатки, документы, справочная информация).

5 стартмани

20.03.2019    29776    327    gudogu    150    

Выгрузка данных из Бухгалтерии ред. 3.0 в Управление небольшой фирмой, ред. 1.6

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Выгрузка данных из 1С БП 3.0 в УНФ 1.6. Обработка переносит документы по банку, кассе, движения ТМЦ + справочники контрагентов, номенклатуры и другие связанные справочники. Полный список документов на скриншоте.

1 стартмани

08.02.2019    36366    525    dinarz    223    

Перенос данных КА 1.1.115.1 => БП 3.0.75.104 (перенос остатков, документов, зарплатный блок и справочной информации)

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Абонемент ($m) Абонемент ($m)

Переносятся: остатки по счетам 01, 02, 10, 20, 41, 60, 62, 71, 97 и их субсчетам; документы; отдельно можно перенести справочники (номенклатура, контрагенты, договоры контрагентов, организации, склады, физические лица, сотрудники).

5 стартмани

22.12.2018    27270    496    gudogu    169    

Редактор объектов информационной базы 8.3 Промо

Универсальные обработки Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Универсальная внешняя обработка для редактирования реквизитов и табличных частей объектов информационной базы, редактирование движений документов. Доступ ко всем реквизитам объектов, есть возможность выгрузки и загрузки данных (объекты и движения документов) через XML. Платформа 8.3, управляемые формы. Версия 1.1.0.65 от 17.01.2023

2 стартмани

23.01.2019    54781    644    ROL32    83    

SOAP для чайников

WEB-интеграция Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Немножко про SOAP сервис. И пример работы с подключением и получением данных по SOAP за 5 минут.

1 стартмани

05.09.2018    107589    73    dusha0020    25    

Создание в 1С 7.7 XML в формате EnterpriseData (универсальный формат обмена), версия 1.5. Инструкции и примеры переноса данных из устаревшей конфигурации 1С 7.7 в любую современную 1С 8.3, поддерживающую EnterpriseData, через Конвертацию данных 3

Файловый обмен (TXT, XML, DBF), FTP Обмен между базами 1C Платформа 1С v7.7 Платформа 1С v7.7 Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv7 Конфигурации 1cv7 Россия Россия Абонемент ($m) Абонемент ($m)

Воспользоваться современным средством переноса данных "Конвертация данных 3.0.5.3" можно только выгрузив из системы - источника данных XML в формате обмена данными EnterpriseData. В этой публикации можно скачать приемы выгрузки из 1С 7.7 универсального формата обмена для Конвертации данных 3. Выполняем перенос данных из «1С:Предприятие 7.7» в «1С:Предприятие 8.3». Используем Конвертацию данных КД 3.0 из 1c 7.7 --> 1С 8.3. На первой стадии еще не опубликовано иного способа подложить файл для Конвертации данных 3 кроме как сформировать его вручную, постараемся решить данную проблему.

1 стартмани

26.02.2018    58351    65    ksnik    4