Управление сбором истории согласования в комплексных процессах

Публикация № 1725393 19.09.22

Управленческий учет - Документооборот и делопроизводство

Расширение с настройками управления сбором истории согласования

Интерфейс настройки сбора истории согласования в комплексных процессах.

Встречаются ситуации, когда провести согласование одним процессом невозможно, в этом случае можно в рамках комплексного процесса создать несколько процессов согласования, но в данном случае в задачах ознакомления будет история согласования по каждому процессу, создадим настройки вывода истории согласования сбором с нескольких процессов. 

Начнем с добавления в основную конфигурацию справочника для хранения элементов настроек:

 

 

 

Далее добавим регистр настроек РАДО_НастройкиПроцессов:

 

 

ОбъектНастройки: СправочникСсылка.ВидыВнутреннихДокументов, СправочникСсылка.ШаблоныСогласования, СправочникСсылка.ВидыВходящихДокументов, СправочникСсылка.ШаблоныИсполнения, СправочникСсылка.ВидыИсходящихДокументов

Параметр: СправочникСсылка.РАДО_ПараметрыПроцессов

ЗначениеНастройки: Булево

В модуль менеджера регистра РАДО_НастройкиПроцессов добавим код с функцией получения параметров процессов:

Функция ПолучитьПараметрПроцесса(ОбъектНастройки, Параметр) Экспорт
	
	УстановитьПривилегированныйРежим(Истина);
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
			"ВЫБРАТЬ
			|	РАДО_НастройкиПроцессов.ЗначениеНастройки КАК ЗначениеНастройки
			|ИЗ
			|	РегистрСведений.РАДО_НастройкиПроцессов КАК РАДО_НастройкиПроцессов
			|ГДЕ
			|	РАДО_НастройкиПроцессов.ОбъектНастройки = &ОбъектНастройки
			|	И РАДО_НастройкиПроцессов.Параметр = &Параметр";
	
	Запрос.УстановитьПараметр("ОбъектНастройки", ОбъектНастройки); 
	Запрос.УстановитьПараметр("Параметр", Параметр);	
	
	РезультатЗапроса = Запрос.Выполнить();
	
	Если РезультатЗапроса.Пустой() Тогда
		Возврат Неопределено;
	КонецЕсли;	
		
    ЗначениеПараметра = РезультатЗапроса.Выгрузить()[0].ЗначениеНастройки;
	
	Возврат ЗначениеПараметра;
	
КонецФункции	

В модуле расширения ОбзорЗадачВызовСервера добавим функцию определения параметров бизнес процесса из регистра настроек РАДО_НастройкиПроцессов

Функция ПолучитьПараметрыПроцесса(БизнесПроцесс)

	МассивТекстовЗапроса = Новый Массив;
	
	ТекстЗапросаРевизитыПроцессов = 
	"ВЫБРАТЬ  РАЗРЕШЕННЫЕ
	|	КомплексныйПроцесс.Ссылка КАК СсылкаКомплексногоПроцесса,
	|	КомплексныйПроцесс.Схема КАК СхемаКомплексногоПроцесса,
	|	ТаблицаТекущегоПроцесса.Наименование КАК НаименованиеТекущегоПроцесса,
	|	РАДО_НастройкиПроцессов.ЗначениеНастройки КАК ЗначениеПараметра	
	|ИЗ
	|	";
	
	МассивТекстовЗапроса.Добавить(ТекстЗапросаРевизитыПроцессов);
	
	ТаблицаТекущегоПроцесса = ОбщегоНазначения.ИмяТаблицыПоСсылке(БизнесПроцесс);
	МассивТекстовЗапроса.Добавить(ТаблицаТекущегоПроцесса);		
	
	ТекстЗапросаПродолжение = 
	" КАК ТаблицаТекущегоПроцесса
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.ДочерниеБизнесПроцессы КАК РегистрСведенийДочерниеБизнесПроцессы
	|			ВНУТРЕННЕЕ СОЕДИНЕНИЕ БизнесПроцесс.КомплексныйПроцесс КАК КомплексныйПроцесс
	|			ПО РегистрСведенийДочерниеБизнесПроцессы.РодительскийПроцесс = КомплексныйПроцесс.Ссылка
	|		ПО РегистрСведенийДочерниеБизнесПроцессы.ДочернийПроцесс = &БизнесПроцесс
	|			И (ТаблицаТекущегоПроцесса.Ссылка = &БизнесПроцесс)
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.РАДО_НастройкиПроцессов КАК РАДО_НастройкиПроцессов
	|		ПО ТаблицаТекущегоПроцесса.Шаблон = РАДО_НастройкиПроцессов.ОбъектНастройки
	|			И (РАДО_НастройкиПроцессов.Параметр = ЗНАЧЕНИЕ(Справочник.РАДО_ПараметрыПроцессов.ПоказатьОписаниеВыполнения))";
	
	МассивТекстовЗапроса.Добавить(ТекстЗапросаПродолжение);
	
	Запрос = Новый Запрос;
	Запрос.Текст = СтрСоединить(МассивТекстовЗапроса);
	
	Запрос.УстановитьПараметр("БизнесПроцесс", БизнесПроцесс);
	
	Результат = Запрос.Выполнить();
	
	Если Результат.Пустой() Тогда
		Возврат Неопределено;
	КонецЕсли;	
	
	РеквизитыПроцессов = Результат.Выгрузить()[0];		
	
	ПараметрыПроцессов = Новый Структура();
	ПараметрыПроцессов.Вставить("ЗначениеПараметра", РеквизитыПроцессов.ЗначениеПараметра);
	ПараметрыПроцессов.Вставить("СсылкаКомплексногоПроцесса", РеквизитыПроцессов.СсылкаКомплексногоПроцесса);
	ПараметрыПроцессов.Вставить("СхемаКомплексногоПроцесса", РеквизитыПроцессов.СхемаКомплексногоПроцесса);
	ПараметрыПроцессов.Вставить("НаименованиеТекущегоПроцесса", РеквизитыПроцессов.НаименованиеТекущегоПроцесса);
	
	Возврат ПараметрыПроцессов;
	
КонецФункции

Далее функцией ПолучитьИсториюВыполненияПроцесса соберем историю выполнения по схеме или этапам процесса

Функция ПолучитьИсториюВыполненияПроцесса(БизнесПроцесс)
	
	РезультатИсторияВыполненияПроцесса = Новый Структура("ДополнитьИсториейПроцесса");
	
	ПараметрыПроцесса = ПолучитьПараметрыПроцесса(БизнесПроцесс);
	
	Если ПараметрыПроцесса = Неопределено Тогда
		РезультатИсторияВыполненияПроцесса.ДополнитьИсториейПроцесса = Ложь;
		Возврат РезультатИсторияВыполненияПроцесса;
	КонецЕсли;		
	
	Запрос = Новый Запрос();
	
	Если ЗначениеЗаполнено(ПараметрыПроцесса.СхемаКомплексногоПроцесса) Тогда
		
		Запрос.Текст =
		"ВЫБРАТЬ РАЗРЕШЕННЫЕ
		|	ИсторияВыполненияЗадач.Описание КАК Описание,
		|	Согласование.Наименование КАК НаименованиеПроцесса
		|ИЗ
		|	Справочник.СхемыКомплексныхПроцессов.ПараметрыДействий КАК СхемыКомплексныхПроцессовПараметрыДействий
		|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.ИсторияВыполненияЗадач КАК ИсторияВыполненияЗадач
		|		ПО СхемыКомплексныхПроцессовПараметрыДействий.Процесс = ИсторияВыполненияЗадач.БизнесПроцесс
		|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ БизнесПроцесс.Согласование КАК Согласование
		|			ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.ШаблоныСогласования КАК ШаблоныСогласования
		|				ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.РАДО_НастройкиПроцессов КАК РАДО_НастройкиПроцессов
		|				ПО (РАДО_НастройкиПроцессов.ОбъектНастройки = ШаблоныСогласования.Ссылка)
		|					И (РАДО_НастройкиПроцессов.Параметр = ЗНАЧЕНИЕ(Справочник.РАДО_ПараметрыПроцессов.СобратьОписаниеВыполнения))
		|					И (РАДО_НастройкиПроцессов.ЗначениеНастройки = &ЗначениеНастройки)
		|			ПО Согласование.Шаблон = ШаблоныСогласования.Ссылка
		|		ПО СхемыКомплексныхПроцессовПараметрыДействий.Процесс = Согласование.Ссылка
		|			И (СхемыКомплексныхПроцессовПараметрыДействий.Ссылка = &Схема)
		|
		|УПОРЯДОЧИТЬ ПО
		|	СхемыКомплексныхПроцессовПараметрыДействий.ПорядокСортировки";
		
		Запрос.УстановитьПараметр("Схема", ПараметрыПроцесса.СхемаКомплексногоПроцесса);	
		
	Иначе 
		
		Запрос.Текст = 
		"ВЫБРАТЬ РАЗРЕШЕННЫЕ
		|	ИсторияВыполненияЗадач.Описание КАК Описание,
		|	Согласование.Наименование КАК НаименованиеПроцесса
		|ИЗ
		|	БизнесПроцесс.КомплексныйПроцесс.Этапы КАК КомплексныйПроцессЭтапы
		|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.ИсторияВыполненияЗадач КАК ИсторияВыполненияЗадач
		|		ПО КомплексныйПроцессЭтапы.ЗапущенныйБизнесПроцесс = ИсторияВыполненияЗадач.БизнесПроцесс
		|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ БизнесПроцесс.Согласование КАК Согласование
		|			ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.РАДО_НастройкиПроцессов КАК РАДО_НастройкиПроцессов
		|			ПО (РАДО_НастройкиПроцессов.Параметр = ЗНАЧЕНИЕ(Справочник.РАДО_ПараметрыПроцессов.СобратьОписаниеВыполнения))
		|				И (РАДО_НастройкиПроцессов.ЗначениеНастройки = &ЗначениеНастройки)
		|				И Согласование.Шаблон = РАДО_НастройкиПроцессов.ОбъектНастройки
		|		ПО КомплексныйПроцессЭтапы.ЗапущенныйБизнесПроцесс = Согласование.Ссылка
		|			И (КомплексныйПроцессЭтапы.Ссылка = &КомплексныйПроцесс)
		|
		|УПОРЯДОЧИТЬ ПО
		|	КомплексныйПроцессЭтапы.ПорядокСортировки";		
		
		Запрос.УстановитьПараметр("КомплексныйПроцесс", ПараметрыПроцесса.СсылкаКомплексногоПроцесса);		
		
	КонецЕсли;	
			
	Запрос.УстановитьПараметр("ЗначениеНастройки", ПараметрыПроцесса.ЗначениеПараметра);	
			
	РезультатОписания = Запрос.Выполнить();	
	
	Если РезультатОписания.Пустой() Тогда
		РезультатИсторияВыполненияПроцесса.ДополнитьИсториейПроцесса = Ложь;
		Возврат РезультатИсторияВыполненияПроцесса;
	КонецЕсли;
	
	ТаблицаОписаний = РезультатОписания.Выгрузить();	
	
	РезультатИсторияВыполненияПроцесса.ДополнитьИсториейПроцесса = Истина;
	РезультатИсторияВыполненияПроцесса.Вставить("ТаблицаОписаний", ТаблицаОписаний);
	РезультатИсторияВыполненияПроцесса.Вставить("НаименованиеТекущегоПроцесса", ПараметрыПроцесса.НаименованиеТекущегоПроцесса);
	
	Возврат РезультатИсторияВыполненияПроцесса;
	
КонецФункции	
	

В заключение переопределим ПолучитьОбзорЗадачи модуля ОбзорЗадачВызовСервера использую ранее добавленную функцию ПолучитьИсториюВыполненияПроцесса для дополнения собранной истории выполнения по настройкам к одной задаче. 

&ИзменениеИКонтроль("ПолучитьОбзорЗадачи")
Функция УОЗ_ПолучитьОбзорЗадачи(Знач Задача)

	HTMLТекст = ОбзорЗадачВызовСервераПереопределяемый.ПолучитьОбзорЗадачи(Задача);
	Если ЗначениеЗаполнено(HTMLТекст) Тогда 
		Возврат HTMLТекст;
	КонецЕсли;
    #Вставка
	ПараметрыИсторияВыполненияПроцесса = ПолучитьИсториюВыполненияПроцесса(Задача.БизнесПроцесс);	
   	#КонецВставки
	// Формируем основное представление процесса
	HTMLТекст = "<html>
	|<head>
	|<style type=""text/css"">
	|	body {
	|		overflow:    auto;
	|		margin-top:  2px;
	|		margin-left: 2px;
	|		margin-right: 2px;
	|		font-family: Arial; 
	|		font-size:   10pt;}
	|	table {
	|		width:       100%;
	|		font-family: Arial; 
	|		font-size:   10pt;
	|		border: 0px solid;}
	|	td {vertical-align: top;}
	| 	a:link {
	|		color: #006699; text-decoration: none;}
	|	a:visited {
	|		color: #006699; text-decoration: none;}
	|	a:hover {
	|		color: #006699; text-decoration: underline;}
	|	p {
	|		margin-top: 7px;}
	|	img {border: 0px;}
	|</style>
	|<body>";

	СостояниеВыполненияЗадачи = РегистрыСведений.ЗадачиДляВыполнения.СостояниеВыполненияЗадачи(Задача.Ссылка);

	// Состояние процесса и результат выполнения задачи
	Если Задача.СостояниеБизнесПроцесса = Перечисления.СостоянияБизнесПроцессов.Прерван Тогда

		ПричинаПрерывания = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(
		Задача.Ссылка, "БизнесПроцесс.ПричинаПрерывания");

		Если ПустаяСтрока(ПричинаПрерывания) Тогда
			ПричинаПрерывания = НСтр("ru = 'Задача прервана'");	
		Иначе			
			ПричинаПрерывания = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
			НСтр("ru = 'Задача прервана: %1'"),
			ПричинаПрерывания);
		КонецЕсли;

		HTMLТекст = HTMLТекст + "<table bgcolor=#F0F0F0><tr>";
		HTMLТекст = HTMLТекст + "<td width=20>";
		ОбзорОбъектовКлиентСервер.ДобавитьКартинку(
		HTMLТекст, БиблиотекаКартинок.ЗнакПрерванПроцесс, "ПоказатьПричинуПрерыванияПроцесса");
		HTMLТекст = HTMLТекст + "</td>";
		HTMLТекст = HTMLТекст + "<td>";
		HTMLТекст = HTMLТекст + СтрШаблон(
		"<A href=ПоказатьПричинуПрерыванияПроцесса>%1</A>",
		РаботаС_HTML.ЗаменитьСпецСимволыHTML(ПричинаПрерывания));
		HTMLТекст = HTMLТекст + "</td>";

		HTMLТекст = HTMLТекст + "</tr></table>";

		HTMLТекст = HTMLТекст + "<p>";

	ИначеЕсли Задача.СостояниеБизнесПроцесса = Перечисления.СостоянияБизнесПроцессов.Остановлен Тогда

		HTMLТекст = HTMLТекст + "<table bgcolor=#F0F0F0><tr>";
		HTMLТекст = HTMLТекст + "<td width=20> ";
		ОбзорОбъектовКлиентСервер.ДобавитьКартинку(HTMLТекст, БиблиотекаКартинок.ЗнакПауза);
		HTMLТекст = HTMLТекст + "</td>";
		HTMLТекст = HTMLТекст + "<td>";
		ОбзорОбъектовКлиентСервер.ДобавитьЗначение(HTMLТекст, НСтр("ru = 'Задача остановлена'"), "");
		HTMLТекст = HTMLТекст + "</td>";
		HTMLТекст = HTMLТекст + "</tr></table>";

		HTMLТекст = HTMLТекст + "<p>";

	ИначеЕсли СостояниеВыполненияЗадачи.СостояниеВыполнения = Перечисления.СостоянияЗадачДляВыполнения.ВыполнениеОтменено Тогда

		HTMLТекст = HTMLТекст + "<table bgcolor=#F0F0F0><tr>";
		HTMLТекст = HTMLТекст + "<td width=20>";
		ОбзорОбъектовКлиентСервер.ДобавитьКартинку(
		HTMLТекст, БиблиотекаКартинок.Предупреждение, "ПоказатьПричинуОтменыВыполнения");
		HTMLТекст = HTMLТекст + "</td>";
		HTMLТекст = HTMLТекст + "<td>";

		ПричинаОтменыВыполненияHTML = "";
		ОбзорОбъектовКлиентСервер.ДобавитьЗначение(
		ПричинаОтменыВыполненияHTML,
		СостояниеВыполненияЗадачи.ПричинаОтменыВыполнения,
		"FF0000");

		HTMLТекст = HTMLТекст + СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
		"<A href=ПоказатьПричинуОтменыВыполнения>%1</A>", ПричинаОтменыВыполненияHTML);

		HTMLТекст = HTMLТекст + "</td>";

		HTMLТекст = HTMLТекст + "</tr></table>";

		HTMLТекст = HTMLТекст + "<p>";

	ИначеЕсли СостояниеВыполненияЗадачи.СостояниеВыполнения = Перечисления.СостоянияЗадачДляВыполнения.ГотоваКВыполнению Тогда

		HTMLТекст = HTMLТекст + "<table bgcolor=#F0F0F0><tr>";
		HTMLТекст = HTMLТекст + "<td width=20> ";
		ОбзорОбъектовКлиентСервер.ДобавитьКартинку(HTMLТекст, БиблиотекаКартинок.СтартБизнесПроцесса);
		HTMLТекст = HTMLТекст + "</td>";
		HTMLТекст = HTMLТекст + "<td>";
		ОбзорОбъектовКлиентСервер.ДобавитьЗначение(HTMLТекст,
		НСтр("ru = 'Задача находится в очереди для выполнения. Выполнение задачи произойдет автоматически в ближайшее время.'"), "");
		HTMLТекст = HTMLТекст + "</td>";
		HTMLТекст = HTMLТекст + "</tr></table>";

		HTMLТекст = HTMLТекст + "<p>";

	ИначеЕсли Задача.Выполнена Тогда

		МетаданныеПроцесса = ОбщегоНазначения.МенеджерОбъектаПоСсылке(Задача.БизнесПроцесс);
		ПредставлениеРезультатаЗадачи = МетаданныеПроцесса.ПредставлениеРезультатаЗадачи(Задача);

		РезультатВыполненияЗадачи = РегистрыСведений.
		РезультатыВыполненияПроцессовИЗадач.РезультатВыполненияПоОбъекту(Задача.Ссылка);

		Если РезультатВыполненияЗадачи = 
			Перечисления.ВариантыВыполненияПроцессовИЗадач.Положительно Тогда

			Картинка = БиблиотекаКартинок.РезультатВыполненияПроцессовИЗадач_Положительный;
			ЦветТекста = "#008000";
		ИначеЕсли РезультатВыполненияЗадачи = 
			Перечисления.ВариантыВыполненияПроцессовИЗадач.Отрицательно Тогда

			Картинка = БиблиотекаКартинок.РезультатВыполненияПроцессовИЗадач_Отрицательный;
			ЦветТекста = "#B22222";
		ИначеЕсли РезультатВыполненияЗадачи = Перечисления.
			ВариантыВыполненияПроцессовИЗадач.ПоложительноСЗамечаниями Тогда

			Картинка = БиблиотекаКартинок.РезультатВыполненияПроцессовИЗадач_ПоложительныйСЗамечаниями;
			ЦветТекста = "#008000";
		Иначе
			Картинка = БиблиотекаКартинок.РезультатВыполненияПроцессовИЗадач;
			ЦветТекста = "";
		КонецЕсли;

		HTMLТекст = HTMLТекст + "<table bgcolor=#F0F0F0><tr>";

		HTMLТекст = HTMLТекст + "<td width=20>";
		ОбзорОбъектовКлиентСервер.ДобавитьКартинку(HTMLТекст, Картинка);
		HTMLТекст = HTMLТекст + "</td>";

		HTMLТекст = HTMLТекст + "<td>";
		ОбзорОбъектовКлиентСервер.ДобавитьЗначение(HTMLТекст, ПредставлениеРезультатаЗадачи, ЦветТекста);
		HTMLТекст = HTMLТекст + "</td>";

		HTMLТекст = HTMLТекст + "</tr></table>";

		HTMLТекст = HTMLТекст + "<p>";

	КонецЕсли;

	HTMLТекст = HTMLТекст + "<table><tr>";
	HTMLТекст = HTMLТекст + "<td>";

	// Наименование
	HTMLТекст = HTMLТекст + "<B>";
	ОбзорОбъектовКлиентСервер.ДобавитьЗначение(HTMLТекст, Задача.Наименование, "");
	HTMLТекст = HTMLТекст + "<br>";
	HTMLТекст = HTMLТекст + "</B>";

	ПредметДокумент = ПолучитьОсновнойПредметДокумент(Задача.Предметы);
	Если ЗначениеЗаполнено(ПредметДокумент) Тогда

		ОбзорПредмета = ПолучитьОбзорПредметаЗадачи(ПредметДокумент);
		Если Не ПустаяСтрока(ОбзорПредмета) Тогда
			HTMLТекст = HTMLТекст + "<p>" + ОбзорПредмета + "</p>";
		КонецЕсли;	

	КонецЕсли;		

	// Описание
	Если ЗначениеЗаполнено(Задача.Описание) Тогда
		HTMLТекст = HTMLТекст + "<p>";

		ОписаниеЗадачиHTML = "";
		ОбзорОбъектовКлиентСервер.ДобавитьРеквизит(ОписаниеЗадачиHTML, "", Задача.Описание);

		ОписаниеЗадачиHTML = СтрЗаменить(ОписаниеЗадачиHTML, Символы.Таб, "&nbsp;&nbsp;&nbsp;");
		ОписаниеЗадачиHTML = СтрЗаменить(ОписаниеЗадачиHTML, Символы.ПС, "<br>");

		HTMLТекст = HTMLТекст + ОписаниеЗадачиHTML;

	КонецЕсли;

	// Важность
	Если Задача.Важность = Перечисления.ВариантыВажностиЗадачи.Высокая Тогда
		Важность = НСтр("ru = 'Высокая'");
	ИначеЕсли Задача.Важность = Перечисления.ВариантыВажностиЗадачи.Обычная Тогда
		Важность = НСтр("ru = 'Обычная'");
	ИначеЕсли Задача.Важность = Перечисления.ВариантыВажностиЗадачи.Низкая Тогда
		Важность = НСтр("ru = 'Низкая'");
	КонецЕсли;
	HTMLТекст = HTMLТекст + "<p>";
	ОбзорОбъектовКлиентСервер.ДобавитьРеквизит(HTMLТекст, НСтр("ru = 'Важность: '"), Важность);

	// Исполнитель
	HTMLТекст = HTMLТекст + "<p>";
	ОбзорОбъектовКлиентСервер.ДобавитьПодпись(HTMLТекст, НСтр("ru = 'Кому:'"));

	ТекущийПользователь = ПользователиКлиентСервер.ТекущийПользователь();
	ИсполнителиЗадачПользователя = БизнесПроцессыИЗадачиСервер.
	ИсполнителиЗадачПользователя(ТекущийПользователь);

	// Признак ролевой/делегированной задачи
	ЗадачаДелегированаТекущемуПользователю = 
	РегистрыСведений.ИсполнителиРолейИДелегаты.ИсполнительЯвляетсяДелегатом(
	Задача.ТекущийИсполнитель,
	ТекущийПользователь,
	"ПроцессыИЗадачи");

	Если ЗадачаДелегированаТекущемуПользователю Тогда
		ОбзорОбъектовКлиентСервер.ДобавитьКартинку(HTMLТекст, БиблиотекаКартинок.ДелегированнаяЗадача);
		HTMLТекст = HTMLТекст + " ";
	ИначеЕсли ТипЗнч(Задача.ТекущийИсполнитель) = Тип("СправочникСсылка.ПолныеРоли") Тогда
		ОбзорОбъектовКлиентСервер.ДобавитьКартинку(HTMLТекст, БиблиотекаКартинок.РолеваяЗадача);
		HTMLТекст = HTMLТекст + " ";
	КонецЕсли;

	Если НЕ Задача.Исполнитель.Пустая() Тогда
		ОбзорОбъектовКлиентСервер.ДобавитьЗначение(HTMLТекст, Задача.Исполнитель, "");
	Иначе
		ИсполнительСтрокой = Строка(Задача.РольИсполнителя);
		HTMLТекст = HTMLТекст + СтрШаблон(
		"<A href=v8doc:%1>%2</A>",
		ПолучитьНавигационнуюСсылку(Задача.РольИсполнителя),
		РаботаС_HTML.ЗаменитьСпецСимволыHTML(Строка(ИсполнительСтрокой)));
	КонецЕсли;

	HTMLТекст = HTMLТекст + "<br>";

	// Срок
	Если ЗначениеЗаполнено(Задача.СрокИсполнения) Тогда
		ОбзорОбъектовКлиентСервер.ДобавитьПодпись(HTMLТекст, НСтр("ru = 'Срок:'"));
		ФормаДаты = ?(ПолучитьФункциональнуюОпцию("ИспользоватьДатуИВремяВСрокахЗадач"),
		"ДФ='dd.MM.yyyy HH:mm'", "ДФ='dd.MM.yyyy'");

		Если ТипЗнч(Задача.БизнесПроцесс) <> 
			Тип("БизнесПроцессСсылка.РешениеВопросовВыполненияЗадач")
			И Не Задача.Выполнена
			И ПолучитьФункциональнуюОпцию("ВестиУчетПереносовСроковЗадач") Тогда

			HTMLТекст = HTMLТекст + СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
			"<A href=%1> %2</A>",
			"ИзменитьСрокВыполнения",
			Формат(Задача.СрокИсполнения, ФормаДаты));
		Иначе
			HTMLТекст = HTMLТекст + " " + Формат(Задача.СрокИсполнения, ФормаДаты);
		КонецЕсли;

		HTMLТекст = HTMLТекст + "<br>";
	КонецЕсли;

	// Автор
	ОбзорОбъектовКлиентСервер.ДобавитьРеквизит(HTMLТекст, НСтр("ru = 'Автор:'"), Задача.Автор);

	// Контроль
	Если ПолучитьФункциональнуюОпцию("ИспользоватьКонтрольОбъектов") Тогда
		Контролеры = РаботаСБизнесПроцессамиВызовСервера.КонтролерыЗадачи(Задача, Не Задача.Выполнена);

		КонтролерыСтрокой = СтрСоединить(Контролеры, ", ");

		Если Задача.Выполнена Тогда
			ПодписьКонтролера = НСтр("ru = 'Контролеры: '");
		Иначе
			КоличествоКонтролеров = Контролеры.Количество();
			Если КоличествоКонтролеров = 1 Тогда
				ПодписьКонтролера = НСтр("ru = 'Контролирует: '");
			ИначеЕсли КоличествоКонтролеров > 1 Тогда
				ПодписьКонтролера = НСтр("ru = 'Контролируют: '");
			КонецЕсли;
		КонецЕсли;

		ОбзорОбъектовКлиентСервер.ДобавитьПодпись(HTMLТекст, ПодписьКонтролера);
		HTMLТекст = HTMLТекст + СтрШаблон(
		"<A href=ОткрытьКарточкуКонтроля>%1</A>", 
		РаботаС_HTML.ЗаменитьСпецСимволыHTML(КонтролерыСтрокой));
		HTMLТекст = HTMLТекст + "<br>";

	КонецЕсли;

	// История выполнения
	ИсторияВыполнения = РегистрыСведений.ИсторияВыполненияЗадач.ИсторияПоБизнесПроцессу(
	Задача.БизнесПроцесс);
	Если ЗначениеЗаполнено(ИсторияВыполнения) Тогда
		HTMLТекст = HTMLТекст + "<p>";
		HTMLТекст = HTMLТекст + "<B>";
		ОбзорОбъектовКлиентСервер.ДобавитьПодпись(HTMLТекст, НСТР("ru = 'История выполнения:'")); 
		HTMLТекст = HTMLТекст + "</B>";
		HTMLТекст = HTMLТекст + "<br>";
 		#Вставка
		Если ПараметрыИсторияВыполненияПроцесса.ДополнитьИсториейПроцесса Тогда
			HTMLТекст = HTMLТекст + "<p>";
			HTMLТекст = HTMLТекст + "<B>";			
			ОбзорОбъектовКлиентСервер.ДобавитьПодпись(HTMLТекст, ПараметрыИсторияВыполненияПроцесса.НаименованиеТекущегоПроцесса);
			HTMLТекст = HTMLТекст + "</B>";
			HTMLТекст = HTMLТекст + "<br>";
        КонецЕсли;			
		#КонецВставки

		ИсторияВыполненияHTML = "";
		ОбзорОбъектовКлиентСервер.ДобавитьРеквизит(ИсторияВыполненияHTML, "", ИсторияВыполнения);
		ИсторияВыполненияHTML = СтрЗаменить(ИсторияВыполненияHTML, Символы.Таб, "&nbsp;&nbsp;&nbsp;");
		ИсторияВыполненияHTML = СтрЗаменить(ИсторияВыполненияHTML, Символы.ПС, "<br>");

		HTMLТекст = HTMLТекст + ИсторияВыполненияHTML;

	КонецЕсли;
    #Вставка
	
	Если ПараметрыИсторияВыполненияПроцесса.ДополнитьИсториейПроцесса Тогда
		
		Если Не ЗначениеЗаполнено(ИсторияВыполнения) Тогда 
			HTMLТекст = HTMLТекст + "<p>";
			HTMLТекст = HTMLТекст + "<B>";
			ОбзорОбъектовКлиентСервер.ДобавитьПодпись(HTMLТекст, НСТР("ru = 'История выполнения:'"));
			HTMLТекст = HTMLТекст + "</B>";
			HTMLТекст = HTMLТекст + "<br>";
		КонецЕсли;
	
		Для Каждого Стр Из ПараметрыИсторияВыполненияПроцесса.ТаблицаОписаний Цикл 
			
			HTMLТекст = HTMLТекст + "<br>";
			HTMLТекст = HTMLТекст + "<B>";
			ОбзорОбъектовКлиентСервер.ДобавитьПодпись(HTMLТекст, Стр.НаименованиеПроцесса);
			HTMLТекст = HTMLТекст + "</B>";	
			HTMLТекст = HTMLТекст + "<br>";
			
			ИсторияСогласованияHTML = "";
			ОбзорОбъектовКлиентСервер.ДобавитьРеквизит(ИсторияСогласованияHTML, "", Стр.Описание);
			ИсторияСогласованияHTML = СтрЗаменить(ИсторияСогласованияHTML, Символы.Таб, "&nbsp;&nbsp;&nbsp;");
			ИсторияСогласованияHTML = СтрЗаменить(ИсторияСогласованияHTML, Символы.ПС, "<br>");
			
			HTMLТекст = HTMLТекст + ИсторияСогласованияHTML;	
			
		КонецЦикла;
		
	КонецЕсли;
	
	#КонецВставки
	HTMLТекст = HTMLТекст + "</td>";

	HTMLТекст = HTMLТекст + "</tr></table>";

	HTMLТекст = HTMLТекст + "</body></html>";

	Возврат HTMLТекст;

КонецФункции

Тестирование проводилось на платформе 8.3.21.1302 конфигурации Документооборот 8 КОРП, редакция 2.1 (2.1.29.18).

Скачать файлы

Наименование Файл Версия Размер
Расширение "Управление сбором истории согласования в комплексных процессах"

.cfe 9,67Kb
4
.cfe 9,67Kb 4 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Групповая обработка по созданию счетов-фактур в 1С: Бухгалтерия 8.3 (Управляемые формы) Промо

Обработка документов Документооборот и делопроизводство Оптовая торговля Производство готовой продукции (работ, услуг) Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Бухгалтерия 2.0 Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Быстро и, главное, удобно. Обработка создает в Бухгалтерии 8.3 счета-фактуры. Также есть возможность обработки документов, введенных позже!!! Главное - все просто, выбрали документы за период, нажали Сформировать, и все!!!

5 стартмани

13.05.2015    30228    34    SuperGena    4    

Продление сертификатов, выданных коммерческими УЦ

Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Универсальное расширение, продлевающее срок действия сертификатов, выданных коммерческими удостоверяющими центрами.

1 стартмани

09.01.2023    1556    9    ixijixi    6    

Заполнение шаблона Word (docx) на сервере без сторонних ПО

Инструментарий разработчика Документооборот и делопроизводство Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Предлагаю оптимальный (имхо) вариант заполнения Word шаблона без использования каких либо компонентов. Метод заимствован из конфигурации Документооборот.

1 стартмани

19.10.2022    1635    10    aibasoft    6    

Добавляем новый документ в обработку Диадок

Файловый обмен (TXT, XML, DBF), FTP Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 1С:Комплексная автоматизация 2.х 1С:Комплексная автоматизация 2.х Абонемент ($m) Абонемент ($m)

Добавляем новый документ для подписания и отправки в обработку Диадок (через подключаемый модуль). Отправлять его будем, как неформализованный (внешняя печатная форма в формате pdf).

2 стартмани

07.10.2022    5058    9    John_d    20    

Конструктор печатных форм для ЗУП 3.1 по шаблонам MSOffice и OpenOffice Промо

Печатные формы Документооборот и делопроизводство Платформа 1С v8.3 Платформа 1С v8.3 Сложные периодические расчеты Сложные периодические расчеты 1С:Зарплата и Управление Персоналом 3.x 1С:Зарплата и Управление Персоналом 3.x Абонемент ($m) Абонемент ($m)

Данная обработка позволяет быстро создавать печатные формы документов на основании документов из программы 1С ЗУП8 версии 3.1. Печатные формы можно заполнять на основании следующих документов: "Прием на работу", "Прием на работу списком", "Кадровый перевод", "Кадровый перевод списком", "Перемещение в другое подразделение", "Договор ГПХ" Обработка протестирована на платформе 1С:Предприятие 8.3 (8.3.12.1714) релиз ЗУП 3.1.9.187 Тонкий клиент (файловый или клиент-сервер) Установленный Microsoft office (2003 и выше) или OpenOffice/LibreOffice 09/04/2019 Исправил ошибку, возникающую, если наименование вида расчета содержит скобки.

10 стартмани

02.11.2017    37430    314    zabaluev    62    

Удаление дублирующихся файлов в томах на диске

Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Типовой механизм хранения файлов позволяет один и тот же файл прикреплять несколько раз. Это бесит наших админов, и по их просьбе был реализован следующий алгоритм.

1 стартмани

05.10.2022    2465    3    human_new    19    

Присоединенные файлы в 1С:Бухгалтерии в расширении

Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Абонемент ($m) Абонемент ($m)

Столкнулся с необходимостью добавить возможность прикреплять файлы в конфигурации 1С:Бухгалтерия предприятия, находящейся на поддержке. Разработал расширение, которое можно подключить к конфигурации не снимая ее с поддержки, и реализовать функционал присоединенных файлов к любому документу системы.

3 стартмани

05.09.2022    2404    13    NightBreez    9    

Печать конвертов из 1С Промо

Пакетная печать Документооборот и делопроизводство Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Внешняя печатная форма для печати конвертов формата C4 и C5. Печать с полной разметкой почтового конверта и размещением адресов отправителя и получателя, включая индекс.

1 стартмани

07.12.2015    40909    28    sashs1980    32    

Параметризация печатных форм под контрагентов (подключаемое расширение)

Печатные формы Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Расширение добавляет возможности параметризации печати для контрагентов. Подробнее описано здесь https://infostart.ru/1c/articles/1510459/

10 стартмани

05.08.2022    6042    7    sapervodichka    4    

Просмотр объектов очереди сообщений в 1С:Документооборот

Адаптация типовых решений Документооборот и делопроизводство Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

В базах с бесшовной интеграцией с 1С:Документооборот есть Регистр сведений "Очередь сообщений в 1С:Документооборот". Для пользователя он мало информативен. Расширение позволяет просматривать сообщение в человеческом виде. И понимать проблему до объекта.

2 стартмани

02.08.2022    6055    17    sapervodichka    4    

Выгрузка документов в формате XML для загрузки в ЭДО операторов СБИС, Диадок и т.п.

Адаптация типовых решений Файловый обмен (TXT, XML, DBF), FTP ЭДО и ОФД Платформа 1С v8.3 Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 Россия Россия Абонемент ($m) Абонемент ($m)

Расширение для добавления дополнительного функционала в библиотеку БЭД , добавляет команду для выгрузки данных в формате XML для загрузки в ЭДО из 1С.

3 стартмани

30.06.2022    3242    35    osa92    14    

Обработка "Распознавание штрихкода с помощью утилиты Zbar" для Документооборот ред. 2 Промо

Универсальные обработки Документооборот и делопроизводство Платформа 1С v8.3 Платформа 1С v8.3 1С:Документооборот 1С:Документооборот Абонемент ($m) Абонемент ($m)

В связи с тем, что стандартный функционал программы «Документооборот» ред. 2.1 дает возможность распознавания штрихкодов только форма EAN-13, данная обработка - альтернативный способ для распознавания штрихкода в программе 1С: Документооборот ред. 2 с помощью утилиты Zbar, которая распознает в том числе и в формате Code 128 (один из стандартных штрихкодов кодирования документов, например, «Управление торговлей» ред. 11), а также с возможностью поэтапно проследить все действия от распознавания до прикрепления к документу или простой загрузки в каталоги файлов в базе 1С.

5 стартмани

05.09.2016    34281    194    SEOAngels    11    

Добавление состояния согласования из 1С: Документооборот

Документооборот и делопроизводство Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 1С:Документооборот 1С:Документооборот Абонемент ($m) Абонемент ($m)

Добавляем статус согласования из подключенной базы 1С Документооборот в типовые и нетиповые конфигурации с использованием библиотеки интеграции с 1С: Документооборотом. Статусы добавляются в формы списка и формы объектов.

1 стартмани

11.05.2022    3791    1    Free_Danial    0    

Автозаполнение шаблонов файлов MXL в "1С:Документообороте"

Документооборот и делопроизводство Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 1С:Документооборот 1С:Документооборот Абонемент ($m) Абонемент ($m)

Добавление возможности создавать автозаполняемые шаблоны файлов в формате MXL в 1С:Документооборот и сохранением заполненного файлы в формате PDF (таблицы, результаты запроса реквизиты...)

1 стартмани

05.05.2022    4235    20    JIEX@    0    

Реализация с кодами маркировки через ЭДО в Рознице 2.3

Оптовая торговля Розничная торговля Документооборот и делопроизводство ЭДО и ОФД Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница Россия Россия Абонемент ($m) Абонемент ($m)

Расширение для возможности формировать и отправлять через ЭДО УПД с маркированными товарами по документу "Реализация".

2 стартмани

27.01.2022    4765    44    boba13    36    

Приемная руководителя, редакция 1.1 Промо

Документооборот и делопроизводство Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

Приемная руководителя, редакция 1.1. Конфигурация на управляемых формах (интерфейс - Такси) с открытым кодом, создана для секретарей.

1500 руб.

19.05.2015    34034    24    12    

Отображение проблем синхронизации с Документооборотом 2.1

Документооборот и делопроизводство Платформа 1С v8.3 Платформа 1С v8.3 1С:Документооборот 1С:Документооборот Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Внешний отчет для Документооборот 2.1, основанный на анализе регистра сведений Сведения о сообщениях обмена с интегрированными системами. Можно использовать для сигнализации о проблемах остановки обмена.

1 стартмани

02.01.2022    3906    5    ardn    0    

Программное создание и расчет документов начисления зарплаты в конфигурации ЗУП 3.1 и ERP (по подразделениям)

Зарплата Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 Сложные периодические расчеты Сложные периодические расчеты 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 1С:Зарплата и Управление Персоналом 3.x 1С:Зарплата и Управление Персоналом 3.x Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Краткое описание типового механизма расчета зарплаты в конфигурации ЗУП 3.1 и ERP и описание разработанной обработки по программному расчету документов зарплаты в разрезе подразделений. Т.к. формирование документов происходит полностью программно, с минимумов параметров, его можно брать за основу для расчета документов по своим условиям, вплоть до создания по расписанию при необходимости.

10 стартмани

27.12.2021    7612    22    maraty    39    

Инструменты разработчика для работы с ЭДО СБИС ExtSdk2

Оптовая торговля Документооборот и делопроизводство ЭДО и ОФД Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Несколько обработок, которые помогут разработчикам в автоматизации рабочих мест бухгалтеров и менеджеров продаж.

1 стартмани

25.12.2021    5235    29    bobylev1980    4    

БСП 3.1.5 Форма отчета. Быстрый вызов редактирования варианта

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Работа с интерфейсом Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

В последних релизах современных конфигураций, основанных на БСП версии 3.1.5, спрятали кнопку настройки варианта в дебри вложенных форм. Вернём всё как было, и даже лучше.

1 стартмани

20.12.2021    5339    1    ixijixi    0    

Работа с API Диадок

Документооборот и делопроизводство WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 1С:Документооборот 1С:Документооборот Абонемент ($m) Абонемент ($m)

Обработка написана для конфигурации Документооборот, затрагивает самые основные методы работы с api Диадок.

5 стартмани

17.12.2021    4737    36    diar01    4    

Устранение проблемы с правами доступа. Документооборот КОРП 2.1

Документооборот и делопроизводство Роли и права Платформа 1С v8.3 Платформа 1С v8.3 1С:Документооборот 1С:Документооборот Абонемент ($m) Абонемент ($m)

Обработка позволяет открыть доступ для пользователей в конфигурации 1С: Документооборот КОРП 2.1, связанных с отсутствием необходимых записей в регистрах сведений СоставСубъектовПравДоступа и ПользователиВКонтейнерах. Проблема выражается в отсутствии доступа к папкам внутренних документов и непосредственно внутренним документам (см.рисунок).

1 стартмани

01.11.2021    5705    21    baturo    2    

Распознавание текста с использованием OCR Tesseract

Документооборот и делопроизводство Платформа 1С v8.3 Платформа 1С v8.3 1С:Документооборот 1С:Документооборот Россия Россия Абонемент ($m) Абонемент ($m)

В 1С:Документооборот полнотекстовый поиск по содержимому отсканированных документов возможен, но не так хорош, как бы хотелось. Всё дело в качестве распознавания сканов. Поднимаем процесс распознавания на новую высоту с использованием Xpdf и OCR Tesseract.

5 стартмани

17.10.2021    6300    15    soulner    2    

Управление пользователями в документообороте

Документооборот и делопроизводство Роли и права Платформа 1С v8.3 Платформа 1С v8.3 1С:Документооборот 1С:Документооборот Россия Россия Абонемент ($m) Абонемент ($m)

Обработка "Управление пользователями в документообороте" позволяет создавать новых пользователей и обновлять права у текущих пользователей. Возможно назначать права группе пользователей и пакетно создавать пользователей с одинаковыми правами. Облегчает рутинную работу при регулярной работе с правами пользователей.

1 стартмани

13.10.2021    5516    24    Smikle    0    

Учет канцтоваров для секретаря - тонкий клиент (без информационной базы, на файлах excel) Промо

Документооборот и делопроизводство Универсальные обработки Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка включает для каждого файла загрузки из excel новую колонку в табличное поле обработки (управляемая форма, тонкий клиент), рассчитывает и выводит общие итоги. Табличку на тонком клиенте выводит в табличный документ. Обработка не использует информационную базу и независима от её структуры, только файлы эксель. Результат объединения тоже сохраняется в файл.

1 стартмани

11.09.2012    26606    22    ksnik    10    

Преобразование doc/docx в PDF для 1С: Документооборот 8 КОРП, ПРОФ, ДГУ через обработчик бизнес-событий

Документооборот и делопроизводство Платформа 1С v8.3 Платформа 1С v8.3 1С:Документооборот 1С:Документооборот Абонемент ($m) Абонемент ($m)

Обработчик после регистрации нужного вида документа выполняет конвертацию файлов, прикрепленных к внутреннему документу формата doc/docx, в формат PDF и добавляет эти файлы к документу. Не требует изменений в конфигурации.

1 стартмани

05.10.2021    7419    6    vashkostya    2    

Проверка настройки заполнения для скриптов 1С:Документооборот

Документооборот и делопроизводство Корректировка данных Платформа 1С v8.3 Платформа 1С v8.3 1С:Документооборот 1С:Документооборот Абонемент ($m) Абонемент ($m)

Доброго времени суток, коллеги. После обновления базы 1С:Документооборот , при проверке заполнения файла по шаблону вылезла ошибка "Следующие реквизиты или скрипты настройки заполнения файла заданы не корректно:...". Захотел узнать, какие ещё скрипты заполнены не корректно. Написал обработку для проверки и исправления всех скриптов.

1 стартмани

19.09.2021    6406    12    Andrei_Ivanov    6    

Загрузка данных из внешних файлов для управляемых форм

Загрузка и выгрузка в Excel Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Простая и удобная обработка загрузки из файлов формата Excel, dbf и csv для конфигураций на управляемых формах (без модальности). Встраивается в любую конфигурацию (на управляемых формах) в любое место, где нужна загрузка из файлов.

2 стартмани

29.08.2021    5195    22    ALBA2009    2    

Согласование документов 1С:Документооборот и 1С:Консолидация из Outlook 2010-2013 без запуска 1С (с исходниками) Промо

Документооборот и делопроизводство Управление проектом Платформа 1С v8.3 Платформа 1С v8.3 1С:Документооборот 1С:Документооборот Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Надстройки для Outlook 2010-2013, позволяющие пользователю без запуска 1С оперативно выполнять согласование документов при поступлении оповещения на электронную почту. Поддерживается интеграция с 1С:Документооборот ПРОФ и КОРП (работа с процессом "Согласование" с поддержкой просмотра файлов по внутренним и исходящим документам) и 1С:Консолидация ПРОФ (согласование "Заявок на расходование средств" и "Экземпляров отчетов" с возможностью просмотра печатных форм).

1 стартмани

16.07.2012    87320    427    Aleksey.Bochkov    123    

Где баланс между производительностью и возможностями программы ? Исправление автоподбора контрагента в УНФ

Рефакторинг и качество кода HighLoad оптимизация Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 1.6 Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Как и у многих ко мне стали поступать обращения от менеджеров о медленной работе 1с (эта ваша один с не дает нормально работать), и чтоб быть объективным, и не основываться на человеческом, субъективном восприятии решил вооружиться цифрами, а именно произвести анализ медленных запросов, и проблема была найдена, где я ее не ожидал.

1 стартмани

27.08.2021    5324    0    con-men    0    

[Расширение] Несколько касс ККМ в РМК для Розницы 2.3

Розничная торговля ККМ Рабочее место Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница Абонемент ($m) Абонемент ($m)

Расширение добавляет возможность добавлять и работать с несколькими кассами ККМ при продаже через РМК с одного рабочего места

1 стартмани

27.08.2021    7445    57    Nonik    65    

Формирование XML документа (УПД, счет, накладная, СФ и прочее)

Документооборот и делопроизводство Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Управление торговлей 11 Россия Россия Абонемент ($m) Абонемент ($m)

С помощью этого кода для документов базы формируется XML-файл, который можно отправить через ЭДО СБИС, Диадок и пр. Поддерживается все форматы, которые поддерживает библиотека БЭД.

1 стартмани

24.08.2021    6582    94    blackhorse1976    15    

Обмен УТ 11 (11.4.13.227) с БП 3.0 (из серии - никогда такого не было, и вот опять)

Обмен между базами 1C Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 11 1С:Управление торговлей 11 Россия Россия Абонемент ($m) Абонемент ($m)

После обновления на редакцию Управление торговлей, редакция 11 (11.4.13.227) перестал работать обмен с конфигурацией Бухгалтерия предприятия, редакция 3.0. Расширение конфигурации, исправляющее эту ошибку.

2 стартмани

28.07.2021    12999    50    capitan    21    

Отправка сообщений пользователям Промо

Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 Россия Россия Абонемент ($m) Абонемент ($m)

Предполагаю, что в организациях, где работает больше 10-15 человек, сложно звонить каждому и сообщать пользователям какую-либо информацию. Я обыскал на всех ресурсах, так того, что требуется, не нашел.

1 стартмани

13.01.2012    20685    374    kojinandrej    54    

Прослеживаемость товара в Диадок (РНПТ). Подключаемый модуль для в УПП 1.3, УТ 10.3

Документооборот и делопроизводство Оптовая торговля Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 1С:Управление производственным предприятием 1С:Управление производственным предприятием Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

С июля 2021 года введена прослеживаемости товаров с передачей данных через ЭДО. На данный момент в модуле Диадок (5.42.10) не реализовано заполнение РНПТ, и предлагаемый подключаемый модуль решает эту проблему.

1 стартмани

21.07.2021    6791    39    itmind    6    

Доработка Диадок для 1С. Заполнение графы 5а в УПД (с 01.07.2021). Подключаемый модуль

Документооборот и делопроизводство Оптовая торговля Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

С 1 июля 2021 года действует новая форма УПД, такое изменение принято постановлением №534 от 02.04.2021 г. Правительством Российской Федерации. В форме УПД в данной редакции появилась графа 5а. Мне так и не удалось разобраться - обязательна она к заполнению или нет - в типовой форме в 1С:Бухгалтерия она заполняется, а в Диадок - нет. И было бы пофиг, но некоторые наши клиенты отказались принимать УПД с прочерком в строке 5а. Служба поддержки Диадок сообщила, что заполнение - не является обязательным, доработка - платная, тикет - закрыт :) Поэтому здесь Вы можете скачать Подключаемый модуль для Диадок, который заполняет графу 5а - Документы основания.

1 стартмани

06.07.2021    19181    133    AlxPop    38    

Формирование файла типа xml для формализованных электронных передаточных и корректировочных документов и неформализованного электронного документа Счет на основании документа бухгалтерии

Документооборот и делопроизводство Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Налоговый учет Налоговый учет НДС НДС Абонемент ($m) Абонемент ($m)

Обработка служит для формирования файла типа xml для следующих формализованных документов: счета-фактуры (СЧФ), документа об отгрузке товаров (выполнении работ), передаче имущественных прав (документа об оказании услуг) (ДОП), универсального передаточного документа (СЧФДОП-УПД), корректировочного счета-фактуры (КСЧФ), документа, подтверждающего согласие (факт уведомления) покупателя на изменение стоимости отгруженных товаров (выполненных работ, оказанных услуг), переданных имущественных прав (ДИС), универсального корректировочного документа (КСЧФДИС-УКД) и неформализованного документа Счет на основании документа, созданного в 1С: Бухгалтерия предприятия БП 3.0 для последующей загрузки на сайт оператора электронного документооборота. После загрузки файла на сайт можно при необходимости скорректировать документ и отправить его на согласование или подпись. Формализованные документы формируются по формату, утвержденному приказом ФНС России от 19.12.2018 г.№ ММВ-7-15/820@ и приказом ФНС России от 12.10.2020 г. № ЕД-7-26/736@ Прослеживаемые товары обрабатываются в соответствие с форматом ФНС, обработка маркированных товаров не реализована.

5 стартмани

28.05.2021    9749    46    fxfan    11    

Сопоставь несопоставленное - пример работы с сопоставлением номенклатуры контрагентов

Обработка справочников Документооборот и делопроизводство Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Абонемент ($m) Абонемент ($m)

Пример использования встроенных типовых конфигураций 1С, в которых есть механизмы сопоставления номенклатуры контрагентов из ЭДО с номенклатурой самой базы 1С.

1 стартмани

24.05.2021    9746    19    delta    4    

Подсистема "Пользовательские автоподстановки" для 1С: Документооборот 2.1

Документооборот и делопроизводство Анализ и проектирование ИТ-систем Платформа 1С v8.3 Платформа 1С v8.3 1С:Документооборот 1С:Документооборот Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Подсистема позволяет описать собственные алгоритмы автоподстановок исполнителей задач бизнес-процессов. Механизмы подсистемы может использовать любой компетентный пользователь/программист.

1 стартмани

12.05.2021    7914    22    Lok`Tar    16    

Адресная книга для 1С:Документооборот

Документооборот и делопроизводство Платформа 1С v8.3 Платформа 1С v8.3 1С:Документооборот 1С:Документооборот Абонемент ($m) Абонемент ($m)

Реализация через http-сервис публикации адресной книги для документооборота.

1 стартмани

27.04.2021    9964    3    SaschaG    8