Получение писем из любой папки электронной почты в 1С:Бухгалтерии

Публикация № 1684933 27.06.22

Интеграция и обмен данными - Email рассылки

Папка получение писем

В данной публикации речь пойдёт о том, как можно в "1С:Бухгалтерии" настроить получение писем из любой папки учетной записи электронной почты.

Из опыта работы с типовой конфигурации «1С:Бухгалтерия предприятия, редакция 3.0» у заказчиков довольно редко возникает необходимость настроить учетную запись электронной почты для получения писем. Однако, когда такая потребность возникла, то оказалось, что письма будут получаться исключительно из папки «Входящие» («Inbox»). И если заказчик в своей электронной почте создал определенное количество папок в папке «Входящие», то «1С:Бухгалтерия» эти все папки проигнорирует. Таким образом, у пользователя нет практической возможности настроить получение писем из другой папки.

1-я часть проблемы заключается в том, что в процедуре «ЗагрузитьСообщения» общего модуля «РаботаСПочтовымиСообщениямиСлужебный» отсутствует строка:
Соединение.ТекущийПочтовыйЯщик = <ВыбраннаяПользователемПапка>;
Наличие такой строки в купе с возможностью её передаче во входящем в процедуру параметре «ПараметрыЗагрузки» решили бы первую часть проблемы.

 



2-я часть проблемы заключается в том, что на форме настройки учетной записи электронной почты нет возможности указать папку, из которой в 1С будут приходить письма.
Ну раз есть проблемы, то они требуют решения. Начнём решение с конца.

Для начала на форме настройки учетной записи электронной почты реализуем следующий алгоритм: 
Для возможности получения писем из другой папки, отличной от папки 'Входящие' ('Inbox'), пользователь на форме учетной записи нажимает на кнопку 'Вывести список папок почтового ящика', в сформированной таблице со всеми папками текущей учетной записи выбрать необходимую папку электронного ящика. Выбранная папку должна отразиться в поле 'Папка почтового ящика для получения писем'. После сохранения и повторного открытия формы учетной записи электронной почты указанная папка должна сохраняться.

 

 

Создадим расширение и захватим в него процедуру «ПриСозданииНаСервере» с типом вызова «После». В процедуре пропишем создание элементов интерфейса и команд, а также добавим процедуру для восстановления ранее выбранной папки из хранилища значений:

#Область ВНачалеРаботы

&НаСервере
Процедура Дельта24083_ПриСозданииНаСервереПосле(Отказ, СтандартнаяОбработка)

	нРеквизиты = Новый Массив;
	нРеквизиты.Добавить(Новый РеквизитФормы("ПапкаПочтовогоЯщикаДляПолученияПисем", Новый ОписаниеТипов("Строка"), , "Папка почтового ящика для получения писем", Ложь));
	ИзменитьРеквизиты(нРеквизиты);
	
	ПолеПапкиПочтовогоЯщикаДляПолученияПисем = ЭтаФорма.Элементы.Добавить("ПапкаПочтовогоЯщикаДляПолученияПисем", Тип("ПолеФормы"),Элементы.ИспользоватьУчетнуюЗапись);
	ПолеПапкиПочтовогоЯщикаДляПолученияПисем.Вид = ВидПоляФормы.ПолеВвода; 
	ПолеПапкиПочтовогоЯщикаДляПолученияПисем.ПутьКДанным = "ПапкаПочтовогоЯщикаДляПолученияПисем";
	ПолеПапкиПочтовогоЯщикаДляПолученияПисем.ТолькоПросмотр = Истина;
	
	ВосстановитьНастройкиПапокПочтовогоЯщикаИзХранилищаЗначений();
	
	нЭлемент = Элементы.Добавить("ДекорацияСОписаниемДействий", Тип("ДекорацияФормы"), Элементы["НастройкиСоединения"]); 
	нЭлемент.Вид = ВидДекорацииФормы.Надпись;
	нЭлемент.АвтоМаксимальнаяШирина = Ложь;
	нЭлемент.Заголовок = "Для возможности получения писем из другой папки, отличной от папки 'Входящие' ('Inbox'), необходимо выполнить следующее:" + 
	Символы.ПС + "1. Нажать на кнопку 'Вывести список папок почтового ящика'." + 
	Символы.ПС + "2. В сформированной таблице со всеми папками текущей учетной записи выбрать необходимую папку." + 
	Символы.ПС + "3. Выбранная папку отразиться в поле 'Папка почтового ящика для получения писем'." +
	Символы.ПС + "4. Сохранить текущую настройку учетной записи.";
		
	НовКоманда = ЭтаФорма.Команды.Добавить("ВывестиСписокПапокПочтовогоЯщика");
	НовКоманда.Действие = "ВывестиСписокПапокПочтовогоЯщика"; 
	
	нЭлемент = ЭтаФорма.Элементы.Добавить("ВывестиСписокПапокПочтовогоЯщика", Тип("КнопкаФормы"), Элементы["НастройкиСоединения"]);
	нЭлемент.Заголовок = "Вывести список папок почтового ящика";
	нЭлемент.ИмяКоманды = "ВывестиСписокПапокПочтовогоЯщика";
	
КонецПроцедуры

&НаСервере
Процедура ВосстановитьНастройкиПапокПочтовогоЯщикаИзХранилищаЗначений()
	
	//восстановить настройки ТЧ
	КлючНастроек = "НастройкиПапокПочтовогоЯщика";	
	ЗначениеНастроек = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("НастройкиПапокПочтовогоЯщика", КлючНастроек);	
	Если ТипЗнч(ЗначениеНастроек) = Тип("Соответствие") Тогда 
		
		Попытка
			Для Каждого ТекСтрока Из ЗначениеНастроек.Получить("ТаблицаНастроекПочтовогоЯщика") Цикл 
				Если ТекСтрока.УчетнаяЗапись = Объект.Ссылка Тогда 
					ЭтаФорма.ПапкаПочтовогоЯщикаДляПолученияПисем = ТекСтрока.НазваниеПапки;
					Прервать;
				КонецЕсли;
			КонецЦикла;
		Исключение
			//
		КонецПопытки;
		
	КонецЕсли;
	
КонецПроцедуры

#КонецОбласти

Далее реализуем механизм получения списка всех папок электронной почты и вывод на форму таблицы с их названиями:

#Область ПолучениеСпискаПапок

&НаСервере
Функция ВывестиСписокПапокПочтовогоЯщикаНаСервере()
	
	УчетнаяЗапись = Объект.Ссылка;
	УстановитьОтключениеБезопасногоРежима(Истина);
	Профиль = РаботаСПочтовымиСообщениямиСлужебный.ИнтернетПочтовыйПрофиль(УчетнаяЗапись, Истина);
	УстановитьОтключениеБезопасногоРежима(Ложь);
	
	Протокол = ПротоколИнтернетПочты.POP3;
	Если ОбщегоНазначения.ЗначениеРеквизитаОбъекта(УчетнаяЗапись, "ПротоколВходящейПочты") = "IMAP" Тогда
		Протокол = ПротоколИнтернетПочты.IMAP;
	КонецЕсли;
	
	УстановитьОтключениеБезопасногоРежима(Истина);
	Соединение = Новый ИнтернетПочта;
	Соединение.Подключиться(Профиль, Протокол);
	МассивПочтовыхЯщиков = Соединение.ПолучитьПочтовыеЯщики();
	Соединение.Отключиться();
	УстановитьОтключениеБезопасногоРежима(Ложь);
	
	Если Не Истина Тогда
		ТаблицаПапокПочтовогоЯщика = "";
	КонецЕсли;

	ТаблицаПапокПочтовогоЯщика = Новый  ТаблицаЗначений;
	ТаблицаПапокПочтовогоЯщика.Колонки.Добавить("НазваниеПапки",Новый ОписаниеТипов("Строка", , Новый КвалификаторыСтроки(100)),"Наименование папки");
    
	Тек = 0;
	Пока Тек <= МассивПочтовыхЯщиков.Количество()-1 Цикл
		НовСтрока = ТаблицаПапокПочтовогоЯщика.Добавить();
		НовСтрока.НазваниеПапки = МассивПочтовыхЯщиков[Тек];
		Тек = Тек + 1;
	КонецЦикла;

	ЭтаФорма.ТаблицаПапокПочтовогоЯщика.Загрузить(ТаблицаПапокПочтовогоЯщика);
	
	Возврат МассивПочтовыхЯщиков;
	
КонецФункции

&НаКлиенте
Процедура ВывестиСписокПапокПочтовогоЯщика(Команда)
	СоздатьТаблицуПапокПочтовогоЯщика();
	МассивПочтовыхЯщиков = ВывестиСписокПапокПочтовогоЯщикаНаСервере();
КонецПроцедуры

&НаСервере
Процедура СоздатьТаблицуПапокПочтовогоЯщика()
	
	ТаблицаПапокПочтовогоЯщика = Новый  ТаблицаЗначений;
	ТаблицаПапокПочтовогоЯщика.Колонки.Добавить("НазваниеПапки",Новый ОписаниеТипов("Строка", , Новый КвалификаторыСтроки(100)),"Наименование папки");
	
	МассивДобавляемыхРеквизитов = Новый Массив;
	МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("ТаблицаПапокПочтовогоЯщика", Новый ОписаниеТипов("ТаблицаЗначений")));
	
	Для Каждого Колонка Из ТаблицаПапокПочтовогоЯщика.Колонки Цикл
		МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы(Колонка.Имя, Колонка.ТипЗначения,"ТаблицаПапокПочтовогоЯщика" ,Колонка.Заголовок));
	КонецЦикла;
	
	ИзменитьРеквизиты(МассивДобавляемыхРеквизитов,);
	
	ВывестиТаблицуЗначенийНаФорму(ЭтаФорма, "ТаблицаПапокПочтовогоЯщика", Элементы["НастройкиСоединения"], "Таблица папок почтового ящика",ТаблицаПапокПочтовогоЯщика);
	
	Элементы["ТаблицаПапокПочтовогоЯщика"].УстановитьДействие("ПриАктивизацииСтроки","ВыбратьПапкуПочтовогоЯщикаДляПолученияПисем");
	
КонецПроцедуры

&НаСервере
Процедура ВывестиТаблицуЗначенийНаФорму(Форма, ИмяТаблицы, Родитель, ЗаголовокТаблицы, ТЗ,НадоЗагрузить = Ложь) Экспорт
	
	ТаблицаФормы = Форма.Элементы.Добавить(ИмяТаблицы, Тип("ТаблицаФормы"), Родитель);
	ТаблицаФормы.ПутьКДанным = ИмяТаблицы;
	ТаблицаФормы.Заголовок = ЗаголовокТаблицы;
	ТаблицаФормы.ПоложениеЗаголовка = ПоложениеЗаголовкаЭлементаФормы.Нет;
	ТаблицаФормы.ИзменятьПорядокСтрок = Ложь;
	ТаблицаФормы.ИзменятьСоставСтрок = Ложь;
	ТаблицаФормы.РазрешитьНачалоПеретаскивания = Ложь;
	
	Для Каждого Колонка Из ТЗ.Колонки Цикл
		ДобавитьНовуюКолонкуТаблицыЗначений(Форма, ТаблицаФормы, ИмяТаблицы, Колонка.Имя, Колонка.Заголовок);
	КонецЦикла;
	
	Если НадоЗагрузить Тогда
		Форма[ИмяТаблицы].Загрузить(ТЗ);
	КонецЕсли;
	
КонецПроцедуры

&НаСервере
Процедура ДобавитьНовуюКолонкуТаблицыЗначений(Форма, ТаблицаФормы, ИмяТаблицы, ИмяКолонки, ЗаголовокКолонки, СтруктураСвойств = Неопределено)
	
	НоваяКолонка = Форма.Элементы.Добавить(ИмяТаблицы+ИмяКолонки, Тип("ПолеФормы"), ТаблицаФормы);
	
	НоваяКолонка.Заголовок = ЗаголовокКолонки;
	НоваяКолонка.ПутьКДанным = ИмяТаблицы + "." + ИмяКолонки;
	НоваяКолонка.Вид = ВидПоляФормы.ПолеВвода;    
	Если НЕ СтруктураСвойств = Неопределено Тогда
		Для Каждого КлючЗначение Из СтруктураСвойств Цикл
			Попытка
				НоваяКолонка[КлючЗначение.Ключ] = СтруктураСвойств[КлючЗначение.Ключ];
			Исключение
			КонецПопытки;
		КонецЦикла;    
	КонецЕсли;
	
КонецПроцедуры

#КонецОбласти

В завершении создадим процедуры по установке необходимой папки и сохранению её значения в информационной базе:

#Область ВыборИСохранениеПапки

&НаКлиенте
Процедура ВыбратьПапкуПочтовогоЯщикаДляПолученияПисем(Команда)
		
	ЭтаФорма.ПапкаПочтовогоЯщикаДляПолученияПисем = Команда.ТекущиеДанные.НазваниеПапки;
	
КонецПроцедуры

&НаСервере
Процедура СохранитьНастройкиПапокПочтовогоЯщикаВХранилищеЗначений()
	
	//сохранить настройки
	КлючНастроек = "НастройкиПапокПочтовогоЯщика";	
	Настройки = Новый Соответствие;

	ТаблицаНастроекПочтовогоЯщика = Новый ТаблицаЗначений;
	ТаблицаНастроекПочтовогоЯщика.Колонки.Добавить("УчетнаяЗапись");
	ТаблицаНастроекПочтовогоЯщика.Колонки.Добавить("НазваниеПапки");
	
	НовСтрока = ТаблицаНастроекПочтовогоЯщика.Добавить();
	НовСтрока.УчетнаяЗапись = Объект.Ссылка;
	НовСтрока.НазваниеПапки = ЭтаФорма.ПапкаПочтовогоЯщикаДляПолученияПисем;
	
	Настройки.Вставить("ТаблицаНастроекПочтовогоЯщика", ТаблицаНастроекПочтовогоЯщика);
		
	ОбщегоНазначения.ХранилищеОбщихНастроекСохранить("НастройкиПапокПочтовогоЯщика", КлючНастроек, Настройки);
	
КонецПроцедуры

&НаКлиенте
Процедура Дельта24083_ПослеЗаписиПосле(ПараметрыЗаписи)
	СохранитьНастройкиПапокПочтовогоЯщикаВХранилищеЗначений();
КонецПроцедуры

#КонецОбласти

Теперь вернёмся к первой части задачи: захватим в расширение процедуру «ЗагрузитьСообщения» и внесём в неё изменения, касающиеся получению писем из выбранной папки
На самом деле нам нужно только указать в параметре ТекущийПочтовыйЯщик название нужной папки, название которой мы ранее получили и сохранили в свойствах учётной записи (с дальнейшем сохранением её в хранилище общих настроек):

//назначаем текущий почтовый ящик, отличную от ящика "Входящие" ("Inbox") 
Попытка
		КлючНастроек = "НастройкиПапокПочтовогоЯщика";	
		ЗначениеНастроек = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("НастройкиПапокПочтовогоЯщика", КлючНастроек);	
		Если ТипЗнч(ЗначениеНастроек) = Тип("Соответствие") Тогда 
			Для Каждого ТекСтрока Из ЗначениеНастроек.Получить("ТаблицаНастроекПочтовогоЯщика") Цикл 
				Если ТекСтрока.УчетнаяЗапись = УчетнаяЗапись Тогда 
					Соединение.ТекущийПочтовыйЯщик = ТекСтрока.НазваниеПапки;
					Прервать;
				КонецЕсли;
			КонецЦикла;
		КонецЕсли;
Исключение
КонецПопытки;

 

Далее приводится полностью код захваченной и изменённой в расширении процедуры «ЗагрузитьСообщения»:


&Вместо("ЗагрузитьСообщения")
Функция Дельта24083_ЗагрузитьСообщения(Знач УчетнаяЗапись, Знач ПараметрыЗагрузки)
	
	// Используется для проверки возможности входа на почтовый ящик.
	Перем РежимТестирования;
	
	// Получать только заголовки писем.
	Перем ПолучениеЗаголовков;
	
	// Приводить почтовые сообщения к простому типу;
	Перем ПриводитьСообщенияКТипу;
	
	// Заголовки или идентификаторы писем, полные сообщения по которым требуется получить.
	Перем ЗаголовкиИдентификаторы;
	
	Если ПараметрыЗагрузки.Свойство("РежимТестирования") Тогда
		РежимТестирования = ПараметрыЗагрузки.РежимТестирования;
	Иначе
		РежимТестирования = Ложь;
	КонецЕсли;
	
	Если ПараметрыЗагрузки.Свойство("ПолучениеЗаголовков") Тогда
		ПолучениеЗаголовков = ПараметрыЗагрузки.ПолучениеЗаголовков;
	Иначе
		ПолучениеЗаголовков = Ложь;
	КонецЕсли;
	
	УстановитьОтключениеБезопасногоРежима(Истина);
	Профиль = ИнтернетПочтовыйПрофиль(УчетнаяЗапись, Истина);
	УстановитьОтключениеБезопасногоРежима(Ложь);
	
	Если ПараметрыЗагрузки.Свойство("ЗаголовкиИдентификаторы") Тогда
		ЗаголовкиИдентификаторы = ПараметрыЗагрузки.ЗаголовкиИдентификаторы;
	Иначе
		ЗаголовкиИдентификаторы = Новый Массив;
	КонецЕсли;
	
	НаборСообщенийДляУдаления = Новый Массив;
	
	Протокол = ПротоколИнтернетПочты.POP3;
	Если ОбщегоНазначения.ЗначениеРеквизитаОбъекта(УчетнаяЗапись, "ПротоколВходящейПочты") = "IMAP" Тогда
		Протокол = ПротоколИнтернетПочты.IMAP;
	КонецЕсли;
	
	УстановитьОтключениеБезопасногоРежима(Истина);
	Соединение = Новый ИнтернетПочта;
	Соединение.Подключиться(Профиль, Протокол);
	
	//назначаем текущий почтовый ящик, отличную от ящика "Входящие" ("Inbox") 
	Попытка
		КлючНастроек = "НастройкиПапокПочтовогоЯщика";	
		ЗначениеНастроек = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("НастройкиПапокПочтовогоЯщика", КлючНастроек);	
		Если ТипЗнч(ЗначениеНастроек) = Тип("Соответствие") Тогда 
			Для Каждого ТекСтрока Из ЗначениеНастроек.Получить("ТаблицаНастроекПочтовогоЯщика") Цикл 
				Если ТекСтрока.УчетнаяЗапись = УчетнаяЗапись Тогда 
					Соединение.ТекущийПочтовыйЯщик = ТекСтрока.НазваниеПапки;
					Прервать;
				КонецЕсли;
			КонецЦикла;
		КонецЕсли;
	Исключение
	КонецПопытки;
	
	Попытка
		Если ПолучениеЗаголовков Тогда
			НаборПисем = Соединение.ПолучитьЗаголовки();
		ИначеЕсли Не РежимТестирования Тогда
			НастройкиТранспорта = ОбщегоНазначения.ЗначенияРеквизитовОбъекта(УчетнаяЗапись, "ПротоколВходящейПочты,ОставлятьКопииСообщенийНаСервере,ПериодХраненияСообщенийНаСервере");
			Если НастройкиТранспорта.ПротоколВходящейПочты = "IMAP" Тогда
				НастройкиТранспорта.ОставлятьКопииСообщенийНаСервере = Истина;
				НастройкиТранспорта.ПериодХраненияСообщенийНаСервере = 0;
			КонецЕсли;
			
			Если НастройкиТранспорта.ОставлятьКопииСообщенийНаСервере Тогда
				Если ЗаголовкиИдентификаторы.Количество() = 0 И НастройкиТранспорта.ПериодХраненияСообщенийНаСервере > 0 Тогда
					Заголовки = Соединение.ПолучитьЗаголовки();
					НаборСообщенийДляУдаления = Новый Массив;
					Для Каждого ЭлементЗаголовок Из Заголовки Цикл
						ТекущаяДата = ТекущаяДатаСеанса();
						РазницаДат = (ТекущаяДата - ЭлементЗаголовок.ДатаОтправления) / (3600*24);
						Если РазницаДат >= НастройкиТранспорта.ПериодХраненияСообщенийНаСервере Тогда
							НаборСообщенийДляУдаления.Добавить(ЭлементЗаголовок);
						КонецЕсли;
					КонецЦикла;
				КонецЕсли;
				АвтоматическиУдалятьСообщенияПриВыбореССервера = Ложь;
			Иначе
				АвтоматическиУдалятьСообщенияПриВыбореССервера = Истина;
			КонецЕсли;
			
			НаборПисем = Соединение.Выбрать(АвтоматическиУдалятьСообщенияПриВыбореССервера, ЗаголовкиИдентификаторы);
			
			Если НаборСообщенийДляУдаления.Количество() > 0 Тогда
				Соединение.УдалитьСообщения(НаборСообщенийДляУдаления);
			КонецЕсли;
		КонецЕсли;
	
		Соединение.Отключиться();
	Исключение
		Попытка
			Соединение.Отключиться();
		Исключение // АПК:280
			// Обработка и журналирование исключения не требуется, т.к. 
			// в вызывающий код передается исходное исключение, которое будет там обработано.
		КонецПопытки;
		ВызватьИсключение;
	КонецПопытки;
	УстановитьОтключениеБезопасногоРежима(Ложь);
	
	Если РежимТестирования Тогда
		Возврат Истина;
	КонецЕсли;
	
	Если ПараметрыЗагрузки.Свойство("ПриводитьСообщенияКТипу") Тогда
		ПриводитьСообщенияКТипу = ПараметрыЗагрузки.ПриводитьСообщенияКТипу;
	Иначе
		ПриводитьСообщенияКТипу = Истина;
	КонецЕсли;
	
	НаборСообщений = НаборПисем;
	Если ПриводитьСообщенияКТипу Тогда
		Если ПараметрыЗагрузки.Свойство("Колонки") Тогда
			НаборСообщений = АдаптированныйНаборПисем(НаборПисем, ПараметрыЗагрузки.Колонки);
		Иначе
			НаборСообщений = АдаптированныйНаборПисем(НаборПисем);
		КонецЕсли;
	КонецЕсли;
	
	Возврат НаборСообщений;
	
КонецФункции

С помощью приведённых в данной публикации картинок, описания и модулей вы можете самостоятельно создать расширение для работы с конкретной папкой почтового ящика. Или можете скачать уже готовое расширение.

Разработка и тестирование обработки осуществлялись на типовой конфигурации «1С:Бухгалтерия предприятия, редакция 3.0 (3.0.115.15)» и платформе 1С:Предприятие 8.3 (8.3.19.1229).

Примечание:
1. Решение построено на использовании расширения и его не получится применить для базовой версии «1С:Бухгалтерия».
2. Все вносимые изменения будут выполнены исключительно с помощью программного кода без внесения изменений в структуру метаданных.

Скачать файлы

Наименование Файл Версия Размер
Расширение для настройки получения писем из любой папки электронной почты в 1С:Бухгалтерия

.cfe 21,64Kb
3
.cfe 1.0 21,64Kb 3 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Загрузка кассовых чеков ФНС в документы "Авансовый отчет", "Расходы предпринимателя", "Путевой лист" и "Приходная накладная" Промо

Кассовые операции Розничная торговля Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Бухгалтерский учет 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Налоговый учет Управленческий учет Платные (руб)

В публикации размещены специализированные обработки для загрузки чеков в базах 1С (для локальных баз) и инструкция по подключению (для облачных баз в сервисе 1С Фреш 1cfresh.com): «1С:Бухгалтерия предприятия, ред. 3.0», «1С:Управление нашей фирмой 8, ред. 1.6» и «1С:Бухгалтерия государственного учреждения, ред. 2.0». Вы просто сканируете QR коды с бумажных и электронных чеков c помощью мобильного приложения ФНС и чеки автоматически (без ручного ввода) загружаются в документы "Авансовый отчет", "Расходы предпринимателя", "Путевой лист" и "Приходная накладная".

9960 руб.

19.08.2020    41176    169    57    

Отправка и получение почтовых сообщений

Email рассылки Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

Расширение позволяет добавить в конфигурацию возможность отправки почтовых сообщений с вложениями, средствами 1С. Не требует вносить изменения в основную конфигурацию.

1 стартмани

08.09.2022    1340    5    DrZombi    5    

История ролей пользователей

Роли и права Email рассылки Платформа 1С v8.3 1С:ERP Управление предприятием 2 Россия Абонемент ($m)

Расширение позволяет записывать историю ролей назначенных пользователям, а также делать рассылки изменений этих ролей по почте.

1 стартмани

31.08.2022    1303    4    Silenser    6    

Легкий почтовый клиент

Email рассылки Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Расширение содержит в себе легкий почтовый клиент для загрузки входящих писем с вложениями и их дальнейшей обработки.

5 стартмани

03.08.2022    1468    4    redtram    0    

Автоматическая рассылка прайс-листов Промо

Прайсы Email рассылки Оптовая торговля Розничная торговля Платформа 1С v8.3 1С:Управление торговлей 10 Абонемент ($m)

Устали от утомительной рассылки прайс-листов своим клиентам? Тогда эта обработка как раз для вас, она сделает полностью все сама! Сформирует прайс с нужными настройками и отправит его по электронной почте, как, куда и когда надо.

1 стартмани

24.03.2014    54672    34    skyadmin    22    

Массовая рассылка печатных форм любых документов по электронной почте

Email рассылки Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Решение для массовой рассылки печатных форм (в том числе и дополнительных) любых документов, и произвольных файлов по электронной почте. Рассылка пакета документов. Добавление факсимильных печати и подписи. Произвольные шаблоны HTML/Simple text с автозаполнением любыми полями документа. Любые форматы файлов. Упаковка вложений в архив. Транслитерация имен файлов. Разбиение рассылки на произвольные порции. Настраиваемые паузы между письмами и порциями. Журналирование рассылок.

3 стартмани

30.06.2022    2812    27    ixijixi    27    

AllContacts

СRM Рабочее место Email рассылки Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Универсальное расширение для централизованного управления контактами. Позволяет организовать хранение, упорядочивание и использование контактной информации объектов информационной базы в едином рабочем пространстве.

3 стартмани

19.04.2022    6331    3    ixijixi    12    

Рассылка об окончании испытательного срока

Email рассылки Кадровый учет Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и Управление Персоналом 3.x Бухгалтерский учет Управленческий учет Абонемент ($m)

Дополнительная внешняя обработка, производящая рассылку об окончании испытательного срока руководителям сотрудников.

1 стартмани

17.02.2022    3503    10    Nicholas    5    

Отправка пакета документов по электронной почте (в формате PDF/XLS/HTML/MXL/ODS) Промо

Печатные формы Пакетная печать Email рассылки Оптовая торговля Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием 1С:Управление торговлей 10 Россия Бухгалтерский учет Абонемент ($m)

С помощью обработки можно нажатием одной кнопки отправить пакет документов контрагенту по электронной почте. Теперь не надо заходить в каждый документ, формировать нужную печатную форму, сохранять на диск, а потом собирать в одном письме. Все это за вас сделает программа самостоятельно. Все, что требуется от пользователя - просто выбрать документ в программе! Доступны варианты обработки для обычного и управляемого приложения!

2 стартмани

22.04.2015    65785    55    trendy    25    

Оповещение по почте о документах

Документооборот и делопроизводство Email рассылки Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

Рассылка писем со ссылками на документы, удовлетворяющие установленному отбору.

1 стартмани

14.02.2022    3139    2    victorree    2    

Групповое скачивание файлов из почты (скачивание вложений писем, скачивание файлов по ссылкам в тексте писем)

Email рассылки Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Обработка выполняет групповое скачивание файлов из E-mail писем в каталог на клиентском компьютере. Обработка скачивает не только приложенные к письмам файлы, но и также ищет html-ссылки на файлы в текстах писем, и тоже скачивает их на клиентский компьютер

1 стартмани

29.01.2022    2902    8    1395969    9    

Email рассылка в формате HTML

Email рассылки Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Обработка предназначена для массовой рассылки писем в формате HTML из 1С.

1 стартмани

19.01.2022    3055    1    DevilBit    8    

Отправка электронной почты с помощью локального почтового клиента из 1С, развернутой под удаленным рабочим столом Промо

Печатные формы Универсальные функции Email рассылки Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Управление производственным предприятием Абонемент ($m)

Решение для интерактивной (нажал-отредактировал) отправки электронных писем и печатных форм через почтовый клиент (Thunderbird, Outlook) находящийся на локальном компьютере, из конфигурации 1С, развернутой под удаленным рабочим столом (RDP, remote-app). Подходит также для локального развертывания 1С. Представлен пример быстрой интеграции с конфигурациями "Управление торговлей 10.3", "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1", "Бухгалтерия предприятия 2.0".

1 стартмани

21.09.2018    37184    24    stvorl    1    

Рассылка электронных писем из БП 3

Email рассылки Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Абонемент ($m)

Массовая рассылка электронных писем для Бухгалтерии предприятия 3.0.

1 стартмани

22.12.2021    2842    25    aksyoma    13    

Выгрузка прайса в EXCEL, с изображениями в облаке, с рассылкой на почту клиенту. УТ 11.4

Прайсы Оптовая торговля Загрузка и выгрузка в Excel Email рассылки Платформа 1С v8.3 1С:Управление торговлей 11 Россия Управленческий учет Абонемент ($m)

Необходимо создать обработку для формирование прайс-листа, с возможность выгрузки в EXCEL и загрузке обратно, с рассылкой на почту покупателям.

3 стартмани

01.11.2021    3849    7    ClickUp    4    

Фоновая отправка информации журнала регистрации из конфигураций на базе 1С:Библиотека стандартных подсистем

Журнал регистрации БСП (Библиотека стандартных подсистем) Email рассылки Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

Внешняя обработка для фоновой отправки информации журнала регистрации по электронной почте из конфигураций на базе 1С:Библиотека стандартных подсистем

1 стартмани

25.10.2021    7610    10    mayz    2    

Конфигурация "Почтовый клиент" на УФ (8.2, 8.3) Промо

WEB-интеграция Email рассылки Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Абонемент ($m)

Конфигурация для работы с почтой на управляемых формах для платформы 8.2, 8.3.

1 стартмани

23.01.2014    66163    569    alexkon    108    

Групповая отправка документов по электронной почте (Счет на оплату покупателя, Реализация товаров и услуг, Счет фактура выданный, Сверка взаиморасчетов). ERP 2, УТ 11.4

Документооборот и делопроизводство Email рассылки Взаиморасчеты Оптовая торговля Платформа 1С v8.3 Бухгалтерский учет 1С:ERP Управление предприятием 2 Бухгалтерский учет Абонемент ($m)

Обработка "Групповая отправка документов по электронной почте" для конфигурации ERP Управление предприятием 2 и УТ 11.4. Позволяет гибко выбирать документы и отправлять их контрагентам.

8 стартмани

12.08.2021    5756    8    MaxxiMiliSan    10    

Групповая отправка писем о задолженности. УТ 11

Взаиморасчеты Email рассылки Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 11 Управленческий учет Абонемент ($m)

Групповая отправка электронных писем клиентам о задолженности для 1С:Управление торговлей 11.4.

2 стартмани

12.08.2021    3989    10    stein13    0    

Автопрайс: Конструктор прайс-листов с автоматической рассылкой по шаблонам Промо

Прайсы Email рассылки Оптовая торговля Платформа 1С v8.3 1С:Управление торговлей 10 Оптовая торговля, дистрибуция, логистика Россия Управленческий учет Абонемент ($m)

Гибкая и удобная система для формирования и автоматической рассылки прайс-листов. Быстрая рассылка - прайсы на 100+ тыс. строк уходят десяткам клиентов с индивидуальными настройками менее чем за 10 мин. Форматы:.XLS, .XLSX, .TXT /CSV(UTF-8/ANSI), .MXL, .HTML, .DOCX, .PDF, .ODS. Поддерживает картинки в прайсе. Создание макетов прайсов, рассылка по почте и FTP, архивация в ZIP, шаблоны, гибкая настройка и расписание, отчеты о рассылке.

10 стартмани

08.06.2016    33325    75    taurus__    5    

Групповая отправка писем о задолженности на почту e-mail в УТ 11, КА 2, ЕРП 2

Взаиморасчеты Email рассылки Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Бухгалтерский учет Управленческий учет Абонемент ($m)

Обработка позволяет выполнить групповую отправку писем о задолженности в соответствии со сроком долга. Присутствует возможность отправки информации о задолженности, которая еще не наступила, но наступит через определенное время. За это отвечает галочка "Приближение оплаты" и "Срок напоминания для оплаты" на странице "Настройки". Разработано для Управление Торговлей 11, Комплексная автоматизация 2, ERP управление предприятием.

10 стартмани

09.06.2021    4513    7    user1527257    0    

Электронная почта - расширение для конфигурации "INFOSTART ERP community edition"

Email рассылки Infostart ERP community Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Расширение "Электронная почта" позволяет отправлять и принимать электронные письма (автоматически сортировать письма папкам c учетом пользовательской настройки).

5 стартмани

30.04.2021    5161    7    33lab    0    

Загрузка заказов из вложений электронной почты

Оптовая торговля Загрузка и выгрузка в Excel Обработка документов Email рассылки Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Управленческий учет Абонемент ($m)

Автоматическая загрузка заказов из входящей электронной почты. Умеет загружать заказы из вложений формата XLS, CSV, HTML, а также из таблицы в теле письма. Умеет создавать документы “Заказ клиента “ или “Реализация товаров услуг”. Существенно облегчает работу менеджера, особенно при большом потоке заказов. В комментарии к заказу пишет о возникших проблемах. Номенклатура ищется по артикулу.

5 стартмани

07.04.2021    5571    21    wonderboy    10    

Конфигурация для партнеров "Инфостарт" для ведения публикаций, рассылки обновлений Промо

Email рассылки Управление услугами и сервисом СRM Платформа 1С v8.3 Конфигурации 1cv8 Управленческий учет Абонемент ($m)

(©ТопчийДЮ) Для упрощения жизни своей я разработал конфигурацию «База клиентов и публикаций», которая практически решает мои «проблемы» с рассылкой обновлений и учетом продаж на сайте «Инфостарт», с возможностью загрузки данных с сайта (авторского раздела) . Обновление от 18.06.2019, версия 1.5!

5 стартмани

28.09.2014    39222    56    hakerxp    20    

Управление получателями рассылок отчетов

Email рассылки БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 1С:Бухгалтерия 3.0 1С:Зарплата и Управление Персоналом 3.x Россия Абонемент ($m)

Обработка для быстрого и удобного управления списком получателей рассылок отчетов.

1 стартмани

19.03.2021    4829    10    Rackhanot    2    

Групповое формирование актов сверки расчетов с контрагентами, печать (в т.ч. и внешние печатные формы) и отправка по e-mail (Бухгалтерия предприятия, ред. 3.0)

Взаиморасчеты Пакетная печать Email рассылки Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Обработка для группового формирования актов сверки расчетов с контрагентами (два варианта: без отправки по e-mail и полная с формированием и отправкой по e-mail).

4 стартмани

11.03.2021    4845    42    Mouros    10    

Автоматическое формирование и отправка документов Акт сверки взаиморасчетов по расчетам с контрагентами

Взаиморасчеты Обработка документов Email рассылки Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия государственного учреждения Россия Бухгалтерский учет Абонемент ($m)

Обработка предназначена для автоматического формирования документов «Акт сверки взаиморасчетов» с контрагентами, их распечатки и(или) отправки по электронной почте в виде вложений (*.pdf, *.xls) с установленными при необходимости факсимиле ответственных лиц и печати организации. Применяется и используется при потребности организации в большом количестве документов «Акт сверки взаиморасчетов». Обработка тестировалась на конфигурации: "Бухгалтерия гос. учреждения 2.0", релиз - 2.0.75.40.

3 стартмани

11.01.2021    5571    6    aderkatch    1    

Мастер рассылки e-mail 2.2 для управляемых форм Промо

Email рассылки Платформа 1С v8.3 Управляемые формы 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    51473    24    milkers    4    

Формирование и отправка актов сверок. УНФ 1.6

Печатные формы Взаиморасчеты Email рассылки Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 Россия Бухгалтерский учет Управленческий учет Абонемент ($m)

Обработка предназначена для автоматического формирования и рассылки актов сверки в УНФ 1.6.

1 стартмани

20.11.2020    6823    34    mic4    14    

Рассылка данных клиентам по документам "Поступление товаров и услуг" через СМС, Viber и E-Mail

Оптовая торговля Розничная торговля SMS рассылки Email рассылки Платформа 1С v8.3 Платформа 1C v8.2 1С:Управление торговлей 10 1С:Управление производственным предприятием Управленческий учет Абонемент ($m)

Когда пришёл товар на Склад/в Магазин, обработка сообщает на электронную почту, мобильный телефон, Viber, СМС клиента, что пришёл его товар по Заказу покупателя № …. от даты. Указывается Номенклатура, Количество, Ед. изм. И что товар можно забрать со склада.

10 стартмани

08.11.2020    5935    1    hachaturov    0    

Фоновая отправка уведомлений

Email рассылки Платформа 1С v8.3 1С:Зарплата и кадры бюджетного учреждения 1С:Розница 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Управленческий учет Абонемент ($m)

Часто нужно уведомлять пользователей о событиях, происходящих в системе, на их электронную почту. Например, сообщение о приходе денег от контрагента для его менеджера.

5 стартмани

20.10.2020    7196    10    milkers    5    

Рассылка счетов, актов и счетов-фактур для БП 3.0 Промо

Email рассылки Оптовая торговля Готовая продукция, работы и услуги Платформа 1С v8.3 1С:Бухгалтерия 3.0 Бухгалтерский учет Абонемент ($m)

Еще одна рассылка, теперь для Бухгалтерии 3.0. Использует встроенные учетные записи и почтовые механизмы. Файлы для отправки формируются только из заданных внешних печатных форм, перед отправкой документы сохраняются в PDF.

1 стартмани

16.02.2014    35611    307    @Sonya    36    

Автоматическая рассылка Актов и Счетов контрагентам из Бухгалтерии

Email рассылки Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Абонемент ($m)

Решение для автоматической рассылки актов и счетов контрагентам с возможностью отслеживать историю рассылки, логи отправки и тд. Есть возможность настроить шаблоны HTML для писем, с использованием параметров. Возможность задавать контрагентам значения шаблонов по умолчанию.

1 стартмани

17.10.2020    6781    42    Segate    10    

Простой почтовый клиент (Моя почта)

БСП (Библиотека стандартных подсистем) Email рассылки Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Почтовый клиент (Моя почта) на основе БСП.

2 стартмани

27.08.2020    7242    15    m_aster    6    

Отправка писем на электронную почту типовой функцией 1С

Email рассылки Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

Если вам необходимо отправить письмо на почту из внешней обработки, вам поможет эта статья.

1 стартмани

04.07.2020    40670    44    Andrei_Ivanov    15    

Автоматическая рассылка сформированных отчетов по электронной почте Промо

Email рассылки Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

Обработка автоматической рассылки отчетов по эл. почте

1 стартмани

18.05.2012    37591    375    darel82    32    

Рассылка расчетных листков 2.0 (с обходом спам-фильтра)

Зарплата Email рассылки Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Абонемент ($m)

Обработка производит рассылку расчетных листков сотрудников в формате PDF с возможностью архивирование и шифрования вложения. Важной особенностью обработки является возможность обходить ограничения на количество отправляемых писем в некий период (обход спам-фильтра). Это не хакерская фича, это реальная проблема, наблюдаемая при вполне легальных при массовых рассылках, даже на корпоративных серверах.

2 стартмани

26.05.2020    7344    36    saver77    14    

Автоматическая загрузка накладных от поставщиков из электронной почты (Розница 2.2)

Обработка документов Розничная торговля Логистика, склад и ТМЦ Email рассылки WEB-интеграция Платформа 1С v8.3 1С:Розница Россия Управленческий учет Абонемент ($m)

Данная обработка предназначена для получения файлов (*.xls;*.xlsx;*.ods;*.dbf) с почтового сервера вашей электронной почты и загрузки прочитанных данных в документы «Поступление товаров». Так же присутствует возможность распаковки архивов, если поставщик шлет вам в письме архивированные файлы (RAR; ZIP; 7Z). Наличие установленного MS Office и Open Office не требуется.

5 стартмани

18.05.2020    9898    10    StiVitS    9    

Групповая рассылка счетов по email для БП 2.0 Промо

Пакетная печать Обработка документов СRM Email рассылки Платформа 1С v8.3 1С:Бухгалтерия 2.0 Россия Абонемент ($m)

Рассылка счетов по email для конфигурации Бухгалтерия Предприятия 2.0 - автоматическое создание необходимых доп. реквизитов и видов контактной информации. - возможность изменения и сохранения изменений в БД адресов электронной почты контрагентов непосредственно в обработке. - отметка отправленных счетов дополнительным реквизитом, который принадлежит только документу «Счет на оплату», а не по всем документам. - поддержка параметров в теме и тексте письма.

1 стартмани

09.06.2014    35062    77    spacc    4    

Небольшой универсальный механизм рассылки документов

Email рассылки Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Рассылка документов, например, кадры оформили командировку - форма отправилась к расчетчикам. Бухгалтерия выписала реализацию - накладная в виде файла в PDF формате "улетела" по почте к кладовщику.

1 стартмани

13.05.2020    6244    7    zavsom    6    

Работа с сервисом Unisender. УТ 11

Email рассылки Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Обработка для работы с сервисом Unisender. Реализована для УТ 11, но можно использовать для любой конфигурации, т.к. методы API реализованы в модуле обработки.

1 стартмани

29.04.2020    7143    11    pscorp    0    

Расширение - рассылка отчета Торг 29 электронной почтой по складам. Управление торговлей 11.4

Email рассылки Платформа 1С v8.3 1С:Управление торговлей 11 Россия Управленческий учет Абонемент ($m)

Расширение производит рассылку отчета Торг 29 (добавлена колонка скидки) в формате XLSX по выбранному списку складов. Тестировалось на конфигурации "Управление торговлей 11.4.11.63", платформа "8.3.16.1224" режим совместимости Версия 8.3.12. 

1 стартмани

16.04.2020    7044    3    IVC_goal    0    

Автоматическое формирование и рассылка отчетов Промо

Email рассылки Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Подсистема позволяет хранить пользовательские настройки СКД, формировать отчеты по расписанию и отправлять по почте либо сохранять в каталог.

1 стартмани

27.01.2014    27274    126    Vo-Va    11    

История отправки электронной почты по документам. Расширение. БП 3.0

Документооборот и делопроизводство Email рассылки Журнал регистрации Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Абонемент ($m)

Расширение для конфигурации Бухгалтерия предприятия, редакция 3.0. Реализует возможность хранить историю отправки электронных писем для документов "Реализация (акты, накладные)" и "Счета покупателям". Расширение может быть расширено и для других документов 1С.

3 стартмани

31.03.2020    9053    26    Diks_Soft    2    

Чтение писем электронной почты (обычные и управляемые формы)

Email рассылки Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Обработка позволяет просматривать письма электронной почты.

2 стартмани

09.03.2020    6882    23    Denr83    0    

Отправка электронных писем с помощью Exchange Web Services (EWS) и авторизацией Active Directory (AD)

Email рассылки Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

В данной публикации показан пример отправки электронного письма из 1С с использованием Exchange Web Services (EWS) и авторизацией Active Directory (AD).

1 стартмани

30.01.2020    11377    17    Isonic    6    

Рассылка электронных писем Промо

Универсальные обработки Email рассылки Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

У меня появилась необходимость совершить массовую рассылку электронной почты. Когда я начал заниматься этим вопросом, то столкнулся с некоторыми трудностями и не смог найти действительно ПРОСТУЮ и УДОБНУЮ обработку для осуществления рассылки. Итогом стала эта обработка:)

1 стартмани

09.01.2014    23585    79    GATTUSO    10    

Обновление пароля системной учетной записи электронной почты, если забыт/утерян текущий

Email рассылки БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Изменение пароля стандартной системной учетной записи электронной почты для отправки отчетов, печатных форм из 1С в любой конфигурации, в которую интегрирована подсистема БСП Органайзер, для возможности перезаполнения стандартной учетки новыми данными.

1 стартмани

06.01.2020    11369    29    1sig    8    

Создание писем в Outlook из 1С с подписью и вложением (Excel-файл с несколькими листами)

Email рассылки Платформа 1С v8.3 Абонемент ($m)

Программное создание писем в Outlook из 1С с подписью и вложением (сгенерировав Excel-файл с листами из нескольких ТабличныхДокументов) используя COM-объект. Как избавиться от рутинного создания однотипных писем.

1 стартмани

22.10.2019    13180    24    Merkalov    5    

Автоматическая рассылка произвольных отчетов по электронной почте (обычные формы)

Email рассылки Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Очень часто возникает необходимость на регулярной основе получать отчеты из 1С, но не всегда есть возможность зайти в программу. Например, директору удобно каждое утро анализировать состояние основных показателей организации за чашечкой кофе, у себя дома, открывая отчеты в почте со смартфона или планшета. В типовых конфигурациях на управляемых формах этот механизм достаточно хорошо реализован и имеет очень гибкую настройку. К сожалению, в конфигурациях на обычных формах приходится довольствоваться лишь рапортом руководителю, который предоставляет достаточно скудные возможности. Поэтому был реализован ниже следующий функционал.

3 стартмани

06.08.2019    18895    89    Nicholas    68