Обработка обслуживания QR Дисплея

Публикация № 1650861 27.04.22

Интеграция и обмен данными - Периферийные устройства

Обработка обслуживания QR Дисплея

Обработка обслуживания QR Дисплея от "Бизнес код." для 1С 8.2. QR-дисплей - это устройство, позволяющее выводить динамический QR-код для оплаты в вашем магазине, ресторане и любом другом заведении, занимающемся торговлей или услугами. При этом в QR-код сразу выводятся ваши реквизиты для оплаты вместе с суммой оплаты. Покупателю нужно только навести камеру своего мобильного телефона, и ... платеж проведен. Зачисление на расчетный счет происходит моментально!

Выводит на QR дисплей сформированный QR код. Судя по API производителей должна работать и с другими производителями QR дисплеев. Подключается как обработка обслуживания торгового оборудования.

Кодировку устанавливаем UTF8. В комплекте (макеты) MSComm32.ocx и файл лицензии.

MSComm32.ocx и Файл лицензий необходимо сохранить из макета. 

MSComm32.ocx необходимо зарегистрировать в системе "regsvr32  MSComm32.ocx"

Файл лицензий внести в реестр windows (без этого работать не будет)

Тестировалось на платформе 8.3.20.1710. Подойдет к конфигурациям, где есть Подключаемое оборудование (неуправляемые формы).  

Подключается как обработка обслуживания торгового оборудования.  Меню "Сервис" - "Служебные" - "Подключение и настройка торгового оборудования"

В форме где будем вызывать вывод на QR дисплей в процедуре "ПриОткрытии" вставить следующий код:

Результат = ПолучитьСерверТО().ПодключитьКлиента(ЭтаФорма);

Разместить процедуры


// Процедура осуществляет вывод информации на дисплей покупателя.
//
// Параметры:
//  Нет.
//
&НаКлиенте
Процедура ВывестиИнформациюНаДисплейПокупателя(Данные) Экспорт
	
	ВидТО    = Перечисления.ВидыТорговогоОборудования.ДисплейПокупателя;
	Дисплеи  = ПолучитьСерверТО().ПолучитьСписокУстройств(ВидТО);
	Дисплей  = Неопределено;
	
	Для Каждого Дисплей Из Дисплеи Цикл
		Если ПустаяСтрока(Данные) Тогда
			ПолучитьСерверТО().ОчиститьДисплейПокупателя(Дисплей);
		Иначе
			ПолучитьСерверТО().ВывестиСтрокуНаДисплейПокупателя(Дисплей, Данные);
		КонецЕсли;
	КонецЦикла;
	
КонецПроцедуры // ВывестиИнформациюНаДисплейПокупателя()


// Функция возвращает признак того, что клиент поддерживает работу с видом ТО,
// переданным в качестве параметра.
//
// Параметры:
//  Вид      - <ПеречислениеСсылка.ВидыТорговогоОборудования>
//           - Вид торгового оборудования, информация о поддержке
//             которого запрашивается.
//
// Возвращаемое значение:
//  <Булево> - Признак поддержки указанного класса торгового оборудования.
//
Функция ПоддерживаетсяВидТО(Вид) Экспорт
	
	Результат = Ложь;
	Если Вид = Перечисления.ВидыТорговогоОборудования.ДисплейПокупателя Тогда
		Результат = Истина;			
	КонецЕсли;
	
	Возврат Результат;
	
КонецФункции // ПоддерживаетсяВидТО()   

Вызывается с помощью 

  ВывестиИнформациюНаДисплейПокупателя(
    "[T1]" + "Верхняя строка"+ Символы.ВК + Символы.ПС + 
    "[QL]" + "QR КОД" + Символы.ВК + Символы.ПС + 
    "[T2]" + "Нижняя строка" + Символы.ВК + Символы.ПС);

Для более корректного отображения русских букв Верхнюю строку и Нижнюю строку перекодировать в UTF8 с помощью функций


Функция Dec_to_Hex(Знач пDec, Знач Разрядность = 2)   
	
	пHex = "0123456789ABCDEF";
	Результат = "";
	
	Для СимвЧисло = 1 По Разрядность Цикл
		ТекЧисло = пDec % 16;
		пDec = Цел(пDec / 16);
		Результат = Сред(пHex, ТекЧисло + 1, 1) + Результат;
	КонецЦикла;
	
	Возврат Результат;
	
КонецФункции


Функция ПереводТекстаUnicodeToUTF8(СтрокаДляКодировки)
	
	СимволыДляИсключения = "-.0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ_abcdefghijklmnopqrstuvwxyz~№";
	Результат = "";
	
	Для а = 1 По СтрДлина(СтрокаДляКодировки) Цикл
		ТекСимв = Сред(СтрокаДляКодировки, а, 1);
		
		Если ТекСимв = " " Тогда
			Результат = Результат + "20";
			Продолжить;
		КонецЕсли;
		Если Найти(СимволыДляИсключения, ТекСимв) > 0 Тогда
			Результат = Результат + ТекСимв;
			Продолжить;
		КонецЕсли;
		
		ЮниКод = КодСимвола(ТекСимв);
		Если ЮниКод < 128 Тогда
			Результат = Результат + "%" + Dec_to_Hex(ЮниКод);
		Иначе
			ИндексЮникод = 32;
			Байт = 8;
			ХексКод = "";
			Пока ИндексЮникод > 4 Цикл
				// установка следующих за первым байтов
				ТекБайт = ЮниКод % 64;
				ХексКод = "%" + Dec_to_Hex(128 + ТекБайт) + ХексКод;
				
				ЮниКод        = Цел(ЮниКод / 64);
				// проверка на закрывающий байт
				Если ЮниКод < ИндексЮникод Тогда
					ХексКод = "%" + Dec_to_Hex((Байт-2) * ИндексЮникод + ЮниКод) + ХексКод;
					Прервать;
				КонецЕсли;
				// переход к следующему уровню закрытия
				ИндексЮникод = ИндексЮникод / 2;
				Байт = Байт * 2;
			КонецЦикла;
			Результат = Результат + ХексКод;
		КонецЕсли;
	КонецЦикла;
	
	Буфер = ПолучитьБуферДвоичныхДанныхИзHexСтроки(Результат);
	Поток = Новый ПотокВПамяти(Буфер);
	ЧтениеТекста = Новый ЧтениеТекста(Поток, КодировкаТекста.ANSI, "", "");
	Данные = ЧтениеТекста.Прочитать();
	
	Возврат Данные;
КонецФункции  

 

Скачать файлы

Наименование Файл Версия Размер
Обработка обслуживая QR дисплея:

.epf 25,03Kb
4
.epf 25,03Kb 4 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Внешняя компонента печати этикеток для 4 моделей принтеров Промо

Розничная торговля Разработка внешних компонент Периферийные устройства Печатные формы Платформа 1С v8.3 Платформа 1С v8.3 Россия Россия Абонемент ($m) Абонемент ($m)

COM-сервер (внешняя компонента) позволяет печатать этикетки на 4-е модели принтеров (+совместимые с ними по языку управления) 1) Godex EZ-2, Godex BZB-2 2) Godex EZ-2P, Godex DT-2 3) Zebra LP 2824 4) Argox OS-203DT

1 стартмани

15.08.2012    47053    109    ImageWriter    5    

Подсистема печати на сетевые принтеры по протоколу IPP без драйверов из любой ОС и серверного контекста

Периферийные устройства Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Печать на сетевые принтеры по протоколу IPP как напрямую, так и с иcпользованием сервера CUPS. Подсистема позволяет печатать из серверного, клиентского контекста, регламентных и фоновых заданий и не требует установки какого-то дополнительного ПО, библиотек и драйверов принтеров как на сервер 1С Предприятия, так и на клиента. Получение статуса принтера, информации о нем и результатов печати. Никаких внешних компонент не используется, под капотом HTTP и работа с двоичными данными средствами платформы. Сериализатор и десериализатор протокола IPP позволяет относительно легко доработать подсистему для поддержки нереализованных методов и типов данных протокола IPP.

5 стартмани

19.08.2022    1342    2    dumsik    4    

Мониторинг ИБП МАП и выключение, включение серверов

Сервера Мониторинг Периферийные устройства Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

В качестве источника бесперебойного питания серверов можно использовать сетевой инвертор и сборку литиевых аккумуляторов. Единственное, чтобы это работало без участия человека, нужно выключать сервера, когда АКБ разряжается, и включать их обратно, когда сетевое напряжение появилось и АКБ зарядился. С этим вполне может справляться и программа на 1С. Далее описывается программа мониторинга и схема подключения МАП Тitanator UPS (Микроарт) с АКБ Vektor LFP (LiFePO4). Обмен данными ведется по протоколу HTTP.

1 стартмани

16.08.2022    1804    2    vad7    0    

Печать на мобильных принтерах по bluetooth и сети (ZPL, TSPL, CPCL)

Периферийные устройства Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Реализация печати на мобильные принтера по bluetooth и сети в формате языка разметки ZPL, TSPL, CPCL из мобильных приложений 1С под Android.

5 стартмани

10.06.2022    2414    13    igorK    15    

Полноценная работа с COM портом через библиотеку MSComm

Периферийные устройства Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Чтение и запись в COM порт через библиотеку MSComm. Без бесконечных циклов и прочих костылей.

1 стартмани

15.09.2021    10870    105    vadnevzorov    29    

Печать этикеток и ценников из УТ 10.3 на обычные и термопринтеры Argox и Godex

Периферийные устройства Печатные формы Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 Абонемент ($m) Абонемент ($m)

Удобная и быстрая печать ценников и этикеток из 1С:Управление торговлей (УТ) 10.3 на обычных принтерах и на термопринтерах Argox OS-203 DT, OS-2130D и Godex BZB2/EZ2/EZ4, Citizen CLP-521/621.

2 стартмани

12.07.2021    7079    19    w0r0n    10    

Отправка накладной на складской принтер (УТ 11)

Печатные формы Оптовая торговля Периферийные устройства Платформа 1С v8.3 Платформа 1С v8.3 Оперативный учет Оперативный учет 1С:Управление торговлей 11 1С:Управление торговлей 11 Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Расширение (.cfe для УТ 11) позволяет автоматически (по требованию) распечатывать заказ клиента на складской принтер (независимо от указанного количества копий, на склад отправляется только одна копия). При возникновении потребности отправки копии накладной на складской принтер достаточно установить галку у параметра «+ печать на склад» (подробнее в прикрепленном изображении).

1 стартмани

31.03.2021    3790    1    Lonelcor    0    

Учет рабочего времени (интеграция с оборудованием ZKTeco)

Учет рабочего времени Периферийные устройства Платформа 1С v8.3 Платформа 1С v8.3 Казахстан Казахстан Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Автоматизация учета рабочего времени. Цель - получение данных о посещении сотрудников с устройства сканера отпечатка пальцев в 1С.

1 стартмани

23.03.2021    7091    24    Almaz    16    

Получение скриншота с камеры Hikvision при digest-аутентификации

Периферийные устройства Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Имея подключенную ip-камеру, требуется по нажатию кнопки в документе 1С получать изображение. Может быть полезна при организации рабочих мест на проходных, весовых и т.п.

1 стартмани

30.12.2020    5650    14    garagauto    5    

Включение и выключение электроприборов из 1С

Периферийные устройства Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

В публикации я постараюсь описать, как в случае необходимости можно расширить возможности 1С при помощи доступного внешнего оборудования. Рассмотрим, каким образом можно легко включать и выключать электроприборы программно из 1С или имитировать нажатие кнопок.

1 стартмани

02.04.2020    12055    8    bobreks    66    

Умный дом. Продолжение: подключаем счётчик воды к 1С

Периферийные устройства Платформа 1С v8.3 Платформа 1С v8.3 Россия Россия Абонемент ($m) Абонемент ($m)

Подключаем стандартный счётчик учета расхода воды к локальной сети по вай фай и работаем с ним из 1С

1 стартмани

07.12.2017    10098    2    sasha777666    10    

Программа для изменения осей движения мыши - IMouse

Периферийные устройства Россия Россия Абонемент ($m) Абонемент ($m)

Программа предназначена для изменения движения курсора мыши.

1 стартмани

10.08.2017    19228    5    GubinDenis    20    

Версия 2. Управление принтерами внутри 1С

Периферийные устройства Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Управление принтерами внутри 1С, обычные формы, операционная система - Windows

1 стартмани

24.07.2017    25376    56    vasilev2015    32    

Вывод информации на второй дисплей (дисплей покупателя)

Периферийные устройства Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

Программа для обеспечения взаимодействия 1С со вторым дисплеем.

1 стартмани

25.07.2016    18327    42    Bienko    23    

Тест прямой печати для Штрих-600 в управляемом приложении

Периферийные устройства Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Появилась необходимость настроить Штрих-600 на Windows-7. Драйверов под эту ОС не существует. Зато у принтера есть возможность печатать без драйвера Windows напрямую, используя ESC последовательности. Эта обработка была написана для тестирования данного метода.

1 стартмани

31.05.2016    11502    5    Rokky78    1    

1С, arduino, http и никаких внешних компонент

Периферийные устройства Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

Подключение к 1С любого оборудования с помощью ардуины, по локальной сети. Отправка команды, её обработка и получения ответа по хттп.

1 стартмани

26.04.2015    23924    17    sasha777666    25    

Подключение к 1С нестандартного оборудования с помощью ардуино

Периферийные устройства Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

Возможно ли из 1С управлять такими устройствами, как: шлагбаум, домофон, кондиционер, телевизор, холодильник и т.д.? Да - возможно. С помощью микроконтроллера можно управлять любыми устройствами при помощи замыкающих реле, ИК передатчиков и другой периферии. Но как подключить сам контроллер к 1С, чтобы получить функцию, отправляющую данные на МК и возвращающую с него ответ? В этой статье будет описано подключение через юсб интерфейс, а точнее через серийный порт.

1 стартмани

19.04.2015    22129    22    sasha777666    46    

Работа с принтером чеков Posiflex PP 6000, 7000, 8000

POS терминал Периферийные устройства Россия Россия Абонемент ($m) Абонемент ($m)

Некоторые варианты для работы с принтером чеков POSIFLEX AURA 6000, 7000, 8000.

1 стартмани

18.08.2014    77544    241    MrFlanker    27    

Пример работы с TCP камерой

Периферийные устройства Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка подключает TCP камеру, захватывает кадр и сохраняет его в файл. Сделана для демонстрации возможности получения изображения с TCP камеры.

1 стартмани

10.05.2014    11577    25    Paltusov    1    

Биометрия ANVIZ для отпечатков пальцев в 1с8

Периферийные устройства Платформа 1С v8.3 Платформа 1С v8.3 Россия Россия Абонемент ($m) Абонемент ($m)

В статье изложена практическая методика использования сканеров Anvizс бесплатным SDKдля идентификации пользователей в конфигурациях 1с. Приложена демо-база 1С81 и exe-коннектор между 1С и сканером.

1 стартмани

04.01.2013    28302    96    fixin    26    

Программа для очистки очереди печати принтера

Периферийные устройства Россия Россия Абонемент ($m) Абонемент ($m)

Иногда бывает так, что пользователь отправил на печать 200-страничный документ, а в свойствах принтера печать никак не отменяется. Данная программа очищает очередь принтера.

1 стартмани

28.04.2012    10632    45    ivangorchakov    9    

Пример использования WMI на примере класса Win32_printers

Периферийные устройства Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Обработка управления принтером на основе класса Win32_printers. Может использоваться в качестве примера использования классов WMI в "1С: Предприятии 8.Х".

1 стартмани

04.12.2011    14074    28    ediks    5    

Пример работы с Web камерой

Периферийные устройства Платформа 1С v8.3 Платформа 1С v8.3 Россия Россия Абонемент ($m) Абонемент ($m)

Обработка подключает Web камеру, захватывает кадр и сохраняет его в файл. Сделана для демонстрации возможности получения изображения с веб камеры.

1 стартмани

26.02.2011    15840    471    Paltusov    12    

Ввод щелчком мыши: правым, левым, двойным

Периферийные устройства Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Щёлкая по минному полю «Сапёра» то левой, то правой кнопкой мыши, задумался, как в „восьмёрке” без соответствующих щелчкам мыши событий так же выполнять разные действия то левой, то правой кнопкой мыши. Так можно ускорить многократный ввод в таблицу двух-трёх разных значений, вводя их одним щелчком: одно значение — левым, другое — правым, и третье — двойным, а сами значения выбрав перед началом их ввода.

1 стартмани

15.12.2009    22984    208    codmal    19    

Отправить факс из 1С - это просто.

Периферийные устройства Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Пример простой отправки факсов из 1С при помощи стандартной компоненты "FaxServer"

1 стартмани

23.09.2009    8579    534    PRoman    22    

Получение списка принтеров

Периферийные устройства Абонемент ($m) Абонемент ($m)

Часто требуется получить список принтеров...

1 стартмани

09.07.2009    43297    92    Dimasik2007    19    

Работаем с последовательным портом (7.7.)

Периферийные устройства Оперативный учет 7.7 Оперативный учет 7.7 Бухгалтерский учет 7.7 Бухгалтерский учет 7.7 Расчет 7.7 Расчет 7.7 Конфигурации 1cv7 Конфигурации 1cv7 Абонемент ($m) Абонемент ($m)

Пишем в порт, читаем из порта. Зная протокол обмена, сможем внешним устройством управлять. Например, ридером меток RFID.

1 стартмани

10.04.2009    17013    322    Арчибальд    8    

Печать на DATAMAX ч/з DPL (встроенный механизм принтера)

Периферийные устройства Платформа 1С v7.7 Платформа 1С v7.7 Конфигурации 1cv7 Конфигурации 1cv7 Абонемент ($m) Абонемент ($m)

Печатать на datamax ч/з драйвер системы - долго. Есть внешние компоненты, но можно обойтись и средствами 1С. Обработка писалась для печати на удаленные принтеры при плохом канале связи (впн ч/з интернет).

08.04.2009    9998    25    rk    6