Фоновая отправка уведомлений

Публикация № 1313233 20.10.20

Интеграция и обмен данными - Email рассылки

Отправка уведомлений рассылка многопоточность параллелизм фоновое задание

Часто нужно уведомлять пользователей о событиях, происходящих в системе, на их электронную почту. Например, сообщение о приходе денег от контрагента для его менеджера.

Фоновая отправка уведомлений

Часто нужно уведомлять пользователей о событиях происходящих в системе на их электронную почту.

 

Например, для того что пришло уведомление о приходе денег от клиента по заказу, теперь перетащить модуль документа в расширение и вставить следующий код:


&После("ОбработкаПроведения")
Процедура Расш1__ОбработкаПроведения(Отказ, РежимПроведения)

	Если Проведен = ложь тогда
		Возврат;
	Конецесли;
	
	ТЗ=Новый ТаблицаЗначений;
	ТЗ.Колонки.Добавить("ОснованиеПлатежа");
	ТЗ.Колонки.Добавить("Партнер");
	ТЗ.Колонки.Добавить("Сумма");
	Для каждого стр из РасшифровкаПлатежа цикл
		ЗаполнитьЗначенияСвойств(ТЗ.Добавить(),Стр);
	Конеццикла;
	
	ТЗ.Свернуть("ОснованиеПлатежа,Партнер","Сумма");
	
	Для каждого стр из ТЗ цикл
		
		Тема ="Приход: "+ стр.Сумма+" от "+Контрагент+?(ЗначениеЗаполнено(стр.ОснованиеПлатежа)," по "+стр.ОснованиеПлатежа,"");
		
		КлючУникальности="Приход "+Ссылка.УникальныйИдентификатор()+" от "+Контрагент; 
		
		ДатаЗадания=ТекущаяДата();
	    Тема="Ознакомьтесь с поступлением денежных средств  "+ Номер+ " от "+Формат(Дата,"ДФ=dd.MM.yy")+" от "+Контрагент;
		Тело= "По "+стр.ОснованиеПлатежа+" поступили д.с. в размере "+ Формат(стр.Сумма,"ЧДЦ=2")+"
		|
		| Гиперссылка на поступление денежных средств:   "+ПолучитьНавигационнуюСсылку(Ссылка)+"
		|
		|
		| Прим. Вы можете перейти в документ, скопировав гиперссылку в буфер обмена и нажав в  1С ""Shift+F11""" ; 
	  	мо_ОтправкаУведомлений_Сервер.ОтправитьУведомлениеПоEmailВФоновомРежиме(стр.Партнер.ОсновнойМенеджер,Тема,Тело,,КлючУникальности,Ссылка);		  
	Конеццикла;

КонецПроцедуры

На почту менеджеру придет уведомление:

Ознакомьтесь с поступлением денежных средств 0A00-001052 от 25.09.20 от ООО Uhff КФ Рус

 

1С:Предприятие

Сегодня, 13:05

Кому: вам

По Заказ клиента от "ООО Гром КФ Рус" А20-0000458 от 27.07.2020 18:29:16 поступили д.с. в размере 661 240,80

 Гиперссылка на поступление денежных средств: e1cib/data/Документ.ПоступлениеБезналичныхДенежныхСредств?ref=80e4ac1f6b91b3ef11eb014d446068dd


 Прим. Вы можете перейти в документ, скопиров гиперссылку в буфер обмена и нажав в 1С "Shift+F11"

 

 

     Преймущества по  сравнению с обычным кодом:

  1.  Уведомления не задублируются. Правильно подобрав ключ уникальности, Вы гарантируете единичную отправку сообщения.
  2.  Вам не нужно вспоминать детали работы с электронными письмами. Все что вам нужно,  это ссылка на пользователя (у него должен быть прописан e-mail в контактной информации, ссылка на  объект (можно даже еще не записанный)  и текст сообщения.
  3.   Экономия времени. Теперь, чтоб добавить уведомление о событие, Вам всего лишь надо скопировать небольшой фрагмент кода и подправить текст сообщения.
  4.  Экономия кода. Уведомлений о событиях много и основная работа с ними выделена в общий модуль.
  5. Все сообщения отправляются в фоновом режиме. Это значит, что сколько бы времени ни занял процесс отправки, это никак не повлияет на работу программы.

 

  1.      Пример отправки сообщения из еще не записанного справочника с отправкой гиперссылки на будущий элемент:

 

&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
	ПередЗаписьюНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПередЗаписьюНаСервере()
	  КонтрольнаяСумма=Объект.ПредпечатнаяПодготовка;
	  Для Каждого СтрокаВарианта Из Объект.ВариантыРасчета цикл
		  КонтрольнаяСумма=КонтрольнаяСумма+ СтрокаВарианта.Цена;
	  КонецЦикла;
	  КонтрольнаяСумма2=Объект.Ссылка.ПредпечатнаяПодготовка;
	  Для Каждого СтрокаВарианта Из Объект.Ссылка.ВариантыРасчета цикл
		  КонтрольнаяСумма2=КонтрольнаяСумма+ СтрокаВарианта.Цена;
	  КонецЦикла;
	  Если  КонтрольнаяСумма2<> КонтрольнаяСумма Тогда
		  
		  Если Объект.Ссылка=Неопределено  Тогда
			  // Получаем возможно уже установленную ранее ссылку нового
			  СсылкаНаОбъект = Объект.ПолучитьСсылкуНового();
			  Если Не ЗначениеЗаполнено(СсылкаНаОбъект) Тогда
				  // Если ссылка нового пустая, то запрашиваем ее у менеджера и устанавливаем
				  СсылкаНаОбъект = Документы.мо_ЗаказНаРасчет.ПолучитьСсылку();
				  Объект.УстановитьСсылкуНового(СсылкаНаОбъект);
			  КонецЕсли;
		  Иначе
			  СсылкаНаОбъект = Объект.Ссылка;
		  КонецЕсли;		  
		ДатаЗадания=ТекущаяДата();
	    Тема="Ознакомьтесь с изменением цен по расчету  "+ Объект.Номер+ " от "+Формат(ДатаЗадания,"ДФ=dd.MM.yy");
		КлючУникальностиДокумента= "Изменение цен по расчету  "+ Объект.Номер+ " от "+Формат(ДатаЗадания,"ДФ=dd.MM.yy");
		
		//Задача.Предмет = Сделка;
		Тело= "По заданию на расчет по сделке"+Объект.Ссылка+" поменялись рассчитанные цены!
		|
		| Гиперссылка на заказ на расчет:   "+ПолучитьНавигационнуюСсылку(СсылкаНаОбъект)+"
		|
		|
		| Прим. Вы можете перейти в документ, скопировав гиперссылку в буфер обмена и нажав в  1С ""Shift+F11""" ; 
	  	мо_ОтправкаУведомлений_Сервер.ОтправитьУведомлениеПоEmailВФоновомРежиме(Объект.Менеджер,Тема,Тело,,КлючУникальностиДокумента,СсылкаНаОбъект);		  
	  КонецЕсли;
КонецПроцедуры

Если В    

       Если Вы цените свое время и чувствуете в себе силы выразить немного благодарности в виде стартмани, то рекомендую  скачать расширение в готовом виде.

     Если Вам это не доступно по каким то причинам, то код основных фрагментов расширения приведен ниже:


Процедура ОтправитьУведомлениеПоEmail(М_Пользователи,Тема,Тело,АдресОтвета="",КлючУникальности="",КлючеваяСсылка="") Экспорт
  	УстановитьПривилегированныйРежим(Истина);	
	ПараметрыПисьма = Новый Структура;

	
	Кому ="";
	Если ТипЗнч(М_Пользователи)=Тип("Массив") Тогда
		Для Каждого Пользователь из  М_Пользователи Цикл
			Адрес=УправлениеКонтактнойИнформацией.КонтактнаяИнформацияОбъекта(Пользователь,Справочники.ВидыКонтактнойИнформации.EmailПользователя);
			Если ЗначениеЗаполнено(Адрес) Тогда 
				Кому =Кому+?(Кому="","",";")+Адрес;
			КонецЕсли;
		КонецЦикла;
	Иначе
			Адрес=УправлениеКонтактнойИнформацией.КонтактнаяИнформацияОбъекта(М_Пользователи,Справочники.ВидыКонтактнойИнформации.EmailПользователя);
			Если ЗначениеЗаполнено(Адрес) Тогда 
				Кому =Кому+?(Кому="","",";")+Адрес;
			КонецЕсли;
	КонецЕсли;
	Если ЗначениеЗаполнено(Кому) Тогда
		ПараметрыПисьма.Вставить("Кому", Кому);
	Иначе
		возврат;
	КонецЕсли;
	
	УчетнаяЗаписьИзНастроек=Справочники.УчетныеЗаписиЭлектроннойПочты.СистемнаяУчетнаяЗаписьЭлектроннойПочты;
	ПараметрыПисьма.Вставить("АдресОтвета", АдресОтвета);

	ПараметрыПисьма.Вставить("Тема", Тема);
	
	//ФайлВФорматеHTML = ПолучитьИмяВременногоФайла();
	//ТабДок.Записать(ФайлВФорматеHTML, ТипФайлаТабличногоДокумента.HTML5);
	//ТекстПисьма = Новый ТекстовыйДокумент;
	//ТекстПисьма.Прочитать(ФайлВФорматеHTML);
	// ХТМЛПоле = ТекстПисьма.ПолучитьТекст();
	
	
	ПараметрыПисьма.Вставить("Тело", Тело);
	ПараметрыПисьма.Вставить("ТипТекста",  ПредопределенноеЗначение("Перечисление.ТипыТекстовЭлектронныхПисем.ПростойТекст"));
	Если КлючУникальности="" ИЛИ  РегистрыСведений.мо_СчетчикСобытий.ПолучитьСчетчик(КлючУникальности,КлючеваяСсылка)=0 Тогда
		Попытка
			РаботаСПочтовымиСообщениями.ОтправитьПочтовоеСообщение(УчетнаяЗаписьИзНастроек, ПараметрыПисьма);
			Если КлючУникальности<>"" Тогда
				РегистрыСведений.мо_СчетчикСобытий.УвеличитьСчетчик(КлючУникальности,КлючеваяСсылка);
			КонецЕсли;
		Исключение
		КонецПопытки;
	КонецЕсли;
КонецПроцедуры

Функция ЗапуститьФоновоеВыполнение(ТекстПроцедуры,СтруктураПараметров=Неопределено) Экспорт
    УникальныйИдентификатор = Новый УникальныйИдентификатор;
    ПараметрыВыполнения = Новый Массив;
    ПараметрыВыполнения.Добавить(ТекстПроцедуры);
    ПараметрыВыполнения.Добавить(СтруктураПараметров);
    
    ФоновыеЗадания.Выполнить("мо_ОтправкаУведомлений_Сервер.ФоноваяПроцедура",ПараметрыВыполнения,УникальныйИдентификатор);
    Возврат УникальныйИдентификатор;
КонецФункции

Процедура ФоноваяПроцедура(ТекстМодуля,ПараметрыВыполнения) Экспорт
    ПолныйТекстМодуля = "";
    Для Каждого ТекПараметр Из ПараметрыВыполнения Цикл
        ПолныйТекстМодуля = ПолныйТекстМодуля+ТекПараметр.Ключ+"=ПараметрыВыполнения."+ТекПараметр.Ключ+";"+Символы.ПС;
    КонецЦикла;
    ПолныйТекстМодуля = ПолныйТекстМодуля + ТекстМодуля;
    Выполнить(ПолныйТекстМодуля);
КонецПроцедуры

Процедура ОтправитьУведомлениеПоEmailВФоновомРежиме(М_Пользователи,Тема,Тело,АдресОтвета="",КлючУникальности="",КлючеваяСсылка="") Экспорт
	ТекстФоновойПроцедуры = "
	|мо_ОтправкаУведомлений_Сервер.ОтправитьУведомлениеПоEmail(М_Пользователи,Тема,Тело,АдресОтвета,КлючУникальности,КлючеваяСсылка);";
	СтруктураПараметров=Новый Структура;
	СтруктураПараметров.Вставить("М_Пользователи",М_Пользователи);
	СтруктураПараметров.Вставить("Тема",Тема);
	СтруктураПараметров.Вставить("Тело",Тело);
	СтруктураПараметров.Вставить("АдресОтвета",АдресОтвета);
	СтруктураПараметров.Вставить("КлючУникальности",КлючУникальности);
	СтруктураПараметров.Вставить("КлючеваяСсылка",КлючеваяСсылка);
	ЗапуститьФоновоеВыполнение(ТекстФоновойПроцедуры,СтруктураПараметров);
КонецПроцедуры


Рег

 

Регистр счетчик событий:

Модуль менеджера:

Процедура УвеличитьСчетчик(ИмяСобытия,КлючеваяСсылка)ЭКСПОРТ
	УстановитьПривилегированныйРежим(Истина);	
	НЗСчетчик= РегистрыСведений.мо_СчетчикСобытий.СоздатьНаборЗаписей();
	НЗСчетчик.Отбор.ИмяСобытия.Установить(ИмяСобытия);
	НЗСчетчик.Отбор.КлючеваяСсылка.Установить(КлючеваяСсылка);
	НЗСчетчик.Прочитать();
	Если НЗСчетчик.Количество() = 0 Тогда
		НовыйСчетчик = НЗСчетчик.Добавить();
		НовыйСчетчик.ИмяСобытия = ИмяСобытия;
		НовыйСчетчик.КлючеваяСсылка = КлючеваяСсылка;
		НовыйСчетчик.Счетчик = 1;
	ИначеЕсли НЗСчетчик.Количество() = 1 Тогда
		НовыйСчетчик = НЗСчетчик[0];
		НовыйСчетчик.Счетчик = НовыйСчетчик.Счетчик+1;
	КонецЕсли;
	НЗСчетчик.Записать();
КонецПроцедуры

Функция ПолучитьСчетчик(ИмяСобытия,КлючеваяСсылка)ЭКСПОРТ
	УстановитьПривилегированныйРежим(Истина);	
	НЗСчетчик= РегистрыСведений.мо_СчетчикСобытий.СоздатьНаборЗаписей();
	НЗСчетчик.Отбор.ИмяСобытия.Установить(ИмяСобытия);
	НЗСчетчик.Отбор.КлючеваяСсылка.Установить(КлючеваяСсылка);
	НЗСчетчик.Прочитать();
	Если НЗСчетчик.Количество() = 0 Тогда
		Возврат 0;	
	КонецЕсли;
	Возврат НЗСчетчик[0].Счетчик;	
КонецФункции	

 

 

 

       Подключение расширения:

          Подключение осуществляется обычным способом:

Расширением гарантированно работает на платформе 8.3 (тестировано на релизах 8.3.13.1644,8.3.18.1334) 1С:Комплексная автоматизация 2 (2.5.7.298) , 1С:ERP Управление предприятием 2 (2.4.7.107)  и Управление торговлей, редакция 11 (11.4.6.188) И Зарплата и управление персоналом КОРП, редакция 3.1 (3.1.11.106)   Режим совместимости Версия 8.3.12 и выше. БСП >3.*

Акция! Вы можете скачать архив всех моих разработок, которые я предлагаю за StartMone, по Специальной  цене:  //infostart.ru/public/960899/#archive

Молочников Олег Spb. 2020

Скачать файлы

Наименование Файл Версия Размер
Отправка уведомлений:

.cfe 12,05Kb
10
.cfe от 15.03.2022 для 2.4, 2.5 12,05Kb 10 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. ltfriend 1008 21.10.20 18:12 Сейчас в теме
Отправка письма в процедуре обработки проведения. Если проблемы с интернетом или низкая скорость соединения, то письмо отправляется, документ ожидает завершения отправки письма, пользователь ждёт, когда же документ проведётся, транзакция висит. Красота!
2. milkers 2749 22.10.20 11:58 Сейчас в теме
(1) Большое спасибо за ваше замечание. Переписал на отправку в фоновом режиме.
3. KazanKokos 9 24.01.21 20:31 Сейчас в теме
Один минус: произошло исключение, завис клиент - письмо не ушло. Может кто подскажет кто есть на инфостарте обработка или расширение работающее по алгоритму:
1. Пул писем к отправке собирается в регистре сведений
2. рассылка ведется регламентным заданием на основе данных этого РС.
4. YA_1130000057973079 19.08.22 06:40 Сейчас в теме
Добрый день.
Можно ли при проведении реализации - фоном отправить УПД в экселе такой обработкой?
5. milkers 2749 19.08.22 08:24 Сейчас в теме
Если слегка доработать процедуру формирования письма.
Оставьте свое сообщение

См. также

Автоматическая рассылка прайс-листов Промо

Прайсы Email рассылки Оптовая торговля Розничная торговля Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 Абонемент ($m) Абонемент ($m)

Устали от утомительной рассылки прайс-листов своим клиентам? Тогда эта обработка как раз для вас, она сделает полностью все сама! Сформирует прайс с нужными настройками и отправит его по электронной почте, как, куда и когда надо.

1 стартмани

24.03.2014    55866    35    skyadmin    22    

Отправка ошибок из журнала регистрации на почту

Журнал регистрации Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка для отправки списка вчерашних ошибок из журнала регистрации на электронную почту. Подключается как внешняя обработка с запуском по расписанию. Для работы требует БСП. Тестировалось на платформе 8.3.21.1607 и конфигурации Бухгалтерия предприятия КОРП 3.0.122.97.

1 стартмани

10.11.2022    1525    5    q_i    7    

Отправка и получение почтовых сообщений

Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Расширение позволяет добавить в конфигурацию возможность отправки почтовых сообщений с вложениями, средствами 1С. Не требует вносить изменения в основную конфигурацию.

1 стартмани

08.09.2022    2070    6    DrZombi    6    

История ролей пользователей

Роли и права Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 Россия Россия Абонемент ($m) Абонемент ($m)

Расширение позволяет записывать историю ролей назначенных пользователям, а также делать рассылки изменений этих ролей по почте.

1 стартмани

31.08.2022    2008    5    Silenser    6    

Отправка пакета документов по электронной почте (в формате PDF/XLS/HTML/MXL/ODS) Промо

Печатные формы Пакетная печать Email рассылки Оптовая торговля Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Бухгалтерия 2.0 1С:Комплексная автоматизация 1.х 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием 1С:Управление производственным предприятием 1С:Управление торговлей 10 1С:Управление торговлей 10 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

С помощью обработки можно нажатием одной кнопки отправить пакет документов контрагенту по электронной почте. Теперь не надо заходить в каждый документ, формировать нужную печатную форму, сохранять на диск, а потом собирать в одном письме. Все это за вас сделает программа самостоятельно. Все, что требуется от пользователя - просто выбрать документ в программе! Доступны варианты обработки для обычного и управляемого приложения!

2 стартмани

22.04.2015    66671    55    trendy    25    

Легкий почтовый клиент

Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Расширение содержит в себе легкий почтовый клиент для загрузки входящих писем с вложениями и их дальнейшей обработки.

5 стартмани

03.08.2022    2006    5    redtram    0    

Массовая рассылка печатных форм любых документов по электронной почте

Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Решение для массовой рассылки печатных форм (в том числе и дополнительных) любых документов, и произвольных файлов по электронной почте. Рассылка пакета документов. Добавление факсимильных печати и подписи. Произвольные шаблоны HTML/Simple text с автозаполнением любыми полями документа. Любые форматы файлов. Упаковка вложений в архив. Транслитерация имен файлов. Разбиение рассылки на произвольные порции. Настраиваемые паузы между письмами и порциями. Журналирование рассылок.

3 стартмани

30.06.2022    3649    36    ixijixi    31    

AllContacts

СRM Рабочее место Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Универсальное расширение для централизованного управления контактами. Позволяет организовать хранение, упорядочивание и использование контактной информации объектов информационной базы в едином рабочем пространстве.

3 стартмани

19.04.2022    7041    3    ixijixi    12    

Отправка электронной почты с помощью локального почтового клиента из 1С, развернутой под удаленным рабочим столом Промо

Печатные формы Универсальные функции Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Управление торговлей 10 1С:Управление производственным предприятием 1С:Управление производственным предприятием Абонемент ($m) Абонемент ($m)

Решение для интерактивной (нажал-отредактировал) отправки электронных писем и печатных форм через почтовый клиент (Thunderbird, Outlook) находящийся на локальном компьютере, из конфигурации 1С, развернутой под удаленным рабочим столом (RDP, remote-app). Подходит также для локального развертывания 1С. Представлен пример быстрой интеграции с конфигурациями "Управление торговлей 10.3", "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1", "Бухгалтерия предприятия 2.0".

1 стартмани

21.09.2018    38159    24    stvorl    1    

Оповещение по почте о документах

Документооборот и делопроизводство Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Рассылка писем со ссылками на документы, удовлетворяющие установленному отбору.

1 стартмани

14.02.2022    3771    3    victorree    3    

Групповое скачивание файлов из почты (скачивание вложений писем, скачивание файлов по ссылкам в тексте писем)

Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка выполняет групповое скачивание файлов из E-mail писем в каталог на клиентском компьютере. Обработка скачивает не только приложенные к письмам файлы, но и также ищет html-ссылки на файлы в текстах писем, и тоже скачивает их на клиентский компьютер

3 стартмани

29.01.2022    3602    11    1395969    9    

Email рассылка в формате HTML

Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка предназначена для массовой рассылки писем в формате HTML из 1С.

1 стартмани

19.01.2022    3705    1    DevilBit    8    

Автопрайс: Конструктор прайс-листов с автоматической рассылкой по шаблонам Промо

Прайсы Email рассылки Оптовая торговля Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 Оптовая торговля, дистрибуция, логистика Оптовая торговля, дистрибуция, логистика Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Гибкая и удобная система для формирования и автоматической рассылки прайс-листов. Быстрая рассылка - прайсы на 100+ тыс. строк уходят десяткам клиентов с индивидуальными настройками менее чем за 10 мин. Форматы:.XLS, .XLSX, .TXT /CSV(UTF-8/ANSI), .MXL, .HTML, .DOCX, .PDF, .ODS. Поддерживает картинки в прайсе. Создание макетов прайсов, рассылка по почте и FTP, архивация в ZIP, шаблоны, гибкая настройка и расписание, отчеты о рассылке.

10 стартмани

08.06.2016    34118    77    taurus__    5    

Фоновая отправка информации журнала регистрации из конфигураций на базе 1С:Библиотека стандартных подсистем

Журнал регистрации БСП (Библиотека стандартных подсистем) Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Внешняя обработка для фоновой отправки информации журнала регистрации по электронной почте из конфигураций на базе 1С:Библиотека стандартных подсистем

1 стартмани

25.10.2021    8264    10    mayz    2    

Конфигурация для партнеров "Инфостарт" для ведения публикаций, рассылки обновлений Промо

Email рассылки Управление услугами и сервисом СRM Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

(©ТопчийДЮ) Для упрощения жизни своей я разработал конфигурацию «База клиентов и публикаций», которая практически решает мои «проблемы» с рассылкой обновлений и учетом продаж на сайте «Инфостарт», с возможностью загрузки данных с сайта (авторского раздела) . Обновление от 18.06.2019, версия 1.5!

5 стартмани

28.09.2014    39878    56    hakerxp    20    

Групповая отправка писем о задолженности на почту e-mail в УТ 11, КА 2, ЕРП 2

Взаиморасчеты Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Комплексная автоматизация 2.х Бухгалтерский учет Бухгалтерский учет Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Обработка позволяет выполнить групповую отправку писем о задолженности в соответствии со сроком долга. Присутствует возможность отправки информации о задолженности, которая еще не наступила, но наступит через определенное время. За это отвечает галочка "Приближение оплаты" и "Срок напоминания для оплаты" на странице "Настройки". Разработано для Управление Торговлей 11, Комплексная автоматизация 2, ERP управление предприятием.

10 стартмани

09.06.2021    5054    10    user1527257    0    

Электронная почта - расширение для конфигурации "INFOSTART ERP community edition"

Email рассылки Infostart ERP community Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Расширение "Электронная почта" позволяет отправлять и принимать электронные письма (автоматически сортировать письма папкам c учетом пользовательской настройки).

5 стартмани

30.04.2021    5664    7    33lab    0    

Мастер рассылки e-mail 2.2 для управляемых форм Промо

Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Управление торговлей 11 Абонемент ($m) Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    52076    24    milkers    4    

Загрузка заказов из вложений электронной почты

Оптовая торговля Загрузка и выгрузка в Excel Обработка документов Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Управление торговлей 11 Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Автоматическая загрузка заказов из входящей электронной почты. Умеет загружать заказы из вложений формата XLS, CSV, HTML, а также из таблицы в теле письма. Умеет создавать документы “Заказ клиента “ или “Реализация товаров услуг”. Существенно облегчает работу менеджера, особенно при большом потоке заказов. В комментарии к заказу пишет о возникших проблемах. Номенклатура ищется по артикулу.

5 стартмани

07.04.2021    6219    21    wonderboy    10    

Рассылка счетов, актов и счетов-фактур для БП 3.0 Промо

Email рассылки Оптовая торговля Производство готовой продукции (работ, услуг) Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Еще одна рассылка, теперь для Бухгалтерии 3.0. Использует встроенные учетные записи и почтовые механизмы. Файлы для отправки формируются только из заданных внешних печатных форм, перед отправкой документы сохраняются в PDF.

1 стартмани

16.02.2014    36207    307    @Sonya    36    

Автоматическое формирование и отправка документов Акт сверки взаиморасчетов по расчетам с контрагентами

Взаиморасчеты Обработка документов Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия государственного учреждения Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Обработка предназначена для автоматического формирования документов «Акт сверки взаиморасчетов» с контрагентами, их распечатки и(или) отправки по электронной почте в виде вложений (*.pdf, *.xls) с установленными при необходимости факсимиле ответственных лиц и печати организации. Применяется и используется при потребности организации в большом количестве документов «Акт сверки взаиморасчетов». Обработка тестировалась на конфигурации: "Бухгалтерия гос. учреждения 2.0", релиз - 2.0.75.40.

3 стартмани

11.01.2021    6041    6    aderkatch    1    

Рассылка данных клиентам по документам "Поступление товаров и услуг" через СМС, Viber и E-Mail

Оптовая торговля Розничная торговля SMS рассылки Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Платформа 1C v8.2 Платформа 1C v8.2 1С:Управление торговлей 10 1С:Управление торговлей 10 1С:Управление производственным предприятием 1С:Управление производственным предприятием Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Когда пришёл товар на Склад/в Магазин, обработка сообщает на электронную почту, мобильный телефон, Viber, СМС клиента, что пришёл его товар по Заказу покупателя № …. от даты. Указывается Номенклатура, Количество, Ед. изм. И что товар можно забрать со склада.

10 стартмани

08.11.2020    6446    1    hachaturov    0    

Автоматическая рассылка Актов и Счетов контрагентам из Бухгалтерии

Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Решение для автоматической рассылки актов и счетов контрагентам с возможностью отслеживать историю рассылки, логи отправки и тд. Есть возможность настроить шаблоны HTML для писем, с использованием параметров. Возможность задавать контрагентам значения шаблонов по умолчанию.

1 стартмани

17.10.2020    7269    45    Segate    10    

Отправка писем на электронную почту типовой функцией 1С

Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Если вам необходимо отправить письмо на почту из внешней обработки, вам поможет эта статья.

1 стартмани

04.07.2020    44100    50    Andrei_Ivanov    15    

Групповая рассылка счетов по email для БП 2.0 Промо

Пакетная печать Обработка документов СRM Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Бухгалтерия 2.0 Россия Россия Абонемент ($m) Абонемент ($m)

Рассылка счетов по email для конфигурации Бухгалтерия Предприятия 2.0 - автоматическое создание необходимых доп. реквизитов и видов контактной информации. - возможность изменения и сохранения изменений в БД адресов электронной почты контрагентов непосредственно в обработке. - отметка отправленных счетов дополнительным реквизитом, который принадлежит только документу «Счет на оплату», а не по всем документам. - поддержка параметров в теме и тексте письма.

1 стартмани

09.06.2014    35524    77    spacc    4    

Рассылка расчетных листков 2.0 (с обходом спам-фильтра)

Зарплата Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Сложные периодические расчеты Сложные периодические расчеты 1С:Зарплата и Управление Персоналом 3.x 1С:Зарплата и Управление Персоналом 3.x Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Обработка производит рассылку расчетных листков сотрудников в формате PDF с возможностью архивирование и шифрования вложения. Важной особенностью обработки является возможность обходить ограничения на количество отправляемых писем в некий период (обход спам-фильтра). Это не хакерская фича, это реальная проблема, наблюдаемая при вполне легальных при массовых рассылках, даже на корпоративных серверах.

2 стартмани

26.05.2020    7930    36    saver77    14    

Автоматическая загрузка накладных от поставщиков из электронной почты (Розница 2.2)

Обработка документов Розничная торговля Логистика, склад и ТМЦ Email рассылки WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Данная обработка предназначена для получения файлов (*.xls;*.xlsx;*.ods;*.dbf) с почтового сервера вашей электронной почты и загрузки прочитанных данных в документы «Поступление товаров». Так же присутствует возможность распаковки архивов, если поставщик шлет вам в письме архивированные файлы (RAR; ZIP; 7Z). Наличие установленного MS Office и Open Office не требуется.

5 стартмани

18.05.2020    10465    10    StiVitS    9    

Автоматическое формирование и рассылка отчетов Промо

Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Подсистема позволяет хранить пользовательские настройки СКД, формировать отчеты по расписанию и отправлять по почте либо сохранять в каталог.

1 стартмани

27.01.2014    27780    126    Vo-Va    11    

Небольшой универсальный механизм рассылки документов

Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Рассылка документов, например, кадры оформили командировку - форма отправилась к расчетчикам. Бухгалтерия выписала реализацию - накладная в виде файла в PDF формате "улетела" по почте к кладовщику.

1 стартмани

13.05.2020    6643    7    zavsom    6    

Работа с сервисом Unisender. УТ 11

Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 11 1С:Управление торговлей 11 Россия Россия Абонемент ($m) Абонемент ($m)

Обработка для работы с сервисом Unisender. Реализована для УТ 11, но можно использовать для любой конфигурации, т.к. методы API реализованы в модуле обработки.

1 стартмани

29.04.2020    7685    12    pscorp    0    

Расширение - рассылка отчета Торг 29 электронной почтой по складам. Управление торговлей 11.4

Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 11 1С:Управление торговлей 11 Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Расширение производит рассылку отчета Торг 29 (добавлена колонка скидки) в формате XLSX по выбранному списку складов. Тестировалось на конфигурации "Управление торговлей 11.4.11.63", платформа "8.3.16.1224" режим совместимости Версия 8.3.12. 

1 стартмани

16.04.2020    7542    3    IVC_goal    0    

Рассылка электронных писем Промо

Универсальные обработки Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

У меня появилась необходимость совершить массовую рассылку электронной почты. Когда я начал заниматься этим вопросом, то столкнулся с некоторыми трудностями и не смог найти действительно ПРОСТУЮ и УДОБНУЮ обработку для осуществления рассылки. Итогом стала эта обработка:)

1 стартмани

09.01.2014    23987    79    GATTUSO    10    

История отправки электронной почты по документам. Расширение. БП 3.0

Документооборот и делопроизводство Email рассылки Журнал регистрации Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Расширение для конфигурации Бухгалтерия предприятия, редакция 3.0. Реализует возможность хранить историю отправки электронных писем для документов "Реализация (акты, накладные)" и "Счета покупателям". Расширение может быть расширено и для других документов 1С.

3 стартмани

31.03.2020    9711    28    Diks_Soft    2    

Отправка электронных писем с помощью Exchange Web Services (EWS) и авторизацией Active Directory (AD)

Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

В данной публикации показан пример отправки электронного письма из 1С с использованием Exchange Web Services (EWS) и авторизацией Active Directory (AD).

1 стартмани

30.01.2020    12080    17    Isonic    6    

Печать и подпись на счете. Авто отправка по электронной почте для Бухгалтерии и УТ Промо

Печатные формы Оптовая торговля Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Управление торговлей 10 Россия Россия Абонемент ($m) Абонемент ($m)

Подключаемая внешняя обработка позволяет формировать и отправлять счет с цветными печатью и подписями на электронную почту клиента

1 стартмани

10.04.2012    58390    1452    PiterPen    92    

Создание писем в Outlook из 1С с подписью и вложением (Excel-файл с несколькими листами)

Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

Программное создание писем в Outlook из 1С с подписью и вложением (сгенерировав Excel-файл с листами из нескольких ТабличныхДокументов) используя COM-объект. Как избавиться от рутинного создания однотипных писем.

1 стартмани

22.10.2019    13958    26    Merkalov    5    

Автоматическая рассылка произвольных отчетов по электронной почте (обычные формы)

Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Очень часто возникает необходимость на регулярной основе получать отчеты из 1С, но не всегда есть возможность зайти в программу. Например, директору удобно каждое утро анализировать состояние основных показателей организации за чашечкой кофе, у себя дома, открывая отчеты в почте со смартфона или планшета. В типовых конфигурациях на управляемых формах этот механизм достаточно хорошо реализован и имеет очень гибкую настройку. К сожалению, в конфигурациях на обычных формах приходится довольствоваться лишь рапортом руководителю, который предоставляет достаточно скудные возможности. Поэтому был реализован ниже следующий функционал.

3 стартмани

06.08.2019    19985    91    Nicholas    68    

[Расширение] Доработка рассылки отчетов, отчет в теле письма

Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 Абонемент ($m) Абонемент ($m)

Я очень люблю механизм рассылки отчетов из БСП - достаточно гибкий, универсальный. Активно пользуюсь им для того, чтобы получать оповещения из программы о том, что "что-то идёт не так"... Однако, и в нем есть что улучшить.

1 стартмани

05.07.2019    16078    35    ardn    15    

Редактор шаблона html-письма

Email рассылки Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Редактор шаблона HTML-письма Обработка позволяет легко составить шаблон письма рассылки / оповещения. Указать параметры шаблона и формулы вычисления. Для того чтобы встроить обработку необходимо: 1. Вставить обработку в конфигурацию 2. Вывести ссылку на редактор в шаблоне сообщений или в виде оповещения 3. Получить измененные параметры в редакторе: текст HTML, таблица параметров, пример письма 4. В процедуре формирования текста письма указать процедуру модуля обработки СформироватьТекстHTML Использование редактора на примере письма от кофейного интернет-магазина.

1 стартмани

03.07.2019    13313    19    ring_andrey    0