Выгрузка из БП 3.0 в УТ 11.4

Публикация № 1260131 04.07.20

Интеграция и обмен данными - Файловый обмен (TXT, XML, DBF), FTP

Выгрузка из БП3 в УТ11 правила обмена задваиваются договор задвоение договоров

Данная публикация была создана для демонстрации решения по переносу данных из имеющейся БП 3.0 в новую УТ 11.4. Сложность заключалась в том, что некоторые документы (Поступления и Реализации) не переносятся в типовом варианте обмена (именно из Бухгалтерии в Торговлю, а не наоборот). Второй нюанс - это перенос договоров. Подробно о проблеме можно почитать здесь https://forum.infostart.ru/forum9/topic146589/ Однако, конкретного решения для своей задачи из указанной публикации найдено не было, но стало понятно, что правила формирования договоров указаны верно, и причина задвоения договоров при обмене таилась в другом. Но обо всём потихоньку...

Итак, имеется БП, в которой велся учет несколько лет.

На предприятии приняли решение, что удобнее было бы вести учет в УТ и периодически делать перенос данных в БП. 

То есть - задача перенести накопленные данные из БП в УТ, а затем настроить одностороннюю синхронизацию документов из УТ в БП.

Первое что делаем - это бэкап бухгалтерской базы с данными, и все операции будем производить на копии базы.

1. Настраиваем типовую двустороннюю синхронизацию между БП и УТ. На просторах инета есть множество инструкций, вот ссылка на одну из них https://scloud.ru/techinfo_1c_online/sinkhronizatsiya-i-obmen-dannymi/nastroyka-sinkhronizatsii-mezhdu-ut-11-i-bp-3-0/

Добавлю лишь, что в настройках обеих баз сначала указываем "отправлять всю" нормативно-справочную информацию и "не отправлять" документы. На первом этапе необходимо отправить только нормативно-справочную информацию, так как после загрузки данных в УТ, необходимо сделать настройки ведения учета, такие как учетная политика и параметры ведения договоров. Позже настройку обмена документами поменяем на "отправлять все документы" с некоторой даты и зарегистрируем документы к обмену в составе обмена.

Итак, данные нормативно-справочной информации загружены в УТ. Настаиваем учетную политику.

Теперь подробнее о настройках ведения учета по договорам... По умолчанию в складских документах в УТ отсутствует поле "договор" (в поступлениях и реализациях). И если оставить ведение учета как есть, то после заведения новых документов и последующего переноса их в Бухгалтерию, для каждого контрагента будет создан новый договор "Основной договор", что категорически не приветствуется бухгалтерами )
Поэтому в УТ делаем парочку настроек: в разделе "НСИ и администрирование" - Настройка НСИ и разделов - CRM и маркетинг - "Настройки CRM" устанавливаем флаг "независимо вести партнеров и контрагентов", далее в разделе "НСИ и администрирование" - Настройка НСИ и разделов - "Закупки" - "соглашения и договоры с поставщиками" устанавливаем флаг "договоры с поставщиками", а также в пункте "Продажи" - "Оптовые продажи" раздела "НСИ и администрирование" устанавливаем флаг "договоры с клиентами".
После данных настроек в документах поступления и реализаций появится поле "договор", а так как все договоры были перенесены из бухгалтерии, то при заведении новых документов, а также при первоначально выгрузке документов из БП в УТ договор будет заполняться имеющимися данными.

На втором этапе типового обмена, перенесем документы из БП в УТ. Для этого в базе БП в настройках обмена необходимо поставить флаг "отправлять все документы с ...", указав начальную дату выгрузки, и в составе отправляемых данных регистрируем все документы и регистр сведений "Статусы документов". Выполняем обмен. Типовой обмен настроен, теперь в БП отключаем настройку "отправлять все документы с ...", устанавливаем "не отправлять".

2. Для нетипового переноса документов Поступления и Реализации из БП 3.0 в УТ 11.4 используем обработку "Универсальный обмен данными XML" и правила обмена, которые я прикладываю в данной публикации, предназначаются для ознакомления и доработки для нужд конкретной задачи.

Правила переносят документы: "Поступление товаров","Поступление услуг", "Поступление оборудования" и "Реализации". Так как все справочники были перенесены из БП в УТ типовым обменом, то правила переноса справочников настроены таким образом, что новые элементы не создаются.

После переноса документов, необходимо снять регистрацию этих документов в составе типового обмена в УТ, и установить дату начала выгрузки документов, начиная со следующего дня перенесенных данных.

Далее, просто настаиваете расписание типового обмена.

 

P.S. Хотелось бы отметить, что обмен настраивался между базами БП 3.0.78.64 и УТ 11.4.12.61.

При типовом обмене возникла ошибка отсутствия поля "Характеристика" в справочнике "Штрихкоды номенклатуры". Решается это установкой расширения в базе УТ. Создайте новое расширение (инструкцию можно найти на просторах инета), добавьте в него общий модуль "МенеджерОбменаЧерезУниверсальныйФормат" и в модуле переинициализируйте процедуру ПКО_Справочник_ШтрихкодыНоменклатуры_Получение_ПередЗаписьюПолученныхДанных.

&Вместо("ПКО_Справочник_ШтрихкодыНоменклатуры_Получение_ПередЗаписьюПолученныхДанных")
Процедура РасшМОБ_ПКО_Справочник_ШтрихкодыНоменклатуры_Получение_ПередЗаписьюПолученныхДанных(ПолученныеДанные, ДанныеИБ, КонвертацияСвойств, КомпонентыОбмена)
	Справочник_Номенклатура_Получение     = ОбменДаннымиXDTOСервер.ПКОПоИмени(КомпонентыОбмена,"Справочник_Номенклатура_Получение");
	Справочник_ХарактеристикиНоменклатуры = ОбменДаннымиXDTOСервер.ПКОПоИмени(КомпонентыОбмена,"Справочник_ХарактеристикиНоменклатуры");
	Справочник_Упаковки                   = ОбменДаннымиXDTOСервер.ПКОПоИмени(КомпонентыОбмена,"Справочник_Упаковки");
	
	ПолученныеДанные.Отбор.Штрихкод.Значение      = ПолученныеДанные.ДополнительныеСвойства.Штрихкод;
	ПолученныеДанные.Отбор.Штрихкод.Использование = Истина;
	
	// Добавление записей в набор записей.		
	Если ПолученныеДанные.ДополнительныеСвойства.Записи <> Неопределено Тогда
		
		Для Каждого Строка Из ПолученныеДанные.ДополнительныеСвойства.Записи Цикл
			
			СтрокаЗаписи          = ПолученныеДанные.Добавить();
			СтрокаЗаписи.Штрихкод = ПолученныеДанные.ДополнительныеСвойства.Штрихкод;
			
			СтрокаЗаписи.Номенклатура = ОбменДаннымиXDTOСервер.СтруктураОбъектаXDTOВДанныеИБ(КомпонентыОбмена, 
				Строка.Номенклатура, 
				Справочник_Номенклатура_Получение, 
				"ПолучитьСсылку").Ссылка;
				
			
			//Если ЗначениеЗаполнено(Строка.Характеристика)
			//	И ПолучитьФункциональнуюОпцию("ИспользоватьХарактеристикиНоменклатуры") Тогда
			//	СтрокаЗаписи.Характеристика = ОбменДаннымиXDTOСервер.СтруктураОбъектаXDTOВДанныеИБ(КомпонентыОбмена, 
			//		Строка.Характеристика, 
			//		Справочник_ХарактеристикиНоменклатуры, 
			//		"ПолучитьСсылку").Ссылка;
			//КонецЕсли;
			
			//Если ЗначениеЗаполнено(Строка.Упаковка)
			//	И ПолучитьФункциональнуюОпцию("ИспользоватьУпаковкиНоменклатуры") Тогда
			//	СтрокаЗаписи.Упаковка = ОбменДаннымиXDTOСервер.СтруктураОбъектаXDTOВДанныеИБ(КомпонентыОбмена, 
			//		Строка.Упаковка, 
			//		Справочник_Упаковки, 
			//		"ПолучитьСсылку").Ссылка;
			//КонецЕсли;
			
			
		КонецЦикла;
		
	КонецЕсли;
КонецПроцедуры

На всякий случай Расширение прикладываю к публикации.

Ещё отмечу, что, для тех кто НЕ хочет вести в УТ договоры, можно обойтись без вышеупомянутых настроек, использовав настройки по умолчанию, но для того, чтобы договоры не задваивались необходимо в расширении к УТ переинициализировать код, который добавляет данные о договоре в выгрузку. Однако, отмечу, что если у контрагента несколько договоров, и отсутствует договор по умолчанию, то в документах поле "договор" заполнен не будет, и документ не будет проведен.

&Вместо("ДоговорИнструкцияКонвертацииПоДаннымВзаиморасчетов")
Функция РасшМОБ_ДоговорИнструкцияКонвертацииПоДаннымВзаиморасчетов(ПараметрыПоУмолчанию, КомпонентыОбмена, ОбъектРасчетов = Неопределено, ДанныеИБ = Неопределено)
	// Функция формирует и возвращает инструкция для выгрузки договора
	// по полученным параметрам и настройкам узла плана обмена.
	//
	// Функция, по сформированной инструкции, выполняет принудительную выгрузку договора в файл обмена.
	//
	// Перед вызовом этой функции выполняется проверка наличия договора в выгружаемом документе
	// или в объекте взаиморасчетов, если договор не найден, то выполняется вызов этой функции.
	
	СтруктураДанныеДоговора = Новый Структура(ДоговорФиксированнаяСтруктураКлючей());
	ДоговорЗаполнен = Ложь;
	СтруктураДанныеДоговора.ВидДоговора = ПараметрыПоУмолчанию.ВидДоговора;
	
	Если ЗначениеЗаполнено(ОбъектРасчетов)
		И ТипЗнч(ОбъектРасчетов) = Тип("СправочникСсылка.ДоговорыМеждуОрганизациями") Тогда
		
		ЗаполнитьЗначенияСвойств(СтруктураДанныеДоговора, ПараметрыПоУмолчанию,
			"Организация, Контрагент");
		
		РеквизитыИнтеркампани = ОбщегоНазначения.ЗначенияРеквизитовОбъекта(ОбъектРасчетов,
			"Дата, Номер, Наименование, ВалютаВзаиморасчетов, ПорядокОплаты");
		ЗаполнитьЗначенияСвойств(СтруктураДанныеДоговора, РеквизитыИнтеркампани);
	
		РасчетыУЕ = РеквизитыИнтеркампани.ПорядокОплаты = Перечисления.ПорядокОплатыПоСоглашениям.РасчетыВВалютеОплатаВРублях;	
		СтруктураДанныеДоговора.РасчетыВУсловныхЕдиницах = РасчетыУЕ;
		
		ДоговорЗаполнен = Истина;
			
	ИначеЕсли ЗначениеЗаполнено(ОбъектРасчетов)
		И ДанныеИБ <> Неопределено
		И Не ДопАналитикаПоДоговорам(КомпонентыОбмена).ДоговорВДоговор Тогда
		Если ТипЗнч(ОбъектРасчетов) = Тип("Структура") Тогда
			// Если в документе соглашение и заказ - 2 разных реквизита, то значения этих реквизитов передаются в структуре:
			// "Заказ" - Ссылка на Заказ клиента (поставщику).
			// "Соглашение" - Ссылка на Соглашение с клиентом (поставщиком).
			// "Сделки" - Ссылка на Сделку с клиентом.
			ЗаказСсылка      = Неопределено;
			СоглашениеСсылка = Неопределено;
			СделкаСсылка     = Неопределено;
			
			ЭтоЗаказ      = ОбъектРасчетов.Свойство("Заказ", ЗаказСсылка) И ЗначениеЗаполнено(ЗаказСсылка);
			ЭтоСоглашение = ОбъектРасчетов.Свойство("Соглашение", СоглашениеСсылка) И ЗначениеЗаполнено(СоглашениеСсылка);
			ЭтоСделка     = ОбъектРасчетов.Свойство("Сделка", СделкаСсылка) И ЗначениеЗаполнено(СделкаСсылка);
		Иначе
			// Подразумевается, что реквизит выгружаемого документа "Заказ" - имеет составной тип
			// и может быть Заказом, Соглашением, Сделкой или другим видом документа/справочника,
			// помимо этого у объекта, указанного в этом реквизите могут быть реквизиты "Соглашение" и/или "Сделка".
			ЗаказСсылка      = ОбъектРасчетов;
			СоглашениеСсылка = ОбъектРасчетов;
			СделкаСсылка     = ОбъектРасчетов;
			
			ЭтоЗаказ = ТипЗнч(ОбъектРасчетов) = Тип("ДокументСсылка.ЗаказКлиента")
				Или ТипЗнч(ОбъектРасчетов) = Тип("ДокументСсылка.ЗаказПоставщику");
			
			РеквизитыЗаказа = Новый Массив;
			Если ОбъектРасчетов.Метаданные().Реквизиты.Найти("Соглашение") <> Неопределено Тогда
				РеквизитыЗаказа.Добавить("Соглашение");
			КонецЕсли;
			Если ОбъектРасчетов.Метаданные().Реквизиты.Найти("Сделка") <> Неопределено Тогда
				РеквизитыЗаказа.Добавить("Сделка");
			КонецЕсли;
			
			Если РеквизитыЗаказа.Количество() > 0 Тогда
				СтруктураЗаказа = ОбщегоНазначения.ЗначенияРеквизитовОбъекта(ОбъектРасчетов, РеквизитыЗаказа);
			Иначе
				СтруктураЗаказа = Новый Структура;
			КонецЕсли;
			
			ЭтоСоглашение = ТипЗнч(ОбъектРасчетов) = Тип("СправочникСсылка.СоглашенияСКлиентами")
				Или ТипЗнч(ОбъектРасчетов) = Тип("СправочникСсылка.СоглашенияСПоставщиками")
				Или (СтруктураЗаказа.Свойство("Соглашение", СоглашениеСсылка) И ЗначениеЗаполнено(СоглашениеСсылка));
				
			ЭтоСделка = ТипЗнч(ОбъектРасчетов) = Тип("СправочникСсылка.СделкиСКлиентами")
				Или (СтруктураЗаказа.Свойство("Сделка", СделкаСсылка) И ЗначениеЗаполнено(СделкаСсылка));
		КонецЕсли;
			
		Если ЭтоЗаказ Или ЭтоСоглашение Или ЭтоСделка Тогда
			Если ЭтоЗаказ И КомпонентыОбмена.ПараметрыКонвертации.НастройкиДопАналитикиПоДоговорам.ЗаказВДоговор Тогда
				
				Запрос = Новый Запрос;
				Запрос.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
				
				Запрос.УстановитьПараметр("Ссылка", ЗаказСсылка);
				
				Если ТипЗнч(ЗаказСсылка) = Тип("ДокументСсылка.ЗаказКлиента") Тогда
					Запрос.Текст = 
					"ВЫБРАТЬ
					|	ЗаказКлиента.Ссылка КАК Ссылка,
					|	ЗаказКлиента.Контрагент КАК Контрагент,
					|	ЗаказКлиента.Организация КАК Организация,
					|	ЗаказКлиента.Дата КАК Дата,
					|	ЗаказКлиента.Номер КАК Номер,
					|	ЗаказКлиента.Валюта КАК Валюта,
					|	ЗаказКлиента.Представление КАК Представление,
					|	ЗаказКлиента.ПорядокОплаты = ЗНАЧЕНИЕ(Перечисление.ПорядокОплатыПоСоглашениям.РасчетыВВалютеОплатаВРублях) КАК РасчетыВУсловныхЕдиницах
					|ПОМЕСТИТЬ ВТ_Документ
					|ИЗ
					|	Документ.ЗаказКлиента КАК ЗаказКлиента
					|ГДЕ
					|	ЗаказКлиента.Ссылка = &Ссылка";
					Запрос.Выполнить();
				ИначеЕсли ТипЗнч(ЗаказСсылка) = Тип("ДокументСсылка.ЗаявкаНаВозвратТоваровОтКлиента") Тогда
					Запрос.Текст = 
					"ВЫБРАТЬ
					|	ЗаявкаНаВозвратТоваровОтКлиента.Ссылка КАК Ссылка,
					|	ЗаявкаНаВозвратТоваровОтКлиента.Контрагент КАК Контрагент,
					|	ЗаявкаНаВозвратТоваровОтКлиента.Организация КАК Организация,
					|	ЗаявкаНаВозвратТоваровОтКлиента.Дата КАК Дата,
					|	ЗаявкаНаВозвратТоваровОтКлиента.Номер КАК Номер,
					|	ЗаявкаНаВозвратТоваровОтКлиента.Валюта КАК Валюта,
					|	ЗаявкаНаВозвратТоваровОтКлиента.Представление КАК Представление,
					|	ЗаявкаНаВозвратТоваровОтКлиента.ПорядокОплаты = ЗНАЧЕНИЕ(Перечисление.ПорядокОплатыПоСоглашениям.РасчетыВВалютеОплатаВРублях) КАК РасчетыВУсловныхЕдиницах
					|ПОМЕСТИТЬ ВТ_Документ
					|ИЗ
					|	Документ.ЗаявкаНаВозвратТоваровОтКлиента КАК ЗаявкаНаВозвратТоваровОтКлиента
					|ГДЕ
					|	ЗаявкаНаВозвратТоваровОтКлиента.Ссылка = &Ссылка";
					Запрос.Выполнить();
				ИначеЕсли ТипЗнч(ЗаказСсылка) = Тип("ДокументСсылка.ЗаказПоставщику") Тогда
					Запрос.Текст = 
					"ВЫБРАТЬ
					|	ЗаказПоставщику.Ссылка КАК Ссылка,
					|	ЗаказПоставщику.Контрагент КАК Контрагент,
					|	ЗаказПоставщику.Организация КАК Организация,
					|	ЗаказПоставщику.Дата КАК Дата,
					|	ЗаказПоставщику.Номер КАК Номер,
					|	ЗаказПоставщику.Валюта КАК Валюта,
					|	ЗаказПоставщику.Представление КАК Представление,
					|	ЗаказПоставщику.ПорядокОплаты = ЗНАЧЕНИЕ(Перечисление.ПорядокОплатыПоСоглашениям.РасчетыВВалютеОплатаВРублях) КАК РасчетыВУсловныхЕдиницах
					|ПОМЕСТИТЬ ВТ_Документ
					|ИЗ
					|	Документ.ЗаказПоставщику КАК ЗаказПоставщику
					|ГДЕ
					|	ЗаказПоставщику.Ссылка = &Ссылка";
					Запрос.Выполнить();
				КонецЕсли;
				
				Если Запрос.МенеджерВременныхТаблиц.Таблицы.Количество() > 0 Тогда
					
					Запрос.Текст = 
					"ВЫБРАТЬ
					|	ВТ_Документ.Ссылка КАК Ссылка,
					|	ВТ_Документ.Контрагент КАК Контрагент,
					|	ВТ_Документ.Организация КАК Организация,
					|	ВТ_Документ.Дата КАК Дата,
					|	ВТ_Документ.Номер КАК Номер,
					|	ВТ_Документ.Валюта КАК ВалютаВзаиморасчетов,
					|	ВТ_Документ.Представление КАК Наименование,
					|	ВТ_Документ.РасчетыВУсловныхЕдиницах КАК РасчетыВУсловныхЕдиницах,
					|	КурсыВалютСрезПоследних.Курс КАК КурсВзаиморасчетов,
					|	КурсыВалютСрезПоследних.Кратность КАК КратностьВзаиморасчетов
					|ИЗ
					|	ВТ_Документ КАК ВТ_Документ
					|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.КурсыВалют.СрезПоследних(&ДатаДок, ) КАК КурсыВалютСрезПоследних
					|		ПО ВТ_Документ.Валюта = КурсыВалютСрезПоследних.Валюта";
					Запрос.УстановитьПараметр("ДатаДок", ДанныеИБ.Дата);
					
					Выборка = Запрос.Выполнить().Выбрать();
					Если Выборка.Следующий() Тогда
						ЗаполнитьЗначенияСвойств(СтруктураДанныеДоговора, Выборка);
						СтруктураДанныеДоговора.Наименование = ОбщегоНазначенияУТ.ПолучитьПредставлениеДокумента(ЗаказСсылка, Выборка.Номер, Выборка.Дата);
						ДоговорЗаполнен = Истина;
					КонецЕсли;
					
				КонецЕсли;
			КонецЕсли;
			
			Если ЭтоСоглашение И ДопАналитикаПоДоговорам(КомпонентыОбмена).СоглашениеВДоговор Тогда
				
				Запрос = Новый Запрос;
				Запрос.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
				
				Запрос.УстановитьПараметр("Ссылка", СоглашениеСсылка);
				
				Если ТипЗнч(СоглашениеСсылка) = Тип("СправочникСсылка.СоглашенияСКлиентами") Тогда
					Запрос.Текст = 
					"ВЫБРАТЬ
					|	СоглашенияСКлиентами.Ссылка КАК Ссылка,
					|	СоглашенияСКлиентами.Контрагент КАК Контрагент,
					|	СоглашенияСКлиентами.Организация КАК Организация,
					|	СоглашенияСКлиентами.Дата КАК Дата,
					|	СоглашенияСКлиентами.Номер КАК Номер,
					|	СоглашенияСКлиентами.Валюта КАК ВалютаВзаиморасчетов,
					|	СоглашенияСКлиентами.Наименование КАК Наименование,
					|	СоглашенияСКлиентами.Типовое КАК Типовое,
					|	СоглашенияСКлиентами.ПорядокОплаты = ЗНАЧЕНИЕ(Перечисление.ПорядокОплатыПоСоглашениям.РасчетыВВалютеОплатаВРублях) КАК РасчетыВУсловныхЕдиницах
					|ПОМЕСТИТЬ ВТ_Соглашение
					|ИЗ
					|	Справочник.СоглашенияСКлиентами КАК СоглашенияСКлиентами
					|ГДЕ
					|	СоглашенияСКлиентами.Ссылка = &Ссылка";
					Запрос.Выполнить();
				ИначеЕсли ТипЗнч(СоглашениеСсылка) = Тип("СправочникСсылка.СоглашенияСПоставщиками") Тогда
					Запрос.Текст = 
					"ВЫБРАТЬ
					|	СоглашенияСПоставщиками.Ссылка КАК Ссылка,
					|	СоглашенияСПоставщиками.Контрагент КАК Контрагент,
					|	СоглашенияСПоставщиками.Организация КАК Организация,
					|	СоглашенияСПоставщиками.Дата КАК Дата,
					|	СоглашенияСПоставщиками.Номер КАК Номер,
					|	СоглашенияСПоставщиками.Валюта КАК ВалютаВзаиморасчетов,
					|	СоглашенияСПоставщиками.Наименование КАК Наименование,
					|	ЛОЖЬ КАК Типовое,
					|	СоглашенияСПоставщиками.ПорядокОплаты = ЗНАЧЕНИЕ(Перечисление.ПорядокОплатыПоСоглашениям.РасчетыВВалютеОплатаВРублях) КАК РасчетыВУсловныхЕдиницах
					|ПОМЕСТИТЬ ВТ_Соглашение
					|ИЗ
					|	Справочник.СоглашенияСПоставщиками КАК СоглашенияСПоставщиками
					|ГДЕ
					|	СоглашенияСПоставщиками.Ссылка = &Ссылка";
					Запрос.Выполнить();
				КонецЕсли;
				
				Если Запрос.МенеджерВременныхТаблиц.Таблицы.Количество() > 0 Тогда
					
					Запрос.Текст = 
					"ВЫБРАТЬ
					|	СоглашенияСКлиентами.Ссылка КАК Ссылка,
					|	СоглашенияСКлиентами.Контрагент КАК Контрагент,
					|	СоглашенияСКлиентами.Организация КАК Организация,
					|	СоглашенияСКлиентами.Дата КАК Дата,
					|	СоглашенияСКлиентами.Номер КАК Номер,
					|	СоглашенияСКлиентами.ВалютаВзаиморасчетов КАК ВалютаВзаиморасчетов,
					|	СоглашенияСКлиентами.Наименование КАК Наименование,
					|	СоглашенияСКлиентами.РасчетыВУсловныхЕдиницах КАК РасчетыВУсловныхЕдиницах,
					|	СоглашенияСКлиентами.Типовое КАК Типовое,
					|	КурсыВалютСрезПоследних.Курс КАК КурсВзаиморасчетов,
					|	КурсыВалютСрезПоследних.Кратность КАК КратностьВзаиморасчетов
					|ИЗ
					|	ВТ_Соглашение КАК СоглашенияСКлиентами
					|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.КурсыВалют.СрезПоследних(&ДатаДок, ) КАК КурсыВалютСрезПоследних
					|		ПО СоглашенияСКлиентами.ВалютаВзаиморасчетов = КурсыВалютСрезПоследних.Валюта";
					Запрос.УстановитьПараметр("ДатаДок", ДанныеИБ.Дата);
					
					Выборка = Запрос.Выполнить().Выбрать();
					Если Выборка.Следующий() Тогда
						ЗаполнитьЗначенияСвойств(СтруктураДанныеДоговора, Выборка);
						
						Если Не ЗначениеЗаполнено(СтруктураДанныеДоговора.Контрагент) Тогда
							Если ЕстьРеквизитДанныхИБ(ДанныеИБ, "Контрагент") Тогда
								СтруктураДанныеДоговора.Контрагент = ДанныеИБ.Контрагент;
							Иначе
								СтруктураДанныеДоговора.Контрагент = ПараметрыПоУмолчанию.Контрагент;
							КонецЕсли;
						КонецЕсли;
						
						Если Не ЗначениеЗаполнено(СтруктураДанныеДоговора.Организация) Тогда
							Если ЗначениеЗаполнено(ДанныеИБ.Организация) Тогда
								СтруктураДанныеДоговора.Организация = ДанныеИБ.Организация;
							Иначе
								СтруктураДанныеДоговора.Организация = ПараметрыПоУмолчанию.Организация;
							КонецЕсли;
						КонецЕсли;
						
						Если ТипЗнч(СоглашениеСсылка) = Тип("СправочникСсылка.СоглашенияСКлиентами") Тогда
							Наименование = ?(Выборка.Типовое, НСтр("ru = 'Типовое'"), НСтр("ru = 'Индивидуальное'")) + "; ";
						Иначе
						    Наименование = "";
						КонецЕсли;
						
						Наименование = Наименование + Выборка.Наименование
							+ " " + ?(ЗначениеЗаполнено(Выборка.Номер), "№" + Выборка.Номер, "")
							+ " " + ?(ЗначениеЗаполнено(Выборка.Дата), НСтр("ru = 'от'") + " " + Формат(Выборка.Дата, "ДЛФ=D"), "");
							
						СтруктураДанныеДоговора.Наименование = СокрЛП(Наименование);
						ДоговорЗаполнен = Истина;
					КонецЕсли;
					
				КонецЕсли;
				
			КонецЕсли;
			
			Если ЭтоСделка И ДопАналитикаПоДоговорам(КомпонентыОбмена).СделкаВДоговор Тогда
				Запрос = Новый Запрос(
				"ВЫБРАТЬ
				|	СделкиСКлиентами.Ссылка,
				|	СделкиСКлиентами.Код КАК Номер,
				|	"""" КАК Контрагент,
				|	"""" КАК Организация,
				|	СделкиСКлиентами.ДатаНачала КАК Дата,
				|	КурсыВалютСрезПоследних.Валюта КАК ВалютаВзаиморасчетов,
				|	СделкиСКлиентами.Наименование КАК Наименование,
				|	КурсыВалютСрезПоследних.Курс КАК КурсВзаиморасчетов,
				|	КурсыВалютСрезПоследних.Кратность КАК КратностьВзаиморасчетов
				|ИЗ
				|	Справочник.СделкиСКлиентами КАК СделкиСКлиентами,
				|	РегистрСведений.КурсыВалют.СрезПоследних(&ДатаДок, Валюта = &Валюта) КАК КурсыВалютСрезПоследних
				|ГДЕ
				|	СделкиСКлиентами.Ссылка = &Ссылка");
				Запрос.УстановитьПараметр("Ссылка",  СделкаСсылка);
				Запрос.УстановитьПараметр("ДатаДок", ДанныеИБ.Дата);
				Запрос.УстановитьПараметр("Валюта",  ПараметрыПоУмолчанию.ВалютаВзаиморасчетов);
				
				Выборка = Запрос.Выполнить().Выбрать();
				Если Выборка.Следующий() Тогда
					ЗаполнитьЗначенияСвойств(СтруктураДанныеДоговора, Выборка);
					СтруктураДанныеДоговора.Организация = ДанныеИБ.Организация;
					Если ЕстьРеквизитДанныхИБ(ДанныеИБ, "Контрагент") Тогда
						СтруктураДанныеДоговора.Контрагент = ДанныеИБ.Контрагент;
					Иначе
						СтруктураДанныеДоговора.Контрагент = ПараметрыПоУмолчанию.Контрагент;
					КонецЕсли;
					Если ПараметрыПоУмолчанию.Свойство("РасчетыВУсловныхЕдиницах") Тогда
						СтруктураДанныеДоговора.РасчетыВУсловныхЕдиницах = ПараметрыПоУмолчанию.РасчетыВУсловныхЕдиницах;
					КонецЕсли;
					СтруктураДанныеДоговора.Наименование = ?(ЗначениеЗаполнено(СделкаСсылка.Метаданные().ПредставлениеОбъекта),
						СделкаСсылка.Метаданные().ПредставлениеОбъекта, СделкаСсылка.Метаданные().Синоним)
							+ ?(ЗначениеЗаполнено(Выборка.Номер), " " + Выборка.Номер, "");
					ДоговорЗаполнен = Истина;
				КонецЕсли;
			КонецЕсли;
		КонецЕсли;
	КонецЕсли;
	
	//Если Не ДоговорЗаполнен Тогда
	//	ЗаполнитьЗначенияСвойств(СтруктураДанныеДоговора, ПараметрыПоУмолчанию, , "Дата, Номер");
	//	СтруктураДанныеДоговора.Наименование = НСтр("ru = 'Основной договор'");
	//ИначеЕсли ВерсияФорматаЧислом(КомпонентыОбмена.ВерсияФорматаОбмена) > ВерсияФорматаЧислом("1.3") Тогда
	//	СтруктураДанныеДоговора.ВнешнийИдентификатор = СтруктураДанныеДоговора.Наименование;
	//КонецЕсли;
	
	ДопРеквизиты = Новый ТаблицаЗначений;
	ДопРеквизиты.Колонки.Добавить("Свойство");
	ДопРеквизиты.Колонки.Добавить("ЗначениеСвойства");
	
	СтрокаДопРеквизитов = ДопРеквизиты.Добавить();
	СтрокаДопРеквизитов.Свойство = Новый Структура("Наименование", "ВиртуальныйДоговор");
	СтрокаДопРеквизитов.ЗначениеСвойства = "ВиртуальныйДоговор";
	
	СтруктураДанныеДоговора.Вставить("ДополнительныеРеквизиты", ДопРеквизиты);
	
	Договор = Новый Структура("Значение, ИмяПКО", СтруктураДанныеДоговора, "Справочник_ДоговорыКонтрагентов_ИзСтруктуры");
	
	ПравилоОбработки = КомпонентыОбмена.ПравилаОбработкиДанных.Найти("Справочник_ДоговорыКонтрагентов_Отправка", "Имя");
	Если Не ПравилоОбработки = Неопределено Тогда
		ОбменДаннымиXDTOСервер.ВыгрузкаОбъектаВыборки(КомпонентыОбмена, СтруктураДанныеДоговора, ПравилоОбработки);
	КонецЕсли;
	
	Возврат Договор;
КонецФункции

Также потребуется добавить расширение в бухгалтерии с общим модулем "МенеджерОбменаЧерезУниверсальныйФормат13" и переинициализацией процедуры:

&Вместо("ОсновнойДоговорКонтрагента")
Функция РасшМОБ_ОсновнойДоговорКонтрагента(Объект, Организация, Контрагент, ВалютаВзаиморасчетов)

	//Если НЕ ЗначениеЗаполнено(Организация)
	//	ИЛИ НЕ ЗначениеЗаполнено(Контрагент) Тогда
	//	// Не заполнены ключевые свойства
	//	// В этом случае ничего не делаем.
	//	Возврат Неопределено;
	//КонецЕсли;
	//
	//Если ТипЗнч(Контрагент) <> Тип("СправочникСсылка.Контрагенты") Тогда
	//	// Передан не контрагент, значит возвращать ничего не нужно.
	//	Возврат Неопределено;
	//КонецЕсли;
	//
	//ГоловнаяОрганизация = ОбщегоНазначенияБПВызовСервераПовтИсп.ГоловнаяОрганизация(Организация);
	
	// Найдем договор по умолчанию для данного вида договора
	ДополнительныеПараметры = Новый Структура();
	Если ЗначениеЗаполнено(ВалютаВзаиморасчетов) Тогда
		ДополнительныеПараметры.Вставить("ВалютаВзаиморасчетов", Новый Структура("ЗначениеОтбора", ВалютаВзаиморасчетов));
	КонецЕсли;
	
	ВидДоговора = РаботаСДоговорамиКонтрагентовБП.ВидДоговораПоОбъекту(Объект);
	СписокВидовДоговоров = Новый СписокЗначений();
	СписокВидовДоговоров.Добавить(ВидДоговора);
	
	ДоговорКонтрагента = Неопределено;
	РаботаСДоговорамиКонтрагентовБП.УстановитьДоговорКонтрагента(ДоговорКонтрагента, Объект.Контрагент, Объект.Организация, СписокВидовДоговоров, ДополнительныеПараметры);
	
	Если ЗначениеЗаполнено(ДоговорКонтрагента) Тогда
		Возврат ДоговорКонтрагента;
	Иначе
		// Проверим, что основной договор данного вида существует, но не подходит по каким-то другим свойствам
		// (в этом случае он не будет определен в РаботаСДоговорамиКонтрагентовБП.УстановитьДоговорКонтрагента).
		// Если основной договор существует, то ничего не делаем.
		// Если не существует, то создаем новый договор и назначаем его основным.
		
		Запрос = Новый Запрос();
		Запрос.Параметры.Вставить("Организация", Объект.Организация);
		Запрос.Параметры.Вставить("Контрагент",  Объект.Контрагент);
		Запрос.Параметры.Вставить("ВидДоговора", ВидДоговора);
		Запрос.Текст =
		"ВЫБРАТЬ
		|	ОсновныеДоговорыКонтрагента.Договор
		|ИЗ
		|	РегистрСведений.ОсновныеДоговорыКонтрагента КАК ОсновныеДоговорыКонтрагента
		|ГДЕ
		|	ОсновныеДоговорыКонтрагента.Организация = &Организация
		|	И ОсновныеДоговорыКонтрагента.Контрагент = &Контрагент
		|	И ОсновныеДоговорыКонтрагента.ВидДоговора = &ВидДоговора";
		
		Выборка = Запрос.Выполнить().Выбрать();
		Если Выборка.Следующий() Тогда
			// Договор в ОсновныеДоговораКонтрагента установлен, новый договор не создаем, что-бы не испортить пользовательские данные
			Возврат Неопределено;
		КонецЕсли;
		
		//// Основной договор не установлен - создадим новый договор и установим его основным.
		//ЗначенияЗаполнения = Новый Структура();
		//ЗначенияЗаполнения.Вставить("ВидДоговора", ВидДоговора);
		//ЗначенияЗаполнения.Вставить("Организация", ГоловнаяОрганизация);
		//ЗначенияЗаполнения.Вставить("Владелец",    Контрагент);
		//Если ЗначениеЗаполнено(ВалютаВзаиморасчетов) Тогда
		//	ЗначенияЗаполнения.Вставить("ВалютаВзаиморасчетов", ВалютаВзаиморасчетов);
		//КонецЕсли;
		//ПараметрыСозданияДоговора = Новый Структура("ЗначенияЗаполнения", ЗначенияЗаполнения);
		//Возврат СоздатьОсновнойДоговорКонтрагента(ПараметрыСозданияДоговора);
			
	КонецЕсли;
КонецФункции

 

Скачать файлы

Наименование Файл Версия Размер
Правила обмена из БП 3.0.78.64 в УТ 11.4.12.61:

.xml 461,64Kb
158
.xml 461,64Kb 158 Скачать
Расширение для УТ 11.4.12.61 для безошибочного типового обмена:

.cfe 6,20Kb
47
.cfe 6,20Kb 47 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Кукуруза 20.10.20 07:11 Сейчас в теме
Добрый день. Попытался воспользоваться правилами обмена с УТ на базе БСО: Бухгалтерия строительной организации. Это конфигурация по сути БП3.0, только с добавленным функционалом. Обмен не проходит с ошибкой:

Ошибка в обработчике события ПередВыгрузкойОбъекта
ПКО = ПриобретениеТоваровУслуг (Документ: Поступление (акты, накладные))
Объект = Отражение НДС к вычету 26 от 21.06.2019 12:00:02 (Отражение НДС к вычету)
Обработчик = ПередВыгрузкойОбъекта
ОписаниеОшибки = Поле объекта не обнаружено (ВидОперации)
ПозицияМодуля = (1)
КодСообщения = 41

Есть ли возможность доработать правила за дополнительную плату?
2. Kitri 91 20.10.20 12:38 Сейчас в теме
(1)Добрый день.
Можете скинуть структуру вашей базы, её нужно выгрузить с помощью файла выгрузки MD83Exp.epf
Если у вас его нет, могу скинуть на почту.
3. Serge_ASB 14.11.20 22:09 Сейчас в теме
Добрый вечер.
Прочел, что стандартным путем, через синхронизацию (универсальный формат данных) из БП 3.0 в УТ 11 документы товарные из бухи не выгружаются. У меня выгрузились только касса и банк.
Будет ли данные правила обмена "работать" гарантированно, или нужно будет внутри бухгалтерии тоже что-то подкорректировать, в каких-нибудь общих модулях?
4. Kitri 91 15.11.20 11:10 Сейчас в теме
(3)Добрый день.
Трудно сказать будет ли гарантированно работать данный обмен, особенно если версии конфигурации отличаются, или отличается ведение учета.
Есть недавний пример, в базе БП в счетах-фактурах документами-основаниями являются "Поступления доп.расходов".
В данных правилах нет выгрузки документа "Поступления доп.расходов", поэтому выгрузка работать не будет.
Я сама долго искала хоть какого-нибудь примерного обмена, чтобы правила писать не с "нуля", но так и не нашла. Пришлось делать самой.
Поэтому данные правила - это скорее пример, чтобы было с чего стартовать.
6. Cherepovets 08.12.20 17:55 Сейчас в теме
(3) Через редактор реквизитов, установи в плане обмене выгрузку торговых документов к примеру, и обмен по ним заработает. Тут правильно написали, из БУХ в УТ не улетают документы по поступлению объектов строительства к примеру.
5. Serge_ASB 16.11.20 08:19 Сейчас в теме
А, вообще, странно, что 1С считает безусловным порядок, где БП является на 110% получателем документов, и никак, кроме банка и кассы - не их отправитель.
Не пробовали, все-таки, в конфе найти и "отключить" "отключатель" регистрации документов товародвижения к обмену?
7. ilay73 22.03.21 20:16 Сейчас в теме
Здравствуйте, в правилах обмена предусмотрена возможности выгрузки из БП 3 документа Ввод остатков (по товарам)?
8. Kitri 91 23.03.21 09:15 Сейчас в теме
(7)Добрый день.
Да, ввод по остаткам товаров есть.
9. nicxxx 246 17.04.21 00:48 Сейчас в теме
Не работают ваши правила. Ругаются на ВидОперации, ИдентификаторСтроки. Вероятно, правило пытается примениться к объектам, где этих реквизитов нет. Например, правило для ПоступлениеТоваровУслуг пытается примениться к документам ПоступлениеДопРасходов.
10. Kitri 91 17.04.21 08:55 Сейчас в теме
(9)Да, возможно так и есть. В моей базе, видно, не было этих документов и у меня не ругалась.
11. user970589 8 01.07.22 11:48 Сейчас в теме
можно актуализировать правила на текущий день? есть интерес, я бы скачал. а дорабатывать не хочется, не факт, что потяну.
12. Kitri 91 04.07.22 13:43 Сейчас в теме
(11) Добрый день.
Можно актуализировать. На какие релизы программ УТ и БП?
13. user970589 8 04.07.22 17:51 Сейчас в теме
14. Kitri 91 05.07.22 10:43 Сейчас в теме
(13)
3.0.109.57 данный релиз не выпускался в виде полного дистрибутива.
Как-то долго обновления ставить на ранний релиз.
А можете скинуть структуры конфигураций, у вас наверное базы с этими релизами развернуты.
Для получения структуры нужно вложенную обработку открыть в режиме предприятия (в обеих базах по очереди), указать путь к файлу с названием релиза и выгрузить данные.
Затем эти структуры присылайте мне, а я их подгружу в правила и сделаю всю необходимую замену.
Или можно заменить 3.0.109.57 на 3.0.109.61... у меня этот релиз стоит развернутый
Прикрепленные файлы:
MD83Exp.epf
15. user970589 8 05.07.22 18:04 Сейчас в теме
(14)
заменить 3.0.109.57 на 3.0.109.61
- это нетрудно. давайте тогда так и сделаем. а ут сейчас выгружаю
16. user970589 8 05.07.22 18:07 Сейчас в теме
17. user970589 8 07.07.22 02:51 Сейчас в теме
(14) добрый день. когда можно скачать результат? время..
18. Slovar 28.07.22 13:06 Сейчас в теме
Добрый день. Тоже интересует. Есть ли актуальные правила?
Оставьте свое сообщение

См. также

Перенос объектов 1С Промо

Обмен между базами 1C Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Простой и наглядный перенос объектов между любыми базами 1С 8 с предварительным анализом на возможные различия в данных (через файл, через интернет, через буфер обмена, через Com). Интерактивная настройка правил обмена на стороне источника и получателя. В обработке есть удобный обзор по подсистемам, поиск и обработка данных по заданному фильтру. Сравнение объектов, поиск ссылок, регистрация в плане обмена. Конструктор кода по созданию объектов, написание скриптов и отладка мини-функций в УФ. Отключение/включение регламентных заданий. Отчеты по наполнению базы и разные проверки. Всевозможные инструменты администратора или программиста в одной обработке.

1 стартмани

16.03.2015    117430    2324    moolex    282    

Добавляем новый документ в обработку Диадок

Файловый обмен (TXT, XML, DBF), FTP Адаптация типовых решений Платформа 1С v8.3 Платформа 1С v8.3 1С:Комплексная автоматизация 2.х 1С:Комплексная автоматизация 2.х Абонемент ($m) Абонемент ($m)

Добавляем новый документ для подписания и отправки в обработку Диадок (через подключаемый модуль). Отправлять его будем, как неформализованный (внешняя печатная форма в формате pdf).

2 стартмани

07.10.2022    5025    9    John_d    20    

Простая конвертация данных

Обмен между базами 1C Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

Тем, кому "не зашла" конвертация данных 2 (или 3), а также тем, кто только еще пробует свои силы в данной теме, предлагается эта простая конвертация данных. С ней у вас точно все получится!

10 стартмани

29.08.2022    6348    79    mkalimulin    190    

Конвертация данных 2 и JSON

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Описание минимально необходимых изменений, которые нужно внести в обработку "УниверсальныйОбменДаннымиXML" для того, чтобы реализовать конвертацию объектов конфигурации в произвольный формат JSON.

1 стартмани

01.07.2022    5724    16    zhichkin    19    

ЗУП 2.5 - УПП 1.3. Обработка “Выгрузка данных в бухгалтерскую программу”, адаптированная к выгрузке в УПП Промо

Обмен между базами 1C Зарплата Платформа 1С v8.3 Платформа 1С v8.3 1С:Зарплата и Управление Персоналом 2.5 1С:Зарплата и Управление Персоналом 2.5 1С:Управление производственным предприятием 1С:Управление производственным предприятием Россия Россия Абонемент ($m) Абонемент ($m)

ЗУП 2.5 - УПП 1.3 Обработка “Выгрузка данных в бухгалтерскую программу” адаптированная к выгрузке в УПП. (Зарплата и Управление Персоналом, редакция 2.5 (2.5.48.1)-->Управление производственным предприятием, редакция 1.3 (1.3.22.1)) В некоторых случаях перенос данных зарлатного учета в УПП затруднен, и зарплатный учет по прежнему приходится вести в ЗУП, имея бухгалтерский учет уже в УПП. В этом случае поможет данное решение. Это стандартная обработка из ЗУП, с адаптированными правилами переноса под УПП.

2 стартмани

05.04.2012    31486    0    milkers    22    

Пульт управления телевизором LG Smart TV

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

Пульт LG телевизором smart TV (2014 года). Цель - управлять телевизором из 1С. Может быть полезна тем, кто потерял и не может найти пульт ДУ, кто смотрит телевизор и сидит за ноутбуком одновременно, для изучения обмена xml с внешними устройствами, в данном случае телевизором.

1 стартмани

11.01.2022    9352    6    confer2003@mail.ru    52    

Защита объектов от изменения обменом

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Расширение позволяет пользователю заблокировать объект 1С (документ, справочник) от изменения последующими загрузками данных или обменами.

5 стартмани

05.01.2022    12832    49    sapervodichka    52    

Создание стартовой базы

Обмен между базами 1C Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Часто требуется создать «Новую базу» почти пустую, но совпадающую с «Исходной базой» по необходимым обязательным настройкам: константам, регистрам сведений, справочникам, видам субконто и планами счетов и т.п., при этом уникальные идентификаторы объектов должны совпадать.

1 стартмани

11.10.2021    12511    23    sapervodichka    48    

Настройка обмена с любой устаревшей конфигурацией на базе 8.2 через обработку "Универсальный обмен данными в формате XML" и "Конвертацию данных 2.0"

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Платформа 1C v8.2 Платформа 1C v8.2 Конфигурации 1cv8 Конфигурации 1cv8 Бухгалтерский учет Бухгалтерский учет Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Разберем кейс, как настроить простенький обмен с любой устаревшей конфигурацией на базе 8.2 через обработку "Универсальный обмен данными в формате XML" и Конвертацию данных 2.0 с возможностью настройки гибких отборов по периоду, организации и списку документов.

1 стартмани

23.11.2020    25024    23    orfos    14    

Улучшенная обработка универсального обмена данными в формате XML (УФ)

Универсальные обработки Внешние источники данных Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Улучшенная обработка "Универсальный обмен данными" с полноценными возможностями СКД для выборки данных (не только для отборов).

1 стартмани

23.06.2020    20999    203    Lem0n    1    

Tunesoft: Универсальная выгрузка, загрузка и обмен данными между похожими конфигурациями, через JSON

Обмен между базами 1C Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка «Универсальная выгрузка и загрузка» предназначена для оперативного переноса объектов между двумя идентичными или похожими конфигурациями. Быстрая, надежная и очень простая в использовании обработка.

2 стартмани

29.01.2020    34193    507    vladnet    64    

АРМ "Касса-Лом". Обмен между 1С и учетной системой по оплате с физическими лицами за сдачу металлолома

Оптовая торговля Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

АРМ "КАССА-ЛОМ" предназначено для проведения безналичных взаиморасчетов между физическими лицами-сборщиками металлолома и предприятиями, являющимися членами НП НСРО «РУСЛОМ.КОМ» и осуществляющими деятельность в области обращения с ломом и отходами металлов.

5 стартмани

23.09.2019    15017    24    vik070777    0    

Мастер XML-обмена Промо

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Конфигурации 1cv7 Конфигурации 1cv7 Абонемент ($m) Абонемент ($m)

Функциональный аналог конвертации данных в кармане - комплекс обработок предназначенный для быстрой и удобной разработки обмена данными между информационными базами 1С.

5 стартмани

02.09.2015    43669    20    Lancelot-2M    23    

Документы и Справочники в JSON

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Пример выгрузки всех данных Документа или Справочника в JSON

1 стартмани

20.06.2019    33717    47    Teut_Vlad    22    

Универсальный обмен данными XML (с гибкими отборами и сохранением вариантов настроек)

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка предназначена для загрузки и выгрузки данных по правилам обмена в любых конфигурациях, реализованных на платформе 1С:Предприятие 8.3. Преимуществом перед типовой обработкой является добавленный функционал: #1. Установка произвольных фильтров на выгружаемые объекты при помощи механизма системы компоновки данных #2. Сохранение различных вариантов настроек (сохраняются правила обмена, фильтры выгрузки, параметры, настройки обработки) - что позволяет гибко настроить в базе-источнике фильтры для выгрузки объектов по различным правилам обмена для различных баз-приемников, сохранить выполненные настройки и в будущем уже пользоваться этими вариантами настроек. Проверялась на 1С:ERP Управление предприятием 2.4.7.141.

1 стартмани

29.04.2019    44182    674    sapervodichka    20    

Выгрузка и загрузка данных XML с гибкими отборами

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Обработка выгрузки и загрузки данных через XML между идентичными конфигурациями с возможностью установки произвольных отборов на выгружаемые объекты.

1 стартмани

07.04.2019    48503    1251    sapervodichka    54    

Выгрузка данных из УТ 11.3/11.4 в БП 3.0 (перенос документов и справочной информации из "Управление торговлей" ред. 11.3/11.4 в "Бухгалтерия предприятием" ред. 3.0). Обновлен до УТ 11.3.4.х/11.4.7х и БП 3.0.7х.х Промо

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Управление торговлей 11 Абонемент ($m) Абонемент ($m)

Данная обработка предназначена для выгрузки в формате XML данных из программы «Управление торговлей» ред. 11.3/11.4 по основным группам документов (документы покупки/продажи товаров и услуг, складские документы, счета-фактуры, ценообразование), а также набор основных справочников. Загрузка данных в БП ред. 3.0 через обработку «Универсальный обмен данными XML». Основная цель обработки – оптимизация работы бухгалтеров во время обмена данными между программами, а также выборочная корректировка загруженных ранее документов.

1 стартмани

04.03.2016    74356    214    SEOAngels    67    

РИБ и расширения

Обмен между базами 1C Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Как заставить работать РИБ с расширением.

1 стартмани

20.02.2019    48530    75    RocKeR_13    58    

Редактор объектов информационной базы 8.3

Универсальные обработки Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Универсальная внешняя обработка для редактирования реквизитов и табличных частей объектов информационной базы, редактирование движений документов. Доступ ко всем реквизитам объектов, есть возможность выгрузки и загрузки данных (объекты и движения документов) через XML. Платформа 8.3, управляемые формы. Версия 1.1.0.65 от 17.01.2023

2 стартмани

23.01.2019    54678    641    ROL32    83    

[Розница 8. Аптека] Загрузка приходных накладных из файлов DBF Промо

Файловый обмен (TXT, XML, DBF), FTP Розничная торговля Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница Фармацевтика, аптеки Фармацевтика, аптеки Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Внешняя обработка для загрузки документов «Поступление товаров» из файлов поставщиков в формате DBF для Розница 8. Аптека редакция 2.1. Для работы с дополнительными реквизитами и сведениями используется БДРС: http://infostart.ru/public/288722/ Для купивших БДРС предусмотрена скидка (второй файл - ...без БДРС - это для Вас). При написании использовался шаблон http://infostart.ru/public/303564/. Описание настройки интерфейса и регистрации обработки подробно можно посмотреть там. 20.03.2018 - Версия 3.2 для Розница - Аптека 2.2 (используется новая версия БДРС)

2 стартмани

11.05.2015    39373    0    Alex_E    12    

Выполнение запроса в другой базе 1С без com-соединения. HTTP-сервис

Обмен между базами 1C Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Выполнение любого запроса с параметрами из одной базы 1С в другую. Используя HTTP-сервис. Посредством POST-запроса и JSON.

1 стартмани

30.11.2018    44763    51    John_d    29    

Пример получения данных из другой базы 1С через Web-сервис

Обмен между базами 1C Платформа 1С v8.3 Платформа 1С v8.3 Россия Россия Абонемент ($m) Абонемент ($m)

В данной статье описан пример получения данных справочника из другой базы 1С через Web-сервис.

1 стартмани

11.11.2018    62368    50    flyDrag    30    

Обмен данными между УТ 10.3 и Розницей 2.2 (правила обмена данными между "Управлением торговлей" ред. 10.3. и "Розницей" ред. 2.2) Промо

Обмен между базами 1C Оптовая торговля Розничная торговля Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 1С:Розница 1С:Розница Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Данные правила предназначены для обмена в формате XML данных из программы «Управление торговлей» ред. 10.3. и "Розница" ред. 2.2 по основным группам документов и основных справочников. Загрузка данных осуществляется через встроенную обработку «Универсальный обмен данными XML». Основная цель обработки – корректировка типовых правил на выявленные ошибки и расширение выгрузки для корректной выгрузки данных по ЕГАИС и продажам в целом. Протестировано до УТ 10.3.47.х и Розница 2.2.11.х

3 стартмани

16.09.2016    68303    19    SEOAngels    65    

SOAP для чайников

WEB-интеграция Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Немножко про SOAP сервис. И пример работы с подключением и получением данных по SOAP за 5 минут.

1 стартмани

05.09.2018    107391    72    dusha0020    25    

Выгрузка документов из ЗУП в БП (1С 8.2-8.3) Промо

Обмен между базами 1C Зарплата Платформа 1С v8.3 Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Бухгалтерия 2.0 1С:Зарплата и Управление Персоналом 2.5 1С:Зарплата и Управление Персоналом 2.5 Абонемент ($m) Абонемент ($m)

Обработка для выгрузки документов из конфигурации "Зарплата и управление персоналом" 8.2 в конфигурацию "Бухгалтерия предприятия" 8.2. Использует правила обмена. В обработке создан удобный интерфейс для гибкого формирования списка документов кадрового учета и начисления ЗП.

1 стартмани

18.12.2012    28847    140    d.zhukov    20    

Синхронизация (выгрузка) данных ЗУП 3.1 - БП 2.0, УПП 1.3

Обмен между базами 1C Зарплата Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет Сложные периодические расчеты Сложные периодические расчеты 1С:Бухгалтерия 2.0 1С:Бухгалтерия 2.0 1С:Зарплата и Управление Персоналом 3.x 1С:Зарплата и Управление Персоналом 3.x Россия Россия Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Подобная выгрузка не была предусмотрена разработчиками 1С, поэтому и существует эта публикация. Поддерживается выгрузка оценочных обязательств и резервов отпусков. Непосредственная выгрузка в базу Бухгалтерии. Решение проблем с COM-соединением одной кнопкой.

3 стартмани

22.03.2018    64855    772    diso    226    

Создание в 1С 7.7 XML в формате EnterpriseData (универсальный формат обмена), версия 1.5. Инструкции и примеры переноса данных из устаревшей конфигурации 1С 7.7 в любую современную 1С 8.3, поддерживающую EnterpriseData, через Конвертацию данных 3

Файловый обмен (TXT, XML, DBF), FTP Обмен между базами 1C Платформа 1С v7.7 Платформа 1С v7.7 Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv7 Конфигурации 1cv7 Россия Россия Абонемент ($m) Абонемент ($m)

Воспользоваться современным средством переноса данных "Конвертация данных 3.0.5.3" можно только выгрузив из системы - источника данных XML в формате обмена данными EnterpriseData. В этой публикации можно скачать приемы выгрузки из 1С 7.7 универсального формата обмена для Конвертации данных 3. Выполняем перенос данных из «1С:Предприятие 7.7» в «1С:Предприятие 8.3». Используем Конвертацию данных КД 3.0 из 1c 7.7 --> 1С 8.3. На первой стадии еще не опубликовано иного способа подложить файл для Конвертации данных 3 кроме как сформировать его вручную, постараемся решить данную проблему.

1 стартмани

26.02.2018    58282    65    ksnik    3    

Универсальная выгрузка/загрузка данных для отличающихся конфигураций (JSON, Такси+ОФ) Промо

Обмен между базами 1C Универсальные обработки Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Простой перенос через JSON данных между двумя базами 1С (документов, справочников, ПВХ, ПВР, счетов). Аналогична произвольной выгрузке в типовой "Выгрузка/загрузка XML", но может использоваться для отличающихся конфигураций. Подходит для любых пар баз с любым интерфейсом (управляемый + обычный). Без настроек. Не требует идентичности конфигураций и платформ. При переносе типы данных сопоставляются по наименованиям метаданных, объекты и ссылки по UID.

1 стартмани

22.10.2014    237920    4569    ekaruk    195    

Синхронизация данных по правилам КД2.0

Обмен между базами 1C Анализ учета Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Новый инструмент для сравнения и загрузки данных, сочетающий в себе: гибкость запросов (используются для сопоставления объектов); наглядный вывод отличий; удобный отбор загружаемых данных; возможность пообъектной синхронизации двух баз по правилам КД2 с помощью вызова обработки "Универсальный обмен XML" в базе-источнике через COM-соединение.

1 стартмани

27.08.2017    37721    129    vikad    40    

Перенос справочников и документов из УТ 10.3 в БП 3.0

Обмен между базами 1C Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Россия Россия Бухгалтерский учет Бухгалтерский учет Налоговый учет Налоговый учет Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Синхронизация справочников и документов из Управление торговлей 10.3 в Бухгалтерию предприятия 3.0. Обработка не затрагивает штатный механизм. Подключение и перенос документов происходит посредством OLE. Без ввода начальных остатков.

10 стартмани

25.07.2017    34329    23    fullstack1c    6    

«Горыныч - то НЕ НАСТОЯЩИЙ!» … или О Конвертации Данных ред.3 (КД 3) и обменах в универсальном формате Enterprise Data… доступным русско-народным языком

Внешние источники данных Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 1С:Конвертация данных 1С:Конвертация данных Абонемент ($m) Абонемент ($m)

Тем, кто хочет быстро разобраться с темой инструмента Конвертация данных 3.0 и технологией обмена по новому формату 1С, активно применяемому во всех новых конфигурациях от 1С на БСП, расширяющем возможности интеграции, пакет полезных материалов.

1 стартмани

13.06.2017    35033    161    Davlad_A    16    

Загрузка XML в дерево значений

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Случайно наткнулся на статью с алгоритмом загрузки XML-строки в дерево значений и подумал, а не проще ли сделать это через механизм XDTO рекурсивно. На мой взгляд, решение получилось неплохое - даже атрибуты грузит..

1 стартмани

17.11.2016    36339    68    starik-2005    26    

Обмен данными онлайн через Веб-сервис с использованием обработки "Универсальный обмен данными XML"

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Доработка позволяет организовать двухсторонний обмен данными в режиме реального времени между любыми конфигурациями (типовые, самописные, обычные формы, управляемые формы). Также предлагается вариант в виде расширения конфигурации (.cfe) для конфигураций стоящих на поддержке без возможности изменения. В обмене может участвовать любое количество баз. Правила обмена подготавливаются с использованием конфигурации "Конвертация данных".

2 стартмани

28.10.2016    61245    356    linkov    58    

Загрузка файлов на сервер с прогрессом и докачкой

Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Пример использования новых возможностей платформы 8.3.9 по низкоуровневой работе с двоичными данными для инкрементальной передачи файлов на сервер.

1 стартмани

04.10.2016    22413    61    mrstomak    22    

Редактор движений документа. Сохранение в XML, обмен между базами, замена регистратора.

Обработка документов Универсальные обработки Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

Редактор набора записей движений документа. Позволяет сохранить набор записей в XML, в настройки пользователя, прочитать сохраненный XML в другой идентичной базе, заменить регистратор. Можно изменять порядок записей, менять активность, как массово, так и по одной и др. Тонкий клиент, управляемые формы.

1 стартмани

07.09.2016    59751    180    Aphanas    5