Консоль HTTP-запросов с генерацией кода

Публикация № 835540

Разработка - Инструментарий разработчика - Консоль запросов

Консоль http-запрос rest post get

Консоль HTTP-запросов, которая не только выполняет запросы и получает результат их выполнения, но и генерирует необходимый код. Использую на 8.3.11.2899.

UPD: Добавил авторизацию OAuth2, включил блок OAuth2 авторизации в генерируемый код.

При разработке очень часто сталкиваюсь с необходимостью взаимодействия со всякого рода сервисами (rest, soap), и возникает потребность начально отладить работу сервиса, так сказать «пощупать». Для этого использую приложение SoapUI, многие используют curl, и после отладки необходимо переносить все настройки в 1С, на ее классы и методы, что занимает некоторое время. Именно так и родилась консоль http-запросов для 1С. Сразу отмечу, что она покрывает только rest сервисы, для soap она не подойдет.

Консоль может не только выполнять запросы и получать результат их выполнения, но и генерировать необходимый код на языке 1С. 

Пробежимся по интерфейсу:

Настройки соединения, стоить отметить, что в поле сервер вносим только весь текст сервиса слева до домена верхнего уровня уровня (ru, com, org и т.п.)

Настройки соединения

Ссылка "Настройка прокси" открывает группу с настройками прокси (сервер прокси, логин, пароль), бывает нужно редко, обычно просто ставлю галку "Использовать прокси" и 1С сама подтягивает прокси по умолчанию.

Путь к самому rest-сервису, это все, что написано после домена верхнего уровня

Само тело запроса, может быть пустым, может содержать JSON запрос (как в примера), а может содержать XML или вообще base64 картинки/файла

Результат ответа - это тело ответа и код ответа с подробным описанием

Команды получения готово кода для конфигуратора

Пример получаемого кода

Если часть процедур/функций по работе с http вшиты в конфу, то генерится не универсальный код, а код с использованием процедур/функций конфы

Настройка заголовков запроса, это может контент тайп или ключ апи, как в примере

Параметры закидываются в/из строки сервиса

 

Данные формы - хитрая штука, с которыми 1С не позволяет работать как с объектом, при внесении этих параметров генерится особое тело запроса с разделителями и т.д. 

Использовал их всего один раз, перекрестился и забыл.

Визуализатор/конструктор JSON-объектов

Использую на 8.3.11.2899.

Скачать файлы

Наименование Файл Версия Размер
Консоль HTTP-запросов с генерацией кода:

.epf 21,00Kb
280
.epf 1.1.3 21,00Kb 280 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Stepa86 1395 25.05.18 11:43 Сейчас в теме
По картинке к статье подумал, что это конвертер строки curl в код 1С. Вот куча кнопочек, полей и прочего не так интересна, как такой конвертер, т.к. почти все примеры в интернетах написаны с использованием curl, например https://rocket.chat/docs/developer-guides/rest-api/chat/postmessage/#example-call

Может кто-нить сделает? Звездочек огребет наверняка
2. leongl 366 25.05.18 11:51 Сейчас в теме
(1) Согласен, сам подумываю написать импорт/экспорт Curl и SoapUI
3. ilyav 25.05.18 15:24 Сейчас в теме
А зачем это в 1с? пользуюсь программой Postman https://www.getpostman.com/ на 100% устраивает
adhocprog; Mortum; nbeliaev; bpc222; +4 Ответить
4. leongl 366 25.05.18 15:59 Сейчас в теме
(3)О, на это есть несколько причин - не везде разрешают стороннее по, поведение 1С все таки иное (все тот-же прокси, конвертация кириллицы в строке запроса), запуск на серве 1С, который является другой тачкой и другим юзером AD.
Чем приближенней к реальным условиям эксплуатации, тем лучше. Да и после getpostman, cUrl, SoapUI придется все перетаскивать в код, а тут сгенерил код и огонь.
KolBbl4; frkbvfnjh; adhocprog; 🅵🅾️🆇; jaroslav.h; vaskomain; JohnyDeath; blackhole321; CyberCerber; van_za; +10 Ответить
7. Vanch90 28.05.18 07:34 Сейчас в теме
(3) Как зачем удобство)
Еще бы на обычных формах похожее)
jaroslav.h; +1 Ответить
5. starik-2005 2252 26.05.18 11:07 Сейчас в теме
Чета в этом есть, ибо можно прикрутить сюда тестирование нагрузки и все такое прочее, что есть в сторонних решениях. В итоге описал сервис, нажал "завалить в 1000 потоков", в итоге чето там протестировал (или повесил сервак) - все опыт. Сразу ясно, тянет 1С это или тут лучше астральный программист на питоне за 10 килорублей...
8. kembrik 3 28.05.18 19:00 Сейчас в теме
Делал нечто подобное "для себя" но у автора пофункциональней. Я правда для вывода использовал "ФорматированныйДокумент" чтобы значения и атрибуты раскрашивать по-всякому, так глазастей. Так сказать, хотелось бы увидеть и у вас) Чтобы инструмент превратился в ультимативный
Прикрепленные файлы:
10. 🅵🅾️🆇 30.05.18 17:13 Сейчас в теме
Однозначно [★] в карму :3
11. s22 19 06.07.18 17:45 Сейчас в теме
Было бы хорошо генерировать защищеный post (исключение двойной отсылки)
А так же более менее стандартный обмен по рестапи
12. shura_k 10.07.18 18:34 Сейчас в теме
Не хватало работы с Digest авторизацией. Доделал.
На форму надо добавить два реквизита, а так все в коде.
Вставлять контекстно.

	Если Digest и Результат.КодСостояния=401 Тогда
		WWW_Authenticate=Результат.Заголовки.Получить("WWW-Authenticate");
		Ответ=СтрРазделить(WWW_Authenticate,",");
		Если Ответ.Количество()>0 Тогда
			realm=ОтветЗначение("realm",Ответ[0]);
			HA1 = ПолучитьХеш(Логин+":"+realm+":"+Пароль);	
			HA1=ХексВСтроку(HA1);
			URI=?(Лев(Сервис,1)<>"/","/"+Сервис,Сервис);
			HA2 = ПолучитьХеш(ВРег(ИмяМетода)+":"+URI);
			HA2=ХексВСтроку(HA2);
			qop=ОтветЗначение("qop",Ответ[1]);
			nonce=ОтветЗначение("nonce",Ответ[2]);
			opaque=ОтветЗначение("opaque",Ответ[3]);
			nc=nc+1;
			ncStr=формат(nc,"ЧЦ=8; ЧДЦ=; ЧВН=; ЧГ=0");
			cnonce=Новый УникальныйИдентификатор;
			cnonce=НРег(СтрЗаменить(Строка(cnonce), "-", ""));
			Если НРег(Лев(qop,4))="auth" Тогда
				Response  = ПолучитьХеш(HA1+":"+nonce+":"+ncStr+":"+cnonce+":"+qop+":"+HA2);	
			Иначе
				Response  = ПолучитьХеш(HA1+":"+nonce+":"+HA2);
			КонецЕсли;
			Response=ХексВСтроку(Response);
			
			DigestЗапрос="Digest username="""+Логин+""", realm="""+realm+""", nonce="""+nonce;
			DigestЗапрос=DigestЗапрос+""", uri="""+URI+""", qop="""+qop+""", nc="""+ncStr;
			DigestЗапрос=DigestЗапрос+""", cnonce="""+cnonce+""", response="""+Response+""", opaque="""+opaque+"""";
			
			УдалитьАвторизацию();
			
			Стр=Заголовки.Добавить();
			Стр.ИмяЗаголовка="Authorization";
			Стр.ЗначениеЗаголовка=DigestЗапрос;
			
			ВыполнитьЗапросПоМетоду(ВРег(ИмяМетода));
			Возврат;
		КонецЕсли; 
		
	КонецЕсли; 



&НаСервере
Процедура УдалитьАвторизацию()
	
	
    Отбор = Новый Структура;
    Отбор.Вставить("ИмяЗаголовка", "Authorization");
    Строки = Заголовки.НайтиСтроки(Отбор);
	Если Строки.Количество()>0 Тогда
		Заголовки.Удалить(Строки[0]);	
	КонецЕсли; 
		
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьХеш(Текст)
	ОбъектХеш = Новый ХешированиеДанных(ХешФункция.MD5);
    ОбъектХеш.Добавить(Текст);
    Возврат ОбъектХеш.ХешСумма;
КонецФункции

&НаСервереБезКонтекста
Функция ОтветЗначение(Ответ,Значение)
	результат=Сред(Значение,Найти(Значение,Ответ+"=")+СтрДлина(Ответ)+2);
	результат=Лев(результат,СтрДлина(результат)-1);
	Возврат результат;
КонецФункции

&НаСервереБезКонтекста
Функция ХексВСтроку(Текст)
	 Возврат НРег(СтрЗаменить(Строка(Текст), " ", ""));
КонецФункции
 
Показать
Vida; swimdog; eeeio; +3 Ответить
13. swimdog 732 11.01.19 14:29 Сейчас в теме
(12) Переделал под универсальное получение Digest, если предыдущее значение вернуло ошибку аутентификации

	// Выполнить GET запрос:
	Попытка
		Результат = Соединение.Получить(HTTPЗапрос, ФайлРезультат);
	Исключение
		ПоказатьПредупреждение(Новый ОписаниеОповещения(), "Не удалось получить фото, проверьте параметры запроса!" + Символы.ВК + Символы.ВК + ОписаниеОшибки(), , "Получение фото автомобиля");
	КонецПопытки;
	
	Если Результат.КодСостояния = 200 Тогда
		
		ФотоМашины = Новый Картинка(ФайлРезультат, Истина);
		АдресФото = ПоместитьВоВременноеХранилище(ФотоМашины);
		
	ИначеЕсли Результат.КодСостояния = 401 Тогда
		
		WWW_Authenticate=Результат.Заголовки.Получить("WWW-Authenticate");
		ИмяМетода = "GET";
		Сервис = АдресРесурса;
		nc = 0;
		
		Ответ=СтрРазделить(СтрЗаменить(WWW_Authenticate, "Digest ", ""), ",");
		Если Ответ.Количество()>0 Тогда
			realm = ОтветЗначение("realm", Ответ);
			HA1 = ПолучитьХеш(Логин+":"+realm+":"+Пароль);    
			HA1 = ХексВСтроку(HA1);
			URI = ?(Лев(Сервис,1)<>"/","/"+Сервис, Сервис);
			HA2 = ПолучитьХеш(ВРег(ИмяМетода)+":"+URI);
			HA2 = ХексВСтроку(HA2);
			qop = ОтветЗначение("qop", Ответ);
			nonce = ОтветЗначение("nonce", Ответ);
			opaque = ОтветЗначение("opaque", Ответ);
			nc = nc+1;
			ncStr = Формат(nc,"ЧЦ=8; ЧДЦ=; ЧВН=; ЧГ=0");
			cnonce = Новый УникальныйИдентификатор;
			cnonce = НРег(СтрЗаменить(Строка(cnonce), "-", ""));
			Если НРег(Лев(qop,4))="auth" Тогда
				Response  = ПолучитьХеш(HA1+":"+nonce+":"+ncStr+":"+cnonce+":"+qop+":"+HA2);    
			Иначе
				Response  = ПолучитьХеш(HA1+":"+nonce+":"+HA2);
			КонецЕсли;
			Response = ХексВСтроку(Response);
			
			DigestЗапрос = "Digest username="""+Логин+""", realm="""+realm+""", nonce="""+nonce;
			DigestЗапрос = DigestЗапрос+""", uri="""+URI+""", qop="""+qop+""", nc="""+ncStr;
			DigestЗапрос = DigestЗапрос+""", cnonce="""+cnonce+""", response="""+Response+""", opaque="""+opaque+"""";
			
			HTTPЗапрос.Заголовки.Вставить("Authorization", DigestЗапрос);
			
			Попытка
				Результат = Соединение.Получить(HTTPЗапрос, ФайлРезультат);
			Исключение
				ПоказатьПредупреждение(Новый ОписаниеОповещения(), "Не удалось получить фото, проверьте параметры запроса!" + Символы.ВК + Символы.ВК + ОписаниеОшибки(), , "Получение фото автомобиля");
				Возврат;
			КонецПопытки;
			
			Если Результат.КодСостояния = 200 Тогда
				ФотоМашины = Новый Картинка(ФайлРезультат, Истина);
				АдресФото = ПоместитьВоВременноеХранилище(ФотоМашины);
			Иначе
				ПоказатьПредупреждение(Новый ОписаниеОповещения(), "Не удалось получить фото, проверьте параметры запроса!" + Символы.ВК + Символы.ВК + "Код результата = " + Результат.КодСостояния, , "Получение фото автомобиля");
			КонецЕсли;
			
		КонецЕсли; 
		
	КонецЕсли; 
	
	
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьХеш(Текст)
	ОбъектХеш = Новый ХешированиеДанных(ХешФункция.MD5);
	ОбъектХеш.Добавить(Текст);
	
	Возврат ОбъектХеш.ХешСумма;
КонецФункции

&НаСервереБезКонтекста
Функция ОтветЗначение(Значение, Ответ)
	результат = "";
	Для каждого СтрокаОтвета Из Ответ Цикл
		Если Найти(СтрокаОтвета, Значение) Тогда
			результат=Сред(СтрокаОтвета, Найти(СтрокаОтвета, "=")+2);
			результат=Лев(результат,СтрДлина(результат)-1);
		КонецЕсли;
	КонецЦикла;
	
	Возврат результат;
КонецФункции

&НаСервереБезКонтекста
Функция ХексВСтроку(Текст)
	
	Возврат НРег(СтрЗаменить(Строка(Текст), " ", ""));
	
КонецФункции
Показать
14. leemuar 18.01.19 11:45 Сейчас в теме
Попробовал вашу обработку, спасибо!

Есть небольшое неудобство: обработка не выводит заголовки и тело ответа если код ответа не равен 200. Мне кажется было бы удобнее видеть заголовки и тело ответа всегда, при любом коде ответа.
15. dndw 6 13.03.19 15:52 Сейчас в теме
Про попытке добавления сервиса:

{ВнешняяОбработка.ОтправитьHTTPЗапрос.Форма.Форма.Форма(558)}: Индекс находится за границами массива
Рез.Сервер = Лев(МассивДанныхСсылки[1], Найти(МассивДанныхСсылки[1], "/")-1);

при попытке заполнить по cURL
{ВнешняяОбработка.ОтправитьHTTPЗапрос.Форма.Форма.Форма(957)}: Индекс находится за границами массива
ВремТекстТела = МассивСтрокТела[1];
16. Vida 14 13.05.19 18:06 Сейчас в теме
Подскажите пожалуйста на совместимости = 8.3.5 пойдет?
17. DVBLEX 13.08.19 10:35 Сейчас в теме
Кто может закинуть ето решения беслатно в пм ?
18. cprit 425 26.12.19 13:52 Сейчас в теме
Добрый день!
Для обычных форм есть замечательный набор инструментов "Инструменты разработчика 1С", но его невозможно использовать в линуксе и в тонком и веб клиенте.

Поэтому мы решили собрать подобный пакет, но который будет работать только на платформенных механизмах или с использованием кроссплатформенных компонент.

Использование этого пакета инструментов хотим сделать общедоступным(OpenSource), разработку вести через гитхаб с использованием EDT.

Можем ли мы включить в этот набор обработки(или часть идей и функционала) из этой публикации?

На текущий момент нашли основные инструменты (консоль запросов, консоль кода, редактор реквизитов, консоль компоновки и др.) для включения в инструментарий. Сейчас занимаемся получением одобрения авторов. Часть включаем свои- редактор предопределенных, редактор констант, Групповая обработка

Ссылка на репозиторий с новыми инструментами https://github.com/cpr1c/tools_ui
19. antonzh 11.11.20 15:39 Сейчас в теме
Добрый день! Подскажите, где найти примеры CRUD скриптов для Акта в формате curl?
К сожалению, мои познания в 1С == 0. Нужно интегрироваться с 1С из стороннего приложения через REST. Конфигурация 1С настроена. Сервис откликается.
21. antonzh 11.11.20 16:03 Сейчас в теме
Оставьте свое сообщение

См. также

Управляемая консоль запросов, отчетов 3.8.9 (расширение, внешняя обработка) Промо

Консоль запросов v8 v8::УФ v8::Запросы v8::СКД 1cv8.cf Абонемент ($m)

Работа с запросом и СКД, Полная поддержка пакетных запросов, временных таблиц, Сравнение результатов, текстов, Разбор структуры запроса в виде дерева, Анализ плана запроса, Групповая обработка

5 стартмани

14.08.2018    99816    2571    Evg-Lylyk    679    

Консоль SQL запросов на клиенте/сервере

Консоль запросов v8 1cv8.cf Абонемент ($m)

Быстрый старт по написанию обработки запроса из SQL таблицы: 1) указать параметры подключения к базе SQL 2) написать запрос (в Предприятии или Конфигураторе) и обработчик запроса (в Конфигураторе) 3) встроить как внешнюю обработку - profit

2 стартмани

13.01.2021    677    2    user785225    0    

Отладчик запроса 1С 8.3 (управляемые формы), бета-версия

Консоль запросов v8 v8::УФ 1cv8.cf Абонемент ($m)

По просьбам некоторых своих коллег и пользователей Инфостарта, выкладываю первую версию обработки "Отладчик запросов by Акулов А.С.", переделанной под управляемые формы. Реализованы почти все возможности из отладчика запросов, которые присутствовали в версии под обычные формы, а также добавлено немного нового.

1 стартмани

28.09.2020    7549    98    DrAku1a    27    

Генератор внешних печатных форм

Инструментарий разработчика БСП (Библиотека стандартных подсистем) Консоль запросов Прочие инструменты разработчика Универсальные печатные формы v8 1cv8.cf Абонемент ($m)

Генератор печатных форм - инструмент для создания внешних печатных форм в режиме предприятия с минимальным написанием кода

3 стартмани

18.09.2020    2367    13    andy_zhav    7    

Консоль запросов с графом (Анализатор сложных запросов) Промо

Консоль запросов v8::УФ v8::Запросы 1cv8.cf Абонемент ($m)

Консоль запросов для анализа запросов с большим количеством временных таблиц и вложенных запросов. Отображает структуру взаимосвязей временных таблиц в виде графа. Позволяет быстро передвигаться по тексту запроса и получать результат выполнения подзапросов. Единственная консоль запросов, которая позволяет выводить результат выполнения вложенных запросов и любой части объединения запроса. Удобное получение данных запроса из отладчика включая временные таблицы. Текст запроса в структурированном виде (можно свернуть, развернуть текст подзапроса). И еще много другого, чего вы не найдете в других консолях запросов. Поддержка УФ и ОФ. Версия 0.9.1 от 18.10.2019 (поддержка WebKit).

10 стартмани

03.05.2017    98152    442    manuel    266    

Консоль запросов с перехватом открытых отчетов СКД для получения реального текста запроса

Консоль запросов v8::УФ v8::Запросы v8::СКД ERP2 УТ11 КА2 Абонемент ($m)

Обработка Консоль запросов с перехватом отчётов позволяет выбрать открытый отчёт СКД и получить реальный текст запроса с учётом наложенных пользователем параметров и отборов.

1 стартмани

28.08.2020    2268    12    kran    0    

Консоль запросов (толстый и тонкий клиент) (управляемое приложение)

Консоль запросов v8 v8::УФ 1cv8.cf Абонемент ($m)

Конструктор запросов в управляемом приложении в 1С (толстый и тонкий клиент)

1 стартмани

12.08.2020    2145    6    Denr83    0    

5 ситуаций, когда в экосистеме 1C нужны веб-сервисы

Обмен данными 1С v8 Бесплатно (free)

В 1С существует немало возможностей для обмена данными, включая файловый обмен и COM Connector. В этой статье я расскажу, когда при интеграции 1С не обойтись без веб-сервисов, а также в чем плюсы использования SOAP или, наоборот, HTTP. Кроме этого речь пойдет про рабочие инструменты и примеры использования веб-сервисов. Веб-сервисы — достаточно простая штука. Существует множество инструкций по их созданию, так что запустить свой сервис может почти каждый. Сложности возникают тогда, когда веб-сервисы начинают куда-то встраивать, например, в системы 1С.

24.03.2020    8278    Neti    4    

Консоль запросов + ТЗ как параметры Промо

Консоль запросов v8 1cv8.cf Украина Абонемент ($m)

Стандартная консоль запросов, с добавленной возможностью использования описания/заполнения/использования таблиц значений как параметров. Совместима с настройками базовой консоли. Упрощает отладку запросов, использующих временные таблицы.

2 стартмани

12.11.2010    37319    437    Kashemir    24    

"Запросник 3.0" с раскраской кода в WebKit

Консоль запросов v8 v8::УФ v8::Запросы 1cv8.cf Абонемент ($m)

Развитие легендарного "Запросника" при работе с платформами 8.3.14.1565 и выше с webkit.

1 стартмани

02.03.2020    5660    54    Gmix    7    

Консоль запросов 9000

Консоль запросов v8 v8::Запросы 1cv8.cf Абонемент ($m)

Простая и удобная консоль запросов 1С для управляемых форм 8.3, работает на любой конфигурации без ее модификации. Возможность использования как внешней обработки или в составе расширения. С перехватом любых запросов и поддержкой всех типов данных во временных таблицах. Анализ плана запроса, запроса на уровне СУБД. Обработка результата кодом.

1 стартмани

24.02.2020    13919    287    kuza2000    128    

Консоль запросов к базам SQL

Консоль запросов v8 1cv8.cf Россия Абонемент ($m)

Консоль запросов к базе MS SQL из 1С 8.3.

1 стартмани

18.02.2020    3496    10    nikolasx    5    

Exec - Выполнение кода, консоль запросов и не только! Промо

Консоль запросов v8 1cv8.cf Абонемент ($m)

Незаменимый инструмент администратора БД и программиста: Выполняйте произвольный код из режима 1С Предприятие; сохраняйте/загружайте часто используемые скрипты; выполняйте запросы с замером производительности запроса в целом и каждой из временных таблиц в частности, а также с просмотром содержимого временных таблиц; произвольным образом изменяйте любые объекты БД, редактируя даже не вынесенные на формы реквизиты и записывая изменения в режиме "ОбменДанными.Загрузка = Истина"; легко узнавайте ИД объектов БД; выполняйте прямые запросы к SQL с замером производительности и не только!

5 стартмани

10.11.2015    42089    75    catsam    11    

Конструктор запросов при внешнем подключении

Консоль запросов Прочие инструменты разработчика v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Конструктор запроса при внешнем подключении (с возможностью выборки по табличным частям объектов конфигурации). Управляемые формы, тонкий клиент.

1 стартмани

23.01.2020    4821    7    falcon_wild    2    

Универсальная выгрузка данных и анализ

Обработки Универсальные обработки Обмен данными 1С Загрузка и выгрузка в Excel Обмен через XML Перенос данных из 1C8 в 1C8 Консоль запросов v8 1cv8.cf Абонемент ($m)

Обработка предназначена для выгрузки результатов выполнения запросов в различных форматах, а также анализа данных.

1 стартмани

27.11.2019    6096    20    kozusenok    0    

Консоль запросов для ЗУП 3.х

Консоль запросов v8::Запросы ЗУП3.x Россия Абонемент ($m)

Доработка стандартной консоли запросов для работы с механизмом представлений из ЗУП 3.х.

1 стартмани

05.11.2019    7289    37    evgeni-red    3    

КонЗап - консоль запросов с улучшенным интерфейсом и дополнительными функциями Промо

Консоль запросов v8 1cv8.cf Абонемент ($m)

Консоль запросов (Платформа 8.х режим - обычное приложение) с улучшенным интерфейсом и дополнительными функциями (загрузка параметров запроса из файла, работа с временными таблицами, замер времени выполнения, групповая обработка результатов запроса). Часть функций позаимствованы из других обработок, часть разработаны "с нуля".

1 стартмани

16.07.2014    15727    110    serjpsv    18    

Консоль запросов управляемая с конструктором

Консоль запросов v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка Консоль запросов позволяет использовать полноценный функционал конструктора и получать план выполнения запроса. Так же главная отличительная особенность от аналогов - то что она работает.

1 стартмани

17.10.2019    5695    6    Indgo    27    

Консоль запросов с перехватом отчетов СКД (для получения реального текста запроса) и запросов

Консоль запросов v8::Запросы v8::СКД 1cv8.cf Россия Абонемент ($m)

Доработанная консоль запросов с автоматическим заполнением текста запроса и всех параметров на основании объекта Запрос, полученного в "Конфигураторе" или перехваченного встроенного/внешнего отчёта СКД.

2 стартмани

29.09.2019    9216    38    strek_ivan    4    

Консоль запросов с перехватом открытых отчетов СКД для получения реального текста запроса

Консоль запросов v8::Запросы v8::СКД 1cv8.cf Россия Абонемент ($m)

Доработанная консоль запросов для получения реального текста запроса.

1 стартмани

30.08.2019    12231    53    strek_ivan    29    

Модифицированная консоль запросов от Ярославцева для Управляемых форм в 8.2 Промо

Консоль запросов v8 1cv8.cf Абонемент ($m)

По просьбам участников форума доработал консоль запросов для управляемых форм, добавил возможность исполнения кода. В текущем варианте код исполняется только на сервере. В продолжение темы: http://infostart.ru/public/117157/

1 стартмани

14.03.2012    19415    124    black_doctor    6    

Консоль запросов с возможностью сравнения данных между базами (управляемые формы)

Консоль запросов v8 v8::УФ v8::Запросы 1cv8.cf Россия Абонемент ($m)

Данная консоль позволяет сравнивать любые данные полученные произвольными запросами между текущей базой и внешней базой данных как файловой, так и клиент-серверной.

3 стартмани

26.08.2019    7918    34    Dadriel619960    9    

Встраиваем консоль запросов для отбора в стандартные обработки 1С

Консоль запросов v8 1cv8.cf Абонемент ($m)

Данное руководство поможет встроить форму отбора в стандартные обработки 1С, например "Групповое изменение реквизитов" или "Поиск и удаление дублей". Бывает случаи, что нужно сделать сложный отбор элементов, который невозможно реализовать через стандартный отбор или, в случае поиска и удаления дублей, справочник имеет тысячи элементов и поиск по нему дублей может знять даже не один день. Тут на помощь приходит консоль запросов, которая встраивается в обработки и помогает отобрать нужные элементы для дальнейших с ними действий.

1 стартмани

01.03.2019    6113    2    w.r.    3    

Консоль запросов с их сохранением в базе

Консоль запросов v8 1cv8.cf Казахстан Абонемент ($m)

Консоль запросов стандартная, предназначена для создания и выполнения запросов в режиме предприятия с помощью конструктора запросов или вручную. Долгое время использовал эту стандартную консоль запросов и даже научил нескольких бухгалтеров пользоваться ею, и понял, что основное неудобство - это хранение запросов во внешних файлах, когда копии запросов расползаются по рабочим столам, и бухгалтера (да и я ) должны помнить, где лежит последняя версия запроса. И тогда мне пришла мысль хранить их в самой базе, что я и реализовал. При этом возможности штатного сохранения\чтения в/из внешних файлов осталась неизменной.

1 стартмани

26.02.2019    5816    0    makfromkz    9    

Консоль запросов "Запросник" для управляемых форм с подсветкой синтаксиса Промо

Консоль запросов v8 1cv8.cf Абонемент ($m)

Вот уже много лет я использую замечательный инструмент для работы с запросами - Запросник. Однако, с переходом на управляемые формы для его использования пришлось запускать базы в устаревшем толстом клиенте, да еще и разрешать в свойствах конфигурации использование обычных форм. В 2014 году появился запросник на управляемых формах, который, к сожалению, оказался несовершенен из за ограничений платформы. Самое неприятное из них - отсутствие подсветки синтаксиса. Мне кажется, что я нашел решение этой проблемы.

1 стартмани

19.04.2016    38808    257    1С_Мастер    42    

Консоль запросов для управляемого интерфейса

Консоль запросов v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Данная обработка — предназначена для отладки запросов.

1 стартмани

04.02.2019    6556    14    Xapac    3    

Консоль запросов (управляемые формы) + возможность работы в толстом клиенте

Консоль запросов v8 v8::УФ 1cv8.cf Абонемент ($m)

Одна обработка для Толстого и тонкого клиента. Работает как на управляемых, так и не управляемых формах. Заброс получился большой и громоздкий - ГДЕ ТОРМОЗИТ? Нужно писать в консоли для обработки и часть параметров не используется? 1С зависла при выполнения запроса и текст запроса потерян, а авто сохранение не любите, т.к. он при ошибке не оставляет вам вариантов - ошибка уже вписалась?! Тестируете обработку Табличных Частей документа? Толстый клиент проверен на 8.2.19.130, Управл. формы на 8.3.10.2580. УФ Оптимизация под такси, но нормально под простой интерфейс.

1 стартмани

17.01.2019    6674    8    Sevg    0    

Выгрузка запроса из отладки в консоль запросов (Управляемые формы)

Консоль запросов v8::УФ v8::Запросы 1cv8.cf Россия Абонемент ($m)

Помощник в отладке и доработке запросов использующих менеджер временных таблиц.

1 стартмани

13.11.2018    8481    8    redtram    2    

Консоль запросов, СКД, ADODB. Управляемое приложение. Промо

Консоль запросов v8::УФ v8::Запросы v8::СКД 1cv8.cf Абонемент ($m)

Консоль запросов/отчетов, СКД, ADODB. Ввывод в таблицу значений, дерево или табличный документ(только для СКД)), обработка результата, произвольные обработчики расшифровки и прочие плюшки. Написана с нуля для платформы 8.3.х. На платформе 8.3.5 доступен Конструктор запросов в тонком клиенте.

1 стартмани

21.02.2014    33891    544    unknownDaemon    67    

Консоль запросов для управляемых форм 8.3

Консоль запросов Инструментарий разработчика Универсальные обработки v8 v8::УФ v8::Запросы 1cv8.cf Абонемент ($m)

Универсальная внешняя обработка для создания, редактирования и отладки запросов, с возможностью обработки таблицы результатов произвольными алгоритмами на языке 1С. Выгрузка результатов запроса в таблицу или дерево значений, включая временные таблицы и запросы пакета. Формирование запроса для консоли в отладчике, включая временные таблицы и параметры. Версия 1.1.0.67 от 22.11.2020

3 стартмани

08.11.2018    21680    244    ROL32    22    

1С:Альфа-Авто: обмен с WordPress-сайтом. Часть 2. REST API. Авторизация

WEB v8 1cv8.cf Автомобили, автосервисы Абонемент ($m)

Автоматический обмен данными между 1С:Альфа-Авто и сайтом WordPress в формате JSON. Авторизация и получение данных посредством REST API WordPress'a.

3 стартмани

12.09.2018    8412    12    osivv    9    

Консоль запросов

Консоль запросов v8::УФ v8::Запросы 1cv8.cf Абонемент ($m)

Консоль запросов для УФ. Внешне похожа на консоль для обычного приложения. Но есть ряд новых возможностей.

1 стартмани

25.06.2018    10513    15    17808849    10    

Консоль запросов для тонкого клиента с просмотром временных таблиц и импортом запросов из конфигуратора Промо

Консоль запросов v8 1cv8.cf Абонемент ($m)

Теперь можно в табло посмотреть произвольные ВТ, сделанные в других запросах и переданные через МенеджерВременныхТаблиц. И также посмотреть их в пользовательском режиме.

1 стартмани

28.11.2014    13412    36    Boris-Leleko    3    

Униформальная консоль запросов

Консоль запросов v8::УФ v8::Запросы 1cv8.cf Абонемент ($m)

Минималистичная и функциональная консоль запросов, которая выглядит и работает одинаково, как в обычных формах, так и в управляемых.

1 стартмани

23.05.2018    24346    319    Synoecium    52    

Групповая обработка реквизитов + консоль запросов

Консоль запросов v8 v8::УФ v8::Запросы Розница УНФ БП3.0 УТ11 КА2 Абонемент ($m)

Расширение конфигурации, которое в типовую обработку "Групповое изменение реквизитов" добавляет возможность отбирать объекты для обработки запросом. Необходимо наличие обработки "Консоль запросов" с ИТС.

2 стартмани

20.03.2018    18342    50    Kutuzov    6    

Консоль запросов: работа с временными таблицами

Консоль запросов v8 v8::Запросы 1cv8.cf Россия Абонемент ($m)

Консоль запросов помогает сэкономить время при работе со сложными запросами со временными таблицами.

1 стартмани

12.12.2017    10619    17    lapa_kn    1    

Консоль запросов для платформы 1С 8.2-8.3 (Управляемое приложение, Такси) Промо

Консоль запросов v8 v8::УФ v8::Запросы 1cv8.cf Абонемент ($m)

Данная консоль запросов является доработанной версией стандартной консоли с сайта ИТС т.к. нужного и удобного функционала не было найдено. Для модернизации были взяты наработки из консоли http://infostart.ru/public/126781/ (большое спасибо автору). Консоль протестирована и готова к работе. Обновление от 13.04.2014, версия 1.1

2 стартмани

09.04.2014    49784    396    hakerxp    13    

Консоль запросов OData

Консоль запросов v8 1cv8.cf Абонемент ($m)

Консоль запросов по протоколу OData.

1 стартмани

30.08.2017    21194    81    vlsv    7    

Консоль запросов 8.3 (обычное приложение) с возможностью переноса параметров запроса через строку (из отладки). А также с возможностью очень быстрой выгрузки больших объемов данных в Excel(CSV) исключительно мощностями сервера

Консоль запросов v8 1cv8.cf Россия Казахстан Абонемент ($m)

Доработанная консоль запросов для 1С 8.3. Доработанные функции: 1. Загрузка параметров запроса из строки, полученной в отладке методом ЗначениеВСтрокуВнутр(Запрос.Параметры) 2. Выгрузка результата запроса в CSV файл на сервере и передача его на клиент. Быстрее в 10 раз чем стандартное "Сохранить Как" 3. Получение на основание запроса кода для выполнения обработки. При этом в коде уже прописаны все установленные для запроса параметры, а так же типизировано основное поле результата. 4. Конвертация текста запроса из вложенных запросов, во временные таблицы

1 стартмани

09.07.2017    15055    36    matveev.andrey.v    0    

Консоль запросов к mySQL

Консоль запросов v8 1cv8.cf Россия Абонемент ($m)

Простенькая консоль на УФ для выполнения запросов к БД MySQL.

1 стартмани

14.03.2017    11561    11    dim_zal    1    

Консоль отладки сложных запросов с временными таблицами, оптимизированная (1.4 / 22.11.13 / ЧИА) Промо

Консоль запросов v8 Абонемент ($m)

Реализована возможность работы с временными таблицами по названиям таблиц. Добавлена нумерация строк в ВТ. Добавлена автосортировка строк в ВТ. Список параметров оптимизирован для работы со списком значений.

1 стартмани

15.11.2013    20881    99    ЧИА    8    

Консолька (версия 6.0.44)

Консоль запросов v8::УФ v8::Запросы 1cv8.cf Беларусь Абонемент ($m)

Обработка Консолька предназначена для выполнения запросов к информационной базе 1С в режиме управляемого приложения, выполнения запросов к базам данных SQL, выполнения произвольного кода 1С.

1 стартмани

27.02.2017    21558    73    sertak    42    

Консоль запросов EX (внешние данные)

Консоль запросов v8 1cv8.cf Абонемент ($m)

Работа с внешними данными в консоли запросов (1С 7.7, 8.x, XBase, Excel, ADO)

1 стартмани

30.10.2016    9006    27    Cерый    0    

Консоль запросов SQL

Консоль запросов v8 1cv8.cf Абонемент ($m)

Иногда возникает желание посмотреть, как информация 1С уложена в базе данных. Данная обработка позволяет показать структуру базы данных, а так же обычными SQL-запросами просмотреть содержимое таблиц MsSQL.

1 стартмани

21.10.2016    10867    47    igel9780    8    

Консоль запросов 1С "consquery.ru" Промо

Консоль запросов v8 v8::УФ v8::Запросы 1cv8.cf Россия Абонемент ($m)

Удобная и функциональная консоль запросов со своей историей.

1 стартмани

05.07.2006    42063    259    zenechka    147    

"Консоль запросов" с возможностью вывода UID справочников и документов

Консоль запросов v8 1cv8.cf Абонемент ($m)

Доработанная обработка "Консоль запросов" с возможностью вывода UID справочников и документов.

10 стартмани

11.07.2016    7697    6    graysvd    4    

Консоль запросов для больших баз данных (БД)

Консоль запросов v8 1cv8.cf Абонемент ($m)

Самая обычная консоль запросов для толстого клиента, но обладающая некоторыми специальными возможностями для отладки и сверки сложных запросов, которые выбирают большие объёмы данных. А именно: -Сохранение результата запроса в файл; -Возможность выборки из сохраненного файла; -Замеры времени выполнения отдельных временных таблиц в запросе; -Подготовка текста запроса к помещению в модуль; -Проверка запроса на не уничтоженные временные таблицы;

1 стартмани

28.06.2016    11300    19    ixilimuse    9    

Доработанная консоль запросов 1С 8.3

Консоль запросов v8 1cv8.cf Абонемент ($m)

После многих дней доработок, консоль стала более совершенной. Поменялся интерфейс, добавились новые возможности.

1 стартмани

28.03.2016    18440    126    Раис910    10    

Гламурная консоль запросов "СуперСтар" (толстый клиент) Промо

Консоль запросов v8 1cv8.cf Россия Абонемент ($m)

Инструменты разработчика бывают разного назначения. Бывает технологическая инструментальная консоль для всяких выгрузок и исполнения фрагментов кода. Ну а бывает любимая консоль - нечто более сокровенное, как для меня эта консоль - можно сказать мой "рабочий орган", в котором проводишь большую часть рабочего дня и который самое главное должен быть красивый, удобный и поднимающий настроение. С эстетической точки зрения мне не нравится интерфейс управляемых форм, мне кажется старые формы красивее. Надеюсь прелести рисованных неуправляемых форм со всякими фишечками и рюшечками толстого клиента помогут мне доставить всем программистам удовольствие от работы с данной версией консоли, которое получаю от нее я сам. Огромное уважение автору оригинальной разработки Hobi (http://infostart.ru/profile/132974/), с разрешения которого я занимаюсь доработкой этой формы консоли для толстого клиента обычного приложения 8.2 (устаревшая версия http://infostart.ru/public/125225/).

1 стартмани

21.09.2012    20886    150    ksnik    10    

Консоль запросов для УФ с подсветкой синтаксиса и обработкой результата

Консоль запросов v8 v8::УФ 1cv8.cf Абонемент ($m)

Самая быстрая консоль запросов для управляемых форм с подсветкой синтаксиса и обработкой результата

1 стартмани

08.01.2016    34193    509    BurningChrome    82