Обмен с ЕГАИС из 1С V7.7

Публикация № 416390 13.11.15

Бухгалтерский учет - Оптовая торговля

ЕГАИС оптовые розничные обмен утм РАР Марки

Дорогие друзья! Предлагаю Вашему вниманию обработку, предназначенную для обмена данными из Вашей учетной системы с ЕГАИС, через универсальный транспортный модуль (УТМ). В обработке реализован весь функционал обмена: - загрузка справочных данных по контрагентам, производителям, импортерам алкогольной продукции; - загрузка справочных данных по номенклатуре алкогольной продукции; - загрузка остатков; - помощник сопоставления справочных данных и запись их в базу данных; - загрузка приходных ТТН и справок Б от поставщиков, отправка по ним актов всех типов, создание по ним приходных документов; - выгрузка расходных ТТН покупателям; - управление Марками и ведение Регистра 3; Обработку возможно использовать автономно, не внося изменений в Вашу Учетную систему. Код открыт.

Обработка работает на платформе 1С v7.7

Конфигурации (практически без доработки):

  • винно-водочная Торговля на основе типовой конфигурации «Торговля+Склад»
  • типовая конфигурация «Торговля+Склад»

Вы можете предложить свой вариант конфигурации на базе 1С: Предприятие v7.7, в которой необходимо организовать работу обработки, готов в кратчайшие сроки проанализировать готовность Вашей конфигурации и при возможности, под заказ, её доработать.

Код обработки полностью открыт, не содержит лицензионных ограничений, и может быть доработан по Вашему усмотрению.

Поддерживается в полном объеме работа Опта и Розницы...

Текущая версия обработки 2.4.0.3

При доработке и расширении функционала, новые версии будут предоставлены в рамках поддержки.

Получение обновлений:  Вы делаете запрос с указанием почтового адреса покупки программы, далее обновления получаете на почту.

Техническая поддержка полностью бесплатна в течение 1 мес. со дня покупки, ответы на любые вопросы постараюсь дать в обсуждении данной обработки и в личных сообщениях. Далее возможно приобретение платной техподдержки на 1 квартал.

В архиве находится сама обработка (Obmen_egais.ert), модуль поиска соответствий (Poisk.ert) , модуль Помощника управлением кодами и привязками (HelpEGAIS.ert), модуль Управления партиями постановка и снятие резерва, управление фактическими остатками (УправлениеПартиями.ert).

И два каталога:

  1. dll – здесь все необходимое для регистрации (если их нет в Вашей системе) замечательных библиотек 1CPP.dll и FormEx.dll, предназначенных для удобства в работе с обработкой(Добавлена библиотека OcvitaBarcode.ocx для печати QRкодов).
  2. temp – каталог временных фалов обмена с программой curl.exe (версию для своей системы скачать здесь: http://curl.haxx.se/dlwiz/?type=bin).

По регистрации библиотек! Программа для регистации в любой win системе доступна для скачивания...

Вот, собственно, и все, что необходимо для работы обработки.  

Основные возможности:

Обработка позволяет наладить обмен данными между Вашей учетной системой (УС) и ЕГАИС через  универсальный транспортный модуль (УТМ), следующих видов:

  • запрос и загрузка справочника организации;
  • запрос и загрузка справочников производителей/импортеров;
  • запрос и загрузка справочников алкогольной продукции (АП);
  • запрос и загрузка справочников контрагентов;
  • загрузка остатков;
  • загрузка документов ТТН от поставщиков;
  • отправка актов подтверждения/отказа/расхождения по полученным ТТН;
  • загрузка документов справки Б от поставщиков;
  • выгрузка ТТН для покупателей;
  • отправка актов списания и постановки на Баланс;
  • отправка Чека на ресурс ЕГАИС для подтверждения легальности АП;
  • отправка запроса на повтор ТТН по WbRegId в случае случайного удаления из УТМ или своей УС;
  • запрос на движения продукции по идентификатору справки Б
  • и т. д.

Кроме того, разработан функционал по привязке кодов АП и контрагентов к соответствующим кодам ЕГАИС.

Работает как совместно с модулями Сборка заказов (реализация аля-партионного учета, с привязкой справок А и Б) и Логистическим модулем (заполнение транспортного раздела в ТТН) так и без них (если у Вас уже реализован данный функционал).

Обработка активно дописывается с целью повышения ее возможностей, удобства и гибкости.

 Подготовительный этап:

1. Приобрести ключевой носитель JaCarta PKI/ГОСТ SE или его аналог.

2. Выполнить требования входа в личный кабинет системы ЕГАИС, войти, скачать и установить УТМ (универсальный транспортный модуль).

3. Проверить работу УТМ. В браузере перейти по адресу установки УТМ (если установлен локально, то это: http://localhost:8080/) и убедиться в правильном его функционировании.

Видео-инструкции по процессу подключения и установки можно найти на сайте ЕГАИС.

Работа обработки:

1. После запуска на вкладке Настройки необходимо прописать каталоги для хранения БД соответствий кодов систем (кнопка Инициализация создает в указанном каталоге несколько файлов/таблиц БД, двух видов: все что получили от ЕГАИС и таблицы связей кодов), а также рабочий каталог для отправки и получения файлов, в нем же находится программка curl.exe. Заполнить Адрес УТМ, если установлен локально, то менять нечего не нужно (localhost:8080).

2. Заполнить поле FSRAR_ID, нажав на кнопку справа рядом, или заполнить вручную из свойств ключа JaCarta.

По Вашим предложениям появилась кнопка проверить УТМ.

3. Выбрать Вашу организацию и выполнить первый запрос по ней, ожидать ответа не обязательно!!! Все ответы на запросы и входящие документы можно загрузить в отложенном режиме после их появления на вкладке Входящие (кнопка Обновить и Загрузить ответы).

4. Далее, возможно сразу приступать к работе с Приходами/Расходами (при загрузке любого документа из этих Разделов, всё непривязанное, попадает в Раздел Справочники для отправки запроса… и последующей обработке), либо взяться за решение Главной задачи: Установить соответствие кодов ЕГАИС и Вашей УС. Здесь интерфейс надеюсь, интуитивно понятен….

 

В новой версии 2.4.0.3:

- Реализована поддержка версии 4 формата обмена Документами, стало возможно перейти как на версию 4 так и обратно на 3, добавлена поддержка отправки/получения документов и запросов 4-й версии...

- Добавлен контроль строка Годности АП, ужесточились меры по контролю срока годности АП, на примере пива контроль установлен в 1 год, если отгружается продукция со превышающим этот срок датой розлива, незамедлительно приходят письма от ФСРАР (даже если срок годности у продукции может быть и более длительный, надо быть готовым доказать это), поэтому в обработку добавлен функционал позволяющий отслеживать этот момент...

-  Добавлена проверка даты фиксации ТТН в ЕГАИС, при отправке ТТН добавлена проверка на соответствие даты фиксации ТТН, даты отправки и даты расходного документа. При обнаружении несоответствия выдается предупреждение и происходит корректировка дат. Это предотвращает возможные претензии со стороны ФСРАР на фиксации расходной ТТН после осуществления отгрузки. При этом причины такой ситуации могут быть абсолютно разными.. 

-  Реализована очередь отправки запросов в ЕГАИС, добавлен функционал по контролю и распределению запросов согласно ограничений по таймауту для определенных видов запроса, к примеру: существует ограничение в 10 мин. по запросу остатка марок в 3-м регистре (QueryRestBCode). Вы можете на Вкладке Остатки отметить необходимые для запроса позиции и нажать Запросить Марки... все запросы выстроятся в Очередь с интервалом отправки в 10 мин... и автоматически будут отправлены (таким же образом реализован механизм для отправки еще ряда запросов с ограничениями, в т.ч. и запрос остатков);
-  Доработан модуль Управления Марками Партий, добавлен функционал по помарочной Приемке входных документов и сборке Исходящих, а также управлением списком Марок АП находящихся на балансе организации (дв. клик по столбцу Марки в любой из вкладок позволит просмотреть/изменять или выбирать нужные  Марки  из  Партии), стало возможным отправлять на модуль Марки из разных Партий (Справок Б) отмеченных на вкладке Остатки, а также отмеченные Марки автоматически отправлять на вкладку Инвентаризация для дальнейшей обработки;
-  Добавлен  модуль  Проверки  марок  на  Check1.fsrar.ru, (дв. клик по столбцу  Идентификатор  ТТН позволит запросить статус на ресурсе прямо из обработки);
- Добавлена поддержка Истории Движения ТТН, для Входящих ТТН (в журнале по Идентификатору  ТТН  -  Показать  Движение  ТТН  или в приходе клик по Фиксации ЕГАИС),  полезно для  сверки с бумажными  документами  при  проверке Прихода;

- Добавлен функционал обслуживания Архива входящих документов, т.н. оптимизация Архива обязательная после/перед обновлением/переустановкой УТМ (все случаи когда нумерация входящий документов в УТМ начинается заново), а также ежемесячная рекомендованная процедура для повышения скорости работы обработки (перемещает документы в подкаталог по месяцам 201710).... 

 Добавлен функционал обслуживания Архива входящих документов, т.н. оптимизация Архива обязательная после/перед обновлением/переустановкой УТМ (все случаи когда нумерация входящий документов в УТМ начинается заново), а также ежемесячная рекомендованная процедура для повышения скорости работы обработки (перемещает документы в подкаталог по месяцам 201710).... 

- Добавлен функционал очистки нагруженных таблиц, т.н. оптимизация системы хранения если время записи в Журналы увеличилось неприемлемо воспользуйтесь этим (умная очистка журналов квитанций и актов, можно оставить в нагруженных таблицах только записи за последние две недели и только по проблемным ТТН), скорость обработки входящих возрастет...

- Доработан механизм заполнения документа Списание, теперь возможно заполнение из всех документов указанного вида за указанный период в режиме подбора и т.д.

- Реализован механизм установки цен на вкладке Розница, устанавливать можно как для всех строк так и для каждой, в ручную и автоматически.

- Добавлено автоматическое перемещение АП в ТЗ (Регистр 2) при подтверждении ТТН, устанавите на вкладке Настройки опцию Авто перемещение в ТЗ, и при Подтверждение ТТН все позиции документа будут отправлены в ТЗ.

- Реализована поддержка версии 2 формата обмена Документами, стало возможно перейти как на версию 2 так и обратно, добавлена во все таблицы информация о версии документов и версиях которые поддерживаются Контрагентами ... необходимую версию Исходящей ТТН можно задать в ручном режиме... на вкладке Справочники появилась кнопка запроса Версии... по которой отправляется пачка в 100 запросов (по Российским контрагентам)...

- Добавлен функционал создания документов Перемещение (как и ПоступлениеТМЦ) на основе ТТН Прихода...

- Добавлена дата отправки Акта, теперь Вы можете сами выбирать дату подтверждения ТТН в зависимости от логистики...

- Наведен порядок со статусами Документов,  отработаны все цепочки Отмены и Подтвержения Отмены проведения любых Актов...

- Проработана детальная запись логов всех операций влючая массовые отправки документов..протоколы сохраняются в каталогах пользователей...

- Добавлена фильтрация по Инвентаризационным документам, теперь легко можно найти Акты Списания/Постановки по конкретной АП...

- Добавлены Инвентаризационные документы в основной Журнал, Акты постановки на баланс и списания теперь можно также отбирать, загружать, отменять прямо из Журнала...при первоначальном заполнении все ранее отправленные Акты обработаются и информация появится в Журнале...

Добавлена в Журнал возможность ведения учета Розничных продаж (Чеков) - указываете каталог с файлами чеков Отправленных в ЕГАИС, вся информация по ним будет занесена в Журнал..

- Добавлен функционал по отмене проведения любых Актов, Акты ТТН (случаи случайного либо ошибочного отказа, расхождения, подтверждения), Акты списания и постановки на баланс.. отмену можно выполнить прямо на вкладке Журнала в меню Идентификатора Справки Б или Акта...

Передача Остатков отмеченных позиций в Акт списания или перемещение между  Регистрами, как в Торговый зал так и обратно ..(возможна как полная так и управляемая передача...)

Добавлен в Журнал расчет объема входящих/исходящих документов- возможно использование для подготовки / сверки деклараций..

Контроль на дублирование Марок при постановки на баланс, - функционал по загрузке в БД контроля  марок из Архива документов ранее поставленных на Баланс в ЕГАИС

- Формирование запросов на нечитаемые марки, - печать Кода с возможностью распечатки полученных от ЕГАИС штрих кодов PDF-417

- Списание товара из Модуля Управления Партиями, - заполнение фактических остатков партий, все излишки передать на списание...

Контроль остатков по двум регистрам ... 

Отложенный Чек, сохранение информации о Розничной продажи с возможностью его отправки после отложенной оплаты 

Переработан механизм прогрузки документов, увеличена скорость ...

Поддержка УТМ версии 4.0.2

Сверка движения партий в ЕГАИС и УС, теперь можно видеть расхождения в Приходах / Расходах ЕГАИС и УС...    

Разработан модуль управления партиями, теперь можно управлять и контролировать списанием партий в ЕГАИС...    

Схема привязки партий(Справок Б) для АП имеющей множественные связи организована через Справки А..

Добавлена оптимизация в распределение Справок Б/Партий при создании Расходной ТТН, теперь партии назначаются: 1) с учетом минимизации количества партий (мелкие партии уходят первыми)... 2) с учетом минимизаци получаемых остатков, в пределах одной Даты Розлива...    

Добавлен функционал по поддержке Документов вида Перемещение между Подразделениями/Складами, на вкладке Справочники по колонке Вид Контрагента можно Добавить его в Склады Организации, и при загрузке документов Перемещение сопоставляется назначенный склад ... 

Учтены основные предложения исправлены ошибки, оптимизирована многопользовательская работа, повышена скорость работы обработки... 

- Добавлены новые функции упраления при работе с расходными ТТН, в ручном режиме возможно выбирать партии, ставить в резерв и т.п.

- Реализована связь один ко многим в обе стороны (один алкокод много кодов УС и наоборот...) подсвечиваются данные позиции, для корректного приема приходной ТТН можно указать на какую позицию принять АП... 

Список конфигураций работы с УТМ, позволяет задавать настройки переключения между разными УТМ,

Журнал документов с системой статусов документа, позволяет отображать весь текущий документооборот с ЕГАИС, 

- подгружать входящие, исходящие ТТН, Акты расхождений и т.п. 

- проводить массовую обрабтку входящих (создавать документы системы, привязывать ранее введенные к электронным приходным ТТН)

-отказываться за получателя... 

Вкладка Инвентаризация, которая содержит функционал формирования и отправки Актов Постановка на Баланс (для постановки неучтенной алкогольной продукции на баланс в системе ЕГАИС) и Актов Списания АП (для удаления из системы ЕГАИС утраченной продукции)...

Массовая отправка отмеченных ТТН... выберите журнал Документы по покупателям за определенный период ... отметьте документы для отправки ... нажмите отправить ... все..

- Добавлена возможность массовой загрузки БарКодов (марок) из файлов 2-х форматов, представлены примерами...

позволит Вам быстро поставить на баланс массу позиций, просто сканируйте в файл и подавайте на загрузку....

Вкладка Розница отправка Чека некого Магазина, на ресурс ЕГАИС для подтверждения легальности АП...

Для использования этого функционала Вам необходим Сканер, если АП то 2D (марки). 

- Флаг «State» в таблицу описания Контрагенты, который указывает на подключен или нет к ЕГАИС, чтобы не отправлять ТТН впустую.

- Флаг «TTN» в таблицу описания Номенклатуры, который указывает на то что Товар поступил в систему из ТТН (очень важно!!! в свете появления дублей в кодах ЕГАИС).

Все таблицы с кодами и описаниями данных принятых от ЕГАИС, расположены в заданном Вами каталоге, их можно посмотреть любым редактором .dbf файлов.

- Переработаны таблицы хранения соответствий и информации из ЕГАИС.

- Проверка на превышение остатков системы ЕГАИС.

- Отработана цепочка всех Актов, квитанций, подтверждений... 

- Отдельная обработка Помощника v1.6. Реализованы механизмы управления привязками кодов (удаление/изменение/привязка).  Предложения принимаются..

Добавлена возможность РАСПЕЧАТАТЬ, ВЫГРУЗИТЬ в EXCEL любого из ресурсов (Товары Контрагенты Остатки)

- Доработан вариант получения Справок А по полученным из ЕГАИС Остаткам АП.

- Добавлен Виды документов Прихода и Расхода используемые в Вашей УС..

- Добавлены многочисленные проверки запросов перед их отправкой…

Далее…

Жду Ваших вопросов и предложений …

P.S.

Друзья в архиве Инструкция Пользователя версии 1.2 :(...

Гарантия возврата денег

ООО "Инфостарт" гарантирует Вам 100% возврат оплаты, если программа не соответствует заявленному функционалу из описания. Деньги можно вернуть в полном объеме, если вы заявите об этом в течение 14-ти дней со дня поступления денег на наш счет.

Программа настолько проверена в работе, что мы с полной уверенностью можем дать такую гарантию. Мы хотим, чтобы все наши покупатели оставались довольны покупкой.

Для возврата оплаты просто свяжитесь с нами.

Специальные предложения

Вознаграждение за ответ
Показать полностью
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. 1ckpp 18 14.11.15 09:11 Сейчас в теме
Очень нужная обработка. Сейчас присматриваюсь какую купить в каталоге инфостарта и на просторах интернета. Эта наиболее приглянулась для типовой ТИС 77. Подожду еще с недельку, наверное остановлюсь на этой.
221. trofimovalexey 14.12.15 04:36 Сейчас в теме
Подправил:Спр. НоменклатураЕГАИС
Функция ИННКПП(Конт,реж) 
Если Реж=1 Тогда
Возврат Производитель.ИНН;
Иначе
Возврат Производитель.КПП;	
КонецЕсли;
	
КонецФункции 

 Процедура ОбработкаПодбора(ВыбЗнач, КонтФормыПодбора)
	
Сообщить(ВыбЗнач);	
КонецПроцедуры // ОбработкаПодбора()           

Процедура ПриНачалеРедактированияСтроки()
        // ТМЦ=СоздатьОбъект("Справочник.Номенклатура");
		Параметр	= СоздатьОбъект("СписокЗначений");
	Если флЛитраж=1 Тогда  Параметр.ДобавитьЗначение(Литраж			, "Литраж");иначе Параметр.ДобавитьЗначение(, "Литраж");	КонецЕсли;	
 	Если флПроизводитель=1 Тогда  	Параметр.ДобавитьЗначение(Производитель	, "Производитель");	КонецЕсли;
	Если флИмпортер=1 Тогда  	Параметр.ДобавитьЗначение(Импортер		, "Импортер");КонецЕсли;	
	Если флКатегория=1 Тогда  	Параметр.ДобавитьЗначение(Категория	, "КодТов");иначе Параметр.ДобавитьЗначение(, "КодТов");КонецЕсли;	
   	Параметр.ДобавитьЗначение(НашаНоменклатура	, "НашаНоменклатура");	
	Параметр.ДобавитьЗначение(глВзятьКонтекст(Контекст)	, "Контекст");	

		// открываем форму 
 	ОткрытьФормуМодально("Справочник.Номенклатура.ЕГАИС", Параметр);  
	
	
	
		Сообщить( Параметр.Получить("НашаНоменклатура").ТекущийЭлемент());
		НашаНоменклатура= Параметр.Получить("НашаНоменклатура").ТекущийЭлемент();



КонецПроцедуры

Процедура ПриВыбореСтроки()
	
	// Форма может быть открыта для выбора из процедур ПриНачалеВыбораЗначения()
	// в модальном режиме. В этом случае результат выбора передается передается
	// через параметр формы.
	
	Форма.Параметр = ТекущийЭлемент();
КонецПроцедуры // ПриВыбореСтроки()       
флЛитраж=1;
флПроизводитель=0;
флИмпортер=0;
флКатегория=1;

Показать

Спр.Номенклатура Форма Списка ЕГАИС
Перем Парам;
Перем Литр,Креп,Пр,Имп,КодТов;
Процедура П() 
ИерархическийСписок(0,0);
ИспользоватьСписокЭлементов();
СписОтбора= СоздатьОбъект("СписокЗначений");
    
    СпрТовары= СоздатьОбъект("Справочник.Номенклатура");
    СпрТовары.ВыбратьЭлементы();

	Пока СпрТовары.ПолучитьЭлемент() = 1 Цикл
    Если Число(Литр)<>0 ТОгда
		Ст("есть отбор по Литражу:"+Строка(Литр));
		Если СпрТовары.Литраж<>Литр Тогда Продолжить; КонецЕсли;
	КонецЕсли; 
	
    Если Число(Креп)<>0 ТОгда
		Ст("есть отбор по Крепости:"+Строка(Креп));
		Если СпрТовары.Крепость=Креп Тогда Продолжить; КонецЕсли;
	КонецЕсли;
	  
    Если Число(КодТов)<>0 ТОгда
		Ст("есть отбор по Категории:"+Строка(КодТов));
		Если Число(СпрТовары.Категория.Код)<>Число(КодТов) Тогда Продолжить; КонецЕсли;
	КонецЕсли;
	
    Если СОКРЛП(ПР)<>"" ТОгда
		Ст("есть отбор по ПР:"+Строка(Производитель));
Если (Пр.ИНН=Производитель.ИНН)и(Пр.КПП=Производитель.КПП) Тогда иначе Продолжить; КонецЕсли;
	КонецЕсли;	
	
    Если СОКРЛП(Имп)<>"" ТОгда
		Ст("есть отбор по Имп:"+Строка(Производитель));
Если (Пр.ИНН=Производитель.ИНН)и(Пр.КПП=Производитель.КПП) Тогда иначе Продолжить; КонецЕсли;
	КонецЕсли;	
	
            СписОтбора.ДобавитьЗначение(СпрТовары.ТекущийЭлемент());
    КонецЦикла;
                                     
    ИспользоватьСписокЭлементов(СписОтбора);
    

КонецПроцедуры  

Процедура ПриНачалеРедактированияСтроки()            
		Параметр = "Выбор";

	КонецПроцедуры  
	
		
	
	
Процедура ПриВыбореСтроки()
Сообщить(1);             

	Форма.Параметр.Установить("НашаНоменклатура",ТекущийЭлемент());
	Форма.Параметр.Установить("СтатусВозврата", 1);
	Форма.Закрыть();
	 	Возврат;
    
	
КонецПроцедуры // ПриВыбореСтроки()



Функция ИННКПП(Конт,реж) 
Если Реж=1 Тогда
Возврат Производитель.ИНН;
Иначе
Возврат Производитель.КПП;	
КонецЕсли;
	
КонецФункции 






Процедура ПриОткрытии()    
	
		Если ТипЗначенияСтр(Форма.Параметр) <> "СписокЗначений" Тогда
		Предупреждение("Форма вызывается только для целей подбора партий в документе!", 60);
		СтатусВозврата(0);
		Возврат;
	КонецЕсли;
	 
	Литр	= Форма.Параметр.Получить("Литраж");   
	Сообщить(Литр);
	Креп		= Форма.Параметр.Получить("Крепость");
	Пр= Форма.Параметр.Получить("Производитель");
	Имп		= Форма.Параметр.Получить("Импортер");
	КодТов		= Форма.Параметр.Получить("КодТов");
 	НашаНоменклатура		= Форма.Параметр.Получить("НашаНоменклатура");
 	Сообщить("Подбор с применением фильтров Литраж:"+Строка(Литр)+Строка(", Крепость: ")+Строка(Креп)+Строка(", Пр:")+Строка(Производитель.ИНН)+Строка(", Производитель КПП:")+Строка(Производитель.КПП));

	 П() ;   
//	Форма.Параметр.Установить("СтатусВозврата"	, 0);
	
	
	 
  
	 
		Форма.ОбработкаВыбораСтроки(1);

		
КонецПроцедуры  


Процедура ПриПовторномОткрытии()
ПриОткрытии() ;
КонецПроцедуры  



Показать
477. trofimovalexey 24.12.15 06:54 Сейчас в теме
Процедура ДобавитьВсехКонтеров(ЗначПод) 
	СООБЩИТЬ(ЗначПод);
		Если ЗначПод = "Контрагенты" Тогда							
		С=Создатьобъект("Справочник.Контрагенты");
		С.ВыбратьЭлементы();   
		сч=0; 
		Пока С.ПолучитьЭлемент()=1 Цикл
		  Стр = 0; 
		  	Если (СТРДЛИНА(сокрлп(С.ИННЮрЛица))<>10) Тогда   пРОДОЛЖИТЬ;		КонецЕсли;
 	 		Если	(ИННТЗ.НайтиЗначение(С.ИННЮрЛица,Стр,"INN")=1) Тогда  пРОДОЛЖИТЬ;		КонецЕсли;			
					
	//дубли
д=0;
ИННТЗ.ВыбратьСтроки();
стр=0;
Пока ИННТЗ.ПолучитьСтроку()=1 Цикл
стр=стр+1;
Если ИННТЗ.НайтиЗначение(СокрЛП(С.ИННЮрЛица),Стр,"INN")=1 Тогда Сообщить(С.ИННЮрЛица); д=1; Прервать;		КонецЕсли;			
КонецЦикла;

		    Сообщить(С);
Если д=0 ТОгда
			
            сч=сч+1;

//			Если сч>10 Тогда
//			    прервать;
//			КонецЕсли;    
			
			
	      	
				
		
			ИННТЗ.НоваяСтрока();					
			ИННТЗ.УстановитьЗначение(сч,1,2);
			//Сообщить(ShortName);
			ИННТЗ.ShortName = С.Наименование; 	
			ИННТЗ.INN = СОКРЛП(С.ИННЮрЛица); 
				КонецЕсли;
				КонецЦикла;
				КонецЕсли;

КонецПроцедуры
Процедура ДобавитьВсехПР(ЗначПод) 
	СООБЩИТЬ(ЗначПод);
		Если ЗначПод = "Производители" Тогда							
		С=Создатьобъект("Справочник.Производители");
		С.ВыбратьЭлементы();   
		сч=0;
		Пока С.ПолучитьЭлемент()=1 Цикл
				  Стр = 0; 
    Если (СТРДЛИНА(сокрлп(С.ИНН))<>10) Тогда   пРОДОЛЖИТЬ;		КонецЕсли;
 		
	//дубли
д=0;
ИННТЗ.ВыбратьСтроки();
стр=0;
Пока ИННТЗ.ПолучитьСтроку()=1 Цикл
стр=стр+1;
Если ИННТЗ.НайтиЗначение(СокрЛП(С.ИНН),Стр,"INN")=1 Тогда  д=1;Сообщить(С.ИНН); Прервать;		КонецЕсли;			
КонецЦикла;

		    Сообщить(С);
Если д=0 ТОгда
            сч=сч+1;
//			Если сч>10 Тогда   прервать;КонецЕсли;    
			
			ИННТЗ.НоваяСтрока();					
			ИННТЗ.УстановитьЗначение(сч,1,2);
			//Сообщить(ShortName);
			ИННТЗ.ShortName = С.Наименование; 	
			ИННТЗ.INN = СОКРЛП(С.ИНН); 
			КонецЕсли;
				КонецЦикла;
				КонецЕсли;

КонецПроцедуры

Процедура РаботаСоСписком(Режим,Таблица,ТипСправочника)
	Перем ТекПоз;
	Перем ТекЭлемент;
	Перем Фрм;

	ТекПоз = Таблица.ТекущаяСтрока();

	Если Режим="Добавить" Тогда		// добавляем в список один элемент
		СписокПодбора = Таблица;
		СправочникПодбора = ВРег(ТипСправочника);
		// открываем окно подбора
		ОткрытьПодбор("Справочник."+ТипСправочника,,Фрм,0,ТекЭлемент);
		Фрм.ВыборГруппы(1);		

	ИначеЕсли Режим="ДобавитьНесколько" Тогда  // добавляем в список несколько элементов
		СписокПодбора = Таблица;
		СправочникПодбора = ВРег(ТипСправочника);
		// открываем окно подбора
		ОткрытьПодбор("Справочник."+ТипСправочника,,Фрм,1,ТекЭлемент);
		Фрм.ВыборГруппы(1);
	ИначеЕсли Режим="ДобавитьВсе" Тогда  // добавляем в список несколько элементов
ДобавитьВсехКонтеров(ТипСправочника);

	ИначеЕсли Режим="ДобавитьВсеПР" Тогда  // добавляем в список несколько элементов
ДобавитьВсехПР(ТипСправочника);

 	ИначеЕсли Режим="УдалитьВсе" Тогда	// удаляем все элементы из списка
		Таблица.УдалитьСтроки();

	ИначеЕсли Режим="Удалить" Тогда	// удаляем из списка один элемент
		Если ТекПоз>0 Тогда
			Таблица.УдалитьСтроку(ТекПоз);
		КонецЕсли;
	КонецЕсли;

КонецПроцедуры		// работа со списком
Показать

Кнопки глобальных запросов
957. serg63 1 19.01.16 00:18 Сейчас в теме
Возникла небольшая проблема, если меняем УТМ, то проверка УТМ выдает номер версии первой УТМ, при которой заходили в обработку. Нужно выйти из обработки,
оставив вторую УТМ и снова зайти в обработку, тогда будет работать правильная проверка УТМ для второй УТМ. Увидел это,т.к. стояли разные УТМ рабочая и тестовая на разных фирмах. Вызов проверки УТМ "ПолучитьFSRAR_ID(1)", здесь стоит цифра 1. Берет только текущую строку УТМ.
1169. xmxcrew 02.02.16 17:29 Сейчас в теме
Добрый день!

При приеме накладных от нескольких поставщиков вываливается

АПТЗ.AlcVolume = СокрЛП(ПолучитьЭлемент(хмл_Товар,"AlcVolume";).Text);
{C:\2.0\EGAIS (1)\EGAIS\OBMEN_EGAIS.ERT(3508)}: Значение не представляет агрегатный объект (Text)

понятно что они что-то намудрили с типом переменной, но что с этим делать если они наотрез отказываются у себя что-то менять, аргументируя это тем что с другими контрагентами никаких проблем нет.
1910. victuan 4063 05.10.16 19:58 Сейчас в теме
rvs-slim, небольшие замечания по загрузке внешних компонент (1с++, FormEx):
1) 1с++ рекомендуется загружать перед FormEx, а не наоборот
2) перез загрузкой внешних компонент предлагаю делать проверку, не были ли они загружены ДО запуска обработки Obmen_egais.ert. Иначе Формекс будет недоступна у вас для использования, а 1с++ загрузиться дважды.

Предлагаю следующее изменение кода:
		ПлюсыЗагужены = 1;
		Попытка
			Модуль = СоздатьОбъект("ВыполняемыйМодуль"); //проверка того, что 1С++ была уже загружена
		Исключение
			//Компонента Отображения сетки
			Если ЗагрузитьВнешнююКомпоненту("1cpp.dll")=0 Тогда
				СообщитьПр("Неудачная попытка загрузить  1cpp.dll Некоторые функции будут недоступны !!!");
				ПлюсыЗагужены = 0;
			КонецЕсли;
		КонецПопытки;  
		
		Если ПлюсыЗагужены = 1 Тогда
			Попытка
				МетаИнфо = СоздатьОбъект("MetaInfoClasses");
				Версия = МетаИнфо.ПолучитьВерсиюФайла();
			Исключение
				СообщитьПр("Для корректной работы необходимо использовать 1с++ версии не ниже 3.0.0.0");
				ПлюсыЗагужены = 0
			КонецПопытки;
		     
			Если (Число(Версия) < 3) и (ПлюсыЗагужены=1) Тогда
				СообщитьПр("Для корректной работы необходимо использовать 1с++ версии не ниже 3.0.0.0");
				ПлюсыЗагужены = 0
			КонецЕсли;
			
			Если ПлюсыЗагужены = 0 Тогда
				СообщитьПр("Неудачная попытка загрузить  1cpp.dll Некоторые функции будут недоступны !!!");
			КонецЕсли;   
		КонецЕсли;   

		Попытка
			//Компонента расскраски строк
			глСервис_FormEx = СоздатьОбъект("Сервис");
		Исключение
			Если ЗагрузитьВнешнююКомпоненту("FormEx.dll") = 0 Тогда //
				//СообщитьПр("Неудачная попытка загрузить FormEx.dll Некоторые функции будут недоступны !!!");
			КонецЕсли;
		КонецПопытки;

		Попытка
			Если ПустоеЗначение(глСервис_FormEx)=1 Тогда
				глСервис_FormEx = СоздатьОбъект("Сервис");
			КонецЕсли;
			глСервис_FormEx = СоздатьОбъект("Сервис");
			//разрешаем использование раскраски таблиц
			глСервис_FormEx.ВключитьРаскраскуТаблиц();
			//добавляем индикатор клавиатуры и часы в статус бар
			глСервис_FormEx.ПоказыватьИндикаторКлавиатуры(1);
			//глСервис_FormEx.УстановитьОбои("Logo",5,0);
			глДопМодуль = 0;
		Исключение
			СообщитьПр("Неудачная попытка загрузить FormEx.dll Некоторые функции будут недоступны !!!");
		КонецПопытки;
Показать
(1910) victuan,
спс, так и сделаем.. :)
2. zaoproxy 39 14.11.15 20:29 Сейчас в теме
К обработке прилагается инструкция по подключению и использованию?
3. Техподдержка 14.11.15 22:19
Основные шаги и содержание архива (что для чего нужно) есть в описании.. Если будет этого недостаточно, добавлю инструкцию к применению... Напишите...
4. kerrik249 16.11.15 02:59 Сейчас в теме
Здравствуйте, возможно ли в планах : ведение электронного журнала продаж.
Работа с УТМ на кассе.
5. ivanov_alex 57 16.11.15 07:13 Сейчас в теме
купил обработку, вопрос в следующем: как с обновлениями? каждый раз покупку делать? или есть какой то период на бесплатное обновление?
Далее по самой обработке
вот этот участок в функции записатьфирму() пишет неверный код соответствия.
			Справочник=СоздатьОбъект("Справочник.Контрагенты");
			Если Справочник.НайтиПоКоду(Зн) = 1 Тогда
				Эл = Справочник.ТекущийЭлемент();
				ТекстПривязкиСтр = "Код: "+Эл.Код+" "+Эл.Наименование+" ИНН/КПП: "+Эл.ИННКПП+" Адрес: "+Эл.АдресАкцизногоСклада;
				Если Справочник.НайтиПоКоду(Code) = 1 Тогда
					Эл = Справочник.ТекущийЭлемент();
					ТекстПривязкиНов = "Код: "+Эл.Код+" "+Эл.Наименование+" ИНН/КПП: "+Эл.ИННКПП+" Адрес: "+Эл.АдресАкцизногоСклада;
					Если Вопрос("В БД обнаружена привязка кодов!!!("+СокрЛП(ClientRegId)+")"+РазделительСтрок+"Найдена:"+ТекстПривязкиСтр+РазделительСтрок+"Новая:"+ТекстПривязкиНов+РазделительСтрок+"Заменить на новую?","Да+Нет",60)  <> "Да"  Тогда
						Возврат 0;
					КонецЕсли;	  						
				КонецЕсли;	  							
			КонецЕсли;	  		        	
Показать

делаю запрос по производителю при записи в БД сначала ошибка, ругается на отстутсвие поля иннкпп, когда руками прописываешь .юрфизлицо.ИНН делает запись о контрагенте-производителе,но код берет из юрфизлица а не из контрагента-в торговле спрачоник юрлиц и контрагентов разный
как быть в этой ситуации?
korsar2001; Ovrfox; LVA1; +3 Ответить
11. Техподдержка 17.11.15 00:20
(5) ivanov_alex, Друзья для тех кто купил обработку, обновления как писал выше, полностью бесплатны...
Текущая версия 1.2 (на 16.11.2015)
по процессу обновления: предлагаю, кому необходимо, выслать в личку свою почту или логин, (я знаю, что некоторым нужна только "рыба"...)
6. zaoproxy 39 16.11.15 09:13 Сейчас в теме
Вопрос к тем кто уже приобрел обработку: насколько легко интегрируется?

Предложение к создателю: думаю что инструкция, хоть в самом минимальном варианте, для конечных пользователей нужна. Типа интеграцию провел, дал инструкцию пользователям и пусть учатся пользоваться.
7. ivanov_alex 57 16.11.15 09:44 Сейчас в теме
(6) zaoproxy, распаковал архив, посомтрел подключены ли 1cpp и formex если нет, отдельная папка там бантик нужно запустить один раз
потом открываешь обработку в базе, заполняешь фсрарИД и пользуешься
если поля по другому называются адаптируй под себя
8. Tarlich 103 16.11.15 10:34 Сейчас в теме
Поступление и сопоставление - ГУД!!! а планируется допиливание для розницы (ЧЕК ККМ)?
12. Техподдержка 17.11.15 00:28
(8) Tarlich,
а планируется допиливание для розницы (ЧЕК ККМ)?
Да, по Чеку если требуется сделаю вкладку для розницы...
9. ivanov_alex 57 16.11.15 15:21 Сейчас в теме
при сопоставлении номенклатуры открывается форма для выбора, но выбирать не дает, открывает карточку номенклатуры, если жмешь закрыть возвращает пустой параметр и ошибку про параметр.код
как пофиксить?
10. askv 24 16.11.15 22:21 Сейчас в теме
Есть вопросы к автору:
Через какие объекты сделано чтение, запись XML и отправка XML к УТМ?
Используется ли curl?
На каких по размеру XML тестировалась обработка?
13. Техподдержка 17.11.15 00:37
(10) askv,
Код полностью открыт, размер XML? Сколько АП разных производителей не грузил, занимает не более 3 сек.
14. dvoinik 10 17.11.15 07:35 Сейчас в теме
Добрый день. Есть конфигурация "Бизнес-Логика: Винно-водочная Торговля. Стандартная версия, ред. 9.291 (Торговля+Склад)" Пойдет эта обработка для нее? Где хранятся справочники соответствия? Данные о товаре и контрагенте ЕГАИС? (Алко код, ID контрагента и тд.) Возможно будет доработать ее самостоятельно ? (между структурными подразделениями делается документ перемещение)
18. Техподдержка 17.11.15 20:26
(14) dvoinik,
Добрый день. Есть конфигурация "Бизнес-Логика: Винно-водочная Торговля. Стандартная версия, ред. 9.291 (Торговля+Склад)" Пойдет эта обработка для нее?
Подойдет, на ней и пишется…
Где хранятся справочники соответствия? Данные о товаре и контрагенте ЕГАИС? Данные о товаре и контрагенте ЕГАИС?
Локально в указанном Вами месте, при первом запуске обработки (задаем каталог хранения и жмем кнопку Инициализация) Несложно доработать и хранить где угодно механизм одинаковый, код открыт…, но мне кажется это лишним, так как всего позиций .. ну не более 10 тыс. а это в поиске соответствий доли сек. И накоплений здесь не происходит… Таблица соответствий максимально облегчена… и т.п.
Возможно будет доработать ее самостоятельно ? см. выше…
15. s_v_p 17.11.15 16:45 Сейчас в теме
Добрый день! В этой обработке есть или будет добавлен механизм ввода начальных остатков АП для оптовиков пива?
(15) s_v_p, (467) Brad,
В помощнике..удалить привязку
16. viktorn 17.11.15 18:56 Сейчас в теме
Если приобретаю сейчас, есть ли возможность и как получить последующие изменения?
17. Техподдержка 17.11.15 20:15
(16) viktorn,
Обработка приобретается один раз!
Обновление:
1 вариант: Вы получаете ссылку на скачивание, она действительна для Вас бесконечно долго (так объяснил представитель инфостарта), при обновлении версии, по той же ссылке Вы еще раз скачиваете уже обновленный архив.
2 вариант: Вы делаете запрос с указанием почтового адреса покупки программы, далее обновления Вы получаете на почту по запросу (Здесь я постараюсь оперативно указывать новую версию…)
19. Техподдержка 17.11.15 23:24
Друзья поступают однотипные вопросы, отвечу здесь:
1.Насколько рабочая и проверенная в работе с реальнымы накладными?
Сейчас идет тестовый режим работы с ЕГАИС, все накладные отправленные Поставщиками (производители/Импортеры/Оптовики) в системе видны и загружаются..на основе их создаются приходные накладные в учетной системе… Все обработанные поступления (составлен какой либо из Актов) видны в остатках… Выбрав Расходный документ формируется ТТН .. и т.п. а вот насколько данные циркулирующие в системе сейчас Реальны? Сомневаюсь, данные тестовые (в этом легко убедится загрузив АП от производителей… видны явные ляпы…)
2.Много ли придется переделывать? Думаю, что нет.. тем более от помощи и техподдержки я не отказываюсь, а с учетом Ваших предложений доработаем до хорошего уровня, кроме того эта обработка работает в реально существующей организации, где имеет место и опт и розница...
20. mootriskoff 18.11.15 08:50 Сейчас в теме
Цитата:
"В обработке реализован весь функционал обмена:
- загрузка справочных данных по контрагентам, производителям, импортерам алкогольной продукции;"

Вы работаете на людей, которые торгуют алкоголем?

Адольф Шикельгрубер (Гитлер): «Население должно быть сокращено наполовину. Никакой гигиены. Только водка и табак».

Парижская Хартия ещѐ 1975 года определила: «К 2025 году население России не должно превышать 20-25 миллионов человек».

Работаете на нацистов?

Помогаете уничтожать население России?
25. ivanov_alex 57 18.11.15 18:01 Сейчас в теме
(20) mootriskoff, мы помогаем правительству избавить и без того пьющих людей от паленки и контрафакта, торгуя качественным продуктом, вспомните 90-е годы и засилие контрафакта на алкорынке и как следствие черезмерный рост смертности от этого контрафакта
запретите людям пить и они вам свернут за это голову. проверено неоднократно
21. enter 16 18.11.15 09:07 Сейчас в теме
Хорошо было бы еще сделать формирование Журнала розничных продаж - фиктивного, конечно же, но с максимальным приближением к реальности (т.е. с учетом приходов, рандомным списанием в течение заданного пользователем периода). Ведь это одна из основных проблем розничных продавцов, у которых не автоматизирован товарный учет - закупку подтвердить то подтвердим через Вашу обработку, а вот вести Журнал предстоит вручную.
22. Гость 18.11.15 09:10
Нельзя ли выложить пробную версию?
23. sodrk 18.11.15 09:42 Сейчас в теме
Будет работать на 1С 7.7 Бухгалтерский учет, ред.4.5(один из последних релизов)?
24. viktorn 18.11.15 15:26 Сейчас в теме
Инструкция по работе есть?
Если есть то можно выслать nv_velsk@mail.ru
26. s_v_p 18.11.15 21:44 Сейчас в теме
Добрый день. Купил обработку. Указал код ФС РАР.
1) Важно ли расположение каталогов с данной обработкой (локально или на сервере)?
2) Каким образом проверить подключены ли DLL? при запуске файла с регистрацией, выходит сообщение "Не удалось загрузить модуль ..."
3) Делаю запрос по организации - "21:39:19 - Запрос справочника по ИНН ... Файл "reply.xml" не найден!"
4) Делаю запрос по контрагенту - "21:39:49 - Запрос справочника по ИНН 7726260234
Файл "reply.xml" не найден!"

Во входящих ничего нет, при обновлении "Файл "\\...\Torg\EGAIS\Temp\reply.xml" не найден!"
Что делаю не так? Как проверить работает ли обработка?

При запросе через cmd:
Microsoft Windows [Version 6.1.7601]
© Корпорация Майкрософт (Microsoft Corp.), 2009. Все права защищены.

C:\Users\Администратор>curl -X GET http://localhost:8080/opt/out
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<A>
<url>http://localhost:8080/opt/out/FORMBREGINFO/1</url>;
<url>http://localhost:8080/opt/out/WAYBILL/2</url>;
<url>http://localhost:8080/opt/out/WAYBILL/3</url>;
<url>http://localhost:8080/opt/out/FORMBREGINFO/4</url>;
<url>http://localhost:8080/opt/out/WAYBILL/5</url>;
<url>http://localhost:8080/opt/out/FORMBREGINFO/6</url>;
<url>http://localhost:8080/opt/out/WAYBILL/7</url>;
<url>http://localhost:8080/opt/out/WAYBILL/8</url>;
<url>http://localhost:8080/opt/out/FORMBREGINFO/9</url>;
<url>http://localhost:8080/opt/out/FORMBREGINFO/10</url>;
<url>http://localhost:8080/opt/out/WAYBILL/11</url>;
<url>http://localhost:8080/opt/out/FORMBREGINFO/12</url>;
<url>http://localhost:8080/opt/out/WAYBILL/13</url>;
<url>http://localhost:8080/opt/out/FORMBREGINFO/14</url>;
<url>http://localhost:8080/opt/out/WAYBILL/15</url>;
<url>http://localhost:8080/opt/out/FORMBREGINFO/16</url>;
<ver>1</ver>
</A>
27. s_v_p 18.11.15 23:37 Сейчас в теме
Поискал файл reply.xml , нашел в папке "C:\Windows\".
мне кажется проблема в строке определения ФайлОтвета , в нем нет явного указания пути:

Процедура ПолучитьСписокДокументов(ДопИнфо =0)
ФайлОтвета = "reply.xml";
КомандаСистемыСрипт("curl.exe -X GET http://"+СокрЛП(АдресУТМ)+"/opt/out?refresh=true"+">"+ФайлОтвета);
28. Техподдержка 19.11.15 00:12
(27) s_v_p,
Посмотрите вкладку Настройки
Должно быть примерно так:
Каталог хранения файлов обмена: C:\TT\Temp\
Каталог БД соответствий:C:\DemoDB\ExtForms\EGAIS\
Если у Вас не так исправьте...
По dll: система вероятно Win7 x64? тогда используйте regsvr32, из каталога syswow64
38. s_v_p 19.11.15 14:27 Сейчас в теме
(28)

Поменял каталог хранения файлов обмена на C:\TT\Temp\.
Каталог БД соответствий оставил в сетевой папке.
Заработало только после того, как я скинул в C:\TT\Temp\ ранее скаченный curl для своей системы.
По dll: у меня система W7x32, так их и не зарегистрировал, хотя брал regsvr32 из системы, скопировал dll везде где можно и вот чудо, при работе с запросами 1Cpp сама зарегистрировалась ""1С++ Загружен. Требуется открыть обработку еще раз!"".

В итоге запросы приходят, разбираюсь с соответствиями: пока не понятно, почему не доступны кнопки "Отвязать контрагента" и "Отвязать номенклатуру", что если не так привязали?
39. ivanov_alex 57 19.11.15 17:28 Сейчас в теме
(38) s_v_p, думается модуль в разработке, поэтому
29. Техподдержка 19.11.15 00:24
Указанные в настройках каталоги должны СУЩЕСТВОВАТЬ!!!
И еще, попробуйте запросить остатки...
и посмотреть http://localhost:8080/opt/in/
Текущая версия обработки 1.3 (добавлена вкладка Розница)
30. ivanov_alex 57 19.11.15 06:50 Сейчас в теме
(29) акты постановки на баланс будут? и когда ждать?
31. Техподдержка 19.11.15 07:22
Следующим обновлением (30) ivanov_alex,
32. serg75 19.11.15 07:35 Сейчас в теме
У меня при запуске curl.exe сообщение, что версия C://TT/Temp/curl.exe не совместима с версией Win 7. У меня 32 разрядная Максимальная. При запуске Установить.bat регистрируется только OcvitaBarcode.ocx, библиотеки 1CPP.dll и FormEx.dll не регистрируются (пишет не удалось загрузить модуль)
33. serg75 19.11.15 11:27 Сейчас в теме
Наконец заработало после того как скачал пакет curl http://curl.haxx.se/dlwiz/?type=bin и кинул curl.exe в папку C:/TT/Temp. Остается только вопрос с регистрацией модулей из папки DLL
34. serg75 19.11.15 12:19 Сейчас в теме
Не долго музыка играла... Запросы формируются (На вкладке Справочники в таблице Запросы в ЕГАИС по нашей организации появляется ЗапросИД). Выскакивает окно ожидания или отмены. Делаю отмену. Жду 10 мин. Нажимаю кнопку Проверить/Загрузить ответы. Перехожу на вкладку Входящие. Жму кнопку Обновить и Загрузить ответы. Все таблицы пустые. Новую версию обработки 1.3 скачал и переустановил. В чем проблема.
35. serg75 19.11.15 12:42 Сейчас в теме
Еще такой вопрос. Почему нигде не указывается КПП подразделения, ведь сертификаты и ключи на JaCarta привязаны к нему.
36. Техподдержка 19.11.15 13:51
Правильно я понял: по Вашему ИНН ответ системы пуст. Т.е. фирм с таким инн в ЕГАИС не зарегистрировано? Обычно ситуация обратная на один инн есть множество подразделений среди которых по кпп надо выбрать свою...
41. serg75 20.11.15 06:06 Сейчас в теме
(36) Здравствуйте. Как таких фирм не зарегистрировано, если я получил из ЕГАИС сертификат RSA на КПП обособленного подразделения. Проверил также в сводном реестре лицензий на fsrar.ru . По нашему ИНН указано 3 разных КПП и 3 разных адреса деятельности. Один КПП по месту регистрации организации и 2 КПП по обособленным подразделениям. При входе в личный кабинет ЕГАИС тоже показывает 3 адреса деятельности и 3 КПП. По одному из них и получил RSA сертификат. И снова тот же вопрос почему не регистрируются модули из DLL ? Объясните подробней куда их кидать и как запускать регистрацию ?
37. Техподдержка 19.11.15 13:54
И на вкдадку Входящие переходить не обязательно. На той же вкладке есть кнопка Загрузить ответы...
40. s_v_p 19.11.15 21:58 Сейчас в теме
Ошибка: после привязке номенклатуры во многих позициях повторяются кодБД (на закладке приход и справочники).
Предложение по улучшению: при привязке (синзронизации) номенклатуры, сделать поиск по производителю/крепости/емкость/кодАП
48. s_v_p 20.11.15 13:56 Сейчас в теме
(40) s_v_p,

Снимаю вопрос по дублям - это один товар с разными справками А и Б, но появились новые:
1) делаю "Акт подтверждения" , как понять прошло все или нет?
2) что будет, если я удалю все запросы и документы без подтверждения прихода, они так и будут висеть неподтвержденные где-то в недрах ЕГАИСа?

И все-таки хотелось бы получить подробную инструкцию, чтобы не задавать глупых вопросов

Еще одно предложение: при поиске товаров не показывать те из них, которые уже привязаны
50. Техподдержка 20.11.15 21:00
(48) s_v_p,
1) делаю "Акт подтверждения" , как понять прошло все или нет?
У Вас во Входящих должны появиться квитанции…
Сейчас работаю на тем, чтобы все Входящие документы выстраивались в Дерево, т.е. Вы получили ТТН (+ справки Б), подтвердили ее Актом, получили квитанции…
все эти документы должны объединиться в ветку, посмотрим должно получиться нагляднее…
Ну и конечно результат Вашего Акта должен отразиться на Остатках.

2) что будет, если я удалю все запросы и документы без подтверждения прихода, они так и будут висеть неподтвержденные где-то в недрах ЕГАИСа?
Думаю если Вы НЕ будете реагировать на Входящие документы (не подтверждать прием товара), то больше отгрузок от Вашего Дорогого Поставщика Вы не дождетесь…
Поставщик в свою очередь приобрел право за Вас отправить Акт отказа….
52. s_v_p 21.11.15 13:28 Сейчас в теме
(50)

1) делаю "Акт подтверждения" , как понять прошло все или нет?
У Вас во Входящих должны появиться квитанции…
Сейчас работаю на тем, чтобы все Входящие документы выстраивались в Дерево, т.е. Вы получили ТТН (+ справки Б), подтвердили ее Актом, получили квитанции…
все эти документы должны объединиться в ветку, посмотрим должно получиться нагляднее…
Ну и конечно результат Вашего Акта должен отразиться на Остатках.

Я бы предложил: при удачном подтверждении акта удалять приход со справками из входящих (с вопросом), может быть при этом на всякий случай сохранить во временную базу на какой-то период , но и там ее удалять по прошествию например 7 дней.

2) что будет, если я удалю все запросы и документы без подтверждения прихода, они так и будут висеть неподтвержденные где-то в недрах ЕГАИСа?
Думаю если Вы НЕ будете реагировать на Входящие документы (не подтверждать прием товара), то больше отгрузок от Вашего Дорогого Поставщика Вы не дождетесь…
Поставщик в свою очередь приобрел право за Вас отправить Акт отказа….

я немного про другое спрашивал, про опасность того, что пользователь случайно удалит из входящих приход, этот вопрос перекликается с первым, если приходы будут удаляться автоматом после актов, то и пользователю незачем ползать во входящих и удалять все вручную
53. Техподдержка 21.11.15 20:09
(52) s_v_p,
Ок! Давайте вместе над этим подумаем (обсудим предлагайте)...
А пока сделаем:
-Акт постановки на баланс;
-Акт о списании товара;
-Проверку любых исходящих движений товара на соответствие остаткам в ЕГАИС;
-Продвинутого Помощника управлением связями кодов ЕГАИС и нашей УС;
-Архивные каталоги, куда будем сохранять все полученные/сформированные документы…
42. serg75 20.11.15 07:27 Сейчас в теме
Проверил в браузере http://localhost:8080/opt/in/ свои запросы. XML cписок запросов показывает, их уже стоит 18 такого вида <url replyId="222b3c2c-0010-43fc-ab57-36e17d830221">http://localhost:8080/opt/in/QueryPartner/18</url>; Набираю адрес ответов http://localhost:8080/opt/out/ - пустая страница
43. Техподдержка 20.11.15 08:09
По dll: у кого какие-то проблемы с регистрацией модулей пишите в личку. Вышлю регистрилку..
44. Техподдержка 20.11.15 08:13
При отправке запроса по орг проверьте файл запроса в части корректности ИНН
45. Техподдержка 20.11.15 08:33
УТМ это служба на Вашем компе и судя по аходной очереди все запросы от обработки она получает. Проверьте связь с серверами ЕГАИС. ..
46. serg75 20.11.15 08:38 Сейчас в теме
По каким адресам проверить связь
47. trofimovalexey 20.11.15 11:26 Сейчас в теме
<A>
<error>org.xml.sax.SAXParseException; cvc-pattern-valid: Value '' is not facet-valid with respect to pattern '[0-9]{9}' for type 'KPPType'.</error>
<ver>2</ver>
</A>

я понял, что 'KPPType' нет в обработке. в описании утм тоже нет. а в схемах есть.
49. пользователь 20.11.15 14:04
Сообщение было скрыто модератором.
...
51. Техподдержка 20.11.15 21:22
Дорогие друзья! Писать инструкцию, к сожалению, абсолютно нет времени.
Пытаюсь все сделать дружелюбно и понятно, цена обработки считаю вполне адекватна, для того чтобы самим немного вникнуть…
А небольшая «Помощь» создается Здесь при обсуждении с Вами ее работы…
Спасибо за понимание..
Жду Ваших предложений...
54. trofimovalexey 22.11.15 09:37 Сейчас в теме
Будет ли реализован Акт постановки на баланс, как у опта? Тут примеры есть. http://egais2016.ru/forum/viewtopic.php?f=2&t=377
55. trofimovalexey 22.11.15 09:45 Сейчас в теме
Напишите свой электронный адрес. есть пару вопросов.
56. trofimovalexey 23.11.15 03:57 Сейчас в теме
https://www.youtube.com/watch?v=93H80Or5-RY&feature=youtu.be
Тут грамотно сделан справочник НоменклатураЕГАИС. К нему уже подцепляется штатная номенклатура. Я бы сделал по аналогии.
57. trofimovalexey 23.11.15 03:59 Сейчас в теме
Если у вас есть распределенная база данных, каким образом будут передаватся дбф? по мне так-этот подход не совсем правильный.
58. Техподдержка 23.11.15 07:09
(57) trofimovalexey
При работе с ЕГАИС распределннности не нужно. Работа со справочником в последней версии оптимизирована Вы скоро это увидите. ..используется Помощник.
83. ilyins 27.11.15 06:01 Сейчас в теме
(57) trofimovalexey,
У нас распределенная база. Сомнения о возможности работать с одной папкой синхронизации не покидают и меня.
В версии 1.4 решена эта задача?
84. Техподдержка 27.11.15 07:10
(83) ilyins,
Алексей, для решения задачи по распределенности необходимо таблицы хранения соответствий реализовать в конфигурации и вкл в раср. обмен, но здесь об автономности обработки тогда можно забыть. .
Если многим это нужно, пишите здесь..
Будут желающие сделаем.. или сделаем второй вариант с изменением конфы..
Хотя Код открыт можете сами это сделать. .
85. knight 27.11.15 07:38 Сейчас в теме
(84) заказал обработку отдал счет в бухгалтерию, думаю сегодня оплатят. в идеале бы обращения к хранимым данным локализовать в отдельных процедурах/функциях.
Чтобы люди с распределенками или теми кому просто удобнее хранить соотвествия, коды и тд в самой 1с подправили бы один раз эти места под себя и при обновлениях обработки просто копировали пару процедур,а не лопатили весь код. Еще вопрос судя по скриншотам ттн-ки покупателям отправляются по одной. А какой-то пакетный режим планируется?
P. S. спасибо вам от всех семерочников, помогаете многим людям неоценимо!
88. ilyins 27.11.15 08:07 Сейчас в теме
(85) knight, Еще одна проблема может возникнуть из-за дублей номенклатуры и контрагентов в ЕГАИС - 1 позиция в 1с должна включать в себя несколько позиций из ЕГАИС.
59. Phanat0m 23.11.15 07:50 Сейчас в теме
Добрый день, в вашей обработке определение "справки Б" прихода ТТН определяется по полю
<wb:InformB>
<!--Раздел Б - ид записи предыдущей отгрузки (по которому продукция поступила на склад)-->
<pref:InformBItem>
<pref:BRegId>000000000000008</pref:BRegId>
</pref:InformBItem>

из самой ТТН, что, вроде, в корне не корректно, ибо это справка-б прихода товара к нашему поставщику.

У нас же данные по справке Б надо получать из файла FORMBREGINFO, где в поле
<wbr:InformBRegId>TEST-FB-000000000668534</wbr:InformBRegId>
хранятся нужный нам номер справки Б.

или я не правильно понимаю?
60. Phanat0m 23.11.15 07:59 Сейчас в теме
Либо уж вводить 2 свойства для номенклатуры - это справка б входящая и поставщика
61. sodrk 23.11.15 10:36 Сейчас в теме
Будет работать на 1С 7.7 Бухгалтерский учет, ред.4.5(один из последних релизов)?
62. trofimovalexey 24.11.15 04:37 Сейчас в теме
Еще столкнулся спроблемой, в Егаим адреса выглядят так РОССИЯ,,ТВЕРСКАЯ ОБЛ,Конаковский р-н,,Новозавидовский пгт,Первомайский пер,д. 1,, , однако страну и регион нужно отправлять кодом.
63. trofimovalexey 24.11.15 04:38 Сейчас в теме
Еще столкнулся спроблемой, в Егаисе адреса выглядят так: РОССИЯ,,ТВЕРСКАЯ ОБЛ,Конаковский р-н,,Новозавидовский пгт,Первомайский пер,д. 1,, , однако страну и регион нужно отправлять кодами.
68. Техподдержка 24.11.15 20:25
(63) trofimovalexey,
Алексей, а какая здесь проблема-то? Или в формировании адресов у Вас получается что-то некорректное?
64. serg75 24.11.15 10:18 Сейчас в теме
Здравствуйте. Если при запросе остатков прервать ожидание ответа, то как позже результат ответа получить в таблицу остатков ?
66. Техподдержка 24.11.15 20:14
(64) serg75,
Во вкладке Водящие (после кнопки Обновить) загружаются все входящие Документы, в текущей версии они отсортированы по типу и дате прихода,
соответственно самый последний Документ Остатки содержит самые актуальные данные, ставим на нем Отметку и жмем Загрузить ответы….
Переходим на вкладку Остатки, там все должно уже быть…
65. Пользователь 1С 3 24.11.15 15:42 Сейчас в теме
Добрый день! Обработку уже приобрели. Спасибо! А как получить новую версию? И неплохо бы описание, хотя бы краткое. Например не понятно, нажали "Акт подтверждения", в сообщении написала "отправка акта". Как понять, отправилось (добралось) до ЕГАИС наше подтверждение?
67. Техподдержка 24.11.15 20:22
(65) Пользователь 1С
Новая версия проверятся и дорабатывается (что-бы у Вас возникало меньше трудностей, думаю на этой неделе выйдет)…
А как получить новую версию? См. выше…
Например не понятно, нажали "Акт подтверждения", в сообщении написала "отправка акта". Как понять, отправилось (добралось) до ЕГАИС наше подтверждение?
В ответ должны прийти две квитанции… и Товар (подтвержденный) появиться в Остатках… Кстати, этот вопрос поднимался чуть выше…
Далее, планируется сделать Архив входящих документов, после этого успешно подтвержденные документы можно будет автоматически удалять…
70. Пользователь 1С 3 25.11.15 10:28 Сейчас в теме
(67) Вы имеете по "см выше" в виду перечитать ветку или это написано в описании? Я так понял, появится ссылка для скачивания? И всё же, краткая инструкции не помешала бы. Я, к примеру, минут 10 прокопался, пока понял, как каталоги задать) впрочем, как программист, Вас понимаю, в нашей работе самое нудное и грустное, это писать инструкции, которые потом никто не читает (я про пользователей - бухгалтеров) :)
72. Техподдержка 25.11.15 20:19
(70) Пользователь 1С,
Ссылку на скачивание Вы уже получили при первом скачивании обработки...
74. serg75 26.11.15 06:50 Сейчас в теме
(72) Здравствуйте. Версия 1.4 доступна для скачивания или нет ?
69. trofimovalexey 25.11.15 09:17 Сейчас в теме
разобрался. тут вот еще нашел интересное http://egais2016.ru/forum/viewtopic.php?f=3&t=427
а свой вопрос я тут разместил. http://egais2016.ru/forum/viewtopic.php?f=2&t=379&start=10 что-то не уходят ттн. квитанция с ошибкой возвращается.(
71. Техподдержка 25.11.15 20:18
(69) trofimovalexey,
Да Алексей спасибо, в версии 1.4 уже изменен тип идентификаторов в таблицах на строковые (кнопка Модернизировать БД)
(действительно проблема в "отсутствии" организации в ЕГАИС, вероятно кроется в потери нулей слева при преобразовании строки в число)..
73. nico2 6 26.11.15 02:51 Сейчас в теме
Здравствуйте, подскажите пожалуйста, есть ли версия данной обработки под 1С. Бухгалтерия УСН 1.3 Если есть отпишите с удовольствием приобретем.
75. serg75 26.11.15 07:19 Сейчас в теме
Каким образом поставить на баланс в ЕГАИС конечные остатки из декларации ?
76. Техподдержка 26.11.15 08:33
(75) serg75,
Как заявлено: ТОЛЬКО ПОМАРОЧНО!
но посмотрим...
77. serg75 26.11.15 08:39 Сейчас в теме
(76) Я имел ввиду через обработку остатки в ЕГАИС можно или нет. И все таки версия 1.4 доступна или нет ?
79. trofimovalexey 26.11.15 15:28 Сейчас в теме
(76) 2 числа в Москве будет совещание по опту. мне непонятна позиция фирмы 1с. есть к примеру утап 195-последний релиз. там учет ведется по сериям. ждать новое обновление придётся если они примут помарочное сканирование, а время на исходе. как-то у них все про розницу и про розницу. я очень благодарен данному автору, что он вселяет надежду для решения общей проблемы- пережить 1января+получить неплохой набросок для опта. пока я только со справочниками работаю+ документы попытался отправить. в утап не работает ничего. выводы:
78. alenaalenkina 26.11.15 12:13 Сейчас в теме
Добрый день, вчера приобрели вашу обработку, только в версии 1.3, как нам можно скачать либо получить 1.4. Спасибо.
80. al-greka 26.11.15 15:49 Сейчас в теме
Добрый день! Можно электронный адрес. Есть работа по адаптации ТиС, измененной под торговлю пивом.
81. kirlog 91 26.11.15 18:21 Сейчас в теме
Купил. Плюсую.
Однако - ошибка имеет место при отправке акта расхождений.
В запросе два раза повторяется wa:Content
Это потому, что в процедуре ОтправитьАкт()
Дважды встречается:
...
Content = WayBillAct.appendChild(DOMDocument.createElement("wa:Content"));
...
ИначеЕсли Вид=3 Тогда
...
Content = WayBillAct.appendChild(DOMDocument.createElement("wa:Content"));
...

УТМ это не ест. Давится ошибкой.

И ЕЩЕ:
Ошибка в в логике этой же процедуре:
В строке: ПриходТЗ.RealQuantity<ПриходТЗ.Quantity нужно бы поствить знак <=
А то ругань идет по каждой строке, где факт равен кол-ву поставщика.

82. Техподдержка 26.11.15 20:56
Друзья поступает типовой вопрос про версию 1.4!
К концу недели будет доступна для обновления и скачивания, хочется реализовать большинство Ваших предложений указанных и в форуме и в личке, по удобству, ясности, и минимизации ошибок… Спасибо..
86. dvoinik 10 27.11.15 07:50 Сейчас в теме
При запросе справочников пишет ошибки.
УзелA=DOMDocument.getElementsByTagName("A").item(0);
{D:\ALCOP\EGAIS\OBMEN_EGAIS.ERT(2021)}: Плохой тип переменной
87. dvoinik 10 27.11.15 08:00 Сейчас в теме
10:59:48 - Запрос отстаков
Создаем Msxml2.DOMDocument.6.0
Удачно создали Msxml2.DOMDocument.6.0
Создаем Msxml2.DOMDocument.6.0
Удачно создали Msxml2.DOMDocument.6.0
УзелA=DOMDocument.getElementsByTagName("A").item(0);
{D:\BASA1C_2015\ALCOP\EGAIS\OBMEN_EGAIS.ERT(2208)}: Плохой тип переменной
(87) dvoinik,
Посмотрите сам ответ (reply.xml) когда происходит ошибка «Плохой тип переменной».
Скорее всего с ним что то не в порядке, в личку файл-ответ скиньте… будет яснее...
89. trofimovalexey 27.11.15 09:03 Сейчас в теме
Сделайте кнопку, чтоб можно было посмотреть "в глаза" утм-у
WSShel = СоздатьОбъект("WScript.Shell");
WSShel.Run("explorer.exe http://"+АдресУТМ);

еще вот пару интересных ссылок:
http://egais2016.ru/forum/viewtopic.php?f=2&t=576
http://www.gazeta.ru/business/news/2015/11/26/n_7936241.shtml
90. viktorn 27.11.15 10:02 Сейчас в теме
Не регистрируются 1CPP.dll FormEx.dll
Windows 7 32
(90) viktorn,
Регистрилку .dll вышлю по запросу (с указанной почтой)...
Оставьте свое сообщение

См. также

АИС: Онлайн-кассы для 1С 7.7 (с поддержкой маркировки ЕГАИС, ТАБАКА, ОБУВИ, ЛЕКАРСТВ, МЕХА, ШИН, ОДЕЖДЫ и пр.) и Обмен с 1С 7.7 "Честный ЗНАК" (ГИСМТ, ЦРПТ, ЭДО) Промо

Фискальный регистратор Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v77::ОУ v77::БУ 1С7:Бух 1С7:Комплекс 1С7:ТиС Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Платные (руб)

Подключение фискального регистратора к 1С 7.7 в режиме онлайн-кассы (в соответствии с 54-ФЗ). Поддерживаются все изменения закона с 01.07.2019 и более поздних. Поддержка тегов 1227,1228,1229,1230,1231 и всех остальных. Поддержка тегов для комиссионеров и платежных агентов. Поддержка крайних версий драйверов ККТ: ДТО 10 и ДТО 8 для Атол, 4.15 для Штрих-М. Поддержка протоколов ФФД 1.0, 1.05, 1.1 и 1.2, развитые настройки для применения частичных оплат и авансов в оптовой и розничной торговле. Поддержка чеков коррекции всех версий. Поддержка розничной продажи маркированной продукции (ЕГАИС, табак, обувь, лекарства, шины, одежда, белье, парфюмерия и пр.), а также передача штрихкодов Средств Индивидуальной Защиты ("коронавирусный" закон). Возможно подключение без доработки конфигураций (см. список поддержки). Возможно подключение к любому виду документов, в котором или в документе-основании которого присутствует Номенклатура. Решена проблема с выводом любых скидок в чек без ошибки округления (!!!) и без изменения алгоритмов конфигурации 1С 7.7. Вывод ФИО кассира в чек в зависимости от смены и других параметров. Поддержка нескольких ККТ в одном сеансе работы. Вывод в чек ставок НДС (при необходимости). Вывод электронного чека (на е-майл, телефон) по требованию покупателя. Поддерживаются комбинированные типы оплаты: наличными и банковской картой с поддержкой автономного и интегрированного эквайринга (Сбербанк). Имеется режим эмуляции печати чека на ФР - для тестирования алгоритмов без использования реального ФР. Поддерживается печать произвольных нефискальных строк в чеке. Реализовано через внешние обработки обслуживания конфигураций без необходимости вносить изменения в конфигурацию 1С. Код разработки полностью открыт, подлежит любой модификации под свои потребности. **** Работа с маркировкой "Честный ЗНАК" (ЦРПТ) из 1С 7.7. ЭДО (табак, обувь, шины, одежда и прочих групп товаров) для розницы и опта (приемка и оптовая отгрузка маркированной продукции). **** Полный цикл работы из 1С 7.7 с ГИСМТ и СУЗ национальной системы маркировки "Честный знак" из 1С 7.7. На текущий момент поддерживаются: Описание GTIN через КМТ (Нац.Кат.), Заказ КМ через API, печать этикеток КМ (нанесение КМ), закрытие заказа КМ, Агрегация КМ, Дезагрегация КМ, Трансформация КМ, Ввод в оборот КМ, Списание КМ, Вывод из оборота КМ, Приемка / Отгрузка ГИСМТ, Приемка / Отгрузка эУПД через универсальную загрузку и отправку файлов XML. для любого оператора ЭДО, Интеграция с ЭДО lite, ЭДО СБИС, Подпись документов в ПО для отправки в ГИСМТ/СУЗ, Логирование запросов/ответов в ГИСМТ/СУЗ, Проверка статусов КМ, Проверка статусов документов.

2400 руб.

28.03.2017    372163    3771    3242    

Форма для ввода количества товаров

Разработка внешних компонент Оптовая торговля v7.7 1cv7.md УУ Платные (руб)

Расширяем уровень взаимодействия c пользователем с помощью новых возможностей - форма для ввода количества для перемещений и форма ввода количества с упаковками и штуками.

1200 руб.

08.09.2021    1272    0    2    

Переход с 1С:Комплексной 7.7 на 1С:УТ 10.3

Оптовая торговля Перенос данных из 1С7.7 в 1C8.X v7.7 v8 Платформа 1C v8.2 УТ10 1С7:Комплекс Россия УУ Платные (руб)

Начните вести учет в УТ 10.3! Перенесите все свои данные в УТ 10.3 в любом месяце года и продолжите вести учет! Программа перенесёт любое количество баз с документами и остатками в больших количествах. Обработка выгрузки выполнит проверку исходных данных и сформирует отчет о найденных ошибках в справочниках и документах. Партии переносятся с себестоимостью. Штрихкоды номенклатуры загружаются. Цена переносится. Автор консультирует.

7000 руб.

17.03.2021    4979    1    4    

Обработка обслуживания ККТ АТОЛ, платформа 5.0 с драйверами v10 для 1С:Торговля и Склад 9.2 (МАРКИРОВКА, частичные оплаты по ФФД 1.1, эквайринг Сбер)

Розничная торговля ККМ Оптовая торговля Эквайринг Фискальный регистратор v77::ОУ 1С7:ТиС Оптовая торговля, дистрибуция, логистика Россия УУ Платные (руб)

Данная обработка предназначена для работы с ККТ АТОЛ на платформе 5.0 с драйверами АТОЛ версии 10.7.0.0 и выше для 1С:Торговля и Склад 9.2 (в соответствии с 54-ФЗ). Проста в установке и настройке. Реализован учет маркируемой продукции. В поставку включена поддержка эквайринга на уровне драйверов (в данный момент – Сбер), реализован учет частичных оплат по ФФД 1.1, добавлены эмуляторы кассы и эквайрингового терминала, добавлена обработка генерации тестовых кодов маркировки.

1200 руб.

20.08.2020    11540    30    55    

Программа для управления ККМ Атол и Штрих нового поколения (он-лайн ККТ под 54-ФЗ) с помощью текстового файла (ini файла). Поддержка маркировки. Для 1с77, 1с8Х любых конфигураций Промо

Разработка внешних компонент WEB Кассовые операции ККМ Кассовые операции Фискальный регистратор Розничная торговля v7.7 v8 1cv8.cf 1cv7.md Россия БУ УУ Платные (руб)

FR_ATOL_SHTRIH.EXE встраивается в SYSTRAY (в правом нижнем углу, там где часы) и следит за появлением обычного текстового файла, в котором перечислено, какие операции необходимо осуществить с ККТ - напечатать чек (нал/безнал), снять Z-отчет, осуществить выемку денег, сделать возврат и т.д. Такой механизм позволяет использовать комплект для WEB сайтов, для нетиповых или сильно измененных 1с7 или 1с8. Для любых программ, которые умеют работать с текстовыми файлами (будь то CLIPPER,FOXPRO,JAVA, WSH, VBS итд). Внутри комплекта лежат готовые к использованию обработки для 1с8: УТ10, БП2, БП2Базовая, БП2Корп, УТ11, БП3, БП3Базовая, БП3Корп, Для 1С7.7:ТиС документ Реализация ТМЦ,Печать из ПКО, Бух4.5, Бух1.3 . Код на 1с открыт - используйте обработки комплекта, как шаблоны для своих программ. Подключать ККМ к 1С не надо! Более 3000 внедрений на ККМ Штрих и Атол. Некоторые из покупателей реализовали работу с ККМ даже из Excel и Axapta. Может работать одновременно с несколькими онлайн-кассами, либо одной с разных рабочих мест. (через RDP, TCP\IP)

20 стартмани

31.07.2017    102105    506    ah7777777    528    

АИС: Проверка и пакетная печать кодов маркировки из 1С 7.7 для всех групп товаров (ТАБАКА, ОБУВИ, ЛЕКАРСТВ, МЕХА, ШИН, ОДЕЖДЫ и пр.)

Оптовая торговля Розничная торговля v7.7 1cv7.md Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Легкая промышленность, мода и одежда Россия УУ Платные (руб)

С помощью обработки 1С 7.7 можно коды маркировки вводить вручную или загружать файлы в формате csv и печатать либо на ленту (принтер этикеток) либо на лист (офисный принтер). Есть возможность создать разные шаблоны этикеток с настраиваемым выводом текста и логотипа, с указанием числа рядов и столбцов при печати этикеток на офисный принтер. Имеется проверка штрихкодов на соответствие форматам согласно документа "Протокол информационного обмена (ОФД). Поддерживаются форматы всех товарных групп, подлежащих маркировке или участвующих в эксперименте (алкоголь, изделия из меха, табак, обувь, лекарства, текстиль, шины и т.д.) Выделение из ШК идентификаторов применения (AI) и их показ. Расшифровка максимальной розничной цены (МРЦ) из Datamatrix табака.

2000 руб.

12.03.2020    10662    13    0    

АИС: Обмен с ФГИС Меркурий (Ветис.API) для всех* конфигураций 1С 7.7

Обработка документов Внешние источники данных Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля v77::ОУ v77::БУ 1С7:Бух 1С7:Комплекс 1С7:ТиС 1С7:УСН Сельское хозяйство и рыболовство Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Пищевая промышленность Россия БУ УУ Платные (руб)

Полностью автоматизированный обмен между конфигурациями 1С 7.7 и ФГИС Меркурий через Ветис.API для всех видов деятельности (Опт, Розница, Производство). Для организации обмена с ФГИС Меркурий требуется минимальная доработка конфигураций (поддерживается "из коробки" 1С: "Торговля и склад ред. 9.2", 1С: "Комплексная ред. 4.5", 1С: "Бухгалтерия 7.7", 1С: "УСН 7.7", 1С Предприниматель, другие конфигурации по заказу, включая нетиповые и самописные). Модуль разработан таким образом, чтобы минимизировать затраты по внедрению в произвольную конфигурацию на базе 1С 7.7. Работа программного решения осуществляется без доработки типовых объектов конфигурации - добавляются новые справочники, документы и пр. без изменения существующих объектов метаданных. Это позволяет поддерживать и легко обновлять даже нетиповые конфигурации. * Благодаря продуманной архитектуре возможно внедрить программный продукт для произвольной конфигурации 1С 7.7. (включая нетиповые и самописные) в кратчайшие сроки на предприятии пользователя и начать обмен документами с отправителями и получателями подконтрольной продукции. Вы можете прямо сейчас БЕСПЛАТНО скачать демо-версию без ограничения по функционалу и опробовать решение в полном объеме перед покупкой. В данном программном продукте реализованы все технические требования Россельхознадзора по обмену в формате 2.0 и 2.1. Решение прошло опытную эксплуатацию и тестирование на крупных объектах всех видов деятельности: Производство, Опт, Розница.

3600 руб.

21.11.2018    37451    124    92    

Служба Windows для интеграции по HTTP-XML (для 1С и не только)

Внешние источники данных Обмен через XML WEB v7.7 v8 Россия Платные (руб)

Служба Windows, которая позволяет подключаться к различным источникам данных (в том числе и 1с), выполняет сформированные запросы, и возвращает результат в формате XML. Устанавливается и настраивается максимум за 1 час. Обеспечивает простой способ для односторонней интеграции систем. Позволяет подставлять в запрос параметры.

3500 руб.

09.10.2018    13240    0    13    

SALE! 17%

Система управления запасами в 1С – min-max.pro Промо

Рабочее место Финансовый учет и бюджетирование (FRP) Оптовая торговля Розничная торговля Финансовый учет и бюджетирование (FRP) Оптовая торговля Розничная торговля Управление торговлей Загрузка и выгрузка в Excel v7.7 v8 КА1 УТ10 Розница УПП1 УНФ УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан УУ Платные (руб)

Система управления запасами для 1С min-max.pro помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28200 23406 руб.

21.04.2017    54107    27    33    

Обмен с системой Меркурий (полный цикл) через Ветис.API для 1С 7.7

Внешние источники данных Оптовая торговля Оптовая торговля v7.7 1cv7.md Сельское хозяйство и рыболовство Оптовая торговля, дистрибуция, логистика Пищевая промышленность БУ Платные (руб)

В обработке реализован полный цикл работы с ГИС Меркурий из 1С на платфоме 7.70.027 (поддерживается конфигурация "Торговля и Склад") через Ветис.API: реализованы процедуры обмена с подсистемами заявок и справочников Ветис.API в формате 2.0.

4800 руб.

03.07.2018    28197    70    25    

Как переходили с 7-ки на 8-ку. Пример небольшого розничного магазина

Перенос данных из 1С7.7 в 1C8.X Бухгалтерский учет Розничная торговля Ценообразование, анализ цен Розничная торговля Ценообразование, анализ цен v8 v77::ОУ 1С7:ТиС УТ11 Розничная и сетевая торговля (FMCG) УУ Абонемент ($m)

Пример проекта из нашей практики - перевод учета в небольшом розничном магазине с 1С v7 Торговля и Склад на 1С v8 Управление Торговлей. Какими инструментами пользовались, какие вопросы возникали на проекте.

1 стартмани

15.05.2018    17200    Kutuzov    15    

Работа с онлайн-кассой Википринт Viki Print 57Ф из 7.7

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v77::ОУ 1С7:ТиС Россия БУ УУ Платные (руб)

Работа с кассами Википринт (производитель DreamKas) и Пирит из конфигураций под платформу 1С 7.7

5500 руб.

24.04.2017    38334    143    140    

Проверка, корректировка, пересчёт документов и создание счетов-фактур с получением дополнительных данных из файлов xls

Обработка документов Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ТМЦ Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ТМЦ v7.7 1С7:Комплекс БУ УУ Платные (руб)

Внешняя обработка "Проверка и корректировка документов" позволяет корректировать и обрабатывать одновременно группу документов, таких как "Возврат товаров от покупателя", "Возврат товаров поставщику", "Реализация" и "Поступление ТМЦ", создавать новые документы "Счет-фактура выданный" и "Счет-фактура полученный", получая дополнительные данные из файлов xls.

4500 руб.

15.11.2016    17505    1    2    

Распределение товаров между складами (подразделениями) для 1С: УТ 11, УНФ, УТ 10.3, УПП, и 1С 7.7 ТиС Промо

Обработка документов Розничная торговля Учет ТМЦ Розничная торговля Учет ТМЦ v77::ОУ v8::ОУ УТ10 1С7:ТиС УПП1 УНФ УТ11 УУ Платные (руб)

Данная обработка служит помощником для распределения товарных запасов между различными складами. В качестве необходимой информации для анализа, руководитель в отчете может наблюдать: 1. Остатки по выбранным складам 2. Продажи с каждого из складов за выбранный период 3. Возможна группировка по свойствам номенклатуры

5900 руб.

08.07.2011    42095    18    0    

Продажа для контрагента от нескольких фирм

Рабочее место Оптовая торговля Оптовая торговля v77::ОУ 1С7:ТиС Розничная и сетевая торговля (FMCG) Россия УУ Платные (руб)

Данная обработка предназначена для выписывания документов реализация в разрезе фирм, в зависимости от  наличия остатков на складе.

1600 руб.

29.08.2016    13983    0    1    

АИС: Обмен с ЕГАИС 4.0 для конфигураций 1С 7.7

Обработка документов Внешние источники данных Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v77::ОУ v77::БУ 1С7:Бух 1С7:Комплекс 1С7:ТиС Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия БУ УУ Акцизы Платные (руб)

Полностью автоматизированный обмен между конфигурациями 1С 7.7 и универсальным транспортным модулем (УТМ) ЕГАИС для всех видов деятельности (Опт, Розница, Производство, Импорт). Для организации обмена с ЕГАИС требуется минимальная доработка конфигураций (поддерживается 1С: "Торговля и склад ред. 9.2", 1С: "Бухгалтерия 7.7", 1С: "УСН 7.7", другие конфигурации по заказу, включая нетиповые). Возможна работа программного решения без доработки типовых объектов конфигурации - добавляются новые справочники, документы и пр. без изменения существующих объектов метаданных. Это позволяет поддерживать и легко обновлять даже нетиповые конфигурации. Возможно внедрение программного продукта отдельно от учетной системы пользователя или вообще без существующей у пользователя учетной системы. В этом случае данный продукт является самостоятельной конфигурацией, позволяющей полностью автоматизировать прием и отправку ТТН без привязки их к данным учетной системы пользователя. Это позволит в кратчайшие сроки внедрить программный продукт на предприятии пользователя и начать обмен документами с отправителями и получателями алкогольной продукции. В данном программном продукте реализованы все технические требования ФСРАР по обмену с УТМ ЕГАИС (включая отправку чеков розничных продаж в ЕГАИС - требование с 01.07.16). Поддержана фиксация чеков ЕГАИС на онлайн-кассах (в соответствии с 54-ФЗ). Поддержана версия 3 документооборота и поштучный (помарочный) учет. Поддержан эксперимент Татарстана по маркировке нефасованного (кегового) пива.

13.12.2015    115730    152    victuan    398    

Функции для работы с транспортным модулем (УТМ) ЕГАИС + готовая конфигурация для ЕГАИС

Обработка справочников Универсальные функции Оптовая торговля Оптовая торговля v77::ОУ 1С7:ТиС Розничная и сетевая торговля (FMCG) Государственные, бюджетные структуры Пищевая промышленность УУ Акцизы Платные (руб)

Предлагаю вашему вниманию функции для использования в целях обмена данными с универсальным транспортным модулем ЕГАИС. При доработке учетной системы с целью интеграции с транспортным модулем ЕГАИС, я столкнулся с серьезной проблемой, связанной с тем, что внешняя компонента V7Plus, предназначенная для работы по протоколу HTTP, а также для разбора XML-файлов, поддерживает только команду GET протокола HTTP, в то время как для работы с УТМ требуется поддержка команд GET, POST и DELETE. P.S. Обновлены все функции и обработки для поддержки XML-ответов больше 100Кб (теперь длина неограничена). Также добавлена обработка выгрузки расходной накладной. Добавлена загрузка приходной накладной, а также диапазона марок из справки А. Внимание! добавлена полностью готовая к работе конфигурация для работы в ЕГАИС оптовых поставщиков. Реализованы следующие функции: автоматическая загрузка накладных и доп. форм из ЕГАИС, отправка актов подтверждения/отклонения/расхождения, загрузка справок А и Б, загрузка сведений о поставщике/производителе, загрузка справочников номенклатуры по ИНН производителя, постановка на баланс учтенного/не учтенного в ЕГАИС товара, штрихкодирование поступления/инвентаризации/реализации/постановки на учет (DataMatrix и PDF417), формирование партий на складе а также электронная выгрузка деклараций по формам 5,6,7,11,12. В дальнейшем могу оказывать сопровождение

4000 руб.

27.10.2015    39988    237    64    

Загрузка документов "Поступление", "Отгрузка", "Счет на оплату" из Excel в Бухгалтерию 7.7

Загрузка и выгрузка в Excel Обработка документов Оптовая торговля Оптовая торговля v77::БУ 1С7:Бух БУ Платные (руб)

Обработка загружает из файла Excel документы "Поступление", "Отгрузка", "Счет на оплату". Возможно сохранение настройки соответствия полей. Есть демоверсия. Есть интересная функция загрузки сразу и поступления, и отгрузки (цены в отгрузке будут установлены больше на выбранный процент). Элементы номенклатуры ищутся по полям поиска и могут создаваться новые, если не найдены.

7800 руб.

02.06.2015    33945    3    5    

Выгрузка книги продаж и книги покупок, декларации НДС 2015, 2019 20% из 1С 7.7 в "Налогоплательщик ЮЛ"

Обмен через XML Регламентированная отчетность Оптовая торговля Производство готовой продукции (работ, услуг) Оптовая торговля Производство готовой продукции (работ, услуг) v77::БУ 1С7:Бух Россия БУ НДС Платные (руб)

Обработка для переноса выставленных и полученных счетов-фактур из "Бухгалтерии 7.7", "Подрядчик Строительства", “Производство+Услуги+Бухгалтерия 7.7”, "Торговля и Склад 7.7", "Комплексной 7.7", еФарма в "Налогоплательщик ЮЛ" (программа с сайта nalog.ru ФНС), СБИС, Контур-Экстерн, Такском (формат 5.04, 5.06 в 2019 году). В новой декларации НДС добавлены, в числе прочих, разделы 8 и 9, которые содержат данные книги покупок и книги продаж соответственно. Ручной ввод большого количества информации не всегда оправдан, поэтому с помощью этой обработки можно выгрузить счет-фактуры из существующей базы, а для сдачи декларации использовать программу от ФНС “Налогоплательщик ЮЛ” или напрямую выгружать в СБИС или онлайн-сервисы (Такском, Контур и т.п.).

6000 руб.

02.03.2015    117480    24    56    

Конфигурация "Информационный киоск". Обработки выгрузки товаров для ТиС 9.2, УТ 10.3, УТ 11 (обмен данными с любой конфигурацией 1С 7.7, 8.х)

Управление услугами и сервисом Управление торговлей Оптовая торговля Розничная торговля Перенос данных из 1С7.7 в 1C8.X 1С7.7<->1C7.7 Оптовая торговля Розничная торговля v7.7 v8 1cv8.cf 1cv7.md Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд УУ Платные (руб)

Конфигурация предназначена для организации offline доступа клиента (покупателя) к информации о товарах, услугах или дисконтных картах посредством сканирования штрих-кода. Основная цель – мгновенно предоставить наиболее актуальную информацию о цене, остатках, наименовании товара (услуги) или накоплениях, держателе, состоянии дисконтной карты.

1500 руб.

21.12.2014    48785    5    20    

Загрузка номенклатуры в справочник и документ из файла Excel и CSV, обновление цен и реквизитов (адаптируется под разные конфигурации 1С: 7.7)

Загрузка и выгрузка в Excel Обработка справочников Обработка документов Внешние источники данных Оптовая торговля Розничная торговля Ценообразование, анализ цен Оптовая торговля Розничная торговля Ценообразование, анализ цен v7.7 1cv7.md УУ Платные (руб)

Загрузка номенклатуры в справочник и документ, обновление цен, реквизитов, подчинённых справочников из файла Excel и CSV в 1С7.7. Формирует структуру групп (иерархию), создаёт полностью готовый справочник. Выгружает товары прайс-листа в документы Поступление, Реализация, Заказ, Оприходование, Отчет ККМ и другие. Автоматически адаптируется под разные конфигурации 1С7.7, в которых есть справочник номенклатуры.

1500 руб.

04.12.2014    66213    35    56    

ТСД: WMS: 7.7: обработки для ТСД, операция "Перемещение", рабочая конфигурация

Терминал сбора данных Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v7.7 1cv7.md Оптовая торговля, дистрибуция, логистика УУ Платные (руб)

Рабочая конфигурация (без ограничений, без паролей/шифрований/защиты) обеспечивающая выполнение на ТСД в режиме подключения к терминальному серверу через RDP-клиент (онлайн работа складского персонала, непосредственно в базу 1С) складскую операцию "Перемещение" из ячейки в ячейку каких-либо ТМЦ. Разрешение экранных форм 480x640. Озвучка событий. Конфигурация с прилагаемым набором обработок может быть использована как основа/шаблон для программирования/создания производственных операций на ТСД для выполнения линейным складским персоналом.

4500 руб.

08.04.2014    33665    3    33    

Пакетный ввод документов при продаже через посредника - Интеркампани

Обработка документов Оптовая торговля Оптовая торговля v8 v77::ОУ КА1 УТ10 УПП1 1С7:Комплекс 1С7:ТиС Россия БУ Платные (руб)

Для уменьшения налогооблагаемой базы, частенько общества с ограниченной ответственностью (ООО и ЗАО, ОАО) продают изначально товар собственному ИП-шнику. Который в свою очередь реализует товар физическим лицам по ЕНВД.

3000 руб.

23.11.2012    20732    5    1    

Загрузка данных на сайт “1С: Сайт управляющей компании ЖКХ, ТСЖ и ЖСК”

Внешние источники данных Обмен через XML WEB v7.7 1cv7.md Энергетика и ЖКХ Россия Платные (руб)

Обработка позволяет загружать данные в формате xml из любой конфигурации 1С 7.7 на сайт “1С: Сайт управляющей компании ЖКХ, ТСЖ и ЖСК” (разработан на базе платформы «1С Битрикс»).

1000 руб.

17.10.2012    35020    0    0    

Выгрузка данных из 1С (7.7) в Интернет-магазин через CSV файл (обработка)

WEB Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v7.7 1С7:Бух 1С7:Комплекс 1С7:ТиС 1С7:ПУБ Платные (руб)

Универсальная обработка "Выгрузка данных в Интернет-магазин" и Универсальная обработка "Выгрузка справочной информации в Интернет-магазин" для программ 1С:Предприятие 7.7 предназначены для формирования файла в формате CSV по шаблону из табличного файла.

1500 руб.

16.07.2012    36312    8    15    

Загрузка данных в 1С (7.7) из файла БАП (блока автономной памяти) или ТСД

Внешние источники данных Терминал сбора данных Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v77::ОУ 1С7:ТиС Платные (руб)

Обработка "Т77. Загрузка данных из файла блока автономной памяти (БАП) или терминала сбора данных (ТСД)" Предназначена для работы в конфигурации "1С:Торговля и Склад 7.7". Результатом ее работы является создание или заполнение документов произвольного вида, имеющих реквизит "Номенклатура" в своем составе, данными из файла переноса информации. Исходные данные берутся из текстового файла, созданного программным обеспечением блока автономной памяти (БАП) 011,012,013. Этот файл состоит из строк, содержащих штрих-код товара и как вариант - количество, отделенное запятой. Пример строк текстового файла: 0000000000100,1 4607028751400,6 4607108477466,4 или 0000000000100 4607028751400 4607108477466

1000 руб.

29.05.2012    24852    2    1    

Автоснятие просроченных заявок (резервов)

Оптовая торговля Обработка документов Оптовая торговля v77::ОУ 1С7:ТиС Россия УУ Платные (руб)

1C v.7.7 Готовое решение. Не требует настройки. Не требует допрограммирования. Обработка предназначена для автоснятия просроченных заявок (резервов) покупателей.

1000 руб.

01.07.2009    69957    19    21    

Выгрузка платежек в банк-клиент ОАО ДАЛЬКОМБАНК

Обмен с банком Обработка документов Внешние источники данных Банковские операции Банковские операции v77::ОУ v77::БУ 1С7:Бух 1С7:ТиС Россия Платные (руб)

Выгрузка платежек в банк-клиент ОАО ДАЛЬКОМБАНК для 1С Бухгалтерия 7.7 общ, УСН. Выгрузка-загрузка в банк-клиент ОАО ДАЛЬКОМБАНК для 1С Торговля + Склад 7.7.

3000 руб.

17.06.2009    18218    0    9    

Прайс-органайзер 7.7: Загрузка прайс-листов и документов произвольного формата из Excel в 1С

Оптовая торговля Учет ТМЦ Ценообразование, анализ цен Загрузка и выгрузка в Excel Оптовая торговля Учет ТМЦ Ценообразование, анализ цен v77::ОУ 1С7:ТиС Россия Платные (руб)

Комплекс «Прайс-органайзер» позволяет прочитать и занести в базу программы 1С:Торговля и склад 7.7 прайс-листы, приходные накладные произвольного формата от поставщиков. Инструмент прост в использовании и позволяет очень эффективно повысить производительность труда товароведов, менеджеров, операторов склада. Работа с «Прайс-органайзером» построена в форме диалога, поэтому настройка и использование не вызовет трудностей. Программа снабжена подробным, иллюстрированным описанием. На фирмах, где используется в работе прайс-органайзер, операторы сообщали, что он позволял обрабатывать список товаров в несколько тысяч наименований в течение одного часа. Победителями бесплатного розыгрыша двух комплектов программы "Прайс-органайзер" стали Konditer и chaus. отчет о прохождении акции - здесь: http://infostart.ru/blogs/1099/

2000 руб.

01.06.2009    33146    4    117    

Автоматический подбор ГТД в выданных счетах-фактурах для 1С:Бухгалтерии 7.7

Обработка документов Оптовая торговля Оптовая торговля v77::БУ 1С7:Бух Россия БУ УУ Платные (руб)

Данная обработка осуществляет автоподбор ГТД в выданных Счет-фактурах на основе остатков по счету ГТД, для подключения к конфигурации используется механизм внешних печатных форм. Обработка предназначена для програмы 1С:Бухгалтерия 7.7.

2900 руб.

06.04.2009    38697    6    12    

Автоматизация магазина: Обмен данными между 1С и СуперМАГ УКМ (комплекс отчетов и обработок)

Внешние источники данных Файловые протоколы обмена, FTP POS терминал Розничная торговля Розничная торговля v7.7 v77::ОУ v77::БУ 1С7:Бух 1С7:Комплекс 1С7:ТиС 1С7:ПУБ Розничная и сетевая торговля (FMCG) Платные (руб)

Комплекс внешних отчетов и обработок для конфигурации 1С:Предприятие 7.7 "Обмен данными между 1С и СуперМАГ УКМ". Предназначен для организации обмена информацией между системами 1С (7.7) и СуперМАГ УКМ.

2500 руб.

27.02.2009    37855    0    4    

Дисконт мастер

Обработка справочников WEB Розничная торговля Управление торговлей Розничная торговля v8 v77::ОУ УТ10 1С7:ТиС Россия Платные (руб)

Система позволяет организовать работу с дисконтными картами в программах 1С:Торговля и склад 7.7 и 1С:Управление торговлей 8.1. Имеется возможность выгрузки данных по дисконтникам на сайт.

5500 руб.

26.01.2009    33777    8    38    

Конфигурация «СКАТ-Профессионал»

СRM Кассовые операции Комиссионная торговля Оптовая торговля Розничная торговля Управление услугами и сервисом Управление торговлей СRM Кассовые операции Комиссионная торговля Оптовая торговля Розничная торговля Производство готовой продукции (работ, услуг) v77::ОУ v77::БУ Россия УУ Платные (руб)

Конфигурация «СКАТ-Профессионал» для 1С:Предприятие 7.7. Основные возможности: - Управление торговлей - Управление заказами - CRM (задачи, контакты, рассылки, корреспонденция, события, напоминания) - Дисконтные карты - Аналитические (финансовые)показатели, план-факт - Панель руководителя - Планирование - Оперативный учет в производстве - Сервисный Центр - Учет расходов - Учет ОС - Платежный календарь - Синхронизация с КПК Переход со стандартной конфигурации ТиС за 1 день.

3700 руб.

09.08.2007    31400    1    116