Отладка расчета себестоимости в ERP - просмотр изменений временных таблиц

Публикация № 1291127

Разработка - Практика программирования

Расчет себестоимости Управление предприятием 2 ERP

Как уследить за изменениями в сотне временных таблиц на различных этапах выполнения расчета себестоимости. Тестировалось на 1С:ERP Агропромышленный комплекс 2 (2.4.12.75)

Перед прочтением рекомендую ознакомиться с выжимкой из описания типовых методов  расчета в этой статье: //soft.crimea.com/1c/articles/658048/

Для отладки расчета себестоимости будет очень удобно использовать методы сравнения данных в МВТ. Поясню. Весь расчет себестоимости - это формирование и перезапись временных таблиц. Их около 50 штук. Для того чтобы понимать, какие ВТ на каком этапе формируются, и какие данные в них меняются, я написал два метода и положил их в общий модуль.

На протяжении расчета во все методы передаётся структура ПараметрыРасчета, содержащая МенеджерВременныхТаблиц. Именно в нём и меняются ВТ, формируемые в разных этапах расчета. 
 

Функция ПолучитьОписаниеТаблицМВТ(МВТ, Параметры = Неопределено, ИмяПараметра = "") Экспорт
    
    ТаблицыМВТ = Новый ТаблицаЗначений;
    ТаблицыМВТ.Колонки.Добавить("Имя", Новый ОписаниеТипов("Строка"));
    ТаблицыМВТ.Колонки.Добавить("КоличествоЗаписей", Новый ОписаниеТипов("Число"));
    ТаблицыМВТ.Колонки.Добавить("ТЗ");
    
    
    Для Каждого цВТ Из МВТ.Таблицы Цикл
        
        новСтрока = ТаблицыМВТ.Добавить();
        новСтрока.Имя = цВТ.ПолноеИмя;
        
        ТЗ = цВТ.ПолучитьДанные().Выгрузить();
        
        новСтрока.КоличествоЗаписей = ТЗ.Количество();
        новСтрока.ТЗ = ТЗ;
        
    КонецЦикла;
    
    ТаблицыМВТ.Сортировать("Имя");
    
    
    Если Параметры <> Неопределено И Не ПустаяСтрока(ИмяПараметра) Тогда
        Параметры.Вставить(ИмяПараметра, ТаблицыМВТ);
    КонецЕсли;
    
    
    Возврат ТаблицыМВТ;
    
КонецФункции
Функция СравнитьОписанияВТ(Описание1, Описание2, ТолькоОтличия = Истина) Экспорт
    
    ОтличияОписаний = Новый ТаблицаЗначений;
    ОтличияОписаний.Колонки.Добавить("Имя", Новый ОписаниеТипов("Строка"));
    ОтличияОписаний.Колонки.Добавить("КоличествоЗаписей1", Новый ОписаниеТипов("Число"));
    ОтличияОписаний.Колонки.Добавить("КоличествоЗаписей2", Новый ОписаниеТипов("Число"));
    ОтличияОписаний.Колонки.Добавить("ЕстьВОписании1", Новый ОписаниеТипов("Булево"));
    ОтличияОписаний.Колонки.Добавить("ЕстьВОписании2", Новый ОписаниеТипов("Булево"));
    ОтличияОписаний.Колонки.Добавить("ДанныеОтличаются", Новый ОписаниеТипов("Булево"));
    ОтличияОписаний.Колонки.Добавить("ТЗ1");
    ОтличияОписаний.Колонки.Добавить("ТЗ2");
    
    Для Каждого цСтрокаОписания1 Из Описание1 Цикл
        
        новСтрока = ОтличияОписаний.Добавить();
        новСтрока.Имя = цСтрокаОписания1.Имя;
        новСтрока.ТЗ1 = цСтрокаОписания1.ТЗ;
        новСтрока.КоличествоЗаписей1 = цСтрокаОписания1.ТЗ.Количество();;
        новСтрока.ЕстьВОписании1 = Истина;
        
        СтрокиВ2Описании = Описание2.НайтиСтроки(Новый Структура("Имя", цСтрокаОписания1.Имя));
        
        Если СтрокиВ2Описании.Количество() = 0 Тогда
            новСтрока.ДанныеОтличаются = Истина;
        Иначе
            
            новСтрока.ЕстьВОписании2 = Истина;
            новСтрока.ТЗ2 = СтрокиВ2Описании[0].ТЗ;
            новСтрока.КоличествоЗаписей2 = новСтрока.ТЗ2.Количество();;
            
            
            Если новСтрока.КоличествоЗаписей1 <> новСтрока.КоличествоЗаписей2 Тогда
                новСтрока.ДанныеОтличаются = Истина;
                Продолжить;
            КонецЕсли;
            
            
            Для Каждого цКолонкаТЗ1 Из новСтрока.ТЗ1.Колонки Цикл
                Если новСтрока.ТЗ2.Колонки.Найти(цКолонкаТЗ1.Имя) = Неопределено Тогда
                    новСтрока.ДанныеОтличаются = Истина;
                    прервать;
                КонецЕсли;
            КонецЦикла;
            
            Для Каждого цКолонкаТЗ2 Из новСтрока.ТЗ2.Колонки Цикл
                Если новСтрока.ТЗ1.Колонки.Найти(цКолонкаТЗ2.Имя) = Неопределено Тогда
                    новСтрока.ДанныеОтличаются = Истина;
                    прервать;
                КонецЕсли;
            КонецЦикла;
            
            Если Не новСтрока.ДанныеОтличаются Тогда
                новСтрока.ДанныеОтличаются = Не ОбщегоНазначения.КоллекцииИдентичны(новСтрока.ТЗ1, новСтрока.ТЗ2);
            КонецЕсли;
            
        КонецЕсли;
        
    КонецЦикла;
    
    Для Каждого цСтрокаОписания2 Из Описание2 Цикл
        
        СтрокиВОписании = ОтличияОписаний.НайтиСтроки(Новый Структура("Имя", цСтрокаОписания2.Имя));
        
        Если СтрокиВОписании.Количество() = 0 Тогда
            новСтрока = ОтличияОписаний.Добавить();
            новСтрока.Имя = цСтрокаОписания2.Имя;
            новСтрока.ТЗ2 = цСтрокаОписания2.ТЗ;
            новСтрока.КоличествоЗаписей2 = цСтрокаОписания2.ТЗ.Количество();;
            новСтрока.ЕстьВОписании2 = Истина;
            новСтрока.ДанныеОтличаются = Истина;
        КонецЕсли;
        
    КонецЦикла;
    
    Если ТолькоОтличия Тогда
        ОтличияОписаний = ОтличияОписаний.Скопировать(Новый Структура("ДанныеОтличаются", Истина));
    КонецЕсли;
    
    ОтличияОписаний.Сортировать("Имя");
    
    Возврат ОтличияОписаний;
    
КонецФункции

Первый метод читает все ВТ из менеджера и возвращает таблицу значений с колонками:

  • Имя (имя временной таблицы), 
  • КоличествоЗаписей, 
  • ТЗ (непосредственно данные из временной таблицы).

Кроме того, этот метод может положить сформированную таблицу с описанием ВТ в любую структуру с произвольным ключом (параметры метода: Параметры, ИмяПараметра). Таким образом мы можем на любом этапе расчета создать "слепок" содержимого менеджера ВТ и положить его, например, в структуру "ПараметрыРасчета".

Второй метод позволяет сравнивать слепки, получившиеся в результате работы первого метода. В результате сравнения возвращается таблица, содержащая поля:

  • Имя (имя временной таблицы), 
  • КоличествоЗаписей1, 
  • КоличествоЗаписей2, 
  • ТЗ1 (непосредственно данные из таблицы первого слепка).
  • ТЗ2 (непосредственно данные из таблицы второго слепка).
  • ЕстьВОписании1 (признак того, что ВТ присутствует в первом слепке)
  • ЕстьВОписании1 (признак того, что ВТ присутствует во втором слепке)
  • ДанныеОтличаются (признак того, что Данные в таблицах с одинаковым именем отличаются - по количеству записей, или по значению полей, или по наличию таблиц)

Как этим пользоваться.
1. Запускаем расчет. Можно накидать внешнюю обработку для запуска

&НаСервере
Процедура ЗапуститьРасчетССНаСервере()
    ПараметрыЗапуска = Новый Структура;
    ПараметрыЗапуска.Вставить("АвтоматическоеТестирование", Ложь);
    ПараметрыЗапуска.Вставить("ВыполняетсяЗакрытиеМесяца", Ложь);
    ПараметрыЗапуска.Вставить("Дата", НачалоМесяца(Период));
    ПараметрыЗапуска.Вставить("МассивОрганизаций", ОбщегоНазначенияКлиентСервер.ЗначениеВМассиве(Организация));
    ПараметрыЗапуска.Вставить("МестоВызоваРасчета", "РасчетСебестоимостиКорректировкаСтоимости.Выполнить_РасчетПартийИСебестоимости");
        
    СхемаРасчета = РасчетСебестоимостиПрикладныеАлгоритмы.СхемаРасчетаПартий(ПараметрыЗапуска.Дата, ПараметрыЗапуска.МассивОрганизаций);
    Если СхемаРасчета.Количество() = 0 Тогда
        новСтрока = СхемаРасчета.Добавить();
        новстрока.Дата = КонецМесяца(ПараметрыЗапуска.Дата);
        новстрока.ИзмененоДокументов = 1;
        новстрока.Организации = ПараметрыЗапуска.МассивОрганизаций;
    КонецЕсли;
    ПараметрыЗапуска.Вставить("СхемаРасчета", СхемаРасчета);
    
    РасчетСебестоимости.РассчитатьВсе(ПараметрыЗапуска);

КонецПроцедуры


Обработка во вложении, там она ещё перепроводит проблемный документ перед расчетом.
2. Тормозим отладку перед интересующим нас методом.
3. В табло пишем:

НашОбщийМодуль.ПолучитьОписаниеТаблицМВТ(ПараметрыРасчета.МенеджерВременныхТаблиц, ПараметрыРасчета, "ТаблицыПередВыполнениемЭтапа")


4. После того как выражение вычислилось, в структуре ПараметрыЗапуска появились данные с ключом "ТаблицыПередВыполнениемЭтапа", комментим (или удаляем из табло) выражение из пункта №3, чтобы данные не перезаписались при следующих шагах
5. Выполняем интересующий нас этап и кладём его данные в структуру с новым ключом. Для этого опять пишем выражение в табло:

НашОбщийМодуль.ПолучитьОписаниеТаблицМВТ(ПараметрыРасчета.МенеджерВременныхТаблиц, ПараметрыРасчета, "ТаблицыПослеВыполненияЭтапа")


6. Сравниваем эти описания, выполняя в табло код: 

НашОбщийМодуль.СравнитьОписанияВТ(ПараметрыРасчета.ТаблицыПередВыполнениемЭтапа, ПараметрыРасчета.ТаблицыПослеВыполненияЭтапа)


В результате имеем Таблицу, содержащую отличия. Открыть её можно прямо из табло, нажав F2.
Также можно вместо этапов 5,6 просто идти по коду, вычисляя в табло выражение:
 

НашОбщийМодуль.СравнитьОписанияВТ(ПараметрыРасчета.ТаблицыПередВыполнениемЭтапа, НашОбщийМодуль.ПолучитьОписаниеТаблицМВТ(ПараметрыРасчета.МенеджерВременныхТаблиц))

Таким образом можно на любом этапе понять, какие ВТ сформировались или изменились.

Скачать файлы

Наименование Файл Версия Размер
Обработка для запуска расчета себестоимости с перепроведением проблемного документа

.epf 6,81Kb
09.09.20
6
.epf 6,81Kb 6 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Помощник по закрытию месяца для УТ 11.3 Промо

Закрытие периода Обработка документов Закрытие периода Закрытие периода v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Помощник по закрытию месяца для УТ 11.3. Имеет две функции: обнуление товаров "К оформлению" в интеркампани и обнуление отрицательных остатков в регистре "Себестоимость товаров".

5 стартмани

10.11.2017    23710    27    Zalipaka    1    

Автоматизированное заполнение документа "Списание НДС" по остаткам регистра "НДС Предъявленный" (счет 19) для БП 3.0

Закрытие периода Обработка документов v8 v8::БУ БП3.0 Россия БУ НУ НДС Абонемент ($m)

Доработка позволяет одним нажатием заполнить документ "Списание НДС" всеми документами с входным НДС, т.е. остатками по регистру "НДС предъявленный" (счет 19).

2 стартмани

03.10.2020    750    3    vakrikun    0    

Закрытие месяца за выбранный период скопом для Бухгалтерии 3.0

Закрытие периода v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Часто бывает ситуация - бухгалтера залезли в прошлый период, надо все перезакрыть и срочно. Если 1, 3 месяца - не проблема, а вот если год и более напряжно - вот для этих случаев я и сделала данную обработку.

2 стартмани

10.09.2020    662    10    lenna1c    0    

Консоль кода для управляемых форм

Прочие инструменты разработчика v8 v8::УФ 1cv8.cf Абонемент ($m)

Консоль кода для управляемых форма с подсказками и подсветкой синтаксиса.

1 стартмани

17.07.2020    12175    195    salexdv    205    

Корректировка остатков регистров бухгалтерии (обычные и управляемые формы) Промо

Свертка базы Универсальные обработки Закрытие периода Чистка базы v8::БУ v8::УФ 1cv8.cf БУ НУ Абонемент ($m)

Внешняя обработка, предназначенная для удобного исправления остатков по регистрам бухгалтерии (Хозрасчетный, Налоговый или любой другой) посредством автоматизации ввода корректировочного документа ("Операция", "Корректировка записей регистров"), приводящего регистр в нужное состояние остатков от текущего. Удобна для массовых правок остатков по бухгалтерскому и налоговому учету на какую-то дату (обычно перед реорганизацией учета, сверткой базы и т.п.)

2 стартмани

03.06.2017    31384    166    stvorl    25    

Распределение косвенных затрат для Бухгалтерии редакции 3.0

Закрытие периода v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Обработка предназначена для распределения 25 и 26 счетов пропорционально суммам реализации по номенклатурным группам.

10 стартмани

25.05.2020    1254    2    vitalbasl    1    

БП 3.0, Закрытие месяца, Отключение проверок операций прошлых периодов

Закрытие периода v8 v8::БУ БП3.0 БУ Абонемент ($m)

Расширение конфигурации, отключающее ошибки прошлых периодов, которые блокируют закрытие текущего месяца. Например, "Нарушена последовательность регламентных операций" и т.д.

1 стартмани

13.05.2020    5664    13    sapervodichka    15    

Простое закрытие затратных счетов для Бухгалтерии 3.0

Закрытие периода Закрытие периода Закрытие периода v8::БУ v8::УФ БП3.0 БУ Абонемент ($m)

Позволяет получить суммы затрат за период и с отборами и закрыть их на выбранный счет и аналитику, тестировалось на 1С:Предприятие 8.3 (8.3.13.1690) Бухгалтерия предприятия, редакция 3.0 (3.0.70.39)

2 стартмани

29.07.2019    3876    7    MikeStav    6    

Списание (корректировка) задолженности контрагентов УНФ 1.6 Промо

Закрытие периода Дебиторская и кредиторская задолженность Обработка документов Дебиторская и кредиторская задолженность v8 УНФ Украина БУ Абонемент ($m)

Обнуление задолженности контрагентов в конфигурации "Управление небольшой (нашей) фирмой" версии 1.6 с помощью документа "Корректировка регистров".

1 стартмани

24.07.2019    22478    13    DMon    1    

Редактирование (установка) даты окончания действия счетов ЕПСБУ в БГУ

Закрытие периода Закрытие периода Закрытие периода v8 v8::БУ БГУ Государственные, бюджетные структуры БУ Абонемент ($m)

При обновлении «1С:Бухгалтерия государственного учреждения, редакция 1.0» (1С:БГУ) на версию 1.0.56.7 не произошла установка даты окончания действия 31.12.2018 у счетов, которые прекратили свое действие в 2018 году. К сожалению, это заметили несколько релизов спустя и вернуться, чтобы разобраться в причинах некорректного обновления, возможности не было. В связи с этим, создана обработка, с помощью которой можно установить дату окончания действия выбранных счетов.

1 стартмани

18.07.2019    5312    16    delta    2    

Решение проблем учета материалов в эксплуатации. УПП, РАУЗ

Учет ТМЦ Практика программирования Учет ТМЦ Разработка v8 v8::БУ УПП1 Россия БУ Абонемент ($m)

Если в вашей организации в течение одного месяца могут происходить несколько перемещений одного и того же материала в эксплуатации между физическими лицами, то УПП с РАУЗ неверно распределяет погашенную стоимость. Эта публикация поможет исправить проблему.

1 стартмани

04.07.2019    3716    14    AnRyb    4    

Дозакрытие месяца по статьям затрат

Закрытие периода Закрытие периода Закрытие периода v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Обработка "дозакрывает" счета 20,23,25,26 в разрезе статей затрат.

1 стартмани

30.05.2019    4790    22    Mihasya    15    

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    20434    4    m-rv    86    

Автоматический зачет доплаты НДС 2% в 2019 году, по авансам полученным ранее 2019 года, при отгрузках в 2019 году

Закрытие периода Оптовая торговля Оптовая торговля v8::БУ БП3.0 Россия БУ НДС Абонемент ($m)

При частичной отгрузке в 2019 году 1С БП 3 в зачет возьмет полученный аванс в 2018 году без учета доплаты НДС 2% в 2019, возникнут расхождения между счетами 62.02 и 76.АВ Работа обработки проверялась на релизе 3.0.68.58.

5 стартмани

20.03.2019    3329    0    detro    0    

Закрытие долгов по зарплате в БП 3.0

Закрытие периода Зарплата Зарплата v8::БУ v8::УФ БП3.0 Россия БУ Абонемент ($m)

Обработка закрытия долгов зарплаты по регистрам.

2 стартмани

20.03.2019    4406    25    dipolm    5    

Управление последовательностью документов (обработка для БП 3.0)

Обработка документов Универсальные обработки Закрытие периода Рабочее место v8::БУ БП3.0 УХ БУ Абонемент ($m)

Наиболее универсальная и удобная обработка по управлению последовательностью документов в конфигурациях на базе "1С:Бухгалтерия 3.0". Быстрое отображение, гибкие динамические отборы, изменение состояний документов, удаление из последовательности, групповые действия, удобная навигация по периодам.

2 стартмани

14.01.2019    8655    43    mbreaker    0    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    30333    86    m-rv    57    

Инструменты бухгалтера: Групповое закрытие месяцев

Закрытие периода Закрытие периода Закрытие периода v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Помощник группового закрытия позволяет закрывать последовательно сразу несколько месяцев в Бухгалтерии 3.0.

1 стартмани

12.12.2018    6284    28    Bazil    5    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    21657    13    RocKeR_13    16    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    28026    26    informa1555    26    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    28186    19    mvxyz    17    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    47084    17    kalyaka    16    

Формирование записей в КУДР ЕСХН данных о земельных участках в размере 1/7 от их стоимости для 1С.БСХП Ред. 3.0

Закрытие периода Учет ОС и НМА Обработка документов Учет ОС и НМА v8 v8::БУ БП3.0 Сельское хозяйство и рыболовство НУ ЕСХН Абонемент ($m)

Внешняя обработка для 1С.БСХП Ред. 3.0 по формированию операций по принятию к расходам в ЕСХН стоимости земельных участков в размере 1/7.

2 стартмани

14.04.2018    6375    1    user744865    1    

Расчет налога на имущество по каждому ОС

Закрытие периода Закрытие периода Учет ОС и НМА Обработка документов Закрытие периода Учет ОС и НМА v8 v8::БУ БП2.0 Россия БУ НУ Налог на имущество Абонемент ($m)

Расчет налога на имущество по каждому ОС и автоматическое формирование документа Бухгалтерская операция для отражения начисления налога.

1 стартмани

11.04.2018    6530    8    vladimir_2107    1    

Универсальное закрытие счетов для 1С:Бухгалтерия предприятия 3.0 Промо

Обработка документов Закрытие периода Закрытие периода Закрытие периода v8::БУ БП3.0 Россия БУ Абонемент ($m)

Внешняя обработка позволяет закрывать счета бухгалтерского учета в ноль, распределять, переносить остатки, обороты бухгалтерского, налогового учета, количества, валютные суммы. Позволяет настроить и сохранить алгоритмы для периодического формирования бухгалтерских операций.

3 стартмани

13.12.2017    33790    243    leha2403    36    

Групповое перепроведение Закрытия месяца в Бухгалтерии 3.0

Закрытие периода Закрытие периода Обработка документов Закрытие периода v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Обработка пригодится для тех, кто закрывает несколько месяцев подряд. В стандартной вы делаете закрытие одного месяца, потом переходите к следующему. В данной обработке вы указываете период, за который вам необходимо провести закрытие месяца.

1 стартмани

09.04.2018    11013    37    sambush    8    

Закрытие отрицательных остатков на 41 и 10 счете (БП 3.0 и Бух 7.7)

Обработка документов Закрытие периода Закрытие периода Учет ТМЦ Закрытие периода Учет ТМЦ v8 v77::БУ v8::БУ 1С7:Бух БП3.0 БУ Абонемент ($m)

Предлагаемые обработки позволят сформировать документ "Поступление товаров и материалов" по отрицательным остаткам ТМЦ (счета 41 и 10) за выбранный период. Для БП 3.0 и Бух 7.7.

1 стартмани

02.04.2018    18129    100    Ant10    0    

Корректировка графы 7 Книги учета доходов и расходов (КУДиР)

Закрытие периода Закрытие периода Закрытие периода v8 v8::БУ БП2.0 БУ УСН Абонемент ($m)

Корректировка суммы принимаемых расходов Книги учета доходов и расходов (КУДиР). Позволяет увеличить или уменьшить сумму расходов УСН. Задается сумма к распределению со знаком + или - и период. Пропорционально изменяются суммы в движениях регистра накопления "Книга учета доходов и расходов (раздел I)".

1 стартмани

14.03.2018    7524    3    VictorKa    2    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    27634    70    vasvl123    9    

Помощник закрытия месяца в УПП 1.3

Рабочее место Закрытие периода Закрытие периода Закрытие периода v8::БУ УПП1 Россия БУ Абонемент ($m)

Обработка предоставляет меню для быстрого вызова операций по закрытию периода в УПП 1.3.70.1 и 1.3.102.1.

1 стартмани

13.02.2018    9331    9    ligsht    1    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    26968    53    kwazi    6    

Автоматическое закрытие счета 29 для 1С:Бухгалтерии 3.0 (управляемые формы)

Обработка документов Закрытие периода Закрытие периода Закрытие периода v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Внешняя обработка для управляемых форм для закрытия 29 счета. Работает так же, как и для платформы 8.2.

1 стартмани

02.11.2017    12578    35    sibirta    6    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут Промо

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    48033    36    Demanoidos    60    

Клиент-банк, поиск плательщиков по назначению платежа

Практика программирования Обмен с банком Банковские операции Банковские операции v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Решение задачи рассмотрим на примере загрузки и разнесения банковской выписки по договорам и контрагентам из текста назначения платежа.

1 стартмани

30.08.2017    11234    1    duhh    14    

Закрытие периода в квартальной отчетности. БГУ 2.0

Закрытие периода Закрытие периода Закрытие периода v8::БУ БГУ Россия Госбюджет Абонемент ($m)

Обработка выполняет закрытие периода (счета 401.10 и 401.20 на финансовый результат прошлых лет) для формирования баланса при квартальной отчетности. Формирует документ "Операция (бухгалтерская)" с завершающими бухгалтерскими записями, в разрезе аналитики. Для отмены закрытия периода, достаточно пометить этот документ на удаление. БГУ 2.0. Управляемые формы.

1 стартмани

18.08.2017    15338    5    alanto23    11    

Быстрое определение интервалов в запросе Промо

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    51366    35    ildarovich    41    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    128823    13    signum2009    48    

Закрытие аналитики счетов для БГУ 1.0

Обработка документов Закрытие периода Закрытие периода Закрытие периода v8::БУ БГУ БУ Госбюджет Абонемент ($m)

Закрывает аналитику счета по указанным отборам для БГУ 1.0

1 стартмани

14.05.2017    11427    36    zadoy    2    

СКД. Использование встроенного макета, разделителя страниц

Практика программирования v8::СКД 1cv8.cf Абонемент ($m)

Пример работы с макетом СКД для начинающих программистов. За основу взят справочник подразделений, который есть в большинстве конфигураций. Показано, как вывести заголовок, детальные записи, подвал группировки и общий подвал. Приведен пример вставки разделителя страниц. Отчет можно использовать в любой конфигурации 1С: 8.

1 стартмани

31.03.2017    15180    18    Vin_Tik    0    

Выравнивание налогового учета по данным бухгалтерского учета

Обработка документов Закрытие периода Закрытие периода Учет ОС и НМА Закрытие периода Учет ОС и НМА v8::БУ БП2.0 Россия БУ НУ Налог на прибыль Абонемент ($m)

Всем добрый день! Хочу поделиться своим скромным опытом по выравниванию НУ по БУ. Заказчиком ставилась следующая задача. В Бухгалтерии 2.0 велся только бух. учет, налоговые проводки формировались как попало, на них никто не обращал внимания. И вот настал такой прекрасный момент, когда захотелось на конец квартала (30 сентября) обнулить весь налоговый учет и ввести по нему входящее сальдо, равное сальдо бух. учета. Все бы ничего, да только по основным средствам появились дополнительные условия. По ним нужно было сформировать корректные налоговые проводки за следующий квартал в соответствии с данными основных средств. Таким образом, по состоянию на 31 декабря вырисовывалась более-менее приемлемая картина в НУ, что позволяло переходить на использование автоматического расчета налога на прибыль в следующем году.

1 стартмани

15.12.2016    13390    27    purgin    4    

Полезные процедуры по работе с СКД и табличными документами (часть 1)

Практика программирования v8::СКД 1cv8.cf Абонемент ($m)

На одном из последних проектов пришлось делать большое количество отчетов на СКД, в которых некоторые требования к оформлению нельзя было реализовать настройками схемы компоновки. В данной публикации приводятся несколько процедур, дополняющие возможности СКД, при решении таких задач

1 стартмани

03.09.2016    56305    97    json    23