Примеры работы с API в Честный знак (обувь)

Публикация № 1236219

Учет и отчетность - Розничная торговля

Честный знак API ЧЗ 1C

К сожалению, документация API честного знака полна пробелов и неточностей. В данной статье описан мой опыт отгрузки маркированных товаров с одного юр. лица на другое.

Для начала вы должны быть зарегистрированы в Честном знаке(https://shoes.crpt.ru/) и иметь сертификат для входа. Честный знак нам предлагает воспользоватся инструкцией по ссылке https://shoes.crpt.ru/docs/API_Track_and_Trace_Government_Information_System_v18_en.pdf она вам поможет, но обращайте внимание, что там довольно много неточностей и устаревших данных.

Начнем с того что нам нужно получить токен для работы с API честного знака. Для этого нам нужно сделать GET запрос в ответ на который мы получим поля GUID(Уникальный идентификатор) и DATA(Данные).

GET Запрос из 1с выглядит следующим образом: 

    сайт = "ismp.crpt.ru";
	хСоединение =    Новый HTTPСоединение(Сайт,443,,,,,Новый ЗащищенноеСоединениеOpenSSL);
	Запрос = новый HTTPЗапрос("/api/v3/auth/cert/key");
	хОтвет = хСоединение.ВызватьHTTPМетод("GET",Запрос);
	
	Если хОтвет.КодСостояния <> 200 Тогда
		
		Сообщить("Ошибка. Код ответа " + хОтвет.КодСостояния);
		
		Возврат;
	КонецЕсли;
	Сообщение = хОтвет.ПолучитьТелоКакСтроку("UTF-8"); 
	
	//десериализуем данные о клиенте из JSON 
	ЧтениеJSON = Новый ЧтениеJSON; 
	ЧтениеJSON.УстановитьСтроку(Сообщение); 
	ОборудованиеJSON = ПрочитатьJSON(ЧтениеJSON); 
	ЧтениеJSON.Закрыть();
	УИД = ОборудованиеJSON.uuid;
	Данные = ОборудованиеJSON.data;
	Файл = Новый ЗаписьТекста("C:\1\test.txt");
	Файл.ЗаписатьСтроку(Данные);
	Файл.Закрыть();	

Данные нам необходимо подписать нашей электронной подписью и прислать в ответ ЧЗ. Для того что бы подписать данные воспользуемся сайтом КриптоПРО https://www.cryptopro.ru/sites/default/files/products/cades/demopage/cades_bes_sample.html Там нам нужно выбрать наш сертификат, а  в поле "Данные для подписи" вставить полученные данные(в моем случае текст из файла test.txt). 

Сформированную подпись копируем в текстовый файл и с помощью Notepad избавляемся от пробелов и переносов строки. Выделяем весь текст жмем Ctrl+H в поле поиска пишем \n затем \r поле замены оставляем пустым. Жмем заменить все.

GUID и текст из получившегося файла нам нужно отправить POST запросом в ЧЗ.

Процедура ПолучитьТокенНаСервере()
	Текст = Новый ТекстовыйДокумент;
	ПолноеИмяФайла = "C:\1\out.txt";
	Текст.Прочитать(ПолноеИмяФайла);
	КоличествоСтрок = Текст.КоличествоСтрок();
	Данные = "";
	Для Счетчик = 1 по КоличествоСтрок Цикл
		ТекСтрока = Текст.ПолучитьСтроку(Счетчик);
		Данные = Данные + ТекСтрока;
	КонецЦикла;
	Соединение = Новый HTTPСоединение("ismp.crpt.ru",443,,,,,Новый ЗащищенноеСоединениеOpenSSL);
	Заголовки = Новый Соответствие;
	
	Заголовки.Вставить("Content-Type", "application/json; charset=UTF-8");
	Заголовки.Вставить("Accept", "application/json");
	
	Запрос = Новый HTTPЗапрос("/api/v3/auth/cert/",Заголовки);
	ЗаписьJOIN = Новый ЗаписьJSON;
	ЗаписьJOIN.УстановитьСтроку();
	ДанныеДляЗапроса = Новый Структура;
	ДанныеДляЗапроса.Вставить("uuid",УИД);
	ДанныеДляЗапроса.Вставить("data",Данные);	
	ЗаписатьJSON(ЗаписьJOIN,ДанныеДляЗапроса);
	СтрокаДляЗапроса = ЗаписьJOIN.Закрыть();
	
	//Формируем ответ клиенту
	Запрос.УстановитьТелоИзСтроки(СтрокаДляЗапроса,КодировкаТекста.UTF8,
	ИспользованиеByteOrderMark.НеИспользовать);
	
	Ответ = Соединение.ОтправитьДляОбработки(Запрос);
	Если Ответ.КодСостояния <> 200 Тогда
		
		Сообщить("Ошибка. Код ответа " + Ответ.КодСостояния);
		ЧтениеJSON = Новый ЧтениеJSON;
		Сообщение = Ответ.ПолучитьТелоКакСтроку("UTF-8");
		ЧтениеJSON.УстановитьСтроку(Сообщение); 
		СообщениеJSON = ПрочитатьJSON(ЧтениеJSON); 
		ЧтениеJSON.Закрыть();
		Сообщить(СообщениеJSON.error_message);
		
		Возврат;
	КонецЕсли;
	
	ЧтениеJSON = Новый ЧтениеJSON;
	ЧтениеJSON.УстановитьСтроку(Ответ.ПолучитьТелоКакСтроку());
	
	Токен = ПрочитатьJSON(ЧтениеJSON, Ложь).token;				
	
КонецПроцедуры

В ответ мы получим токен который нужно будет использовать в любых дальнейших запросах.

После получения токена можно использовать любые методы работы с документами и маркировками описанными в документации. Вот мой пример получения маркировок находящихся в обороте. 

сайт = "ismp.crpt.ru";
	хСоединение =    Новый HTTPСоединение(Сайт,443,,,,,Новый ЗащищенноеСоединениеOpenSSL);
	Запрос = новый HTTPЗапрос("/api/v3/facade/identifytools/listV2?cisStatus=INTRODUCED&limit=10000");
	запрос.Заголовки.Вставить("Authorization","Bearer "+Токен);
	хОтвет = хСоединение.ВызватьHTTPМетод("GET",Запрос);	
	Если хОтвет.КодСостояния <> 200 Тогда
		
		Сообщить("Ошибка. Код ответа " + хОтвет.КодСостояния);
		ЧтениеJSON = Новый ЧтениеJSON;
		Сообщение = хОтвет.ПолучитьТелоКакСтроку("UTF-8");
		ЧтениеJSON.УстановитьСтроку(Сообщение); 
		СообщениеJSON = ПрочитатьJSON(ЧтениеJSON); 
		ЧтениеJSON.Закрыть();
		Сообщить(СообщениеJSON.error_message);
		Возврат;
	КонецЕсли;
	Сообщение = хОтвет.ПолучитьТелоКакСтроку("UTF-8"); 
	
	//десериализуем данные о клиенте из JSON 
	ЧтениеJSON = Новый ЧтениеJSON; 
	ЧтениеJSON.УстановитьСтроку(Сообщение); 
	ОборудованиеJSON = ПрочитатьJSON(ЧтениеJSON); 
	ЧтениеJSON.Закрыть();
	Результат = ОборудованиеJSON.results;
	Для Каждого Строка Из Результат Цикл
		НоваяСтрока = ТаблицаВыбывших.Добавить();
		НоваяСтрока.Маркировка = Строка.cis;		
	КонецЦикла;

Теперь нам необходимо отгрузить маркировки другому юр.лицу. Изначально я пытался создать документ с помощью API в формате JSON, но постоянные ошибки заставили меня сделать это через XML. Выглядело это следующим образом. Сначала я создаю JSON документ 

	РеквизитыДокумента = Новый Структура;	
	РеквизитыДокумента.Вставить("trade_participant_inn_sender",ИННСобственника);   //ИНН собственника
	РеквизитыДокумента.Вставить("trade_participant_inn_receiver",ИННПолучателя); //ИНН получателя
	РеквизитыДокумента.Вставить("trade_participant_inn_owner",ИННСобственника);   //ИНН собственника
	РеквизитыДокумента.Вставить("transfer_date",Формат(ТекущаяДата(),"ДФ=dd.MM.yyyy")); //Дата передачи маркированных товаров
	РеквизитыДокумента.Вставить("move_document_number",НомерДокумента); //Номер первичного документа	
	РеквизитыДокумента.Вставить("move_document_date",Формат(ДатаДокумента,"ДФ=dd.MM.yyyy")); //Дата первичного документа
	РеквизитыДокумента.Вставить("turnover_type","SELLING");   //Код типа отгрузки		                  	
	Товары = Новый Массив;
	Для Каждого Строка ИЗ ТаблицаМаркировок Цикл
		Отбор = Новый Структура;
		Отбор.Вставить("Маркировка",Строка.Маркировка);	
		Если ТаблицаВыбывших.НайтиСтроки(Отбор).Количество() > 0 Тогда
			СтруктураТоваров = Новый Структура;
			СтруктураТоваров.Вставить("ki","<![CDATA["+Строка.Маркировка+"]]>"); //Уникальный идентификатор товара
			СтруктураТоваров.Вставить("cost",Строка.Цена); 
			СтруктураТоваров.Вставить("vat_value",Строка.НДС); 	
			Товары.Добавить(СтруктураТоваров);
		КонецЕсли;	
	КонецЦикла;
	РеквизитыДокумента.Вставить("product",Товары);   //ИНН собственника
	
	ЗаписьJSON = Новый ЗаписьJSON;
	ЗаписьJSON.ОткрытьФайл("C:\1\pills.json");
	ЗаписатьJSON(ЗаписьJSON,РеквизитыДокумента);
	ЗаписьJSON.Закрыть();	

На структуру полей можно ориентироваться с помощью документации и данного шаблона XML

<?xml version="1.0" encoding="UTF-8"?>
<shipment version="4" action_id="10">
    <trade_participant_inn_sender>6317136467</trade_participant_inn_sender>
    <trade_participant_inn_receiver>7721546864</trade_participant_inn_receiver>
    <trade_participant_inn_owner>6317136467</trade_participant_inn_owner>
    <transfer_date>05.12.2019</transfer_date>
    <move_document_number>123</move_document_number>
    <move_document_date>05.12.2019</move_document_date> <!-- Комментарий -->
    <turnover_type>SELLING</turnover_type>
    <products_list>
        <product>
            <ki><![CDATA[0147012334793726213D6uKeCK7LtuO]]></ki>
            <cost>33030.5</cost>
            <vat_value>270.85</vat_value>
        </product>
    </products_list>
</shipment>

Полученный JSON файл мы загружаем в конвентер JSON-XML. Я использовал этот https://www.convertjson.com/json-to-xml.htm Он немного криво конвентирует поэтому после конвертации приводим вид файла по шаблону. 

Полученный xml файл нам остается загрузить в честный знак. Для этого заходим в список документов в ЧЗ. Внизу нажимаем кнопку загрузить, выбираем пункт отгрузка и загружаем наш XML файл. После успешной загрузки без единой ошибки другое юр. лицо может принят себе отгруженные маркировки с помощью создания документа приемки.

Обработка тестировалась на платформе: 8.3.11.3034.

Скачать файлы

Наименование Файл Версия Размер
Пример выгрузки маркировок в ЧЗ

.epf 9,66Kb
14.05.20
25
.epf 9,66Kb 25 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. SeTIrk 29.06.20 09:09 Сейчас в теме
Извините, а разве отгрузка и приемка не через ЭДО идет?
Я считал что в ЭДО подписанный документ с двух сторон отправляется в Честный Знак силами ЭДО. Важно в ЭСФ передать в полях ДопСведТов.НомСредИдентТов.НомУпак или КИЗ
3. stas8359 16 30.06.20 15:11 Сейчас в теме
(1)Все правильно. Но есть ситуации, когда нужно получить или выгрузить данные через Api ЧЗ.
11. EdBush 20.07.20 10:10 Сейчас в теме
Функция ПодписатьЭЦПЧерезСОМОбъекты(СтрокаДляПодписи, СтрокаВBase64 = Истина, Открепл) Экспорт
    
    Попытка
        comStore = Новый COMОбъект("CAdESCOM.Store");
        comCPSigner = Новый COMОбъект("CAdESCOM.CPSigner"); // Аналог "CAPICOM.Signer".
        comSignedData = Новый COMОбъект("CAdESCOM.CadesSignedData");
    Исключение
        Сообщить("Не установлен КриптоПро!");
        Возврат "";
    КонецПопытки;
    
    comStore.Open(
        2, // StoreLocation - CAPICOM_CURRENT_USER_STORE.
        "MY", // StoreName
        ); // OpenMode - CAPICOM_STORE_OPEN_READ_ONLY.
    comCertificates = comStore.Certificates;
    comStore.Close();
    comStore = Неопределено;
    КоличествоСертификатов = comCertificates.Count;
    
    Если КоличествоСертификатов > 0 Тогда
        // Убрать "сертификаты, в которых отсутствует закрытый ключ".
        comCertificates = comCertificates.Find(6, 2); // (CAPICOM_CERTIFICATE_FIND_EXTENDED_PROPERTY, CAPICOM_PROPID_KEY_PROV_INFO)
        КоличествоСертификатов = comCertificates.Count;
    КонецЕсли;
    Если КоличествоСертификатов > 0 Тогда
        // Оставить "только сертификаты, действительные в настоящее время".
        comCertificates = comCertificates.Find(9, ); // (CAPICOM_CERTIFICATE_FIND_TIME_VALID, "the current time is assumed")
        КоличествоСертификатов = comCertificates.Count;
    КонецЕсли;
    
    Если КоличествоСертификатов = 1 Тогда
        comСертификат = comCertificates.Item(1); // Выбрать единственный.
        
    ИначеЕсли КоличествоСертификатов = 0 Тогда
        comCertificates = Неопределено;
        comCPSigner = Неопределено;
        comSignedData = Неопределено;
        Сообщить("Не найдены актуальные ключи ЭЦП для подписи данных!");
        Возврат "";
        
    Иначе
        СертификатыДляВыбора = Новый СписокЗначений;
		флНашли = Ложь;
		Для i = 1 По КоличествоСертификатов Цикл 
			СертификатыДляВыбора.Добавить(i, comCertificates.Item(i).SubjectName);
			comСертификат = comCertificates.Item(i);
			Если (Найти(comСертификат.SubjectName,"ИНН="+Док.Фирма.ИНН)>0) ИЛИ
				(Найти(comСертификат.SubjectName,"ИНН=00"+Док.Фирма.ИНН)>0) Тогда
				флНашли = Истина;
				Прервать;
			КонецЕсли;
            
        КонецЦикла;
		Если НЕ флНашли Тогда
			i = СертификатыДляВыбора.ВыбратьЭлемент();
			Если i = Неопределено Тогда
				comCertificates = Неопределено;
				comCPSigner = Неопределено;
				comSignedData = Неопределено;
				Сообщить("Не выбран ключ ЭЦП!");
				Возврат "";
				
			Иначе
				comСертификат = comCertificates.Item(i.Значение); // Выбрать указанный пользователем.
				
			КонецЕсли;
		КонецЕсли;
        
    КонецЕсли;
    comCertificates = Неопределено;
    
    comCPSigner.Certificate = comСертификат;
    // + Что-то из этого может быть нужным.
//    comCPSigner.TSAAddress = "http://cryptopro.ru/tsp/";
//    comCPSigner.Options = 0; // CAPICOM_CERTIFICATE_INCLUDE_CHAIN_EXCEPT_ROOT. Ещё есть CAPICOM_CERTIFICATE_INCLUDE_WHOLE_CHAIN и CAPICOM_CERTIFICATE_INCLUDE_END_ENTITY_ONLY.
    // -
    comСертификат = Неопределено;
    
    Если СтрокаВBase64 Тогда // Очень важно!
        comSignedData.ContentEncoding = 1; // CADESCOM_BASE64_TO_BINARY
    //Иначе // Так и остаётся 0 - CADESCOM_ENCODE_BINARY
    КонецЕсли;
    comSignedData.Content = СтрокаДляПодписи;
    ПодписанныеДанные = comSignedData.SignCades(
        comCPSigner, // Signer
        1, // CadesType, CADESCOM_CADES_BES.
        Открепл, // bDetached - "флаг открепленной подписи (исходное сообщение не включается в итоговый CMS-контейнер)".
        ); // EncodingType - по умолчанию CAPICOM_ENCODE_BASE64.
    
    comCPSigner = Неопределено;
    comSignedData = Неопределено;
    Возврат УбратьСимволы1013(ПодписанныеДанные);
    
КонецФункции
Показать
user1049861; clev; +2 Ответить
2. serko8547 99 29.06.20 14:32 Сейчас в теме
а есть пример запроса API по сигаретам?
maksa2005; +1 Ответить
4. stas8359 16 30.06.20 15:12 Сейчас в теме
(2)Нет, работал только с обувью.
5. user1430516 01.07.20 19:05 Сейчас в теме
Каждый раз нужно возится с сертификатом, или можно как то автоматически подписать данные? Токен, как я понял, живет только 10 часов.
maksa2005; +1 Ответить
6. yursa26 11.07.20 11:39 Сейчас в теме
А есть вариант отправки документа отгрузки запросом ч/з АПИ, а не руками на сайте?
8. maksa2005 328 15.07.20 10:43 Сейчас в теме
7. maksa2005 328 15.07.20 10:32 Сейчас в теме
Спасибо за развернутую документацию
10. EdBush 20.07.20 10:09 Сейчас в теме
ТелоЗапроса = Новый Структура;
	ТелоЗапроса.Вставить("document_num",   СокрЛП(Док.Номер));
	ТелоЗапроса.Вставить("document_date",    ДатаUTC(Док.Дата));//"2019-11-14T00:00:00.000Z");
	ТелоЗапроса.Вставить("transfer_date", ДатаUTC(ТекущаяДата()));//(Док.Дата));
	ТелоЗапроса.Вставить("receiver_inn", СокрЛП(Док.Контрагент.ИНН));
	ТелоЗапроса.Вставить("sender_inn", СокрЛП(Док.Фирма.ИНН));
	ТелоЗапроса.Вставить("turnover_type", "SELLING");
	ТелоЗапроса.Вставить("to_not_participant", "false");
	
	ТелоЗапроса.Вставить("products", Новый Массив);
	
	Запрос = Новый Запрос("ВЫБРАТЬ
	                      |	ОтгрузкаСоСкладаТоварыШК.ШК,
	                      |	ОтгрузкаСоСкладаТоварыШК.Номенклатура
	                      |ИЗ
	                      |	Документ.ОтгрузкаСоСклада.ТоварыШК КАК ОтгрузкаСоСкладаТоварыШК
	                      |ГДЕ
	                      |	ОтгрузкаСоСкладаТоварыШК.Ссылка.Основание = &Основание");
	Запрос.Параметры.Вставить("Основание", Док);
	Выб = Запрос.Выполнить().Выбрать();
	Пока Выб.Следующий() Цикл
		СтрокаТЧ = Новый Структура;
		СтрокаТЧ.Вставить("uit_code", СокрЛП(Выб.ШК));
		СтрокаТЧ.Вставить("product_description", СокрЛП(Выб.Номенклатура.Наименование));
		ТелоЗапроса.products.Добавить(СтрокаТЧ);
	КонецЦикла;
	ЗаписьJSON = Новый ЗаписьJSON();
	ПараметрыЗаписиJSON = Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Нет, "");
	ЗаписьJSON.УстановитьСтроку(ПараметрыЗаписиJSON);
	
	ЗаписатьJSON(ЗаписьJSON, ТелоЗапроса);
	
	ТекстJSON = ЗаписьJSON.Закрыть();
	
	
	ТекстXML64 = ШтрихкодВBase64(ТекстJSON);
	ПодписанныеДанные = ПодписатьЭЦПЧерезСОМОбъекты(ТекстXML64, Истина, Истина);
	HTTP = Новый HTTPСоединение("ismp.crpt.ru", 443, , , , , Новый ЗащищенноеСоединениеOpenSSL);
	//URLЗапроса = "/api/v3/lk/documents/shipment/create";
	URLЗапроса = "/api/v3/lk/documents/create";
	HTTPЗапрос = Новый HTTPЗапрос(URLЗапроса);
	HTTPЗапрос.Заголовки.Вставить("Content-Type",   "application/json");
	HTTPЗапрос.Заголовки.Вставить("Authorization", "Bearer "+СокрЛП(Док.Фирма.ТокенЧЗ));
	
	ТелоЗапроса = Новый Структура;
	ТелоЗапроса.Вставить("product_document", ТекстXML64);
	ТелоЗапроса.Вставить("document_format",  "MANUAL");
	ТелоЗапроса.Вставить("product_group",  "shoes");
	ТелоЗапроса.Вставить("type",  "LP_SHIP_GOODS");
	ТелоЗапроса.Вставить("signature",        ПодписанныеДанные);
	ЗаписьJSON = Новый ЗаписьJSON();
	ПараметрыЗаписиJSON = Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Нет, "");
	ЗаписьJSON.УстановитьСтроку(ПараметрыЗаписиJSON);
	ЗаписатьJSON(ЗаписьJSON, ТелоЗапроса);
	
	ТекстJSON = ЗаписьJSON.Закрыть();
	HTTPЗапрос.УстановитьТелоИзСтроки(ТекстJSON, КодировкаТекста.UTF8, ИспользованиеByteOrderMark.НеИспользовать);
	Ответ = HTTP.ОтправитьДляОбработки(HTTPЗапрос);
	ИДДок = Ответ.ПолучитьТелоКакСтроку();
	Сообщить(ИДДок);
	ДокОб = Док.ПолучитьОбъект();
	ДокОб.ИдентификаторЧЗ=ИДДок;
	ДокОб.СтатусЧЗ="";
	ДокОб.ОшибкаЧЗ="";
	ДокОб.ДействиеЧЗ="";
	Попытка
		ДокОб.Записать(РежимЗаписиДокумента.Запись);
	Исключение
	КонецПопытки;
Показать
MKozzlik; clev; +2 Ответить
18. MKozzlik 25.09.20 11:46 Сейчас в теме
(10) А если ИДДок получен и код ответа -201, то есть успешно создан документ, где его можно найти в честном знаке? в документах ничего нет, пока тренируюсь на тестовом сервере, то есть demo.lp.crpt.tech
20. Mx00 230 15.10.20 17:16 Сейчас в теме
12. _Enot_ 9 23.07.20 20:40 Сейчас в теме
а в поле "Данные для подписи" вставить полученные данные
А какие данные нам именно нужно скопировать? Возвращает ошибку 500. Подпись не валидна
13. _Enot_ 9 24.07.20 07:41 Сейчас в теме
Разобрался. То что вы получили в файл test. txt нужно скопировать и подписать на сайте крипто про, потом \n и \r заменить все и скопировать получившиеся в out. txt. После этого получаем токен. Автор пожалуйста, в статье укажите конкретнее про это пункт. А так все норм, спасибо, лайк)))
d4rkmesa; +1 Ответить
15. user1075117 02.09.20 21:46 Сейчас в теме
(13) А не можете подсказать, что именно вы добавляете на сайте крипто-про, так как пробовал и из первого кода ОборудованиеJSON.uuid ОборудованиеJSON.data; Возвращает всегда подпись не валидна
16. _Enot_ 9 03.09.20 07:28 Сейчас в теме
(15)То,что получаю в файл test.txt .
14. elephant_x 27.08.20 17:28 Сейчас в теме
Было у кого-то такое?
В честный знак захожу без проблем, а при получении токена вот такая ошибка:

Ошибка. Код ответа 400
Организация не зарегистрирована
17. elephant_x 10.09.20 13:23 Сейчас в теме
(14) Обращайте внимание тестовый сервер или продуктивный, у меня была в этом проблема)
19. Mx00 230 15.10.20 17:12 Сейчас в теме
в типовых 1С 8 всё есть (и в июне 2020 тоже было), зачем такие сложности?
21. carapuzzz 07.11.20 12:44 Сейчас в теме
(19)
согласен взять любую конфу от 1с за день разобраться не составит труда.
но есть сам апи честного знака это УГ часть функций не работают как нужно, за два месяца работы с ними они уже сменили 2 версии причем функции постоянно устаревают. нужна была функция для получения информации по марке.
непонятно зачем делать несколько функций для одного и того же но, одна функция возвращает данные по марке, другая нет, причем по другой марке все с точностью до наоборот, техподдержка ни разу не ответила.
Выкладываю их описание, написано коряво но разобраться можно.
Прикрепленные файлы:
Описание_API_ГИС_МТ.pdf
22. Mx00 230 07.11.20 15:04 Сейчас в теме
(21) у меня есть описание API :-)
я всё сделал для 1С 7.7 и это несколько сложнее чем для 1С 8.3 т.к. не было примеров
но даже то, что ты тут "наваял" вообще полная хрень - зачем использовать конвентер JSON-XML ?
проще сразу XML формировать !
а уж подпись обрабатывать через блокнот вообще хрень полная...
подумай тем ли ты занимаешься? может пора сменить профессию?!?
23. carapuzzz 07.11.20 16:27 Сейчас в теме
(22)ничего не ваял статья не моя, см кто автор, пост не только для тебя а всем кто хочет докопаться до истины, выложил свежее описание. согласился лишь с тем, что все есть в типовых конфигурациях.
24. Mx00 230 08.11.20 19:06 Сейчас в теме
(23) тогда я не понял зачем мне ответил... да и прикреплять описание смысла нет, т.к. оно есть на сайте ЧЗ
извини за наезд ;-)
Оставьте свое сообщение

См. также

BIM: взаимодействие с платформой Autodesk Forge Промо

WEB v8 Строительство Абонемент ($m)

Предлагаемый пример демонстрирует широкие возможности для взаимодействия «1С:Предприятие» с платформой Autodesk Forge и позволяет вам получить базовые представления о применения технологий информационного моделирования в строительстве. Поддерживаются все версии платформы от 8.3.12 и выше до 8.3.18.

1 стартмани

25.11.2020    870    0    kandr    0    

Чатбот WhatsApp

WEB v8 1cv8.cf Абонемент ($m)

Внешняя обработка для написания чат-бота WhatsApp

1 стартмани

21.10.2020    3352    14    ripreal1    5    

Учимся создавать http сервис (часть третья). Передача нескольких параметров в http сервис

WEB Практика программирования v8 1cv8.cf Абонемент ($m)

Пошаговое руководство по созданию http сервиса (часть третья). Передача нескольких параметров в http сервис, a также формирование сложных JSON строк.

1 стартмани

02.10.2020    4176    1    hpi    14    

Обмен через API с Честный знак (Система маркировки товаров)

Оптовая торговля WEB v8 1cv8.cf Оптовая торговля, дистрибуция, логистика Россия Абонемент ($m)

Рассмотрен пример обмена через API с Честным знаком с использованием электронной подписи.

1 стартмани

10.08.2020    4783    36    vasilievil    4    

"Учет штрафов ГИБДД" с возможной загрузкой из открытых источников в интернет Расширение конфигурации 1С: Предприятие 8.3 Промо

Обработка документов WEB v8 v8::УФ 1cv8.cf Россия БУ УУ Абонемент ($m)

Расширение конфигурации Бухгалтерия предприятия, редакция 3.0 (при минимальных изменениях любой типовой конфигурации), позволяющее вести историю данных по штрафам ГИБДД для справочника транспортных средств компании. Бонусом поставляется внешняя обработка, способная загружать эти данные из открытых источников в интернет.

4 стартмани

30.12.2019    8060    9    capitan    9    

HTTP сервисы по OpenAPI спецификациям

Практика программирования WEB v8 1cv8.cf Абонемент ($m)

Начинаем путь разработки HTTP сервисов с создания спецификаций OpenAPI. Автодокументация сервисов формата Swagger UI без зависимостей. Настройка сервисов в режиме предприятия.

1 стартмани

29.06.2020    7297    3    shmalevoz    19    

Загрузка из XML файла ЭДО в документ поступления для конфигураций 1С: Розница 2.2/2.3, Управление торговлей 10.3/11.4

Розничная торговля Обработка документов Документооборот и делопроизводство Обмен через XML v8 УТ10 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Внешние обработки загрузки данных из XML файлов формата ON_NSCHFDOPPRMARK ЭДО в документы поступления 1С Розница версия 2.2.10.19 и выше, Управление торговлей 10.3.52.2 и выше, Управление торговлей 11.4.5.63 и выше

1 стартмани

04.06.2020    13388    173    independ    111    

Пример работы с Trello из 1С

WEB v8 1cv8.cf Россия УУ Абонемент ($m)

Небольшая конфигурация содержит примеры обмена с онлайн-сервисом Trello.

1 стартмани

15.02.2020    11295    44    terrorion    12    

Загрузка весового товара в весы Масса-К ВПМ-Ф (1С Предприятие, УТ 11.2-11.4 управляемые формы) Промо

Весы Розничная торговля Розничная торговля v8 v8::ОУ v8::УФ УТ10 Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Данная обработка загружает весовой товар из базы в весы. Данная обработка тестировалась только на версии УТ 11.2-11.4 (1С Предприятие 8.3) и весах ВПМ-Ф.

2 стартмани

21.07.2016    18312    17    user594264_e.sitnik    4    

Google drive - менеджер файлов

WEB Внешние источники данных v8 1cv8.cf Россия Абонемент ($m)

Синхронизация с гугл диском легко и просто!

10 стартмани

05.12.2019    10024    29    zykov_vitaliy    26    

Работа с Яндекс-картами в 1С (вывод меток, прокладка маршрута, отображение балуна, вывод меток в кластеры) (обычное и управляемое приложение)

WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Работа с Яндекс-картами в 1С (управляемое приложение). Обработка показывает, как можно найти адреса на карте Яндекс, проложить маршрут.

2 стартмани

20.11.2019    12725    121    Denr83    0    

Яндекс сервисы [Расширение]

Универсальные обработки WEB v8 1cv8.cf Абонемент ($m)

Расширение для работы с Яндекс-сервисами (предиктор,переводчик,проверка орфографии)

1 стартмани

24.10.2019    11631    10    noprogrammer    12    

Аналоги номенклатуры для УТ 11.4, КА 2.4, ERP 2.4, Розница 2.2, Розница 8. Магазин автозапчастей. Расширение Промо

Рабочее место Оптовая торговля Розничная торговля Управление торговлей Оптовая торговля Розничная торговля v8 Розница ERP2 УТ11 КА2 Автомобили, автосервисы Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Расширение для работы с аналогами номенклатуры. Отлично подходит для работы с кроссами запчастей и товаров с аналогичными свойствами. Поддерживаемые конфигурации: УТ 11.4, КА 2.4, ERP 2.4, Розница 2.2, Розница 8. Магазин автозапчастей. Лёгкое подключение, без изменения конфигурации.

1 стартмани

30.08.2019    20153    20    AleSSandre    26    

Рекомендательный сервис на основе коллаборативной фильтрации на 1С. Расширение формы подбора для УТ 11.4

Оптовая торговля Розничная торговля Практика программирования Математика и алгоритмы v8 ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

В данной разработке реализован механизм рекомендаций товаров по принципу схожести товаров в корзине на основе алгоритма Item-to-Item от Amazon. Разобран алгоритм с демо базой и сделано расширение для УТ11.4 которое добавляет в форму подбора таблицу рекомендаций. Протестировано на 8.3.13.1865 на Управление торговлей, редакция 11 (11.4.8.63)

3 стартмани

25.09.2019    10710    13    informa1555    24    

Telegram бот на 1С

WEB v8 1cv8.cf Абонемент ($m)

Telegram бот на 1С в виде внешней обработки, встраиваемой в типовые 1С 8.3.

1 стартмани

24.09.2019    16367    35    budidich    19    

Работа с релизами 1С и договорами ИТС

WEB БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Работа с релизами 1С и партнерским кабинетом.

2 стартмани

15.08.2019    14784    44    RocKeR_13    15    

Внешняя компонента для работы по Web-socket протоколу x32 x64 Промо

Разработка внешних компонент WEB v8 Абонемент ($m)

Кто когда-нибудь сталкивался с обменом данными по Web-Socket (wss) протоколу из 1С, тому известно, что в платформе отсутствуют данные механизмы (не путать с HTTP запросами и WebServices). Предлагается использовать внешнюю компоненту, написанную по технологии NativeAPI, для подключения и обмена с серверами из 1С-Предприятия, работающими по протоколу Web-Socket.

1 стартмани

30.03.2018    27248    40    Ditron    83    

Выгрузка номенклатуры в социальную сеть Вконтакте

WEB Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка для быстрой и легкой выгрузки товаров Вконтакт. Так просто еще не было)))

2 стартмани

14.08.2019    14996    49    kaliuzhnyi    46    

Шаблон http-сервиса для вашего проекта

Внешние источники данных WEB Мобильная разработка v8 v8::Mobile 1cv8.cf Абонемент ($m)

Http-сервис для обмена данными в формате JSON. Обработчики этого сервиса находятся во внешней обработке, что позволяет дорабатывать его без изменения конфигурации. Также прилагаю пример мобильного приложения для работы с данным сервисом (получает номенклатуру и остатки на складе). Сервис очень быстро разворачивается и масштабируется под ваши задачи.

3 стартмани

04.05.2019    19867    76    MarkoSokolov    48    

Автоматическая рассылка прайс-листов Промо

Ценообразование, прайсы Email Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 УТ10 Абонемент ($m)

Устали от утомительной рассылки прайс-листов своим клиентам? Тогда эта обработка как раз для вас, она сделает полностью все сама! Сформирует прайс с нужными настройками и отправит его по электронной почте, как, куда и когда надо.

1 стартмани

24.03.2014    39751    48    skyadmin    20    

Обработки для 1С: Розница по работе с ЕГАИС

Розничная торговля Обработка документов Обработка справочников Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия БУ Абонемент ($m)

Несколько простых и нужных обработок для упрощения работы с ЕГАИС в 1С Розница версий 2.2.10.ХХХ и выше.

1 стартмани

25.02.2019    18228    45    independ    15    

1С и WebKit. Вариант взаимодействия

WEB v8 1cv8.cf Абонемент ($m)

В результате перехода на WebKit тип свойства Документ у поля, имеющего вид ПолеHTMLДокумента, изменился с COMОбъект на ВнешнийОбъект. Также изменилась DOM модель документа, доступная через это свойство.

2 стартмани

23.02.2019    30306    78    mi1man    57    

Строим маршруты на картах в 1С с помощью OpenStreetMap, OSRM и Leaflet

WEB v8 1cv8.cf Транспорт, автопарки, такси Абонемент ($m)

Краткая статья о том как вывести на карту (в 1С) маршруты с помощью OpenStreetMap, OSRM и Leaflet. По данной системе очень мало примеров, но так как OpenStreetMap является бесплатным сервисом и не требует никаких ключей и регистраций, и является довольно мощным механизмом, решил написать небольшую статью "как это сделать?". В первую очередь скажу, все намного проще, если вы используете последнюю версию платформы (8.3.14), где есть поддержка практически всех браузеров (IE 11, EDGE, Mozilla), но что делать если у нас не самая свежая платформа, где поддержка только IE 9?

2 стартмани

12.02.2019    26519    103    Ditron    94    

Печать чеков для ККМ АТОЛ и ШТРИХ на основании текстового файла, где содержится описание товаров, цен, НДС (все требования 54-ФЗ, поддержка изменений от 01/07/19). Для 1С (7.7 и 8 УФ, обычных форм) есть готовые обработки Промо

ККМ Фискальный регистратор Кассовые операции Оптовая торговля Розничная торговля Кассовые операции Оптовая торговля Розничная торговля v7.7 v8 v8::УФ 1cv8.cf 1cv7.md Россия Абонемент ($m)

Это программа печати чеков, которая читает обычный текстовый файл, где перечислено, что надо распечатать на ФР - описание содержимого чека. Такой механизм позволяет использовать комплект для WEB сайтов, для не типовых или сильно измененных 1с7 или 1с8. Для любых программ которые умеют работать с текстовыми файлами (будь то CLIPPER,FOXPRO,JAVA, WSH, VBS итд). Внутри комплекта лежат готовые внешние печатные формы для печати из документов Реализация товаров и услуг 1с8 УТ10, БП2, БП2Базовая, БП2Корп, УТ11, БП3, БП3Базовая, БП3Корп, Для 1с:ТиС 7.7 Реализация ТМЦ, Бух4.5, Бух1.3 и Печать из ПКО Подключать ФР к 1С не надо! Не надо открывать смену. Подходит для любой конфигурации, для любого документа. Более 300 внедрений на ккм Штрих-Мини-ФР-К, Штрих ОнЛайн Атол 11Ф, 55Ф, 30. Возможна пробитие оплаты наличным или VISA  (Электронные деньги). Поддерживает передачу в ОФД имени кассира, телефон или email покупателя. Для каждого чека можно поменять ОСН (ЕНВД, Доходы-расходы итд). Возможна печать чека с выровненными колонками, Наименование,Количество Цена, Сумма, в этом случае фискализация будет одной строкой с общей суммой. Можно пробить не фискальный чек. (чек будет, но в налоговую не уйдет). Добавлена расшифровка длинных наименований, что актуально для Штрих (программа сама переносит длинные наименования на след строку). Есть внесение и выплата денег. 29.06.17 добавлено пробитие 2 видов оплат в одном чеке.

7 стартмани

11.04.2017    69436    194    ah7777777    517    

1С: Розница/УТ 10.3. ЕГАИС, загрузка акцизных марок в справочник Штрихкоды и Упаковки, регистр Акцизные марки из XML-сообщений входящих ТТН ЕГАИС + Печать акцизных марок

Розничная торговля Обработка справочников Обмен через XML Ценники Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Пакетная загрузка/обновление списка акцизных марок ЕГАИС из входящих ТТН ЕГАИС. Для 1С Розница 2.2.9.ХХХ/2.2.10.ХХХ//2.2.11.ХХХ/2.2.12.ХХХ/Управление торговлей 10.3.49.ХХХХ и выше с возможностью печати

1 стартмани

31.01.2019    23093    175    independ    124    

Яндекс карты 2.1. Построение маршрута. Передача длины маршрута в реквизит формы

WEB v8 1cv8.cf Абонемент ($m)

Пригодится как пример использования Яндекс карты 2.1 для построения маршрута.

1 стартмани

24.01.2019    14462    76    John_d    32    

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019)

Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ v8 v8::Mobile БУ УУ Абонемент ($m)

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    45717    254    informa1555    232    

Трекинг номеров РПО в Почте России Промо

WEB Оптовая торговля Оптовая торговля v8 Оптовая торговля, дистрибуция, логистика Абонемент ($m)

Относительно недавно Почта России стандартизировала и описала сервисы получения информации о регистрируемом почтовом отправлении (РПО). Представляю вашему вниманию конфигурацию-обертку над сервисами Почты России. Она позволяет просто (http-запросы) и без изменений конфигурации подключить сервисы отслеживания к своим информационным системам.

2 стартмани

28.03.2016    27376    11    Smaylukk    3    

Проверка VAT номеров

WEB v8 1cv8.cf Абонемент ($m)

Обработка для вызова сервиса проверка VAT номера.

1 стартмани

26.11.2018    12971    2    wtlz    1    

Загрузка чека онлайн-касс (загрузка товаров из чека)

Внешние источники данных WEB Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка-пример, позволяет любому и из любой конфигурации загрузить информацию о товарах из чека(и не только) из почтового сообщения, отправленного из приложения ФНС проверка чеков.

2 стартмани

08.10.2018    21653    39    echo77    73    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    22110    13    RocKeR_13    16    

Работа с картой. Кадастровый учет (Росреестр). Тематические карты Промо

WEB Рабочее место v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка для работы с картами в 1С. Получения изображения с публичной кадастровой карты России, построения тематических карт

5 стартмани

31.08.2017    18786    15    vipchep    0    

Помощник корректировки остатков ЕГАИС в небольшом магазине. Розница 2.2

Розничная торговля Обработка документов Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Абонемент ($m)

Данная обработка упрощает корректировку остатков алкогольной продукции небольшого магазина, где предполагается передача всей продукции в торговый зал сразу после приемки.

5 стартмани

08.09.2018    33466    83    asdfgcom    46    

SOAP для чайников

Обмен через XML WEB v8 1cv8.cf Абонемент ($m)

Немножко про SOAP сервис. И пример работы с подключением и получением данных по SOAP за 5 минут.

1 стартмани

05.09.2018    52179    46    dusha0020    18    

Класс-обработка “Работа с картами Яндекс”

Разработка внешних компонент WEB v8 Абонемент ($m)

Как показать точку или маршрут на карте Яндекс. Как получить координаты по строке адреса (геокодирование).

1 стартмани

01.08.2018    25799    203    RSConsulting    16    

Работа с картами 1С 4 в 1: Яндекс, Google , 2ГИС, OpenStreetMap(OpenLayers) Промо

Универсальные обработки WEB v8 1cv8.cf Абонемент ($m)

С каждым годом становится все очевидно, что использование онлайн-сервисов намного упрощает жизнь. К сожалению по картографическим сервисам условия пока жестковаты. Но, ориентируясь на будущее, я решил показать возможности API выше указанных сервисов: Инициализация карты Поиск адреса на карте с текстовым представлением Геокодинг Обратная поиск адреса по ее координатами Взаимодействие с картами - прием координат установленного на карте метки Построение маршрутов по указанным точками Кластеризация меток на карте при увеличении масштаба Теперь также поддержка тонкого и веб-клиента

1 стартмани

28.12.2012    107136    1207    Smaylukk    355    

Пример использования REST API Яндекс Диска

WEB v8 1cv8.cf Абонемент ($m)

Пример использования REST API Яндекс Диска: чтение диска, добавление каталога, загрузка файла, скачивание файлов или каталогов, удаление файлов или каталогов.

1 стартмани

26.06.2018    25996    42    MKFreeUser    15    

ЕГАИС 3 Контролёр для 1С:Розница

Терминал сбора данных Розничная торговля Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Оградите себя от рисков отзыва лицензии на торговлю алкоголем, штрафов и блокировок в ЕГАИС. Проверяйте поступающую алкогольную продукцию помарочно на соответствие ТТН ЕГАИС v3 перед тем, как подтвердить получение и принять её на баланс в ЕГАИС. С 01.07.2018 начинается переход ЕГАИС на помарочный учет алкогольной продукции на всех стадиях товародвижения, начиная от производства или ввоза на территорию России, до реализации в розничной торговле, т.н. "ЕГАИС 3.0". В типовой Рознице уже появилась обработка для контроля поступивших акцизных марок на ПК. Предлагаю ознакомиться с мобильным решением. Контроль производится в Android приложении на ТСД или на обычном смартфоне.

1 стартмани

13.06.2018    21041    17    kuld    30    

Обмен файловыми базами данных через Yandex диск

WEB v8 Россия Абонемент ($m)

Выполнение операций обмена с Yandex диском для файловых БД, по протоколу WebDav, в автоматическом или ручном режимах.

1 стартмани

11.06.2018    17529    7    slimper    1    

Чтение сжатого gzip, deflate HTTP ответа сервера. Без ВК. Уменьши время загрузки и сократи трафик в 3 раза

WEB v8 1cv8.cf Абонемент ($m)

В платформе 1С:Предприятие не реализовано штатного механизма декодирования ответа веб серверов, в которых присутствует gzip сжатие. Некоторые использовали WinHttpRequest.5.1 , кто-то писал ВК. Друзья, хватит. Вот вам решение.

1 стартмани

08.06.2018    16058    80    Malfarion    16    

Пробитие чеков через ККМ в офисе (для курьеров)

ККМ Фискальный регистратор Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 v8::ОУ Розница УТ11 Россия БУ Абонемент ($m)

Предлагается интеграция 1С с ККТ СтарРус. Поддерживается одновременная работа с разных рабочих мест. ККТ СтарРус работает как сервер, и принимает команды через API по http-протоколу, что позволяет пробивать чеки через центральную базу 1С для интернет-магазина и для курьеров.

1 стартмани

07.06.2018    32628    12    Kutuzov    12    

Конфигурация для просмотра публичных телеграм каналов

WEB v8 Абонемент ($m)

Просмотр и каталогизация в более удобном виде публичных телеграм каналов, групп и чатов.

1 стартмани

02.06.2018    18284    11    DO_WHILE_LOOP    7    

Корректировка остатков ЕГАИС для 1С:Розница/УТ 10.3 - альтернативный вариант

Обработка документов Розничная торговля Учет ТМЦ Розничная торговля Учет ТМЦ v8 Розница Розничная и сетевая торговля (FMCG) БУ Абонемент ($m)

Обработка корректировки остатков ЕГАИС для 1С Розница версии 2.2.7/2.2.8/2.2.9/2.2.10/2.2.11/УТ 10.3.47.ХХХ-48.XXX-49.XXX-50.XXX раздельно по маркируемому/немаркируемому алкоголю + создание документов постановки/списания по пересортице.

1 стартмани

02.06.2018    35390    404    independ    277    

Интеграция между Atlassian Jira и 1С:Предприятие 8.3 используя Jira REST API (выборка, создание и изменение запросов, чтение, создание и удаление записей о работах, чтение комментариев и другие возможности)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка на управляемой форме для 1С:Предприятие 8.3 по интеграции с Atlassian Jira используя Jira REST API. Ключевые функции: выборка запросов с использованием JQL; добавление и изменение запросов; добавление, изменение и удаление записей о работах; чтение комментариев к запросам; сохранение всех ключевых параметров между сеансами работы. Тестирование проводилось на платформе 1С (8.3.11.2954) совместно с JIRA Server platform (7.3.7)

1 стартмани

24.04.2018    33328    184    Ko1t    81    

Простая и пошаговая интеграция Яндекс-Алисы и 1С

WEB v8 Абонемент ($m)

Интеграция Алисы и 1С через http сервис на платформе 8.3.9. Используем виртуальный сервер, сертификат от letsencrypt, и делаем простые запросы к базе из Алисы.

1 стартмани

09.04.2018    23208    19    kiv1c    35    

Чтение и запись из таблиц гугл (google sheets) в табличный документ 1С (8.3, управляемые формы)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка на управляемой форме для 1С версии 8.3 для доступа к сервисам Google Sheets c использованием протокола авторизации OAuth 2.0. Выполняет получение списка листов таблицы гугл, чтение таблицы гугл в табличный документ 1С и запись из табличного документа 1С в таблицу гугл. Тестирование проводилось на платформе 1С:Предприятие 8.3 (8.3.11.2954).

1 стартмани

09.04.2018    40855    273    Ko1t    76