Очередной "мягкий" отключатель активных и не очень пользователей

Публикация № 1154117

Администрирование - Информационная безопасность - Роли и права

Расширение пример

Тема отключения пользователей не нова, но это чуть другой взгляд на проблему.

Поставлено ТЗ написания как можно более простого метода, чтобы "мягко" отключать пользователей. Базы как клиент-серверные, так и файловые. И отключать надо по команде, а не каждую сессию отдельно руками.
Концепция решения "мягкого" отключения следующая - пользователь должен "сам" завершить свою работу. Иными словами необходимо дать клиенту понять, что необходимо завершить работу. Вариаций можно добавить сколько угодно.

Для этого была написана админовская часть, использующая некую табличную часть сеансов, получающая сеансы с АГЕНТА для клиент-серверных баз, так и  с файловых баз, используя механизм COM(медленный) или HTTP-сервисы(быстрый, предпочтительно), с функцией отключения нужного сеанса:

Процедура ДатьЗаданиеНаОтключениеСеансовИБ(ИБ, ИмяПользователя, НомерСеанса, ИмяПриложения, Компьютер, СообщениеПользователю = "", ТаймАут=10) Экспорт
	// Сеанс.ИмяПриложения
	//1CV8 - идентификатор приложения 1С:Предприятие в режиме запуска "Толстый клиент"; 
	//1CV8C - идентификатор приложения 1С:Предприятие в режиме запуска "Тонкий клиент"; 
	//WebClient - идентификатор приложения 1С:Предприятие в режиме запуска "Веб-клиент"; 
	//Designer - идентификатор приложения Конфигуратор; 
	//COMConnection - идентификатор сессии внешнего соединения 1С:Предприятия через COM; 
	//WSConnection - идентификатор сессии Web-сервиса; 
	//BackgroundJob - идентификатор сессии обработки заданий; 
	//SystemBackgroundJob - идентификатор системного фонового задания; 
	//SrvrConsole - идентификатор сессии консоли кластера; 
	//COMConsole - идентификатор административной сессии внешнего соединения; 
	//JobScheduler - идентификатор сессии планировщика заданий; 
	//Debugger - идентификатор сессии отладчика; 
	//OpenIDProvider - провайдер OpenID; 
	//RAS - идентификатор сервера администрирования.

	Если ИмяПриложения = "1CV8" или ИмяПриложения = "1CV8C" или ИмяПриложения = "WebClient" или ИмяПриложения = "Толстый клиент" или ИмяПриложения = "Тонкий клиент" или ИмяПриложения = "Веб-клиент" Тогда
		КлючОбъекта			= "ЗавершениеРаботы";
		КлючНастроек		= СтрЗаменить(Строка(НомерСеанса), Символы.НПП,"");
		Настройки			= ИБ.NewObject("Структура");
			Настройки.Вставить("Пользователь",				ИмяПользователя);
			Настройки.Вставить("ТекущийПользователь",		ПараметрыСеанса.ТекущийПользователь.Наименование);
			Настройки.Вставить("Компьютер",					Компьютер);
			Настройки.Вставить("Сеанс",						НомерСеанса);
			Настройки.Вставить("ДатаИнициацииОтключения",	ТекущаяДата());
			Настройки.Вставить("ТаймАут",					ТаймАут);
			Если НЕ СообщениеПользователю = "" тогда
				Настройки.Вставить("РежимОтключения",		2);// 0 - отключение без предупреждения, 1 - вывести с предупреждением , 2 - просто сообщение
				Настройки.Вставить("СообщениеПользователю",	СообщениеПользователю);
			Иначе
				Настройки.Вставить("РежимОтключения",		1);// 0 - отключение без предупреждения, 1 - вывести с предупреждением
				Настройки.Вставить("СообщениеПользователю",	"Сообщение от Админа: ""Просьба выйти из базы для выполнения архивации""");
			КонецЕсли;
		ОписаниеНастроек 	= "Отключение пользователя по запросу администратора";
		ИБ.ХранилищеОбщихНастроек.Сохранить(КлючОбъекта, КлючНастроек, Настройки, ОписаниеНастроек, ИмяПользователя);
	КонецЕсли;
КонецПроцедуры

Поскольку почти все клиентские базы стоят на поддержке без возможности вносить изменения, то было написано расширение. В нем присутствует функция оценки задания на отключение. Отключается только необходимый пользователь. По сути дела, решение принимает клиентская часть - "Если МНЕ задание на завершение работы, то будет предпринята попытка отключения". Ниже сама функция отключения

Функция КонтрольЗавершенияРаботы() Экспорт
	НомерСеанса 		= ЗРП_ОбщийМодульСервер.ПолучитьНомерСеанса();
	НачалоРаботы		= ЗРП_ОбщийМодульСервер.ПолучитьдатуСеанса(НомерСеанса);
	СтруктураПараметров = ЗРП_ОбщийМодульСервер.ЗагрузитьХранилищеОбщихНастроек("ЗавершениеРаботы", СтрЗаменить(Строка(НомерСеанса),Символы.НПП,""), ИмяПользователя());
	Если НЕ СтруктураПараметров = Неопределено Тогда
		Если НЕ ЗРП_ОбщийМодульСервер.ЗапущенКонфигуратор() Тогда
			Если НомерСеанса = СтруктураПараметров.Сеанс Тогда
				ЗРП_ОбщийМодульСервер.УдалитьХранилищеОбщихНастроек("ЗавершениеРаботы", СтрЗаменить(Строка(НомерСеанса),Символы.НПП,""), ИмяПользователя());
				Попытка
					Если СтруктураПараметров.ДатаИнициацииОтключения > НачалоРаботы Тогда  // если пользователь успел выйти до команды
						Если СтруктураПараметров.РежимОтключения = 0 Тогда  // безусловное завершение без вопросов
							ЗавершитьРаботуСистемы(Ложь);
						ИначеЕсли СтруктураПараметров.РежимОтключения = 1 Тогда // только сообщение с описанием того кто выдал задание на закрытие
							Оповещение = Новый ОписаниеОповещения("ПослеЗакрытияПредупреждения", ЗРП_ОбщийМодульКлиент);
							ПоказатьПредупреждение(Оповещение, СтрЗаменить(СтруктураПараметров.СообщениеПользователю, "%", СтруктураПараметров.ТекущийПользователь), СтруктураПараметров.ТаймАут);
						ИначеЕсли СтруктураПараметров.РежимОтключения = 2 Тогда // выдача вопроса с интерактивным выбором ЗАКРЫТЬ или НЕТ
							Оповещение = Новый ОписаниеОповещения("ПослеЗакрытияВопроса", ЗРП_ОбщийМодульКлиент);
							Кнопки = Новый СписокЗначений;
							Кнопки.Добавить(КодВозвратаДиалога.ОК, "Завершить");
							Кнопки.Добавить(КодВозвратаДиалога.Отмена, "Отмена");
							ПоказатьВопрос(Оповещение, СтрЗаменить(СтруктураПараметров.СообщениеПользователю, "%", СтруктураПараметров.ТекущийПользователь), Кнопки, СтруктураПараметров.ТаймАут, , "Завершение работы системы");
						ИначеЕсли СтруктураПараметров.РежимОтключения = 3 Тогда // только сообщение
							Предупреждение(СтруктураПараметров.СообщениеПользователю, СтруктураПараметров.ТаймАут);
						КонецЕсли;
					КонецЕсли;
				Исключение
					ЗРП_ОбщийМодульСервер.ЗЖР("ЗавершениеРаботыПользователей.КонтрольЗавершенияРаботы()", "Ошибка",,ОписаниеОшибки());
				КонецПопытки;
			КонецЕсли;
		КонецЕсли;
	КонецЕсли; 
КонецФункции 

Расширение на данный момент работоспособно на версии ЗУП 3.1.11.133, БУХ 3.0.73.60, КА2 2.4.7.141/3.2.23.3(БИТфинанс). Поскольку не использовалось БСП, то и проблем с библиотекой тоже нет.
Остались две проблемы:

1. Разрешимая - условие совместимости, меняемое при обновлении, которое можно исправить в любой момент;
2. Не решённая - если на главном окне вылезло окно с вопросом, блокирующим весь интерфейс, ожидающего интерактивного принятия решения. Поиск решения ведётся.

 

P.S. Сильно прошу палками не кидать. Любые реальные ссылки будут восприняты с благодарностью.

Скачать файлы

Наименование Файл Версия Размер
ЗавершениеРаботыПользователей_ТАКСИ_009.cfe

.cfe 9,50Kb
15.11.19
4
.cfe 191024.009 9,50Kb 4 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Xershi 1029 15.11.19 19:15 Сейчас в теме
Какое может быть решение, когда пользователь ушел домой. Только рубить.
А какая цель публикации, академический интерес?
По поводу расширения. Пишут обработку и она анализирует совместимость и затем ставит нужную версию.
2. ybatiaev 51 16.11.19 00:03 Сейчас в теме
(1) Если необходимо АВТОМАТИЧЕСКИ обновить базы, без участия программистов, но:
- база файловая(как можно рубить программно? Научите);
- необходимо обновить около 500 баз за ночь и ничто не должно помешать;
- необходимо отключать только те базы, в которых не работают в конфигураторе или отключить по определённому правилу .

Цель публикации - поделиться опытом.

По поводу обработки напишите путь решения. Буду признателен. Кроме интерфейса только "Такси" или "Такси. Разрешено..," есть ещё и совместимость версий.
zabaluev; +1 Ответить
3. Xershi 1029 16.11.19 09:48 Сейчас в теме
(2) для примера посмотрите как сейчас ставится Битрикс.

На файловой базе запуск обработки блокировки пользователей, как и в клиент серверной.
Про 500 баз. Так у вас же расширение, а не конфигурация для обновления.
4. ybatiaev 51 17.11.19 01:15 Сейчас в теме
(3) про битрикс не понял. В смысле как ставится? Хочу с ним познакомится, но руки не доходят.
Не понял и про блокировки. К чему Вы это написали? И я про блокировку не писал (моя конфа и это делает при необходимости).
Про 500 баз - данное расширение помогает выкинуть пользователей без участия программиста... у меня в том числе и конфигурация обновлений.
5. dock 41 18.11.19 08:59 Сейчас в теме
1) в ЗУП3 и БУХ3 прекрасно отрабатывает и типовой механизм... (в том числе и для файловых баз).
2) На скрине очень интересное сообщение от админа: "... для выполнения архивации"
В серверных базах архивация (бекап) выполняется средствами SQL, в файловых базах - специальными утилитами (например cobian backup), посредством теневой копии. В обоих случаях, выгонять пользователей не требуется :).
6. ybatiaev 51 18.11.19 14:43 Сейчас в теме
(5)
- "Смешное сообщение" - сделал для теста. Задаётся любое в админовской части.
- У нас сисадмины отделены от программеров вообще и средствами SQL делается всё с разрезом неделя. Всего неделя. Главная их задача - бесперебойная работа СУБД, скорость и оперативность исправления ошибок;
- с базами работают и пользователи-администраторы. Других не дёргают. Хранение баз (любой базы) настраиваемое. Без администраторов баз сами базы могут быть восстановлены или сделан срез перед операциями. Таких срезов много и дергать администраторов не разрешают;
- Восстановление из бакапа SQL процесс более затратный по времени, чем из DT;
- файловую базы можно просто скопировать, если что, но обновить после этого всё же не удастся, если база залочена. Прошу подсказать типовой программный механизм с файловыми базами, без участия программиста пожалуйста. Направьте, может что упустил. Работы много... всего читать не успеваю.
7. dock 41 18.11.19 15:06 Сейчас в теме
(6)
1)
- Восстановление из бакапа SQL процесс более затратный по времени, чем из DT;

Если загрузка из DT происходит быстрее, чем загрузка из бекапа SQL.... значит у вас что-то не так с SQL базой :) однозначно!
Чисто технически, при загрузке из DT, выполняется больше операций :)
2)
- файловую базы можно просто скопировать, если что, но обновить после этого всё же не удастся, если база залочена.

просто скопировать, если в базе "сидит" хотя бы один пользователь ? ни разу не получалось "просто скопировать" :)
про "залочена" не понял... залочена средствами 1С или системой ?
8. ybatiaev 51 19.11.19 08:03 Сейчас в теме
(7) по 1 вопросу - передам сисадминам. Насколько мне известно восстановление с DT "чистит" пустое место и частично восстанавливает "битые" ссылки, если это возможно. С SQL восстанавливается ВСЁ полностью. Поэтому операций да, больше.
по 2 пункту - да прям. Сейчас проверил, может что изменилось. Открыл и конфигуратор и клиента. *.1CD прекрасно скопировался. И это является стандартным механизмом "бакапа" при автообновления у самих 1С-ников.
9. dock 41 19.11.19 11:21 Сейчас в теме
(8)
*.1CD прекрасно скопировался.

соглашусь, я не прав... Но это уже изменение на уровне самой платформы - раньше была ошибка "файл занят"...
Всё течёт, все меняется :)
10. NoRazum 28 14.01.20 16:38 Сейчас в теме
(9) Запустите проведение с трех клиентов и попробуйте скопировать. Результат будет другой.
11. ybatiaev 51 16.01.20 09:37 Сейчас в теме
(10) Этот механизм был сделан самой 1С и только для интерактивного режима. Предполагаю идею - всплывает сообщение кому-то, что вышла новая версия, мол "ОБНОВИТЬ ВЕРСИЮ?", бухгалтер(с полными правами) кричит всем "буду обновлять", все выходят и далее по плану. Никакого автоматического обновления файловой базы не могло быть. Ну и тем более, если не один работает, а другой, не посмотрев активных, начинает все действия. Тут уж совсем надо быть глупым.
Ну а мягкое отключение как раз для таких вот случаев. Выдал сообщение, если пользователя нет - отключил, если работает(и ответил интерактивно) - не трогать.до времени.
Вариант со скриптами намного проще, конечно. Но этот механизм у меня встроен в некий администратор баз. Там некий комплекс действий по ситуации. Основная идея - оперативность.
Оставьте свое сообщение

См. также

Изменение наименования отчета в настройках пользователя

Роли и права v8 БП3.0 Абонемент ($m)

При переименовании отчета в конфигурации (расширении) слетают все пользовательские настройки этого отчета, так как в хранилище пользовательских настроек ключ объекта содержит наименование объекта. Данная обработка позволяет переименовать настройки с новым значением ключа (соответствующим новому наименованию отчета) или скопировать настройки для нового значения ключа.

1 стартмани

13.10.2020    561    0    ipoloskov    0    

Отражение зарплаты в бухгалтерском учете: права старшего расчетчика

Зарплата Обработка документов Роли и права v8::СПР v8::Права ЗУП3.x БУ Абонемент ($m)

В ЗУП 3.1.14.208 пользователь с правами старшего расчетчика не может заполнить документ "Отражение зарплаты в бухучете". Проблему можно решить с помощью расширения.

1 стартмани

07.10.2020    562    0    Hla    0    

Анализ применения ролей пользователя по отдельному объекту

Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

Обработка для анализа ролей пользователей: В каких ролях прописано право на конкретный объект? Какие из этих ролей получил пользователь? Есть ли дополнительные ограничения RLS?

1 стартмани

02.10.2020    597    1    japopov    0    

Копирование настроек пользователя для УТ 10.3

Роли и права v8 v8::Права УТ10 Россия УУ Абонемент ($m)

Копирование настроек пользователя для УТ 10.3 (настройки пользователя и дополнительных прав).

1 стартмани

30.09.2020    614    3    artemua    2    

Просмотр пользователей и их прав - инструмент администрирования

Роли и права v8 v8::Права 1cv8.cf Россия Абонемент ($m)

Позволяет проанализировать Пользователей и их роли. В случае большого количества пользователей быстро понять, какие наборы прав нужны для выполнения заданных целей.

1 стартмани

23.09.2020    594    5    Vardar    7    

Запрет на изменение проведенного документа для УНФ 1.6

Роли и права v8 УНФ Россия Абонемент ($m)

Запрет на изменение проведенного документа Расходная накладная для УНФ 1.6.

2 стартмани

21.09.2020    583    1    Kerim09    0    

Расширение для запрета изменений в документе "Регистрация трудовой деятельности" по дате запрета.

Адаптация типовых решений Роли и права v8 ЗУП3.x Россия Абонемент ($m)

В ЗУП 3.1.14.183 оставлена возможность отменить проведение и провести заново для документа "Регистрация трудовой деятельности" из списка документов, чем сотрудники отдела кадров успешно пользуются. Позже они возмущаются, что появляется несколько одинаковых записей отмены и такая же для отправки по сотруднику в "мероприятиях" при заполнении документа "Сведения о трудовой деятельности работников, СЗВ-ТД". Расширение устанавливает запрет на изменения по общей дате запрета, если нет отдельно по пользователю. Никакие изменения в основную конфигурацию вносить не нужно, просто добавляете расширение.

1 стартмани

07.09.2020    914    0    Svetlanka_sv    0    

Запрет произвольной цены

Расширения Роли и права Ценообразование, анализ цен v8 v8::Права ERP2 УТ11 КА2 Россия УУ Абонемент ($m)

Расширение для запрета произвольной цены в документе Заказ клиента и обработке Подбор товаров в документ продажи.

1 стартмани

06.09.2020    1167    3    user1209971    6    

Все объекты, на которые у роли есть право доступа

Роли и права v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m)

Получение всех объектов, на которые у указанной роли есть указанное или хоть какое-то право доступа, в виде дерева метаданных.

1 стартмани

28.08.2020    1185    3    Yashazz    4    

Роль "Менеджер по продажам" в Бухгалтерии 3. Даем доступ к документам Поступления, к ОСВ по счету только 41.01 и карточке счета только 41.01

Оптовая торговля Роли и права v8 v8::Права БП3.0 Россия БУ Абонемент ($m)

Расширяем возможности стандартной роли "Менеджер по продажам" в Бухгалтерии 3. Даем доступ к просмотру и редактированию документов Поступление ТМЦ. А также к Оборотно-сальдовой ведомости по счету 41.01 и Карточке счета по счету 41.01.

3 стартмани

26.08.2020    1087    2    ah7777777    5    

Массовый перенос ролей пользователей из одной конфигурации в другую

Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

Данная обработка позволяет получить список текущих ролей всех пользователей 1С или установить роли согласно списку для всех пользователей 1С. Тестировалось на платформе 8.3.15. Привязки к конфигурации нет - любая.

1 стартмани

21.08.2020    1208    1    donpadlo    6    

Настройка панели разделов с помощью Ролей, гибкая настройка начальной Страницы для Бухгалтерии

Роли и права v8::БУ БП3.0 Аудит и бухгалтерские услуги, юриспруденция Россия БУ Абонемент ($m)

Расширение прав с главным приоритетом в 1С Бухгалтерии, если пользователю не нужен "Раздел производства", "Зарплаты и кадры" мы можем их убрать. Можно конечно, убрать через панель навигации каждому пользователю, но это крайне не удобно и пользователь может сам себе вернуть разделы. Так же я столкнулся с БазовымиПравамиБСП, которая дает права на все разделы, а если эту роль исключить то мы получим ошибку при входе(не имеем базовых прав). Как этого избежать?

1 стартмани

06.08.2020    1350    6    Profenix    0    

Пользователи программы

Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

Отчет по справочнику "Пользователи", соединенный с данными пользователей системы.

1 стартмани

20.07.2020    1812    2    Pro-tone    0    

Анализ прав пользователей в Бухгалтерии предприятия 3.0

Роли и права v8 v8::Права БП3.0 Абонемент ($m)

Наглядное представление прав пользователей со сводкой доступа к организациям.

1 стартмани

14.07.2020    1949    2    wenzor    0    

Подсистема прав доступа к объектам с гибкими отборами (расширение)

Роли и права v8 ERP2 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m)

Возможность без доработок конкретизировать пользователям права Просмотра и Изменения объектов базы 1С, установив ограничения с помощью отборов системы компоновки данных.

2 стартмани

02.07.2020    8068    62    sapervodichka    48    

Доступ к функционалу ЭДО пользователя без администраторских прав

Документооборот и делопроизводство Роли и права v8 v8::Права УНФ Абонемент ($m)

Данная обработка предназначена для запуска функционала Электронного документооборота пользователем с ограниченными правами, не имеющим доступ к разделу Компания, из которого в свою очередь запускается меню с Электронными Документами ( Архив ЭДО ,Текущие дела ЭДО , Производные документы), а также меню Администрирование / Обмен с контрагентами / Настройки электронной подписи и шифрования.

1 стартмани

26.06.2020    2951    2    its_33    0    

Альфа-Ника: Кладовщик – расширение для 1С:Бухгалтерии 3.0

Учет ТМЦ Роли и права v8::БУ v8::Права БП3.0 Россия БУ Абонемент ($m)

Целью данного расширения является создание профиля “Кладовщик”, который очень востребован в типовой конфигурации 1С: Бухгалтерия Предприятия 3.0.

10 стартмани

16.06.2020    1874    0    alfanika    0    

Кто может создавать дубли?

Роли и права v8::Права ERP2 Абонемент ($m)

Ролей в ЕРП очень много, вручную не проконтролировать. Как определить у каких пользователей есть права на объект? Как определить роль, отвечающую за тот или иной объект метаданных? Какой профиль нужно назначить группе доступа? Куда отнести пользователя?

1 стартмани

13.06.2020    1704    1    Redokov    0    

Система доступа к объектам на уровне открытия форм

Роли и права v8::УФ v8::Права 1cv8.cf Украина Абонемент ($m)

Простенькая система настройки доступа в режиме Предприятия к различным объектам конфигурации на уровне открытия форм.

2 стартмани

10.06.2020    1766    5    xcooptex    0    

Анализ прав доступа по ролям объектов конфигурации на СКД

Роли и права v8::Права БП3.0 Россия Абонемент ($m)

Отчет сделан в виде стандартного отчета на системе компоновки данных типовой конфигурации, что делает возможность гибкой настройки и создания своего варианта отчета.

1 стартмани

09.06.2020    1905    10    ryan    2    

Дата запрета изменения по организации

Роли и права v8::Права ERP2 УТ11 КА2 Россия Абонемент ($m)

Расширение поможет быстро настраивать дату запрета изменения по организациям

1 стартмани

07.06.2020    1867    2    dima21m    0    

Копирование настроек пользователей

Роли и права v8 БП2.0 УТ10 УПП1 Беларусь Украина Россия Абонемент ($m)

Внешняя обработка для копирования настроек пользователей. Предназначена для типовых конфигураций, "Управление торговлей", редакция 10.3, БУХ 2.0, УПП, и их аналогов на рынке СНГ.

1 стартмани

28.05.2020    1778    10    JayZ    0    

Групповое удаление доступа из ролей, выгруженных в файлы

Роли и права v8 1cv8.cf Абонемент ($m)

Обработка предназначена для группового поиска и удаления доступа из ролей.

1 стартмани

27.05.2020    1515    1    unknown181538    0    

Настройка ограничений входа пользователей в базу (расширение)

Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

Настраиваем для пользователей 1С разрешенное количество открытых сеансов к текущей базе данных 1С в привязке к компьютерам. (У пользователя не будет возможности превысить допустимое количество сеансов или зайти с чужого компьютера).

2 стартмани

19.05.2020    7280    13    sapervodichka    14    

Установка пароля на изменение настройки пользователей "Дата запрета изменений" в БГУ 2

Роли и права Пароли v8::Права БГУ Государственные, бюджетные структуры Россия БУ Абонемент ($m)

В БГУ 2 (2.0.68.16) на уровне БСП у всех пользователей, имеющих роль "Администратор", есть возможность менять дату запрета изменений. Некоторым клиентам хотелось, чтобы только один пользователь мог менять дату запрета. Данное расширение позволяет определенному программно в расширении пользователю устанавливать пароль, а остальным пользователям позволяет менять даты только при вводе пароля. На красоту не претендует - не пеняйте.

1 стартмани

14.05.2020    2301    3    taras20    0    

Анализ прав пользователей

Роли и права v8 v8::УФ v8::Права 1cv8.cf Россия Абонемент ($m)

Отчет по правам в разрезе пользователей, ролей и объектов метаданных.

1 стартмани

05.05.2020    3699    10    Batoo    0    

Запрет редактирования цены в документах продажи

Ценообразование, анализ цен Роли и права v8 v8::БУ v8::Права БП3.0 Россия БУ Абонемент ($m)

После установки расширения, только пользователи с полными правами или с доп. ролью смогут менять цену и сумму в документах реализации.

1 стартмани

26.04.2020    2673    0    Shalnov    2    

Создание нового пользователя путем копирования существующего, всех его ролей, групп и профилей

Роли и права v8::УФ v8::Права БП3.0 Россия Абонемент ($m)

Часто бывает так, что надо создать нового пользователя с определенными правами доступа. Перечисляются организации и роли нового пользователя. На это тратится иногда очень много времени. Часто бывает проще создать нового пользователя на основе уже существующего, а потом, если нужно подправить его права.

1 стартмани

23.04.2020    1996    3    user633783_Wladigor    0    

Поиск ролей и прав доступа в 1С 8.3

Роли и права v8::УФ v8::Права 1cv8.cf Россия Абонемент ($m)

Обработка позволяет упростить настройку ролей и прав доступа. Показывает набор прав и ролей к необходимым объектам, в том числе нетиповым.

1 стартмани

19.04.2020    2740    14    plotnikov1c    0    

Установка даты запрета изменения по расписанию

БСП (Библиотека стандартных подсистем) Роли и права v8 БП3.0 Абонемент ($m)

Внешняя обработка для установки даты запрета изменений по расписанию. Применяется для всех пользователей, кроме уже имеющихся в списке дат запрета.

1 стартмани

14.04.2020    2738    2    user1393353    0    

Установка кода доступа в 1С (обычные и управляемые формы)

Роли и права v8 v8::УФ 1cv8.cf Абонемент ($m)

Универсальная обработка по вводу кода доступа.

1 стартмани

03.04.2020    2883    4    Denr83    0    

Создание нового пользователя копированием

Роли и права v8 v8::Права УТ10 Абонемент ($m)

Создание пользователя ИБ и элемента справочника "Пользователя" копированием существующего.

1 стартмани

27.03.2020    2886    2    tamerlan922    0    

Установка групп доступа физических лиц

Роли и права v8 v8::СПР v8::Права ЗУП3.x Россия БУ Абонемент ($m)

Внешняя обработка для 1С: ЗУП 3 для установки групп доступа физическим лицам.

1 стартмани

13.03.2020    2555    4    SamMix    0    

Проверка прав по объекту метаданных у пользователя или роли и обратное

Роли и права v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m)

Обработка позволяет посмотреть, какие пользователи или роли имеют доступ к объекту метаданных. Также к каким объектам имеет доступ роль или пользователь информационной базы.

1 стартмани

03.03.2020    3327    15    iCortezik    4    

Ограничение доступа по контрагентам для Бухгалтерии (RLS) 3.0 (3.0.75.58) - менеджер видит только своих контрагентов

Управление взаимоотношениями с клиентами (СRM) Адаптация типовых решений Роли и права v8 БП3.0 Россия БУ Абонемент ($m)

Расширение предназначено для Бухгалтерии 8 ред. 3.0. Типовая конфигурация остается на поддержке (с замком). Решает оно следующую задачу: Менеджеры по продажам должны видеть документы и отчеты только по контрагентам, которых они ведут.

5 стартмани

27.02.2020    3728    13    teyana    4    

Решение разработчика в зависимости от опыта работы. Как ограничить отображаемый пользователю список и ничего не потерять

Роли и права v8 1cv8.cf Абонемент ($m)

Решение разработчика в зависимости от опыта работы. Ограничение отображаемого пользователю списка без применения RLS.

1 стартмани

25.02.2020    3002    0    user633166    8    

Анализ прав доступа к метаданным конфигурации

Роли и права v8 v8::Права 1cv8.cf Россия Абонемент ($m)

Лёгкий отчёт, предназначенный для анализа прав доступа к метаданным конфигурации. Написан без использования БСП (Библиотека стандартных подсистем).

5 стартмани

31.01.2020    3436    10    v_elkin    15    

Копирование настроек и дополнительных прав пользователей

Роли и права v8 УПП1 Россия Абонемент ($m)

Модификация обработки из https://infostart.ru/public/204756/. Не копируется основной ответственный, а кроме настроек копируются и дополнительные права.

1 стартмани

28.01.2020    2694    3    FullMoon    2    

Автоматическое создание ролей (объектов метаданных)

Роли и права v8 1cv8.cf Абонемент ($m)

Обработка позволяет создать 2 роли на объекты метаданных (Чтение и Изменение).

2 стартмани

22.01.2020    3319    3    kokorishvili    9    

Повторяющиеся логины пользователей

Роли и права v8 1cv8.cf Россия Абонемент ($m)

В этой статье хочу предложить для рассмотрения небольшую но полезную обработку, которая работает в режиме внешней обработки и выявляет задвоенные логины пользователей. Обработка предназначена для работы в клиент-серверных базах и тестировалась на платформе 8.3.14.1854.

1 стартмани

13.01.2020    3222    0    bryantsev.yury    5