Завершение работы пользователей

Публикация № 1129070

Администрирование - Информационная безопасность - Роли и права

Завершение работы пользователей ПодключитьОбработчикОжидания

Завершение работы пользователей с помощью подключения обработчика ожидания.

Завершение работы пользователей с помощью подключения обработчика ожидания.

Когда базой пользуются  5-10 человек, можно поднять трубку и позвонить пользователям  или написать в какой-нибудь мессенджер и попросить  выйти из базы. А если у вас сотни пользователей и обработки со списком пользователей которых надо выбирать завершать, а как же уведомить пользователей, постоянно дергать админа кластера: «сделай пожалуйста….» Ну и так далее.

Задачи были следящие:

1.Уведомить всех пользователей базы о скором выключении базы.

2.Завершить сеансы пользователей с возможностью сохранения данных.

3.Ну и для особо «Работящих», завершить без сохранения.

Решение получилось достаточно простым, теперь по порядку.

Первым делом создаем перечисление «РежимыЗавершенияРаботыПользователей»

Затем две константы «РежимЗавершенияРаботыПользователей» (ПеречислениеСсылка.РежимыЗавершенияРаботыПользователей) и «РежимЗавершенияРаботыПользователейТаймАут» (Число)

 

Нам потребуется общая форма:

В модуле данной формы пишем:

&НаСервере
Процедура ЗаписатьНаСервере()
	Константы.РежимЗавершенияРаботыПользователей.Установить(ЭтотОбъект.РежимыЗавершенияРаботыПользователей);
	Константы.РежимЗавершенияРаботыПользователейТаймАут.Установить(ЭтотОбъект.РежимЗавершенияРаботыПользователейТаймАут);
КонецПроцедуры

&НаКлиенте
Процедура Записать(Команда)
	ЗаписатьНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	ЭтотОбъект.РежимыЗавершенияРаботыПользователей = Константы.РежимЗавершенияРаботыПользователей.Получить();
	ЭтотОбъект.РежимЗавершенияРаботыПользователейТаймАут = ЗавершенияРаботыПользователей.РежимЗавершенияРаботыПользователейТаймАут();
КонецПроцедуры

И наконец, создаем два общих модуля один для «Сервера» другой для «Клиента» (у меня это «ЗавершенияРаботыПользователей» и «ЗавершенияРаботыПользователейКлиент»)

Модуль ЗавершенияРаботыПользователейКлиент:

Процедура ОбработчикКонтрольРежимаЗавершенияРаботыПользователей() Экспорт
	
	ТекущийРежим = ЗавершенияРаботыПользователей.ТекущийРежимЗавершенияРаботыПользователей();
	
	Если ТекущийРежим = ЗавершенияРаботыПользователей.ПредупредитьПользователейОЗавершенииРаботы() Тогда
		ВывестиПредупреждение("Работа системы будет завершена через несколько минут!", 10, "Завершение работы системы");
	ИначеЕсли ТекущийРежим = ЗавершенияРаботыПользователей.ЗавершитьССохранениемДанныхПользователей() Тогда
		ВывестиПредупреждение("Работа системы будет завершена!", 10, "Завершение работы системы");
		ЗавершитьРаботуСистемы(Истина);
	ИначеЕсли ТекущийРежим = ЗавершенияРаботыПользователей.ПрекратитьРаботуБезусловно() Тогда
		ПрекратитьРаботуСистемы();
	КонецЕсли; 
	
КонецПроцедуры 

Процедура УстановитьКонтрольРежимаЗавершенияРаботыПользователей() Экспорт
	ТекущийРежим = ЗавершенияРаботыПользователей.ТекущийРежимЗавершенияРаботыПользователей();
	
	Если ЗавершенияРаботыПользователей.РольДоступнаЗавершенияРаботыПользователей() Тогда
		Если ТекущийРежим <> ЗавершенияРаботыПользователей.РазрешитьРаботу() Тогда
			Если ЗавершенияРаботыПользователей.РежимыЗавершенияРаботыПользователейЗначениеЗаполнено() Тогда
				ВывестиПредупреждение("Установлен режим завершения работы пользователей: " + ТекущийРежим + ".",10, "Завершение работы системы");
			Иначе
				ВывестиПредупреждение("Режим завершения работы пользователей не установлен.", 10, "Завершение работы системы");
			КонецЕсли; 
		КонецЕсли; 
	Иначе
		ОбработчикКонтрольРежимаЗавершенияРаботыПользователей();
		ТаймАут = ЗавершенияРаботыПользователей.РежимЗавершенияРаботыПользователейТаймАут();
		ПодключитьОбработчикОжидания("ОбработчикКонтрольРежимаЗавершенияРаботыПользователей", ТаймАут);
	КонецЕсли; 
КонецПроцедуры 

Функция ВывестиПредупреждение(ТекстСообщения, ТаймАут = 0, Заголовок = "") Экспорт
	Предупреждение(ТекстСообщения, ТаймАут, Заголовок);
КонецФункции

 

 Модуль ЗавершенияРаботыПользователей:

Функция ТекущийРежимЗавершенияРаботыПользователей() Экспорт 
	Возврат Константы.РежимЗавершенияРаботыПользователей.Получить();	
КонецФункции

Функция РольДоступнаЗавершенияРаботыПользователей() Экспорт 
	Возврат РольДоступна("ПравоЗавершенияРаботыПользователей");
КонецФункции

Функция ПредупредитьПользователейОЗавершенииРаботы() Экспорт 
	Возврат Перечисления.РежимыЗавершенияРаботыПользователей.ПредупредитьПользователейОЗавершенииРаботы;
КонецФункции

Функция ЗавершитьССохранениемДанныхПользователей() Экспорт 
	Возврат Перечисления.РежимыЗавершенияРаботыПользователей.ЗавершитьССохранениемДанныхПользователей;
КонецФункции

Функция ПрекратитьРаботуБезусловно() Экспорт 
	Возврат Перечисления.РежимыЗавершенияРаботыПользователей.ПрекратитьРаботуБезусловно;
КонецФункции

Функция РазрешитьРаботу() Экспорт 
	Возврат Перечисления.РежимыЗавершенияРаботыПользователей.РазрешитьРаботу;
КонецФункции

Функция РежимыЗавершенияРаботыПользователейЗначениеЗаполнено() Экспорт 
	Возврат ЗначениеЗаполнено(Константы.РежимЗавершенияРаботыПользователей.Получить());
КонецФункции

Функция РежимЗавершенияРаботыПользователейТаймАут() Экспорт 
	Если ЗначениеЗаполнено(Константы.РежимЗавершенияРаботыПользователейТаймАут.Получить()) Тогда 
	    ТаймАут = Константы.РежимЗавершенияРаботыПользователейТаймАут.Получить();
	Иначе
		ТаймАут = 60;
	КонецЕсли;
	Возврат ТаймАут;
КонецФункции

Теперь чтобы все заработало  нам необходимо добавить  строчку в модуль приложения:

Процедура ПриНачалеРаботыСистемы()
	УстановитьКонтрольРежимаЗавершенияРаботыПользователей();
КонецПроцедуры

Описание:

Пользователям которые должны работать (администраторы, чтобы сделать обновления) даем Роль – «ЗавершенияРаботыПользователей». Таким пользователям при запуске базы  сообщается в каком режиме работает в данное время система. У всех остальных пользователей запускается обработчик ожидания "ОбработчикКонтрольРежимаЗавершенияРаботыПользователей", который в зависимости от установленного значения константы «РежимЗавершенияРаботыПользователей» с периодичностью константы «РежимЗавершенияРаботыПользователейТаймАут» выполняет действия:

- «ПредупредитьПользователейОЗавершенииРаботы» - пользователю выдается сообщение "Работа системы будет завершена через несколько минут!" с периодичностью константы «РежимЗавершенияРаботыПользователейТаймАут»;

- «ЗавершитьССохранениемДанныхПользователей» - пользователю выдается сообщение «Работа системы будет завершена!», после закрытия всех документов работа будет завершена;

- «ПрекратитьРаботуБезусловно» работа будет завершена без предупреждения пользователя.

В режиме «РазрешитьРаботу» сообщения никакие не выдаются

Обработка тестировалась на платформе  1С:Предприятие 8.3 (8.3.14.1694).

Скачать файлы

Наименование Файл Версия Размер
Завершение работы пользователей.:
.dt 46,67Kb
30.09.19
7
.dt 46,67Kb 7 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Sedaiko 309 07.10.19 11:25 Сейчас в теме
2. demon1981 07.10.19 11:44 Сейчас в теме
А чем не устроила типовая система завершения работы пользователей при помощи объекта БлокировкаСеансов.
3. user921814 19 07.10.19 16:04 Сейчас в теме
(2) конфигурация самописная. Это решение мне показалось гораздо проще чем решение из Библиотеки стандартных подсистем.
4. demon1981 08.10.19 05:40 Сейчас в теме
(3)а, я просто БСП в свою самописку внедрил :)
5. gaglo 09.10.19 09:50 Сейчас в теме
Решение практически совпадает с примененным в очень древнем УПП (1.0 - когда БСП, поди, еще не было).
6. webresurs 177 24.10.19 12:53 Сейчас в теме
Интересная разработка!
Было бы ваше "ВАУУ" добавив выполнение по условию...
- например,
--- в 12-00 предупреждать и завершать все сеансы
--- или при простое более 30 минут

возможно?
Оставьте свое сообщение

См. также

Автоматическое создание ролей (объектов метаданных)

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Роли и права

Обработка позволяет создать 2 роли на объекты метаданных (Чтение и Изменение).

2 стартмани

22.01.2020    542    kokorishvili    7       

INFOSTART MEETUP Krasnodar. 14 февраля 2020 г. Промо

Краснодар станет первым в 2020 году местом, где пройдет региональная встреча IT-специалистов сообщества Инфостарт. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Стоимость участия - 5000 рублей. Цена действительна до 26.12.2019.

Анализ ролей и прав доступа

Отчеты и формы Системный администратор Программист Внешний отчет (ert,erf) v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m) Роли и права

Показывает у каких пользователей активирована Роль или Права доступа.

1 стартмани

14.01.2020    482    t278    0       

Повторяющиеся логины пользователей

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Роли и права

В этой статье хочу предложить для рассмотрения небольшую но полезную обработку, которая работает в режиме внешней обработки и выявляет задвоенные логины пользователей. Обработка предназначена для работы в клиент-серверных базах и тестировалась на платформе 8.3.14.1854.

1 стартмани

13.01.2020    467    bryantsev.yury    3       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Права на объект

Статья Программист Внешний отчет (ert,erf) v8 v8::Права 1cv8.cf Абонемент ($m) Роли и права

Если пользователю не хватает прав на объект, то на практике в 90 % случаев, недостающую роль можно найти через типовой регистр сведений Права ролей. Также с помощью дополнительного отчета или небольшого расширения можно ускорить описанный процесс.

1 стартмани

07.01.2020    6840    51    sapervodichka    12       

Анализ прав и ролей пользователей (обычные и управляемые формы)

Отчеты и формы Программист Внешний отчет (ert,erf) v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m) Роли и права

Отчет поможет в просмотре и анализе прав по ролям и пользователям по всем (или выбранным) объектам конфигурации.

1 стартмани

16.12.2019    975    4    Diana.dedov.91    0       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Перенос пользователей ИБ через COM-соединение (обычные и управляемые формы)

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ v8::Права 1cv8.cf Россия Windows Абонемент ($m) Роли и права

Необходимо скопировать несколько или всех пользователей в новую ИБ? Обработка (обычное и управляемое приложение) сможет это сделать!

1 стартмани

29.11.2019    1224    7    Diana.dedov.91    0       

Менеджер подключений к удаленным рабочим столам (RDP)

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 Windows Абонемент ($m) Роли и права

Менеджер подключений к удаленным рабочим столам для организации доступа сотрудникам, без передачи паролей для доступа.

2 стартмани

19.11.2019    1599    2    Shalnov    1       

Базовый курс по управлению ИТ-проектами. Курс проходит с 26 февраля по 22 апреля 2020 года. Промо

Отличительная черта курса - органичное сочетание трех вещей: 1.Теория проектного управления (PMI®+Agile Alliance+Российские ГОСТ+Методологии от 1С); 2. Опыт внедрения продуктов 1С (опыт франчайзи и успешных компаний + тренды Infostart Event и Agile Days); 3. Разбор реальных проблем и рекомендации экспертов по проектам слушателей. Мы будем фиксироваться на тех инструментах, которые реально оказываются полезными в практике руководителей проектов внедрения. Ведущая курса - Мария Темчина.

от 11000 рублей

Изменение запрета редактирования в дереве по группам пользователей

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8::Права УПП1 Россия Абонемент ($m) Роли и права

Обработка позволяет менять дату запрета редактирования по пользователям в раскрывающемся списке группы пользователей. Тестировалась на УПП 1.3.126.2.

1 стартмани

19.11.2019    979    2    trest30    0       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Анализ прав пользователей

Отчеты и формы Системный администратор Внешняя обработка (ert,epf) v8 ERP2 Россия Абонемент ($m) Роли и права

Отображает права по ролям и пользователям на конкретный объект конфигурации.

1 стартмани

13.11.2019    1372    10    linder    9       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Анализ прав доступа

Отчеты и формы Системный администратор Программист Внешний отчет (ert,erf) v8 v8::Права v8::СКД 1cv8.cf Абонемент ($m) Роли и права

Отчет по правам доступа, который позволяет выбрать объект метаданных и проанализировать, какие роли дают права на объект.

1 стартмани

08.11.2019    2018    9    Unk92    15       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Блокировка учетных записей пользователей, кроме "Администратор"

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Роли и права

Обработка блокирует все учетные записи, кроме учетной записи именуемой - "Администратор".

3 стартмани

04.11.2019    1326    2    Alex1053669    0       

Установка даты запрета на любое число дней

Инструменты и обработки no Внешняя обработка (ert,epf) v8 УТ11 Абонемент ($m) Администрирование данных 1С Роли и права

Примитивная обработка для установки даты запрета на произвольное число дней от текущей даты для всех пользователей

1 стартмани

29.10.2019    1745    2    Kutuzov    0       

PgConf.Russia 2020. 3-5 февраля 2020 г. Москва. Промо

PGConf.Russia – международная техническая конференция по открытой СУБД PostgreSQL, ежегодно собирающая более 700 разработчиков, администраторов баз данных и IT-менеджеров для обмена опытом и профессионального общения. Для участников сообщества infostart.ru скидка 5% на участие в конференции.

от 12350 рублей

Быстрое удаление ролей из профилей групп доступа.

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8::УФ v8::Права Абонемент ($m) Роли и права

Обработка позволяет найти все профили групп доступа по роли, понять для каких групп доступа и пользователей доступна эта роль, удалить роль из выбранных профилей.

1 стартмани

23.10.2019    1700    1    igoSolo    0       

Перенос документов, остатков и справочников КА 1.1 => КА 2 / УТ 11. Обновлено до КА 2.4.12.х и УТ 11.4.11.х! Промо

Более 130 компаний выполнили переход на КА 2 или УТ 11 с помощью нашей разработки! Позволяет перенести не только остатки и справочники (как типовая обработка), но и документы за нужный период времени. Предоставляем техподдержку, оперативно исправляем замечания, выпускаем обновления при выходе новых релизов программ 1С. Вы можете проверить разработку до покупки: сделаем бесплатный тестовый перенос из вашей базы КА 1.1 и предоставим доступ к базе-результату через веб-клиент!

29700 руб.

Копирование дополнительных прав, групп доступа между пользователями/группами [1С:Розница]

Инструменты и обработки no Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Абонемент ($m) Роли и права

Копирование, сравнение и редактирование дополнительных прав пользователей. Включение пользователя-приемника в те же группы доступа, в которых участвует пользователь-источник.

1 стартмани

21.10.2019    1811    1    RocKeR_13    0       

Расширение для установки запрета редактирования отдельных справочников и документов для Бухгалтерии 3.0

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 v8::Права БП3.0 Россия БУ Абонемент ($m) Расширения Роли и права

Расширение позволяет устанавливать запрет на редактирование отдельного справочника или отдельного документа для отдельного пользователя базы данных. Написано для Бухгалтерии 3.0, проверено на релизе 3.0.72.70 и платформе 8.3.14.1854. Работает после применения ограничений профиля пользователя. Ограничивает даже права профиля с полными правами в открытом периоде.

1 стартмани

17.10.2019    1886    3    e-tixom    2       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

RLS - дубли условий в запросах к СУБД

Статья Программист Конфигурация (md, cf) v8 v8::Права 1cv8.cf Абонемент ($m) Практика программирования Роли и права

"Подводные камни", возникающие при бездумном копировании ролей с ограничениями RLS, как это отражается на производительности, разбор примера и инструмент для анализа.

1 стартмани

07.10.2019    4526    11    geron4    4       

Сравнение прав пользователей

Отчеты и формы Системный администратор Внешняя обработка (ert,epf) v8 v8::Права 1cv8.cf Россия Windows Абонемент ($m) Роли и права

Иногда требуется понять, почему какому-то пользователю не доступны какие-либо объекты или действия, а "вручную" сравнивать довольно утомительное занятие.

1 стартмани

23.09.2019    2938    14    ivnik    3       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Оптимизация прав ролей

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8::УФ v8::Права 1cv8.cf Россия Windows Абонемент ($m) Производительность и оптимизация (HighLoad) Роли и права

Решение вопроса по неоптимальной настройке (избыточной) ролей, влияющей на производительность системы (потребление оперативной памяти). Алгоритм работы следующий: Выгрузка конфигурации в файлы - Обработка (изменение) файлов прав ролей - Загрузка измененных прав в конфигурацию. Проверено на платформе начиная с 8.3.12.

1 стартмани

09.09.2019    3678    3    toxilamer    11       

Расширение "Туманность" - помощник настройки профилей групп доступа. ERP 2.4.9+

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 v8::Права ERP2 Абонемент ($m) Роли и права

Расширение позволяет настраивать профили групп доступа как комбинации из других профилей групп доступа.

1 стартмани

30.08.2019    1825    3    Brawler    0       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Расширение для БП 3. Роль "Покупки"

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 v8::БУ БП3.0 БУ Оптовая торговля Учет ТМЦ Абонемент ($m) Информационная безопасность

Дополнительная роль "Покупки" менеджеру по продажам для Бухгалтерии предприятия 3. Типовые права предусматривают только роль "Менеджер по продажам".

1 стартмани

23.08.2019    1955    4    Akuji    0       

Ограничение прав пользователя на изменение типов объектов конфигурации при помощи расширения

Инструменты и обработки Системный администратор Расширение (cfe) v8 v8::Права БП3.0 Абонемент ($m) Роли и права

Расширение позволяет ограничивать права пользователя на изменение типов объектов конфигурации при наличии прав, заданных профилями групп доступа.

1 стартмани

06.08.2019    2003    its_33    0