Завершение работы пользователей

Публикация № 1129070

Администрирование - Информационная безопасность - Роли и права

Завершение работы пользователей ПодключитьОбработчикОжидания

Завершение работы пользователей с помощью подключения обработчика ожидания.

Завершение работы пользователей с помощью подключения обработчика ожидания.

Когда базой пользуются  5-10 человек, можно поднять трубку и позвонить пользователям  или написать в какой-нибудь мессенджер и попросить  выйти из базы. А если у вас сотни пользователей и обработки со списком пользователей которых надо выбирать завершать, а как же уведомить пользователей, постоянно дергать админа кластера: «сделай пожалуйста….» Ну и так далее.

Задачи были следящие:

1.Уведомить всех пользователей базы о скором выключении базы.

2.Завершить сеансы пользователей с возможностью сохранения данных.

3.Ну и для особо «Работящих», завершить без сохранения.

Решение получилось достаточно простым, теперь по порядку.

Первым делом создаем перечисление «РежимыЗавершенияРаботыПользователей»

Затем две константы «РежимЗавершенияРаботыПользователей» (ПеречислениеСсылка.РежимыЗавершенияРаботыПользователей) и «РежимЗавершенияРаботыПользователейТаймАут» (Число)

 

Нам потребуется общая форма:

В модуле данной формы пишем:

&НаСервере
Процедура ЗаписатьНаСервере()
	Константы.РежимЗавершенияРаботыПользователей.Установить(ЭтотОбъект.РежимыЗавершенияРаботыПользователей);
	Константы.РежимЗавершенияРаботыПользователейТаймАут.Установить(ЭтотОбъект.РежимЗавершенияРаботыПользователейТаймАут);
КонецПроцедуры

&НаКлиенте
Процедура Записать(Команда)
	ЗаписатьНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	ЭтотОбъект.РежимыЗавершенияРаботыПользователей = Константы.РежимЗавершенияРаботыПользователей.Получить();
	ЭтотОбъект.РежимЗавершенияРаботыПользователейТаймАут = ЗавершенияРаботыПользователей.РежимЗавершенияРаботыПользователейТаймАут();
КонецПроцедуры

И наконец, создаем два общих модуля один для «Сервера» другой для «Клиента» (у меня это «ЗавершенияРаботыПользователей» и «ЗавершенияРаботыПользователейКлиент»)

Модуль ЗавершенияРаботыПользователейКлиент:

Процедура ОбработчикКонтрольРежимаЗавершенияРаботыПользователей() Экспорт
	
	ТекущийРежим = ЗавершенияРаботыПользователей.ТекущийРежимЗавершенияРаботыПользователей();
	
	Если ТекущийРежим = ЗавершенияРаботыПользователей.ПредупредитьПользователейОЗавершенииРаботы() Тогда
		ВывестиПредупреждение("Работа системы будет завершена через несколько минут!", 10, "Завершение работы системы");
	ИначеЕсли ТекущийРежим = ЗавершенияРаботыПользователей.ЗавершитьССохранениемДанныхПользователей() Тогда
		ВывестиПредупреждение("Работа системы будет завершена!", 10, "Завершение работы системы");
		ЗавершитьРаботуСистемы(Истина);
	ИначеЕсли ТекущийРежим = ЗавершенияРаботыПользователей.ПрекратитьРаботуБезусловно() Тогда
		ПрекратитьРаботуСистемы();
	КонецЕсли; 
	
КонецПроцедуры 

Процедура УстановитьКонтрольРежимаЗавершенияРаботыПользователей() Экспорт
	ТекущийРежим = ЗавершенияРаботыПользователей.ТекущийРежимЗавершенияРаботыПользователей();
	
	Если ЗавершенияРаботыПользователей.РольДоступнаЗавершенияРаботыПользователей() Тогда
		Если ТекущийРежим <> ЗавершенияРаботыПользователей.РазрешитьРаботу() Тогда
			Если ЗавершенияРаботыПользователей.РежимыЗавершенияРаботыПользователейЗначениеЗаполнено() Тогда
				ВывестиПредупреждение("Установлен режим завершения работы пользователей: " + ТекущийРежим + ".",10, "Завершение работы системы");
			Иначе
				ВывестиПредупреждение("Режим завершения работы пользователей не установлен.", 10, "Завершение работы системы");
			КонецЕсли; 
		КонецЕсли; 
	Иначе
		ОбработчикКонтрольРежимаЗавершенияРаботыПользователей();
		ТаймАут = ЗавершенияРаботыПользователей.РежимЗавершенияРаботыПользователейТаймАут();
		ПодключитьОбработчикОжидания("ОбработчикКонтрольРежимаЗавершенияРаботыПользователей", ТаймАут);
	КонецЕсли; 
КонецПроцедуры 

Функция ВывестиПредупреждение(ТекстСообщения, ТаймАут = 0, Заголовок = "") Экспорт
	Предупреждение(ТекстСообщения, ТаймАут, Заголовок);
КонецФункции

 

 Модуль ЗавершенияРаботыПользователей:

Функция ТекущийРежимЗавершенияРаботыПользователей() Экспорт 
	Возврат Константы.РежимЗавершенияРаботыПользователей.Получить();	
КонецФункции

Функция РольДоступнаЗавершенияРаботыПользователей() Экспорт 
	Возврат РольДоступна("ПравоЗавершенияРаботыПользователей");
КонецФункции

Функция ПредупредитьПользователейОЗавершенииРаботы() Экспорт 
	Возврат Перечисления.РежимыЗавершенияРаботыПользователей.ПредупредитьПользователейОЗавершенииРаботы;
КонецФункции

Функция ЗавершитьССохранениемДанныхПользователей() Экспорт 
	Возврат Перечисления.РежимыЗавершенияРаботыПользователей.ЗавершитьССохранениемДанныхПользователей;
КонецФункции

Функция ПрекратитьРаботуБезусловно() Экспорт 
	Возврат Перечисления.РежимыЗавершенияРаботыПользователей.ПрекратитьРаботуБезусловно;
КонецФункции

Функция РазрешитьРаботу() Экспорт 
	Возврат Перечисления.РежимыЗавершенияРаботыПользователей.РазрешитьРаботу;
КонецФункции

Функция РежимыЗавершенияРаботыПользователейЗначениеЗаполнено() Экспорт 
	Возврат ЗначениеЗаполнено(Константы.РежимЗавершенияРаботыПользователей.Получить());
КонецФункции

Функция РежимЗавершенияРаботыПользователейТаймАут() Экспорт 
	Если ЗначениеЗаполнено(Константы.РежимЗавершенияРаботыПользователейТаймАут.Получить()) Тогда 
	    ТаймАут = Константы.РежимЗавершенияРаботыПользователейТаймАут.Получить();
	Иначе
		ТаймАут = 60;
	КонецЕсли;
	Возврат ТаймАут;
КонецФункции

Теперь чтобы все заработало  нам необходимо добавить  строчку в модуль приложения:

Процедура ПриНачалеРаботыСистемы()
	УстановитьКонтрольРежимаЗавершенияРаботыПользователей();
КонецПроцедуры

Описание:

Пользователям которые должны работать (администраторы, чтобы сделать обновления) даем Роль – «ЗавершенияРаботыПользователей». Таким пользователям при запуске базы  сообщается в каком режиме работает в данное время система. У всех остальных пользователей запускается обработчик ожидания "ОбработчикКонтрольРежимаЗавершенияРаботыПользователей", который в зависимости от установленного значения константы «РежимЗавершенияРаботыПользователей» с периодичностью константы «РежимЗавершенияРаботыПользователейТаймАут» выполняет действия:

- «ПредупредитьПользователейОЗавершенииРаботы» - пользователю выдается сообщение "Работа системы будет завершена через несколько минут!" с периодичностью константы «РежимЗавершенияРаботыПользователейТаймАут»;

- «ЗавершитьССохранениемДанныхПользователей» - пользователю выдается сообщение «Работа системы будет завершена!», после закрытия всех документов работа будет завершена;

- «ПрекратитьРаботуБезусловно» работа будет завершена без предупреждения пользователя.

В режиме «РазрешитьРаботу» сообщения никакие не выдаются

Обработка тестировалась на платформе  1С:Предприятие 8.3 (8.3.14.1694).

Скачать файлы

.dt
Наименование Файл Версия Размер
Завершение работы пользователей.:

.dt 46,67Kb
30.09.19
8
46,67Kb 8 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. Sedaiko 376 07.10.19 11:25 Сейчас в теме
2. demon1981 07.10.19 11:44 Сейчас в теме
А чем не устроила типовая система завершения работы пользователей при помощи объекта БлокировкаСеансов.
3. user921814 19 07.10.19 16:04 Сейчас в теме
(2) конфигурация самописная. Это решение мне показалось гораздо проще чем решение из Библиотеки стандартных подсистем.
4. demon1981 08.10.19 05:40 Сейчас в теме
(3)а, я просто БСП в свою самописку внедрил :)
5. gaglo 09.10.19 09:50 Сейчас в теме
Решение практически совпадает с примененным в очень древнем УПП (1.0 - когда БСП, поди, еще не было).
6. webresurs 181 24.10.19 12:53 Сейчас в теме
Интересная разработка!
Было бы ваше "ВАУУ" добавив выполнение по условию...
- например,
--- в 12-00 предупреждать и завершать все сеансы
--- или при простое более 30 минут

возможно?
Оставьте свое сообщение

См. также

Анализ ролей и прав по профилю или пользователю и отбору метаданных Промо

Роли и права v8::УФ v8::Права v8::СКД 1cv8.cf Россия Абонемент ($m)

Отчет анализа ролей и прав с фильтром по профилю ИЛИ пользователю и отбору по метаданным (документы, справочники, регистры сведений и накоплений, обработок, планов обмена, констант, отчетов), ролям и правам. Тестировано на платформах: 8.3.11.2899,8.3.12.1440. Конфигурация: ERP 2.4.6.154

1 стартмани

02.08.2018    11465    78    strelec13    5    

Права доступа к объектам с гибкими отборами (расширение)

Роли и права v8 ERP2 КА2 Абонемент ($m)

Возможность без доработок конкретизировать пользователям права Просмотра и Изменения объектов базы 1С, установив ограничения с помощью отборов системы компоновки данных.

2 стартмани

вчера в 15:45    1008    0    sapervodichka    6    

Доступ к функционалу ЭДО пользователя без администраторских прав

Документооборот и делопроизводство Роли и права v8 v8::Права УНФ Абонемент ($m)

Данная обработка предназначена для запуска функционала Электронного документооборота пользователем с ограниченными правами, не имеющим доступ к разделу Компания, из которого в свою очередь запускается меню с Электронными Документами ( Архив ЭДО ,Текущие дела ЭДО , Производные документы), а также меню Администрирование / Обмен с контрагентами / Настройки электронной подписи и шифрования.

1 стартмани

26.06.2020    1025    0    its_33    0    

Альфа-Ника: Кладовщик – расширение для 1С:Бухгалтерии 3.0

Учет ТМЦ Роли и права v8::БУ v8::Права БП3.0 Россия БУ Абонемент ($m)

Целью данного расширения является создание профиля “Кладовщик”, который очень востребован в типовой конфигурации 1С: Бухгалтерия Предприятия 3.0.

10 стартмани

16.06.2020    638    0    alfanika    0    

Роли пользователей Промо

Роли и права v8 v8::Права v8::СКД 1cv8.cf Россия Абонемент ($m)

Отчет предназначен для анализа ролей пользователей.

1 стартмани

09.04.2011    18611    34    Veselchak    15    

Система доступа к объектам на уровне открытия форм

Роли и права v8::УФ v8::Права 1cv8.cf Украина Абонемент ($m)

Простенькая система настройки доступа в режиме Предприятия к различным объектам конфигурации на уровне открытия форм.

2 стартмани

10.06.2020    662    1    xcooptex    0    

Анализ прав доступа по ролям объектов конфигурации на СКД

Роли и права v8::Права БП3.0 Россия Абонемент ($m)

Отчет сделан в виде стандартного отчета на системе компоновки данных типовой конфигурации, что делает возможность гибкой настройки и создания своего варианта отчета.

1 стартмани

09.06.2020    785    2    ryan    2    

Копирование настроек пользователей

Роли и права v8 БП2.0 УТ10 УПП1 Беларусь Украина Россия Абонемент ($m)

Внешняя обработка для копирования настроек пользователей. Предназначена для типовых конфигураций, "Управление торговлей", редакция 10.3, БУХ 2.0, УПП, и их аналогов на рынке СНГ.

1 стартмани

28.05.2020    655    6    JayZ    0    

Групповое удаление доступа из ролей, выгруженных в файлы

Роли и права v8 1cv8.cf Абонемент ($m)

Обработка предназначена для группового поиска и удаления доступа из ролей.

1 стартмани

27.05.2020    611    0    unknown181538    0    

Настройка ограничений входа пользователей в базу (расширение)

Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

Настраиваем для пользователей 1С разрешенное количество открытых сеансов к текущей базе данных 1С в привязке к компьютерам. (У пользователя не будет возможности превысить допустимое количество сеансов или зайти с чужого компьютера).

2 стартмани

19.05.2020    4860    3    sapervodichka    10    

Установка пароля на изменение настройки пользователей "Дата запрета изменений" в БГУ 2

Роли и права Пароли v8::Права БГУ Государственные, бюджетные структуры Россия БУ Абонемент ($m)

В БГУ 2 (2.0.68.16) на уровне БСП у всех пользователей, имеющих роль "Администратор", есть возможность менять дату запрета изменений. Некоторым клиентам хотелось, чтобы только один пользователь мог менять дату запрета. Данное расширение позволяет определенному программно в расширении пользователю устанавливать пароль, а остальным пользователям позволяет менять даты только при вводе пароля. На красоту не претендует - не пеняйте.

1 стартмани

14.05.2020    806    2    taras20    0    

Анализ прав пользователей

Роли и права v8 v8::УФ v8::Права 1cv8.cf Россия Абонемент ($m)

Отчет по правам в разрезе пользователей, ролей и объектов метаданных.

1 стартмани

05.05.2020    1799    3    Batoo    0    

Запрет редактирования цены в документах продажи

Ценообразование, анализ цен Роли и права v8 v8::БУ v8::Права БП3.0 Россия БУ Абонемент ($m)

После установки расширения, только пользователи с полными правами или с доп. ролью смогут менять цену и сумму в документах реализации.

1 стартмани

26.04.2020    1145    0    Shalnov    2    

Создание нового пользователя путем копирования существующего, всех его ролей, групп и профилей

Роли и права v8::УФ v8::Права БП3.0 Россия Абонемент ($m)

Часто бывает так, что надо создать нового пользователя с определенными правами доступа. Перечисляются организации и роли нового пользователя. На это тратится иногда очень много времени. Часто бывает проще создать нового пользователя на основе уже существующего, а потом, если нужно подправить его права.

1 стартмани

23.04.2020    1060    3    user633783_Wladigor    0    

Поиск ролей и прав доступа в 1С 8.3

Роли и права v8::УФ v8::Права 1cv8.cf Россия Абонемент ($m)

Обработка позволяет упростить настройку ролей и прав доступа. Показывает набор прав и ролей к необходимым объектам, в том числе нетиповым.

1 стартмани

19.04.2020    1340    7    plotnikov1c    0    

Установка даты запрета изменения по расписанию

БСП (Библиотека стандартных подсистем) Роли и права v8 БП3.0 Абонемент ($m)

Внешняя обработка для установки даты запрета изменений по расписанию. Применяется для всех пользователей, кроме уже имеющихся в списке дат запрета.

1 стартмани

14.04.2020    1724    2    user1393353    0    

Ограничение доступа пользователей к внешнему отчёту на СКД

Роли и права v8 v8::Права v8::СКД 1cv8.cf Абонемент ($m)

Метод ограничения доступа пользователей к данным внешнего отчёта.

1 стартмани

04.04.2020    2037    0    user925427    14    

Установка кода доступа в 1С (обычные и управляемые формы)

Роли и права v8 v8::УФ 1cv8.cf Абонемент ($m)

Универсальная обработка по вводу кода доступа.

1 стартмани

03.04.2020    2021    4    Denr83    0    

Создание нового пользователя копированием

Роли и права v8 v8::Права УТ10 Абонемент ($m)

Создание пользователя ИБ и элемента справочника "Пользователя" копированием существующего.

1 стартмани

27.03.2020    1724    2    tamerlan922    0    

Поиск пользователей с нужной ролью

Роли и права v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m)

Показывает список пользователей, у которых установлена указанная роль. Для управляемых форм.

1 стартмани

18.03.2020    1673    2    kaps22    3    

Установка групп доступа физических лиц

Роли и права v8 v8::СПР v8::Права ЗУП3.x Россия БУ Абонемент ($m)

Внешняя обработка для 1С: ЗУП 3 для установки групп доступа физическим лицам.

1 стартмани

13.03.2020    1463    3    SamMix    0    

Отчет по группам доступа, профилям и ролям

Роли и права v8 v8::Права 1cv8.cf Россия Абонемент ($m)

Отчет с 3-мя вариантами "Группы доступа", "Профили", "Роли". В отчет выводится вхождение пользователя в ту или иную роль, профиль, группу доступа.

1 стартмани

11.03.2020    1608    4    grinder    0    

Просмотр ролей пользователей

Роли и права v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m)

С помощью данного отчета можно быстро проанализировать наличие тех или иных ролей у пользователей.

1 стартмани

07.03.2020    1833    4    razars    2    

Просмотр доступности объектов в ролях и группах доступа

Роли и права v8 v8::Права 1cv8.cf Россия Абонемент ($m)

Просмотр ролей, профилей, групп доступа, групп пользователей для доступа к выбранному объекту и его регистрам.

1 стартмани

06.03.2020    1638    12    JackGamer_    0    

Проверка прав по объекту метаданных у пользователя или роли и обратное

Роли и права v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m)

Обработка позволяет посмотреть, какие пользователи или роли имеют доступ к объекту метаданных. Также к каким объектам имеет доступ роль или пользователь информационной базы.

1 стартмани

03.03.2020    2202    12    iCortezik    4    

Информация о пользователях информационной базы (отчет на СКД)

Администрирование данных 1С Роли и права v8 v8::Права v8::СКД 1cv8.cf Абонемент ($m)

Два простых отчета по пользователям информационной базы и информации по ним.

1 стартмани

02.03.2020    4133    16    YPermitin    8    

Ограничение доступа по контрагентам для Бухгалтерии (RLS) 3.0 (3.0.75.58) - менеджер видит только своих контрагентов

Управление взаимоотношениями с клиентами (СRM) Адаптация типовых решений Роли и права v8 БП3.0 Россия БУ Абонемент ($m)

Расширение предназначено для Бухгалтерии 8 ред. 3.0. Типовая конфигурация остается на поддержке (с замком). Решает оно следующую задачу: Менеджеры по продажам должны видеть документы и отчеты только по контрагентам, которых они ведут.

5 стартмани

27.02.2020    2046    4    teyana    4    

Решение разработчика в зависимости от опыта работы. Как ограничить отображаемый пользователю список и ничего не потерять

Роли и права v8 1cv8.cf Абонемент ($m)

Решение разработчика в зависимости от опыта работы. Ограничение отображаемого пользователю списка без применения RLS.

1 стартмани

25.02.2020    2006    0    user633166    8    

Список ролей, у которых установлено определенное право доступа к объекту

Роли и права v8::УФ v8::Права 1cv8.cf Россия Абонемент ($m)

В современных типовых конфигурациях используется огромное количество ролей для ограничения доступа к объектам конфигурации. Это приводит к тому, что приходится прокручивать список ролей на закладке "Права" в окне объекта конфигурации и ждать, когда в окошке "Права" появятся "заветные галочки". Данная обработка поможет программисту быстро сформировать список ролей, у которых установлено то или иное право доступа к объекту конфигурации.

1 стартмани

06.02.2020    2054    9    Igor030370    0    

Анализ прав доступа к метаданным конфигурации

Роли и права v8 v8::Права 1cv8.cf Россия Абонемент ($m)

Лёгкий отчёт, предназначенный для анализа прав доступа к метаданным конфигурации. Написан без использования БСП (Библиотека стандартных подсистем).

5 стартмани

31.01.2020    2196    8    v_elkin    15    

Копирование настроек и дополнительных прав пользователей

Роли и права v8 УПП1 Россия Абонемент ($m)

Модификация обработки из https://infostart.ru/public/204756/. Не копируется основной ответственный, а кроме настроек копируются и дополнительные права.

1 стартмани

28.01.2020    1847    3    FullMoon    2    

Автоматическое создание ролей (объектов метаданных)

Роли и права v8 1cv8.cf Абонемент ($m)

Обработка позволяет создать 2 роли на объекты метаданных (Чтение и Изменение).

2 стартмани

22.01.2020    2338    1    kokorishvili    9    

Анализ ролей и прав доступа

Роли и права v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m)

Показывает у каких пользователей активирована Роль или Права доступа.

1 стартмани

14.01.2020    2129    6    t278    0    

Повторяющиеся логины пользователей

Роли и права v8 1cv8.cf Россия Абонемент ($m)

В этой статье хочу предложить для рассмотрения небольшую но полезную обработку, которая работает в режиме внешней обработки и выявляет задвоенные логины пользователей. Обработка предназначена для работы в клиент-серверных базах и тестировалась на платформе 8.3.14.1854.

1 стартмани

13.01.2020    2320    0    bryantsev.yury    5    

Права на объект (расширение, отчет)

Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

Если пользователю не хватает прав на объект, то на практике в 90 % случаев, недостающую роль можно найти через типовой регистр сведений Права ролей. Также с помощью дополнительного отчета или небольшого расширения можно ускорить описанный процесс.

1 стартмани

07.01.2020    14794    92    sapervodichka    21    

Анализ прав и ролей пользователей (обычные и управляемые формы)

Роли и права v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m)

Отчет поможет в просмотре и анализе прав по ролям и пользователям по всем (или выбранным) объектам конфигурации.

1 стартмани

16.12.2019    3128    14    Denr83    0    

Перенос пользователей ИБ через COM-соединение (обычные и управляемые формы)

Роли и права v8 v8::УФ v8::Права 1cv8.cf Россия Абонемент ($m)

Необходимо скопировать несколько или всех пользователей в новую ИБ? Обработка (обычное и управляемое приложение) сможет это сделать!

1 стартмани

29.11.2019    2928    20    Denr83    0    

Менеджер подключений к удаленным рабочим столам (RDP)

Роли и права v8 Абонемент ($m)

Менеджер подключений к удаленным рабочим столам для организации доступа сотрудникам, без передачи паролей для доступа.

2 стартмани

19.11.2019    3447    4    Shalnov    1    

Изменение запрета редактирования в дереве по группам пользователей

Роли и права v8::Права УПП1 Россия Абонемент ($m)

Обработка позволяет менять дату запрета редактирования по пользователям в раскрывающемся списке группы пользователей. Тестировалась на УПП 1.3.126.2.

1 стартмани

19.11.2019    2595    1    trest30    0    

Очередной "мягкий" отключатель активных и не очень пользователей

Роли и права v8 1cv8.cf Россия Абонемент ($m)

Тема отключения пользователей не нова, но это чуть другой взгляд на проблему.

1 стартмани

15.11.2019    2974    3    ybatiaev    11    

Анализ прав пользователей

Роли и права v8 ERP2 Россия Абонемент ($m)

Отображает права по ролям и пользователям на конкретный объект конфигурации.

1 стартмани

13.11.2019    3329    19    linder    9    

Ошибка в ограничении доступа пользователей к списку Регистр накопления

Роли и права v8 БП3.0 Россия БУ Абонемент ($m)

Ошибка обновления Бухгалтерия предприятия, редакция 3.0 (3.0.74.51).

1 стартмани

11.11.2019    4228    1    Montecrizto    9