Мобильное приложение 1С: Список покупок и анализ расходов

Публикация № 1071075

Управление - Финансовый учет и бюджетирование (FRP)

мобильное приложение android список покупок анализ расходов сканирование штрихкодов встроенной камерой загрузка чеков ФНС Налоговая наименование товара по штрихкоду PUSH

В публикации рассмотрено небольшое домашнее мобильное приложение для составления списка покупок и анализа расходов. В приложении реализованы: работа с штрихкодами (сканирование встроенной камерой), поиск наименования товара по штрихкоду из интернета, загрузка чеков из ФНС по QR-коду, вывод QR-кода ранее загруженного чека и др.

В мобильном приложении всего один документ Заказ, зато реализованы следующие механизмы:
- обмен с центральной базой (подробно описано здесь http://its.1c.ru/db/pubintromobile);
- отправка PUSH-уведомлений (подробно описано здесь http://its.1c.ru/db/pubintromobile);
- сканирование штрихкодов встроенной камерой;
- загрузка наименования товара по штрихкоду из интернета при создании товара (описание сервиса здесь https://barcodes.olegon.ru/);
- получение чека из ФНС по QR-коду (API здесь https://habr.com/ru/post/358966/);
- вывод QR-кода уже загруженных чеков для возможности получить чек на другом устройстве.

Кому интересно, выкладываю куски кода некоторых механизмов.

 

Сканирование штрихкодов встроенной камерой смартфона (объект СредстваМультимедиа)

Модуль формы документа или справочника, где нужно сканировать штрихкод:

// Кнопка Сканировать на форме
&НаКлиенте
Процедура Сканировать(Команда)
	ДополнительныеПараметры = Новый Структура;
	ДополнительныеПараметры.Вставить("Форма", ЭтотОбъект);
	ДополнительныеПараметры.Вставить("ИмяОбработчикаЗакрытияСканирования", "ОбработкаЗакрытияСканирования");
	ПодключаемоеОборудованиеКлиент.ПолучитьШтрихкод(ДополнительныеПараметры);
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаЗакрытияСканирования(ДополнительныеПараметры) Экспорт
	Возврат;
КонецПроцедуры

// Здесь обрабатываем полученный штрихкод, QR-код и т.п.
&НаКлиенте
Процедура ОбработатьПолученныйШтрихкод(ПолученныйШтрихкод, Параметры) Экспорт
	Сообщить(ПолученныйШтрихкод);
КонецПроцедуры

Общий модуль ПодключаемоеОборудованиеКлиент:

Процедура ПолучитьШтрихкод(ДополнительныеПараметры) Экспорт
	ЗаголовокСканирования = НСтр("ru = 'Считайте штрихкод'");
	Если ДополнительныеПараметры.Свойство("ЗаголовокСканирования") Тогда
		ЗаголовокСканирования = ДополнительныеПараметры.ЗаголовокСканирования;
	КонецЕсли;
	#Если МобильноеПриложениеКлиент Тогда
		ОбработчикСканирования = Новый ОписаниеОповещения("ОбработкаСканирования", ПодключаемоеОборудованиеКлиент, ДополнительныеПараметры);
		ОбработчикЗакрытияСканирования = Новый ОписаниеОповещения(ДополнительныеПараметры.ИмяОбработчикаЗакрытияСканирования, 
			ДополнительныеПараметры.Форма, ДополнительныеПараметры);
		СредстваМультимедиа.ПоказатьСканированиеШтрихКодов(ЗаголовокСканирования, ОбработчикСканирования, ОбработчикЗакрытияСканирования);
	#КонецЕсли
КонецПроцедуры

Процедура ОбработкаСканирования(Штрихкод, Результат, Сообщение, ДополнительныеПараметры) Экспорт
	Если НЕ ДополнительныеПараметры.Свойство("ПотоковоеСканирование") Тогда
	#Если МобильноеПриложениеКлиент Тогда
		СредстваМультимедиа.ЗакрытьСканированиеШтрихКодов();
	#КонецЕсли
	КонецЕсли;
	Если Результат = Неопределено Тогда
		Возврат;
	КонецЕсли;
	ДополнительныеПараметры.Форма.ОбработатьПолученныйШтрихкод(Штрихкод, ДополнительныеПараметры);
КонецПроцедуры

 

Загрузка наименования товара по штрихкоду из интернета

Поиск наименований товара по штрихкоду реализован через сервис https://barcodes.olegon.ru/. Сервис возвращает массив имен, я беру первое имя ТекМассив.names[0]. Модуль формы элемента справочника товаров:

&НаКлиенте
Процедура ОбработатьПолученныйШтрихкод(ПолученныйШтрихкод, Параметры) Экспорт
	Объект.Штрихкод = СокрЛП(ПолученныйШтрихкод);
	ssl4 = Новый ЗащищенноеСоединениеOpenSSL( неопределено, неопределено );
	HTTPСоединение = Новый HTTPСоединение("barcodes.olegon.ru", 443,,,,,ssl4,); 
	HTTPЗапрос = Новый HTTPЗапрос("/api/card/name/" + Объект.Штрихкод + "/B644542640852064273024635143606"); 
	Результат =  HTTPСоединение.Получить(HTTPЗапрос);
	Если Результат.КодСостояния = 200 Тогда 
		СтрокаРезультат = Результат.ПолучитьТелоКакСтроку(КодировкаТекста.UTF8);
		ЧтениеJSON = Новый ЧтениеJSON;
		ЧтениеJSON.УстановитьСтроку(СтрокаРезультат);
		ТекМассив = ПрочитатьJSON(ЧтениеJSON);
		ЧтениеJSON.Закрыть();
		Если СтрДлина(Объект.Наименование) = 0 Тогда
			Объект.Наименование = ТекМассив.names[0];
		КонецЕсли;	
	Иначе
		Сообщить("Статус ответа:" + Результат.КодСостояния);
	КонецЕсли;
КонецПроцедуры

 

Получение чека из ФНС по QR-коду

QR-код чека является строкой вида t=20190602T2026&s=1854.00&fn=9282000100073930&i=74555&fp=3968601409&n=1, содержащей дату, сумму, номер фискального накопителя, номер чека, фискальный признак и вид операции. Используя эти данные можно получить сам чек из ФНС. Для получения чека в заголовке HTTP-запроса необходимо указать номер телефона и пароль, которые можно получить при регистрации в мобильном приложении Проверка кассового чека https://play.google.com/store/apps/details?id=ru.fns.billchecker&hl=ru.

&НаКлиенте
Процедура ЗагрузитьЧек(Команда)
	ВидЧека = "1";
	ДатаВремя = "20190602T1150";
	Сумма = "299.00";
	ФН = "8710000101180608";
	ФД = "98325";
	ФП = "309098793";
	Заголовки = Новый Соответствие;
	Заголовки.Вставить("Authorization", "Basic " + ЗашифроватьBase64("+79637413216:702187", "US-ASCII"));
	Заголовки.Вставить("Device-Id", "Android");
	Заголовки.Вставить("Device-OS", "Android");
	HTTPСоединение = Новый HTTPСоединение("proverkacheka.nalog.ru", 8888);
	HTTPЗапрос = Новый HTTPЗапрос("/v1/ofds/*/inns/*/fss/" + СокрЛП(ФН) + "/operations/" + СокрЛП(ВидЧека) + "/tickets/" + СокрЛП(ФД) + "?fiscalSign=" + СокрЛП(ФП) + "&date=" + СокрЛП(ДатаВремя) + "&sum=" + СокрЛП(СтрЗаменить(Сумма,".","")), Заголовки); 
	Ответ = HTTPСоединение.Получить(HTTPЗапрос);   
	Если Ответ.КодСостояния = 204 Тогда
		//Сообщить("Чек корректен");
	    ИмяВременногоФайла = ПолучитьИмяВременногоФайла();
		HTTPЗапрос = Новый HTTPЗапрос("/v1/inns/*/kkts/*/fss/" + СокрЛП(ФН) + "/tickets/" + СокрЛП(ФД) + "?fiscalSign=" + СокрЛП(ФП) + "&sendToEmail=no", Заголовки); 
		Ответ = HTTPСоединение.Получить(HTTPЗапрос, ИмяВременногоФайла);
		Если Ответ.КодСостояния = 200 Тогда
			//Сообщить("Чек получен");
			Форма = ПолучитьФорму("Документ.Заказ.Форма.ФормаДокумента");
			ДанныеФормы = Форма.Объект;
			ОбработатьФайлОтвета(ИмяВременногоФайла, ДанныеФормы);
			КопироватьДанныеФормы(ДанныеФормы, Форма.Объект); 
			Форма.Открыть();
		Иначе
			Сообщить("Получение чека: " + Ответ.КодСостояния);
		КонецЕсли;
	Иначе
		Сообщить("Проверка корректности: " + Ответ.КодСостояния);
	КонецЕсли; 
КонецПроцедуры

&НаСервере
Функция ЗашифроватьBase64(Строка, Кодировка) Экспорт
	ИмяВременногоФайла = ПолучитьИмяВременногоФайла();
	ЗаписьТекста = Новый ЗаписьТекста(ИмяВременногоФайла, Кодировка);
    ЗаписьТекста.Записать(Строка);
    ЗаписьТекста.Закрыть();
    Двоичные = Новый ДвоичныеДанные(ИмяВременногоФайла);
    Результат = Base64Строка(Двоичные);
	Если Лев(Результат, 4) = "77u/" Тогда
		Результат = Сред(Результат, 5);
	КонецЕсли; 
	Результат = СтрЗаменить(Результат, Символы.ПС, "");
    УдалитьФайлы(ИмяВременногоФайла);
    Возврат Результат;
КонецФункции

&НаСервере
Процедура ОбработатьФайлОтвета(ИмяФайла, ДанныеФормы)
	ЧтениеJSON = Новый ЧтениеJSON;
	ЧтениеJSON.ОткрытьФайл(ИмяФайла, "UTF-8");
	Результат = ПрочитатьJSON(ЧтениеJSON,,"dateTime");
	Организация = Результат.document.receipt.user;
	ИНН = Результат.document.receipt.userInn;
	СтрокиТовары = Результат.document.receipt.items;
		Для каждого СтрокаТовар Из СтрокиТовары Цикл
			Сообщить(СтрокаТовар.name);
			Сообщить(СтрокаТовар.price / 100);
			Сообщить(СтрокаТовар.quantity);
			Сообщить(СтрокаТовар.sum / 100);
		КонецЦикла; 
КонецПроцедуры

 

Вывод QR-кода

Для возможности вывода QR-кода чека строка QR-кода сохраняется в реквизите документа Заказ. Для вывода QR-кода в табличный документ используется типовая компонента 1С КомпонентаПечатиQRКода, которая есть в общих макетах типовых конфигураций 1С. Правда в мобильном приложении компонента не работает, поэтому приходится запрашивать QR-код из центральной базы.

&НаСервере
Функция ПолучитьКартинкуQR(QRКод)
	Макет = ПолучитьОбщийМакет("КомпонентаПечатиQRКода");
	Адрес = ПоместитьВоВременноеХранилище(Макет);
	
	КодВозврата = ПодключитьВнешнююКомпоненту(Адрес, "QRCodeExtensionSymbolicName");
	Если Не КодВозврата Тогда
		Сообщить("Проблема подключения внешней компоненты!");
	КонецЕсли;
	ГенераторQRКода = Новый("AddIn.QRCodeExtensionSymbolicName.QRCodeExtension");	

	ДанныеQRКода = ГенераторQRКода.GenerateQRCode(QRКод, 1, 190);
	
	Если ДанныеQRКода = Неопределено Тогда
		КартинкаQRКода = Новый Картинка();
	Иначе
		КартинкаQRКода = Новый Картинка(ДанныеQRКода);
	КонецЕсли;
	
	Макет = ПолучитьОбщийМакет("Макет");
	Макет.Рисунки.ШК.Картинка = КартинкаQRКода;
	ТабДок = Новый ТабличныйДокумент;
	ТабДок.Вывести(Макет);
	Возврат ТабДок;	
КонецФункции

 

О мобильном приложении

Центральную базу необходимо опубликовать на web-сервере, например http://192.168.103.28/BuyCentr. В центральной базе заполнить узлы плана обмена Мобильные устройства (предопределенный Ц - Центральный, второй К - Константин, третий Н - Николай и т.п.) и константу Ключ доступа отправителя PUSH, например PUSH_SRV_API_KEY_F55C7685_602D_4F06_BD4B_727CFBFAA85F (можно получить здесь https://pushnotifications.1c.com/). Также через консоль заданий можно настроить расписание регламентного задания, которое оповещает сколько денег потрачено сегодня.

Мобильное приложение необходимо собрать в Сборщике приложений, запустить на телефоне, заполнить узлы плана обмена (предопределенный К - Константин, второй  Ц - Центр), константу Адрес центральной базы, например http://192.168.103.28/BuyCentr, константу Код центральной базы - Ц, Номер проекта мобильного приложения, например 797785657074 (можно получить здесь https://pushnotifications.1c.com/), Номер и пароль для проверки чеков, например +79637413216 и 702187 (можно получить зарегистрировавшись в мобильном приложении ФНС https://play.google.com/store/apps/details?id=ru.fns.billchecker&hl=ru).

Проверялось на платформе 1С версии 8.3.14.1630 и мобильной платформе 1С версии 8.3.14.53.

Скачать файлы

Наименование Файл Версия Размер
Мобильное приложение
.cf 477,56Kb
06.06.19
13
.cf 477,56Kb 13 Скачать
Центральная база
.cf 475,87Kb
06.06.19
12
.cf 475,87Kb 12 Скачать
Мобильное приложение для Android
.apk 35,60Mb
06.06.19
5
.apk 35,60Mb 5 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. capitan 1619 06.06.19 17:37 Сейчас в теме
2. coollerinc 40 11.06.19 21:52 Сейчас в теме
3. coollerinc 40 12.06.19 19:32 Сейчас в теме
Частенько веб сервис валится в 202 ошибку, да и сканер на моем телефоне как то сложно распознает на реальных мятых чеках штрихкод. Даже поэксперементировал с стророниим сканером, чуть лучше, но все равно долго.
4. user_gea 14.06.19 11:28 Сейчас в теме
Спасибо за фрагменты кода! Взяты на заметку !
5. Derushev 5 10.04.20 13:52 Сейчас в теме
Спасибо! Но пуши не доходят. Вываливается ошибка: gcm has been deactivated and remove from google api
UPD: Простите, увидел. https://forum.infostart.ru/forum92/topic223641/
Оставьте свое сообщение

См. также

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019) Промо

Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ v8 v8::Mobile БУ УУ Абонемент ($m)

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    36263    238    informa1555    200    

Бюджетирование движения денежных средств для Бухгалтерии 3.0

Финансовый учет и бюджетирование (FRP) v8 v8::БУ БП3.0 Россия БУ УУ Абонемент ($m)

Самые востребованные бюджеты в организациях, это Бюджет движения денежных средств, далее БДДС, и Бюджет доходов и расходов (БДР). Это первая публикация, в которой речь пойдет про БДДС, он же денежный поток, он же "cash flow".

2 стартмани

17.04.2020    849    5    human_new    8    

Android Java и NativAPI C++ внешняя компонента для широковещательных сообщений (отправка и прием). Подключаем сканер ШК и клавиатуру к "1С мобильное приложение"

Оптовая торговля Розничная торговля Сканер штрих-кода Разработка внешних компонент Мобильная разработка v8::Mobile Оптовая торговля, дистрибуция, логистика Абонемент ($m)

Подключаем сканер ШК и клавиатуру к "1С мобильное приложение", на терминале сбора данных "ATOL Smart.Lite android 7.0". Работаем с буфером обмена. В архиве к теме; 1. исходник компоненты (папка package готовый zip); 2. исходник "AccessibilityService" для перехвата клавиатуры (папка package готовый apk); 3. cf - тестовая конфигурация

1 стартмани

15.04.2020    1055    7    SanyMaga    7    

Мобильная платформа. Реакция на внешнее событие в Android при помощи внешней компоненты

Мобильная разработка Разработка внешних компонент v8::Mobile Молдова Абонемент ($m)

Внешняя компонента для мобильной платформы на Android. Пришиваем платформе уши, чтобы лучше слышать.

3 стартмани

06.04.2020    1755    3    kinan    13    

Беспроводные метки NFC Промо

Мобильная разработка v8::Mobile Абонемент ($m)

Технический прогресс не стоит на месте, появляющиеся новые технологии со временем дешевеют и становятся доступны практически всем желающим. Как пример можно привести мобильные телефоны. Середина 80-ых - начало 90-ых были переносные таксофоны с ручками или кирпичи стоимостью несколько тысяч $, конец 90-ых - большого размера трубки, с торчащими антеннами со стоимостью от 100$ Такую же аналогию можно провести с NFC метками, используемыми в учетных целях.

1 стартмани

16.05.2017    19708    44    PloAl    18    

[Расширение] Готовые решения для инвентаризации товаров и основных средств на мобильных устройствах для КА, УТ, ERP и БП 3.0 на базе Simple UI

Оптовая торговля Розничная торговля Учет ОС и НМА Мобильная разработка Учет ТМЦ v8 ERP2 БП3.0 УТ11 КА2 БУ УУ Абонемент ($m)

В расширениях для Бухгалтерия 3.0 и КА2.4/УТ11.4/ERP2.4 представлены готовые рабочие места для онлайн и оффлайн инвентаризации товаров (для БП 3.0 также инвентаризации основных средств) на базе бесплатного конструктора мобильного фронта Simple UI. При этом используется расширенная работа с идентификацией товаров и ОС с помощью различных подходов – сканирование штрих кода, распознавание артикулов и инвентарных номеров и различные поиски. Также используются различные возможности платформы Simple UI. Используются только бесплатные возможности Simple UI (не Pro-версия), т.е. решение бесплатное. Данная разработка может быть полезна как конечным пользователям, так и разработчикам в качестве заготовки, так как на базе этих блоков можно сделать ввод любого документа конфигурации , связанного с товаром или с ОС. Тестировалось на 1С 8.3.13.1865, КА 2.4.8.63 и БП 3.0.74.69

5 стартмани

28.02.2020    1897    9    informa1555    5    

Пример реализации HTML-формы календаря для мобильного приложения

Работа с интерфейсом Мобильная разработка v8::Mobile Абонемент ($m)

Реализация функциональной мобильной формы календаря, которая красиво трансформируется в список задач.

5 стартмани

13.02.2020    2039    8    ingeneerz@gmail.com    0    

Наш путь к эффективной инвентаризации склада

Учет ТМЦ Учет ТМЦ Розничная торговля Мобильная разработка v8 УУ Абонемент ($m)

В работе любой торговой организации всегда остро стоит вопрос контроля остатков на складе. И здесь не обойтись без проведения инвентаризации товаров. В этой публикации рассмотрим наш путь и выбранное решение ее проведения.

8 стартмани

12.01.2020    2380    1    Johny_v    21    

Приложение Android для идентификации/распознавания образов (с обучением с одного раза, One-Shot Learning) с возможностью работы с 1С через веб-сервис Промо

Мобильная разработка v8 Абонемент ($m)

В данной статье описано приложение, алгоритм и методика распознавания изображений, предоставляющее посредством http-запросов информацию о распознанных объектах в 1С. В качестве примера интеграции прилагается конфигурация, реализующая веб-сервис для приема запросов от приложения.

1 стартмани

19.06.2018    12902    4    informa1555    15    

Обмен данными с Android через USB

Практика программирования Мобильная разработка v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка с примером обмена данными конфигурации 1С через USB. Без установки Web сервера и настройки WiFi.

1 стартмани

23.12.2019    2183    3    asdfgcom    2    

Simple UI: простой конструктор мобильных приложений для устройств на Android.Самый быстрый способ создания рабочего места на смартфоне или ТСД. Обновление от 09.05.2020:развитие функций работы в самостоятельном режиме и Микро-WMS

Мобильная разработка v8 УУ Абонемент ($m)

Simple UI – это бесплатная платформа для создания мобильных рабочих мест на Android. Конструктор позволяет создавать мобильные клиенты для учетных систем и самостоятельные приложения на телефонах, ТСД (терминалах сбора данных), планшетах, электронных киосках и других устройствах. При этом не нужно разбираться в мобильной разработке, Android SDK ведь основная цель платформы – максимально упростить процесс разработки и поддержки, сделать его визуальным, собирать приложения из готовых блоков с минимумом кода. Причем код обработчиков можно писать на языке учетной системы либо задавать логику обработки событий с помощью команд REST, SQL и визуального конструктора. Проект постоянно развивается изыскивая новые способы упрощения разработки и повышения функционала и является пожалуй самым быстрым способом как создать MVP-проект так и продакшн-систему под конкретное внедрение или тиражный продукт.Тестировалось на 1С: Предприятие 8.3 релиз 8.3.13.1865.

5 стартмани

14.11.2019    9554    86    informa1555    64    

Получение AndroidID в мобильном приложении

Мобильная разработка v8::Mobile Россия Абонемент ($m)

Получаем Android DeviceID в мобильном приложении/клиенте, используя стороннее приложение.

1 стартмани

05.11.2019    5631    3    sam441    11    

Мобильное приложение "Отчет по проделанной работе" Промо

Мобильная разработка Учет рабочего времени Учет рабочего времени v8 Россия УУ Абонемент ($m)

Приложение выполняет фиксацию рабочего времени у клиентов, а также заявок на работы, пригодится как шаблон для разработки своего или как готовое решение для работников в сфере услуг, которые фиксируют время у клиентов. В приложении 2 документа: первый "отчет за день", второй "заявка" и полезный инструмент "Отчет задачи", который в свою очередь создан для просмотра, анализа и закрытия заявок. Тестировал на Iphone 6s.

10 стартмани

01.12.2017    18439    10    olejnikov_m    6    

Мобильное приложение для Android для отправки СМС из 1C

SMS рассылки Мобильная разработка v8 1cv8.cf Абонемент ($m)

Вашему вниманию предлагается мобильное приложение (конфигурация .cf) + HTTP сервис для отправки СМС из 1С8

2 стартмани

04.11.2019    5403    3    dimasikus31    2    

ODa - Android приложение для подключения к любой конфигурации 1С, используя OData протокол

Мобильная разработка v8 1cv8.cf Абонемент ($m)

В платформе 1С реализована прекрасная возможность работы с открытым веб-протоколом OData, который предоставляет любой другой платформе интерфейс доступа - возможность запрашивать и обновлять данные из базы 1С. Далее в статье будут описаны особенности работы мобильного приложения ODa, которое без программировании на стороне Android'a позволит разработчикам публиковать базы 1С, что даст возможность обычным пользователям взаимодействовать с объектами метаданных, используя нативные элементы интерфейса платформы Android.

1 стартмани

22.10.2019    7553    8    Kosigo    11    

Компонента аутентификации и шифрования с помощью биометрической информации для Андроид

Разработка внешних компонент Мобильная разработка Защита и шифрование v8::Mobile Абонемент ($m)

Компонента для мобильной платформы, позволяющая идентифицировать пользователя и шифровать данные с помощью биометрических сканеров.

5 стартмани

17.09.2019    4167    1    IgorKissil    7    

Внешние компоненты. Мобильное приложение 1С Промо

Разработка внешних компонент Мобильная разработка v8::Mobile 1cv8.cf Абонемент ($m)

Пример применения технологии внешних компонент для мобильной платформы 1С (Android)

1 стартмани

17.02.2017    40055    118    flyer    35    

Отчет для руководителя. УПП 1.3

Управленческие Финансовый учет и бюджетирование (FRP) Оптовая торговля Учет доходов и расходов Финансовый учет и бюджетирование (FRP) Оптовая торговля Учет доходов и расходов v8 v8::СКД УПП1 УУ Абонемент ($m)

Понадобился отчёт для начальства, где он мог бы посмотреть продажи, будущие продажи, поступление и расход денег, поступление и заказ товаров за день. Выкладываю, вдруг кому тоже нужно.

1 стартмани

11.09.2019    3542    5    Nefilimus    0    

Подсистема Яндекс.Деньги

WEB Финансовый учет и бюджетирование (FRP) Финансовый учет и бюджетирование (FRP) v8 1cv8.cf Домашние учет и финансы УУ Абонемент ($m)

Подсистема полноценного учёта денежных средств для яндекс кошелька.

2 стартмани

09.09.2019    2806    2    CeHbKA    0    

Пример простого и приятного внешнего HTML интерфейса для мобильного приложения

Работа с интерфейсом Мобильная разработка v8::Mobile Абонемент ($m)

Реализация простого и приятного внешнего HTML интерфейса для мобильного приложения. Делимся исходниками, чтобы разработчики мобильных приложений разрабатывали больше приятных интерфейсов для приложений.

5 стартмани

05.09.2019    5271    52    Baksheev-Nikita    12    

Gant 1C 2.* - диаграмма Ганта с таблицей + Планировщик + Отчет (8.1, на управляемой форме/Такси 8.2, 8.3) Промо

Рабочее место Универсальные обработки Управление проектом Финансовый учет и бюджетирование (FRP) Производство готовой продукции (работ, услуг) Учет рабочего времени Финансовый учет и бюджетирование (FRP) Производство готовой продукции (работ, услуг) Учет рабочего времени v8 1cv8.cf УУ Абонемент ($m)

Внешняя обработка, аналог MS Project в 1Се для работы с задачами: параллельный ввод данных по задачам и график Ганта, дополнительный режим в виде календаря (планировщик), связывание задач и пересчет длительности и дат с учетом выходных, видов связей и запаздываний, расчет затрат, сохранение/открытие проектов в файл на диск или файл ИБ, импорт/экспорт документов Microsoft Project.

1 стартмани

02.12.2011    133157    1057    rare-avis    210    

ERP 2.4 "Рабочее место работника склада" на ТСД + Android 7

Терминал сбора данных Рабочее место Мобильная разработка Учет ТМЦ Учет ТМЦ v8 ERP2 УУ Абонемент ($m)

Решение задачи использования терминала сбора данных в режиме онлайн при помощи типовой обработки ERP 2.4 "Рабочее место работника склада", запуском ERP на мобильном клиенте 1С. Для настройки использовался ТСД Urovo V5100 на ОС Андроид 7.

1 стартмани

07.08.2019    8153    8    chemezov    8    

Мобильное приложение 1С для помарочной инвентаризации маркируемой (алкогольной) продукции

Терминал сбора данных Мобильная разработка Розничная торговля Розничная торговля v8::Mobile Розничная и сетевая торговля (FMCG) Абонемент ($m)

Мобильное приложение 1С для помарочной инвентаризации маркируемой (алкогольной) продукции на ТСД под Android. Получение данных марок (штрихкодов), используя БПО для мобильного приложения. Разработка на платформе 8.3.13.1809. Мобильная платформа 8.3.13.64. Версия сборщика 2.0.8.19.

1 стартмани

18.07.2019    5649    16    savostin.alex    5    

Hello world на metadata.js Промо

Инструментарий разработчика WEB Мобильная разработка v8 1cv8.cf Абонемент ($m)

Про браузерные offline-first приложения можно написать миллионы слов. Сэкономлю своё и ваше время и перейду сразу к делу. В статье не будет рекламы и агитации за новые технологии, не будет критики традиционных или попсовых решений. Рассмотрим по шагам разработку простейшей программы на metadata.js. Постараюсь сделать акцент не на том «как это сделано», а «почему сделано именно так»

1 стартмани

11.08.2016    53819    111    unpete    205    

Инвентаризация на мобильном устройстве. УТ 10

Мобильная разработка Учет ТМЦ Учет ТМЦ v8 УТ10 УУ Абонемент ($m)

Мобильное приложение и обработка выгрузки для инвентаризации в УТ 10.

2 стартмани

22.06.2019    3997    6    olejnikov_m    0    

Мобильное приложение "Сбор заказов" версия 2.0.1

Мобильная разработка Монитор заказов v8 v8::Mobile 1cv8.cf Украина УУ Абонемент ($m)

Приложение «Сбор заказов» разрабатывалось и разрабатывается для хранения и накопления данных от торговых представителей и автоматического обмена данными с программой учёта на базе платформы 1С:Предприятие. Мобильное приложение написано на технологии мобильной платформы 1С:Предприятие. Механизм обмена данных происходит посредством почтового сервера. В дальнейшем будет реализован механизм непосредственного доступа приложения к учётной системе через прямое интернет-соединение. FTP-соединение не работает как надо, так что будем довольствоваться тем, что есть... :)

4 стартмани

06.06.2019    5496    2    yarsort    10    

[Расширение] для подключения мобильного устройства к УТ11.4/ КА 2/ERP 2 для работы с ордерным складом на базе Simple WMS. Для автоматизации склада нужен только телефон

Сканер штрих-кода Терминал сбора данных Мобильная разработка Управление торговлей Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v8 ERP2 УТ11 КА2 УУ Абонемент ($m)

Представляю готовое решение для работы с ордерами и проведения инвентаризаций в виде расширения на базе конструктора Simple WMS. Не требует доработки конфигурации, подключается как обычное расширение. Работать может с обычного телефона на Андроид либо с ТСД либо через RDP. Расширение содержит справочники, поэтому режим совместимости конфигурации должен быть не меньше 8.3.11. Расширение написано для конфигурации Управление торговлей 11.4.7 и тестировалось на Комплексная автоматизация 2.4.7.151.

5 стартмани

27.05.2019    9816    31    informa1555    22    

Мобильное приложение по учету личных финансов Android 7.0

Мобильная разработка Финансовый учет и бюджетирование (FRP) Финансовый учет и бюджетирование (FRP) v8 Домашние учет и финансы УУ Абонемент ($m)

Мобильное приложение по учету личных финансов, имеется возможность вести учет по банкам, по валюте сканировать чеки, вести учет по статьям движения денежных средств, реализована возможность резервного сохранения данных и синхронизации с приложением на ПК. Имеется демо-версия и собранный apk файл. Тестирование производилось Android 7.0 1С:Предприятие 8.3 (8.3.14.1694) Мобильная платформа 1С:Предприятия 8.3.14.53.

1 стартмани

26.05.2019    4570    2    o.kovalev    4    

Оффлайн телефонный справочник для IOS и Android

Мобильная разработка v8 1cv8.cf Россия Абонемент ($m)

Как сделать телефонный справочник компании на мобильном телефоне для IOS, если у тебя android, бюджет в 100 долларов, несколько стартмани, а ты мастер программирования только в 1С? + БОНУС, как в компании бесплатно использовать телефонный справочник IOS и Android.

1 стартмани

20.05.2019    5718    2    rujiy_kot    2    

Шаблон http-сервиса для вашего проекта

Внешние источники данных WEB Мобильная разработка v8 v8::Mobile 1cv8.cf Абонемент ($m)

Http-сервис для обмена данными в формате JSON. Обработчики этого сервиса находятся во внешней обработке, что позволяет дорабатывать его без изменения конфигурации. Также прилагаю пример мобильного приложения для работы с данным сервисом (получает номенклатуру и остатки на складе). Сервис очень быстро разворачивается и масштабируется под ваши задачи.

3 стартмани

04.05.2019    15246    62    MarkoSokolov    47    

Telemonitor - объединяем Telegram и 1С Промо

Сервисные утилиты Администрирование данных 1С Мобильная разработка v8 1cv8.cf Абонемент ($m)

Не так давно Telegram предоставил API для создания ботов. Telemonitor - программа, позволяющая легко настроить собственного бота для работы с 1С.

1 стартмани

09.08.2015    73304    208    salexdv    178    

Управление задачами (мобильное приложение)

Мобильная разработка v8 1cv8.cf Абонемент ($m)

Конфигурация "Управление задачами" для мобильного приложения.

2 стартмани

29.04.2019    5067    10    noprogrammer    0    

Управление ТСД Zebra с помощью внешней компоненты для мобильной платформы

Разработка внешних компонент Мобильная разработка v8::Mobile Абонемент ($m)

Представлена внешняя компонента для управления сканерами терминалов Zebra из мобильных приложений 1С.

2 стартмани

15.04.2019    6078    18    IgorKissil    4    

Анкеты для проведения обследования по подсистемам 1С:ERP

Управление проектом Финансовый учет и бюджетирование (FRP) Производство готовой продукции (работ, услуг) Учет ТМЦ Финансовый учет и бюджетирование (FRP) Производство готовой продукции (работ, услуг) Учет ТМЦ v8 ERP2 1С:Франчайзи, автоматизация бизнеса Россия УУ Абонемент ($m)

Предлагаем вниманию анкеты, используемые для оценки объема проекта внедрения. Анкеты могут использоваться на этапе экспресс-обследования. На более поздних этапах требуется углублять собираемую с клиента информацию для проектирования системы на базе 1С:ERP Управление предприятием 8.

1 стартмани

03.04.2019    15097    787    1СERP    38    

7 причин, почему интеграция стала приятной. Не упускайте ряд потрясающих возможностей Промо

Внешние источники данных Интеграция Мобильная разработка v8 1cv8.cf Абонемент ($m)

В статье показаны примеры получения данных без программирования на стороне «1С:Предприятие 8». Вам нужно проверить гипотезу и проанализировать данные, почему бы не интегрироваться с Excel? Используете технологии .NET и «1С:Предприятие 8», процесс связывания систем движется катастрофически медленно? Хотите native Android приложение с вашими данными всегда под рукой?

1 стартмани

01.10.2015    53270    44    pbazeliuk    18    

Подписи для 1С

Мобильная разработка Документооборот и делопроизводство Документооборот и делопроизводство v8 Россия Абонемент ($m)

Получение подписей в Мобильной платформе 1С с помощью приложения.

1 стартмани

28.02.2019    5870    2    Grivba    7    

Внешние компоненты мобильной платформы 1С для ОС Андроид

Разработка внешних компонент Мобильная разработка v8::Mobile Абонемент ($m)

На трех простых примерах описана процедура разработки внешних компонент для Андроид. Статья написана по мотивам доклада на конференции INFOSTART 2018 EDUCATION.

31.01.2019    13768    0    IgorKissil    24    

Мобильное приложение для формирования заказов. Агент

Мобильная разработка Управление торговлей Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Розничная торговля Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Розничная торговля v7.7 v8 Оптовая торговля, дистрибуция, логистика УУ Абонемент ($m)

Мобильное приложение на платформе Андроид для формирования заказов клиентов. Основное предназначение - работа торговых агентов, представителей, что включает в себя: список клиентов с адресами, телефонами, историей взаиморасчетов; список товаров с остатками, с несколькими типами цен; составление заявки; регистрация поступления оплаты; отслеживание координат. Приложение можно состыковать с 1С любой версии. Поддерживаемые протоколы передачи: файловый (FTP), Web-service, HTTP-service.

1 стартмани

30.01.2019    7115    5    ruslan_hut    2    

Давайте подружим 1С и Android. Часть 1 - постановка задачи и подход к решению Промо

Мобильная разработка v8 Абонемент ($m)

Серия уроков по созданию простейшего приложения на платформе Android для взаимодействия с 1С.

1 стартмани

29.02.2016    29159    40    solarisman    32    

Мобильное приложение: Терминал сбора данных (Автоматизация работы склада в режиме он-лайн)

Терминал сбора данных Мобильная разработка Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v8::ОУ v8::Mobile ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Мобильное приложение предназначено для автоматизации работы склада в режиме он-лайн. Программа работает на ТСД (или на смартфоне) под управлением Android. Для работы необходим постоянный доступ к веб-публикации центральной базы данных через интернет.

1 стартмани

10.12.2018    13024    62    prof-it60    20    

HTML-редактор для 1С (мобильное приложение)

Мобильная разработка v8 Абонемент ($m)

Простой, но полноценный HTML-редактор для мобильного приложения с поддержкой CSS и JavaScript Релиз платформы: 8.3.12 Релиз мобильной платформы: 8.3.13

1 стартмани

07.12.2018    5105    15    djvu    1    

Интерактивная оборотно-сальдовая ведомость 2.0 Промо

Бухгалтерские Анализ учета Налоговые Финансовый учет и бюджетирование (FRP) Дебиторская и кредиторская задолженность Закрытие периода Оборотно-сальдовая ведомость, Анализ счета Учет доходов и расходов Учет ОС и НМА Учет ТМЦ Дебиторская и кредиторская задолженность Закрытие периода Оборотно-сальдовая ведомость, Анализ счета Учет ОС и НМА Учет ТМЦ v8 v8::БУ КА1 БП2.0 УПП1 УНФ БУ НУ Абонемент ($m)

Полностью универсальная Оборотно-сальдовая ведомость, также включающая возможности ОСВ по счету, Анализа счета и другие. С возможностью интерактивных разворотов в пару кликов по любым разрезам регистра бухгалтерии с подключением к типовым механизмам конфигураций расшифровки.

1 стартмани

23.07.2009    111729    47    Леонов Александр    491    

Отчет о движении денежных средств по месяцам для "1С:Бухгалтерии 3.0"

Бухгалтерские Финансовые Управленческие Банковские операции Финансовый учет и бюджетирование (FRP) Кассовые операции Банковские операции Финансовый учет и бюджетирование (FRP) Кассовые операции v8 v8::БУ v8::СКД БП3.0 Россия БУ УУ Абонемент ($m)

Внешний отчет управленческого характера, показывающий поступления и списания денежных средств предприятия на расчетных счетах и в кассе за произвольный период с разворотом по месяцам.

1 стартмани

06.12.2018    11784    56    accounting_cons    40    

Бюджет семьи (конфигурация)

Финансовый учет и бюджетирование (FRP) Управленческий учет (прочее) v8 Домашние учет и финансы УУ Абонемент ($m)

Простая конфигурация на платформе 8.3, позволяющая вести учет семейного бюджета. Бюджет семьи у нас общий, ведется в разрезе "счетов" - например Кредитная карта, кошелек, шкатулка и т.д. Работает на платформе 8.3.13.1513

1 стартмани

19.11.2018    5699    2    vln    10    

Мобильное приложение "Вслух"

Мобильная разработка v8 Обучение, бизнес-тренинг, курсы Россия Абонемент ($m)

Не с кем учить уроки? Говорящий репетитор в твоём мобильном! Обучающее мобильное приложение для детей и слабовидящих.

1 стартмани

16.11.2018    5919    3    RSConsulting    4    

Универсальная система планирования ресурсов, URP Промо

Финансовый учет и бюджетирование (FRP) Управление холдингом (CPM) Учет доходов и расходов Производство Финансовый учет и бюджетирование (FRP) Управление холдингом (CPM) Учет доходов и расходов v8 1cv8.cf 1С:Франчайзи, автоматизация бизнеса УУ Абонемент ($m)

Представляю очень простое и универсальное решение для сквозного планирования всех ресурсов предприятия от продаж до производства, логистики, HR, финансов и т.д. Система позволяет создавать расписания для любых ресурсов и планировать календарные потребности всех ресурсов предприятия, включая отражение в бюджетах рамках одного цикла планирования (например, планировать платежный календарь сразу к поставкам сырья к календарным потребностям производства одним нажатием кнопки). Также данный подход и система пригодны для задач моделирования и прогнозирования, например, для задач моделирования прибыли, нахождения точки безубыточности, ценообразования.

1 стартмани

25.11.2015    26410    49    informa1555    8    

Bluetooth сканер штрихкодов и мобильное приложение 1С (Android)

Сервисные утилиты Сканер штрих-кода Мобильная разработка v8 1cv8.cf Абонемент ($m)

Сервис для работы со сканером штрихкодов и передачи данных в мобильное приложение 1С.

1 стартмани

06.11.2018    13437    48    Isonic    21    

Самая простая конфигурация для сканирования штрихкодов из мобильного приложения 1С

Сканер штрих-кода Мобильная разработка v8 v8::УФ Абонемент ($m)

Перед началом работы над этим приложением была поставлена задача в кратчайшие сроки разработать мобильное приложение - сканер штрихкода для нескольких конфигураций 1С, на управляемых формах и не только, причем нельзя было использовать драйвера торгового оборудования, что я и выполнил.

1 стартмани

01.11.2018    6736    18    Romyl01    4    

Применение цифровой подписи при организации учёта ТМЦ и ГСМ

Защита и шифрование Управление бизнес-процессами (BPM) Мобильная разработка v8::Mobile v8::Бизнес-процессы 1cv8.cf Абонемент ($m)

Статья о том, как внедрение мобильного приложения в бизнес-процессы компании сократило оборот бумажных документов, а простая электронная подпись - заменила аналоговую.

1 стартмани

25.10.2018    6572    2    ikekoval    2    

Планирование платежей. Прогнозирование прибылей и убытков. Часть 1.

Финансовые Финансовый учет и бюджетирование (FRP) Финансовый учет и бюджетирование (FRP) v8 v8::ОУ УТ10 УУ Абонемент ($m)

Планирование поступлений от клиентов, списаний налогов и оплат поставщикам. И как следствие - прогнозирование прибыли или убытков.

2 стартмани

21.10.2018    8192    1    Rustig    57