Поле "Отбор" в управляемой форме используя СКД

Публикация № 1061866

Разработка - Практика программирования

Отбор форма СКД пример программно схема компоновки данных УФ управляемые

Пример, который осуществляет отбор ссылок при помощи СКД, макет компоновки создается программно.

Несмотря на опыт работы, такая задача, как вытащить отбор СКД на управляемую форму, часто становится многочасовой потерей времени.

Поэтому реализовал пример, который осуществляет отбор ссылок при помощи СКД.

Для выбора объекта метаданных используется БСП 2.1  - 2.4, но имя объекта метаданных можно написать текстом.

Работает, например, в УТ 11.4.

Для реализации примера достаточно добавить поля в новую обработку согласно изображениям. У поля "ОбъектНазначения" 2 события:

"ОбъектНазначенияОкончаниеВводаТекста" И "ОбъектНазначенияНачалоВыбора", параметр кнопка выбора "Да"

И добавлена одна команда "Отобрать" с одноименным событием.

Привожу модуль формы:

// СКД программно

// Процедура удаляет все элементы настроек СхемыКД 
//
&НаСервереБезКонтекста
Процедура ОчиститьНастройкиСКД(Настройки)
	
	Если Настройки = Неопределено ИЛИ Тип(Настройки) <> Тип("НастройкиКомпоновкиДанных") Тогда
		Возврат;
	КонецЕсли;
	
	Для Каждого Параметр Из Настройки.ПараметрыДанных.Элементы Цикл
		Параметр.Значение = Неопределено;
		Параметр.Использование = Ложь;
	КонецЦикла;
	
	Настройки.ПользовательскиеПоля.Элементы.Очистить();
	Настройки.Отбор.Элементы.Очистить();
	Настройки.Порядок.Элементы.Очистить();
	Настройки.Структура.Очистить();
	Настройки.Выбор.Элементы.Очистить();
	
КонецПроцедуры

// Добавляет отбор в набор отборов компоновщика или группы отборов.
// 
&НаСервереБезКонтекста
Функция ДобавитьОтбор(ЭлементСтруктуры, Знач Поле, Значение, ВидСравнения = Неопределено, Использование = Истина) Экспорт
	
	Если ТипЗнч(Поле) = Тип("Строка") Тогда
		Поле = Новый ПолеКомпоновкиДанных(Поле);
	КонецЕсли;
	
	Если ТипЗнч(ЭлементСтруктуры) = Тип("КомпоновщикНастроекКомпоновкиДанных") Тогда
		Отбор = ЭлементСтруктуры.Настройки.Отбор;
	Иначе
		Отбор = ЭлементСтруктуры;
	КонецЕсли;
	
	Если ВидСравнения = Неопределено Тогда
		ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
	КонецЕсли;
	
	НовыйЭлемент = Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
	НовыйЭлемент.Использование  = Использование;
	НовыйЭлемент.ЛевоеЗначение  = Поле;
	НовыйЭлемент.ВидСравнения   = ВидСравнения;
	НовыйЭлемент.ПравоеЗначение = Значение;
	Возврат НовыйЭлемент;
	
КонецФункции

// Создает и сохраняет компоновку данных во временном хранилище.
// Важно то что настройки не могут существовать без схемы компоновки.
&НаСервере
Процедура УстановитьКомпоновку()
	
	Если НЕ ЗначениеЗаполнено(ОбъектНазначения) Тогда
		Возврат;
	КонецЕсли;
	
	
	ОчиститьНастройкиСКД(КомпоновщикНастроек.Настройки);
	СхемаКомпоновки = Новый СхемаКомпоновкиДанных();		
	
	Источник = СхемаКомпоновки.ИсточникиДанных.Добавить();
	Источник.Имя = "ИсточникДанных";
	Источник.СтрокаСоединения="";
	Источник.ТипИсточникаДанных = "local";
	
	
	НаборДанных = СхемаКомпоновки.НаборыДанных.Добавить(Тип("НаборДанныхЗапросСхемыКомпоновкиДанных"));
	НаборДанных.Запрос = "Выбрать * из "+ОбъектНазначения;
	НаборДанных.Имя = "НаборДанныхЗапроса";
	НаборДанных.ИсточникДанных = Источник.Имя;
	НаборДанных.АвтоЗаполнениеДоступныхПолей = Истина;
	
	АдресСхемы = ПоместитьВоВременноеХранилище(СхемаКомпоновки, УникальныйИдентификатор);
	
	КомпоновщикНастроек.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(АдресСхемы)); 
	
	ГруппировкаСКД = КомпоновщикНастроек.Настройки.Структура.Добавить(Тип("ГруппировкаКомпоновкиДанных"));
	ГруппировкаСКД.Использование = Истина;
	
	ПолеОбъект = Новый ПолеКомпоновкиДанных("Ссылка");
	
	ВыбранноеПоле = ГруппировкаСКД.Выбор.Элементы.Добавить(Тип("ВыбранноеПолеКомпоновкиДанных"));
	ВыбранноеПоле.Использование = Истина;
	ВыбранноеПоле.Поле = ПолеОбъект;
	
	Для каждого ЭлементДоступногоОтбора Из КомпоновщикНастроек.Настройки.ДоступныеПоляОтбора.Элементы Цикл
		ДобавитьОтбор(КомпоновщикНастроек.Настройки.Отбор, ЭлементДоступногоОтбора.Поле, , ВидСравненияКомпоновкиДанных.Равно, Ложь);
	КонецЦикла;
	
КонецПроцедуры


// Команда Отобрать на сервере.
&НаСервере
Процедура КомандаНаСервере()
	
	СКД = ПолучитьИзВременногоХранилища(АдресСхемы);
	
	КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
	МакетКомпоновки = КомпоновщикМакета.Выполнить(СКД, КомпоновщикНастроек.ПолучитьНастройки(),,,Тип("ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений"));
	
	ПроцессорКД = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКД.Инициализировать(МакетКомпоновки);
	
	ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВКоллекциюЗначений;
	ПроцессорВывода.ОтображатьПроцентВывода = Истина;
	Результат = Новый ТаблицаЗначений;
	ПроцессорВывода.УстановитьОбъект(Результат);
	ПроцессорВывода.Вывести(ПроцессорКД);
	
	
	ТаблицаРезультата.Загрузить( Результат);
	
КонецПроцедуры

// Команда Отобрать
&НаКлиенте
Процедура Отобрать(Команда)
	КомандаНаСервере()
КонецПроцедуры

// выбор метаданного

&НаКлиенте
Процедура ОбъектНазначенияОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, СтандартнаяОбработка)
	Оповестить("УстановитьКомпоновку",Текст,Этаформа);
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
	Если ИмяСобытия = "ВыборОбъектовМетаданных" Тогда
		ОбъектНазначения = Параметр[0].Значение;
		УстановитьКомпоновку();
	ИначеЕсли ИмяСобытия = "УстановитьКомпоновку" Тогда
		ОбъектНазначения = Параметр;
		УстановитьКомпоновку();
	КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ОбъектНазначенияНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
	ПараметрыФормы = ПодготовитьПараметрыФормыВыборОбъектовМетаданных();
	ОткрытьФорму("ОбщаяФорма.ВыборОбъектовМетаданных", ПараметрыФормы,Элемент);
	СтандартнаяОбработка = Ложь;
КонецПроцедуры

&НаСервере
Функция ПодготовитьПараметрыФормыВыборОбъектовМетаданных()
	
	ФильтрПоОбъектамМетаданных = Новый СписокЗначений;
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	ИдентификаторыОбъектовМетаданных.ПолноеИмя
	|ИЗ
	|	Справочник.ИдентификаторыОбъектовМетаданных КАК ИдентификаторыОбъектовМетаданных
	|ГДЕ
	|	ИдентификаторыОбъектовМетаданных.Родитель В(&Родитель)";
	
	Родитель = Новый Массив;
	Родитель.Добавить(Справочники.ИдентификаторыОбъектовМетаданных.НайтиПоНаименованию("Документы"));
	Родитель.Добавить(Справочники.ИдентификаторыОбъектовМетаданных.НайтиПоНаименованию("Справочники"));
	
	Запрос.УстановитьПараметр("Родитель", Родитель);
	
	Результат = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = Результат.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		ФильтрПоОбъектамМетаданных.Добавить(ВыборкаДетальныеЗаписи.ПолноеИмя);
	КонецЦикла;
	
	ПараметрыФормы = Новый Структура;
	ПараметрыФормы.Вставить("ФильтрПоОбъектамМетаданных", ФильтрПоОбъектамМетаданных);
	ПараметрыФормы.Вставить("ВыборЕдинственного", Истина);
	ПараметрыФормы.Вставить("РежимВыбора", Истина);
	ПараметрыФормы.Вставить("Заголовок", НСтр("ru = 'Назначение дополнительной обработки'"));
	
	Возврат ПараметрыФормы;
КонецФункции


 

Скачать файлы

Наименование Файл Версия Размер
:Отбор кодом

.epf 8,33Kb
16.05.19
10
.epf 8,33Kb 10 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Быстрый запрос Промо

Универсальные обработки v8 v8::УФ 1cv8.cf Абонемент ($m)

Можно ли дать пользователю "удочку", а не "рыбу"? До сих пор ответ на этот вопрос был отрицательным. Всякий инструмент, который мог бы делать с базой данных все или почти все (или хотя бы многое), отвергался пользователями, как слишком сложный. Вспомните тот же SQL, который изначально разрабатывался именно как пользовательский инструмент. "Быстрый запрос" - это попытка устранить сложность, но сохранить при этом универсальность.

1 стартмани

29.04.2019    15017    28    mkalimulin    30    

Автоматическая отправка на почту ежедневного отчета руководителю об активности сотрудников из 1С (без доработки и использования расширений)

Учет рабочего времени Удаленное управление Email v8 v8::УФ УНФ ДО ERP2 ЗКГУ3.0 БП3.0 УТ11 УХ КА2 ЗУП3.x 1С:CRM Россия УУ Абонемент ($m)

Многим руководителям и директорам компаний требуется анализировать активность их сотрудников. Это особенно актуально, если сотрудники работают удаленно из дома и за ними необходимо вести контроль. Представленная настройка позволяет руководителям компаний получать ежедневный отчет об активности их сотрудников в 1С на электронную почту, не открывая программы.

1 стартмани

08.05.2020    4845    7    RATIONAL    7    

График выполнения заказа покупателя

Монитор заказов Оптовая торговля v8 v8::УФ УТ11 Россия УУ Абонемент ($m)

Аналитическая структура связанных документов.

1 стартмани

30.04.2020    4292    1    v3132    0    

Печать формы "Денежный аттестат"

Печатные формы документов Зарплата v8::СПР v8::УФ ЗКГУ3.0 Государственные, бюджетные структуры Россия Госбюджет Абонемент ($m)

Печать денежного аттестата при переводе и при назначении пенсии.

1 стартмани

12.03.2020    2075    6    Svetlana_E    0    

Расширение: Темы для 1С: Предприятия Промо

Работа с интерфейсом v8::УФ 1cv8.cf Абонемент ($m)

Расширение позволяет сменить цвет оформления для интерфейса Такси.

1 стартмани

10.02.2019    14875    69    spec8s    10    

Задачка: Список всех документов за заданный период, используя СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Вывести все документы за заданный период, используя СКД.

1 стартмани

11.03.2020    2226    3    MaxxiMiliSan    7    

Накладная на отпуск материалов на сторону (М-15) для документа "Приемка товаров на хранение" и документа "Отгрузка товаров с хранения" (ERP 2.4, КА 2.4)

Печатные формы документов Учет ТМЦ v8::УФ ERP2 КА2 Россия БУ Абонемент ($m)

Внешняя печатная форма "Накладная на отпуск материалов на сторону (М-15)" для документа "Приемка товаров на хранение" от имени Поставщика и для документа "Отгрузка товаров с хранения" от имени Организации для ERP 2.4, КА 2.4 с выводом подписантов.

1 стартмани

11.03.2020    4834    2    SergAl    1    

Формы КС-2, КС-3 для 1С: БП 3.0 (управляемое) c печатью дополнительных реквизитов или дополнительных сведений Промо

Печатные формы документов Производство готовой продукции (работ, услуг) Производство готовой продукции (работ, услуг) v8::БУ v8::УФ БП3.0 Строительство Россия БУ Абонемент ($m)

ВПФ КС-2 и КС-3 для 1С Бухгалтерия предприятия 3.0 (управляемое приложение), взятые отсюда: https://infostart.ru/public/197941/. К ним добавлен вывод параметров "Стройка" и "ОбъектСтроительства"

1 стартмани

31.01.2018    24825    118    utrumar    11    

Расходный кассовый ордер для 1С:Зарплата и управление персоналом 3.1

Печатные формы документов Кассовые операции v8::СПР v8::УФ ЗУП3.x Россия БУ Абонемент ($m)

Внешняя печатная форма РКО к документу "Ведомость на выплату зарплаты в кассу".

1 стартмани

09.03.2020    1846    2    Igorexa    0    

Создание контекстного отчета на БСП (Лист ознакомления с графиком отпусков, ЗУП 3.1)

БСП (Библиотека стандартных подсистем) Бухгалтерские v8 v8::СПР v8::СКД ЗУП3.x БУ УУ Абонемент ($m)

Создание контектного отчета с использованием БСП 3.1.2. Внешний отчет Лист ознакомления с Графиком отпусков для программы ЗУП 3.1.12.

1 стартмани

03.03.2020    2340    0    angler225    0    

Получение списка совпадающих адресов при наборе адреса (Яндекс-карты) (обычные и управляемые формы)

WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка позволяет получить список адресов при его наборе в Яндекс API (обычные и управляемые формы).

2 стартмани

03.03.2020    1778    0    Denr83    0    

Печатная форма акта сверки в рублях для договоров в у.е. для КА 2.x, ERP Промо

Печатные формы документов Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8::БУ v8::УФ ERP2 КА2 Россия БУ Абонемент ($m)

Возникла потребность делать сверку взаиморасчетов в рублях по валютным договорам. В КА и ERP такой возможности нет.

1 стартмани

22.09.2017    28425    172    mamba    38    

СКД: красивые надписи в заголовках колонок

Практика программирования Работа с интерфейсом v8 v8::СКД УПП1 Россия Абонемент ($m)

Необходимо немного исправить вывод надписей в заголовках колонок, сделать более читаемый вариант. Как это сделать?

2 стартмани

27.02.2020    9982    7    wowik    36    

Печать комплекта документов для Реализации товаров и услуг. УТ 11.4

Пакетная печать Оптовая торговля v8::ОУ v8::УФ УТ11 Россия БУ УУ Абонемент ($m)

Комплект печатных форм к документу "Реализация товаров и услуг" для УТ11.4 (УПД, Реестр сертификатов, Счет, ТТН).

1 стартмани

16.02.2020    1922    8    kovv    0    

Прорыв и провал 3D графики в 1С

Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Здравствуйте, уважаемые. Эта статья опоздала, хотя я спешил как мог. В любом случае, речь тут пойдет про WebGL и технологии работы с 3D в 1C. Сразу оговорюсь, что всё это работало до последнего времени и на тонком, толстом, вэб клиентах, платформах 8.3 и на 8.2. Единственное, что изменило ситуацию, это WebKit, внедренный в 1С начиная с релиза 8.3.14.1565.

1 стартмани

11.02.2020    6394    9    dinopopyys    23    

График работы сотрудников + Маршруты экспедиторов с путевыми листами (управляемые и обычные формы) Промо

Рабочее место Учет рабочего времени Учет рабочего времени v8 v8::УФ 1cv8.cf Россия УУ Абонемент ($m)

Простой и удобный график для учета посещаемости с возможностью контролировать опоздания сотрудников.

5 стартмани

02.04.2015    15587    2    taurus__    8    

Скромный вклад в юзабилити

Работа с интерфейсом Рабочее место v8::УФ УТ11 Абонемент ($m)

Оптимизация рутинных действий. Вызов отчетов по Партнеру и Номенклатуре сразу из документа. Выбор объекта для журнала регистрации из открытых окон.

2 стартмани

11.02.2020    2972    5    andryandry    0    

Сохранение и изменение настроек форм у всех пользователей 1С: Документооборот

Документооборот и делопроизводство Расширения Работа с интерфейсом v8 v8::УФ ДО Абонемент ($m)

Расширение позволяет быстро и удобно сохранять и тиражировать настройки форм от Администратора всем пользователям программы.

5 стартмани

01.02.2020    5078    19    st_Etlau    2    

Тендерная печать документов

Печатные формы документов Оптовая торговля v8::ОУ v8::УФ УТ11 УУ Абонемент ($m)

Решаем задачу - как подготовить документы с учетом персональных требований клиента к написанию наименования товара. Иногда их называют "левые", "серые" или "звезды"

5 стартмани

23.01.2020    1895    5    andryandry    1    

Внешняя печатная форма счета на оплату (обновлено до БП 3.0.44.x) Промо

Печатные формы документов Оптовая торговля Производство готовой продукции (работ, услуг) Оптовая торговля Производство готовой продукции (работ, услуг) v8::БУ v8::УФ БП3.0 Россия Абонемент ($m)

На Инфостарте уже не раз выкладывали внешнюю печатную форму счета на оплату для Бухгалтерии 3.0 для документа "Счет на оплату". Но все они не работают в релизе БП 3.0.44.х. Предлагаю внешнюю печатную форму, она сделана на основе макета именно этого релиза и поэтому шрифт в ней крупнее, чем в старых релизах.

1 стартмани

21.09.2015    43796    180    primat    11    

Банковский счет по умолчанию

Расширения Банковские операции v8::УФ КА2 Россия БУ Абонемент ($m)

Небольшое расширение для Комплексной автоматизации 2, добавляющее в справочники "Банковские счета организаций" и "Банковские счета контрагентов" реквизит типа Булево - "Счет по умолчанию". Формы в расширении не заимствуются, элементы добавляются на формы программно, поэтому применение расширения не окажет никакого влияния при последующих обновлениях конфигураций.

2 стартмани

19.01.2020    4181    14    Alfn    2    

Печать и сравнение справочников, документов (печать реквизитов и табличных частей) (обычные и управляемые формы)

Универсальные печатные формы v8 v8::УФ 1cv8.cf Абонемент ($m)

Печать реквизитов и табличных частей объектов метаданных, сравнение объектов с выводом на печать.

1 стартмани

26.12.2019    2457    4    Denr83    0    

Уведомление менеджера об оплате заказа

Монитор заказов v8::ОУ v8::УФ УТ11 УУ Абонемент ($m)

Менеджер получит штатное уведомление (Задача) о факте оплаты Заказов своих клиентов. Реализовано в виде расширения конфигурации.

2 стартмани

25.12.2019    2214    8    andryandry    0    

Заполнение шаблона Word docx на сервере, без ComОбъект и внешних компонент, только механизмами самой Платформы 1С, методом XML-инъекции

Универсальные печатные формы Печатные формы документов v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Внешние печатные формы для документа Счет на оплату позволяют сформировать на сервере без использования технологии OLE (Com объекта) и сохранить на печать заполненные docx шаблоны договора поставки и спецификации к договору (УНФ 1.6) (идея универсальна, подойдет для любой конфигурации). Используются только средства самой Платформы 1С:Предприятие 8.3 (8.3.13.1644). Проверено на релизе УНФ 1.6.16.176.

1 стартмани

23.12.2019    10062    31    1sig    3    

Маршрутный лист с заказами, накладными и упаковочными листами

Печатные формы документов Оптовая торговля v8::УФ УНФ ERP2 УТ11 УУ Абонемент ($m)

Внешняя печатная форма с расширенным составом информации

5 стартмани

18.12.2019    3340    1    andryandry    2    

Имена метаданных и синонимы

Структура метаданных v8 v8::УФ УПП1 Россия Абонемент ($m)

Обработка показывает имена объектов конфигурации и их синонимы.

1 стартмани

13.12.2019    2211    0    Senator_I    4    

Пример формирования и печати QR кода (обычное и управляемое приложение)

Ценники v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка показывает пример формирования QR кода в последующей печатью в табличный документ.

1 стартмани

09.12.2019    2761    3    Denr83    0    

Решение задач по мотивам статьи "30 задач. Странных и не очень"

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка по мотивам статьи: https://infostart.ru/public/1161686/

1 стартмани

04.12.2019    3150    2    batsy66    9    

АРМ самообслуживания (информационный киоск) (ЗУП 3.1)

Зарплата Рабочее место v8 v8::СПР v8::УФ v8::СКД ЗУП3.x БУ Абонемент ($m)

Внешняя обработка «АРМ Самообслуживания» выводит расчетный листок, график работы и информацию по остаткам отпуска при считывании магнитной карты (пропуска сотрудника). Не требует изменений в конфигурации. Подключается как дополнительная внешняя обработка.

1 стартмани

28.11.2019    4244    6    LavinVadik    9    

Программное добавление параметров редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

В данной публикации приводится пример программного добавления параметров редактирования для поля выборки в СКД.

1 стартмани

25.11.2019    5926    1    Isonic    8    

Динамическое управление свойствами реквизитов управляемых форм

Работа с интерфейсом v8::УФ 1cv8.cf Абонемент ($m)

Расширение позволяет для указанных пользователей или роли динамически изменять доступность, видимость и заголовок реквизитов форм справочников или документов.

1 стартмани

20.11.2019    4902    10    shalex5    5    

Наглядные доп.реквизиты товара в табличной части документа за 5 минут

Розничная торговля Учет ТМЦ Работа с интерфейсом Производство Управление торговлей v8::УФ Розница ERP2 УТ11 КА2 УУ Абонемент ($m)

Это расширение конфигурации даёт возможность отображать произвольные "дополнительные реквизиты" Номенклатуры и Характеристик в колонках табличной части «Товары». Позволяет свои настройки доп.реквизитов для каждого пользователя и для каждого типа документа. Без программиста и без конфигуратора, подключи в базу файл, задай настройки и получи в документах СВОИ столбцы с доп.данными о товаре.

3 стартмани

20.11.2019    5821    14    itsmith    12    

html + css + js в поле HTML документа 1С на примере решения задачи ханойских башен

Практика программирования v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Рассматривается пример использования html + css + js в полеHTMLдокумента 1с. Вызов функций javascript со стороны 1С с передачей параметров. Решение головоломки "Ханойская башня" с визуализацией в среде 1С.

1 стартмани

11.11.2019    6385    9    mangushov    0    

"Все функции" с плюшками

Универсальные обработки Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Замена штатному меню для тех, кто хочет открывать "Все функции" быстро и кто скучает по быстрому позиционированию по первым символам как было раньше

1 стартмани

06.11.2019    6581    20    codejs    6    

Пример вывода картинок в отчете на СКД.

Работа с интерфейсом v8::СКД ERP2 УТ11 КА2 Абонемент ($m)

Коллеги, в данной публикации я хочу поделиться отчетом "Остатки и доступность товаров" для ERP 2.4, КА 2.4, УТ 11 с выводом картинок.

1 стартмани

21.10.2019    4175    3    pavelpribytkin96    0    

Быстрый просмотр табличной части "Товары" без открытия формы документа

Работа с интерфейсом v8 v8::ОУ v8::УФ УТ11 УУ Абонемент ($m)

Разработка позволят осуществить "быстрый просмотр" табличных частей документов "Реализация товаров и услуг", "Корректировка реализации", "Возврат товаров от клиента" из формы списка "Документы продажи (все)" без необходимости открытия формы просматриваемого документа.

2 стартмани

08.10.2019    3817    8    simuljakr    6    

1С: Розница 2.2. Ошибка при оплате: "Тэг Оплата не заполнен"

Розничная торговля Рабочее место v8::УФ Розница Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Кто работает с 1С: Розница 2.2 в режиме РМК достаточно много, наверняка сталкивался с ошибкой при пробитии чека "Тэг Оплата не заполнен". Найдено вот такое решение.

1 стартмани

25.09.2019    5093    2    AneJIbcuH    1    

Конфигурация для подготовки к тестированию 1С Профессионал

Решение задач на 1С:Специалист v8::УФ Россия Абонемент ($m)

Конфигурация для подготовки к тестированию на сертификат "Профессионал 1С". Тренажер для тестирования. Подготовка к профессионалу по 1С (1С:Профессионал) по ERP, Бухгалтерия 8, Управление торговлей 8, Документооборот, Розница, ЗУП и т. д. Конфигурация служит для подготовки к тестированию. Функционал получился универсальный, подойдёт для подготовке к любой сдаче на сертификат профессионала по 1С. Тестировалось на платформе 1С:Предприятие 8.3 (8.3.15.1534).

1 стартмани

23.09.2019    14742    63    vik2006    24    

Картинки конфигурации

Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Иногда перед разработчиками 1С встает вопрос: есть ли подходящая общая картинка в конфигурации или нужно рисовать свою для кнопки? А какие вообще картинки есть в конфигурации и какие у них размеры? Поиск подходящей картинки через конфигуратор мне показался не совсем удобным, поэтому и появился отчет по общим картинкам конфигурации. Отчет универсальный, должен работать в любой конфигурации и на обычных, и на управляемых формах. Важно: версия платформы 1С должна быть 8.3.14 или выше.

1 стартмани

10.09.2019    5204    16    rusmil    6    

Начальная страница с избранным, историей и настраиваемым журналом документов. Управляемые формы

Рабочее место v8 v8::УФ БП3.0 УТ11 ЗУП3.x Россия Абонемент ($m)

Начальная страница с избранным, историей и настраиваемым журналом документов, сделана максимально универсально, подходит для УТ 11.4, ЗУП 3.1, БП КОРП 3.0.

1 стартмани

06.09.2019    3780    3    oladko    0    

Поиск изменений объектов по реквизитам для любых конфигураций с подсистемой "Версионирование объектов" (БСП 3.0.X.X)

Журнал регистрации Поиск данных БСП (Библиотека стандартных подсистем) v8::УФ 1cv8.cf Абонемент ($m)

Отчет использует данные версий объектов (кто? что? когда изменял?) из регистра подсистемы "Версионирование объектов" (История изменений) . Если вы знаете, что изменилось, но не знаете, в каком конкретно объекте и хотите это понять, то этот отчет для вас! Он предназначен для поиска объектов, в которых изменялись искомые реквизиты за указанный отрезок времени. Работает только с теми объектам, версионирование которых включено! Для любых конфигураций с БСП 3.0.X.X.

1 стартмани

05.09.2019    4924    19    razars    0    

Лист согласования для 1С:Документооборот

Печатные формы документов Документооборот и делопроизводство Документооборот и делопроизводство v8 v8::УФ ДО Россия УУ Абонемент ($m)

Внешняя печатная форма Лист Согласования. Во внешней печатной форме также добавлен инициатор и название документа.

1 стартмани

04.09.2019    3928    19    user598128_able123    0    

Расчет сложных итогов СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Малоизвестный прием для расчета итогов в отчетах на СКД.

1 стартмани

05.08.2019    19955    16    masterkio    17